DIVER
Disclaimer

Dimensional Insight, Inc. disclaims the implied warranties of merchantability and fitness for a particular purpose and makes no express warranties except as may be stated in its written agreement with and for its customer.

In no event is Dimensional Insight liable to anyone for any indirect, special, or consequential damages. The information and specifications in this manual are subject to change without notice.

Copyright © Dimensional Insight, 1991-2014.

Trademarks

Microsoft®, Windows®, and Excel® are registered trademarks of Microsoft Corporation in the United States and other countries.

AIX®, AS/400®, and DB2® are registered trademarks and iSeries™ is a trademark of International Business Machines Corporation.

Adobe®, Acrobat®, and Distiller® are registered trademarks of Adobe Systems Incorporated.

Oracle® and Java® are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

Google Maps™ is a trademark of Google Inc. Other product and company names mentioned in this manual are the service mark, trademark, or registered trademark of their respective owners.

Limited Warranty and Liability

Dimensional Insight, Inc. (DII) is the owner of the Software to which this documentation applies. The Software is subject to copyrights, patents and other intellectual property rights of DII, is furnished only under a license to use it, and no ownership rights are conveyed in the Software under any circumstances. License rights are set out in written license agreements entered into by all licensees either prior to delivery of the Software or prior to first use of the Software. No use of the Software is permitted unless the user has first agreed to the terms of the license. DO NOT USE THE SOFTWARE IF YOU HAVE NOT REVIEWED AND AGREED TO THE TERMS OF THE LICENSE.

THE SOFTWARE IS FURNISHED “AS IS” AND WITHOUT WARRANTY OF ANY KIND OR NATURE TO THE EXTENT PERMITTED BY APPLICABLE LAW. DII EXPRESSLY DISCLAIMS ALL WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE, SATISFACTORY QUALITY AND NONINFRINGEMENT, AND THEIR EQUIVALENTS UNDER ANY LAW OF ANY JURISDICTION. IF APPLICABLE LAW IMPLIES ANY WARRANTIES OR CONDITIONS WITH RESPECT TO THE SOFTWARE, ALL SUCH WARRANTIES OR CONDITIONS ARE LIMITED TO A PERIOD OF THIRTY (30) DAYS FROM THE DATE OF DELIVERY OF THE SOFTWARE TO THE LICENSEE.

DII DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET YOUR REQUIREMENTS, OR THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE SOFTWARE WILL BE CORRECTED. FURTHERMORE, DII DOES NOT WARRANT OR MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE IN TERMS OF THEIR CORRECTNESS, ACCURACY, RELIABILITY, OR OTHERWISE. SHOULD THE SOFTWARE PROVE DEFECTIVE, LICENSEE (AND NOT DII, ITS DISTRIBUTORS, DEALERS OR EMPLOYEES) WILL ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR, OR CORRECTION.
SOME STATES AND JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF EXPRESS OR IMPLIED
WARRANTIES OR CONDITIONS UNDER CERTAIN CIRCUMSTANCES, SO THE ABOVE EXCLUSIONS
MAY NOT APPLY TO YOU. IF SUCH EXCLUSIONS DO NOT APPLY TO YOU, AND ONLY IN SUCH EVENT,
YOUR SOLE REMEDY WILL BE, AT DII’S OPTION, REPAIR OR REPLACEMENT OF THE SOFTWARE OR
A REFUND OF THE PRICE PAID BY YOU FOR THE SOFTWARE. THIS WARRANTY GIVES YOU SPECIFIC
LEGAL RIGHTS. YOU MAY ALSO HAVE OTHER LEGAL RIGHTS WHICH VARY FROM STATE TO STATE
AND JURISDICTION TO JURISDICTION.

While efforts have been made to ensure THAT the program and its documentation are free from defects, under no
circumstances and under no legal theory, whether tort, contract, or otherwise, shall DII, or its distributors, dealers or
employees, be liable to you or any other person for any loss or damage sustained in connection with ANY ATTEMPT
TO use the Software, including without limitation, any economic, consequential or other indirect loss or damage, even
if DII has been previously advised of the possibility of such loss or damage. Some states and jurisdictions do not allow
the exclusion or limitation of INCIDENTAL or consequential damages under certain circumstances, so this limitation
and exclusion may not apply to you.

U.S. Export Administration Act: Restrictions on Exporting Software

The Software may include certain cryptographic software that may be subject to export controls under the U.S. Export
Administration Act. The Software may not be exported to any country or to any foreign entity or “foreign person” to
the extent prohibited under applicable U.S. government regulations. By downloading or using the Software, you are
acknowledging and agreeing to the foregoing limitations on your right to export or re-export the Software, and are also
representing and warranting that you are neither on any of the U.S. government’s lists of export precluded parties nor
otherwise ineligible to receive software containing cryptography that is subject to export controls under the U.S.
Export Administration Act.

If a version of DiveLine that uses encryption is running, administrators must be aware that allowing users outside the
United States to access data via certain DI-Clients qualifies as exporting encryption software (either the client
executable or the Java applet sent to the browser). Export or re-export of encrypted software must be in accordance
with the Export Administration Regulations. Diversion of encryption software contrary to U.S. law is prohibited.

Third Party Licensing

OpenSSL Toolkit

The licensing below applies to the third party encryption library routines ONLY.

This product may include software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://
www.openssl.org/) [Copyright © 1998-2011 The OpenSSL Project. All rights reserved.]

This product may include cryptographic software written by Eric Young (eay@cryptsoft.com) [Copyright ©
1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.]

Below are the two licenses which cover the use of these routines.

LICENSE ISSUES
==============

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of
the OpenSSL License and the original SSLeay license apply to the toolkit.
See below for the actual license texts. Actually both licenses are BSD-style
Open Source licenses. In case of any license issues related to OpenSSL
please contact openssl-core@openssl.org.

OpenSSL License
---------------
/* ====================================================================
 * Copyright (c) 1998-2005 The OpenSSL Project. All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 *
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in
 *    the documentation and/or other materials provided with the
 *    distribution.
 *
 * 3. All advertising materials mentioning features or use of this
 *    software must display the following acknowledgment:
 *    "This product includes software developed by the OpenSSL Project
 *    for use in the OpenSSL Toolkit. (http://www.openssl.org/)"
 *
 * 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
 *    endorse or promote products derived from this software without
 *    prior written permission. For written permission, please contact
 *    openssl-core@openssl.org.
 *
 * 5. Products derived from this software may not be called "OpenSSL"
 *    nor may "OpenSSL" appear in their names without prior written
 *    permission of the OpenSSL Project.
 *
 * 6. Redistributions of any form whatsoever must retain the following
 *    acknowledgment:
 *    "This product includes software developed by the OpenSSL Project
 *    for use in the OpenSSL Toolkit (http://www.openssl.org/)"
 *
 * THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
 * EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR
 * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
 * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
 * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
 * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
 * OF THE POSSIBILITY OF SUCH DAMAGE.
 * ====================================================================
 *
 * This product includes cryptographic software written by Eric Young
 * (eay@cryptsoft.com). This product includes software written by Tim
 * Hudson (tjh@cryptsoft.com).
 */
* The licence and distribution terms for any publicly available version or
derivative of this code cannot be changed. i.e. this code cannot simply be
copied and put under another distribution licence
* [including the GNU Public Licence.]
*/

**Google Automated Error Reporting**

This product includes portions of automated error reporting software which require the display of the following
disclaimer. This disclaimer applies only to those portions of code, not to the product as a whole.

Copyright (c) 2010, Google Inc.
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright
  notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above
  copyright notice, this list of conditions and the following disclaimer
  in the documentation and/or other materials provided with the
  distribution.
* Neither the name of Google Inc. nor the names of its
  contributors may be used to endorse or promote products derived from
  this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product may include the GOLD parser created by Devin Cook, http://www.devincokk.com. This software is
specified to be free under a freeware license based on the common ZLib license. This software is provided 'as-is',
without any expressed or implied warranty. In no event will the author(s) be held liable for any damages arising from
the use of this software. Permission is granted to anyone to use this software for any purpose.

This product may contain FTP code created by Jaimon Mathew (jaimonmathew@rediffmail.com) and Dan Rolander
(Dan.Rolander@marriott.com) as posted on http://www.csharphelp.com. This is believed to be sample code that is
freely reusable.

Copyright © 2014 Dimensional Insight, Inc., 60 Mall Road, Burlington, MA 01803
(http://www.dimins.com)
DIVER
# Contents

## Chapter 1: Introduction To Diver .......................................... 1-1
- Using this Manual ...................................................................................................................1-1
  - Manual Conventions ...........................................................................................................1-2
  - Related Documents ..........................................................................................................1-2
- Technical Support ..................................................................................................................1-3
- The Diver Solution™ .............................................................................................................1-4
- Licensing The Diver Solution .............................................................................................1-9
- Diver Glossary ......................................................................................................................1-10
- File Extensions ....................................................................................................................1-15

## Chapter 2: Diver Basics .......................................................... 2-1
- Locating Diver ....................................................................................................................2-1
- Starting Diver ......................................................................................................................2-2
- Opening Files .....................................................................................................................2-2
- File Naming Conventions .................................................................................................2-3
- File Types ............................................................................................................................2-3
- The Diving Process .............................................................................................................2-9
  - How Diving Works ...........................................................................................................2-11
- Understanding the Console ...............................................................................................2-14
  - Using Console Areas ........................................................................................................2-14
  - Using Additional Console Features ................................................................................2-26
- Using the Diver Toolbar ......................................................................................................2-35
  - The Default Toolbar Buttons .........................................................................................2-36
  - Additional Toolbar Buttons ............................................................................................2-38
Chapter 3: Menus

Using the File Menu
- Opening Files
- Closing Models
- Saving a DivePlan
- Saving a Window in Various Formats
- Saving a Marker
- Saving a Report Template
- Saving a Graph Template
- Saving a DiveBook
- Saving a Model
- Saving a QuickView Set
- Previewing a Window for Print
- Setting Print Options
- Printing Files
- Cascade Print
- Logging in to ProDiver
- Using the Proxy Login
- Downloading a Model
- Setting Preferences
- Building and Editing Models
- Opening Recently Used Files
- Exiting Diver

Using the Edit Menu
- Undoing and Redoing Actions
- Cutting Text
- Copying Text
- Copying Console Contents
Chapter 4: Tabular Displays ................................................................. 4-1

Using Tabular Displays ............................................................................ 4-1
  Understanding the Tabular Display ............................................................ 4-2
  Understanding the CrossTab Display .......................................................... 4-3
  Understanding the MultiTab Display ........................................................... 4-5
  Understanding the MultiCrossTab Display .................................................. 4-7
  Understanding the MultiTabMultiCrossTab Display .................................... 4-9

General Characteristics of Tabular Displays ............................................... 4-10
  Using Basic Window Functions ................................................................. 4-10
  Understanding Row and Column Behavior ............................................... 4-11
  Making Selections in a Tabular Display ....................................................... 4-15
  Using the Tabular Window Context Menu .................................................. 4-16
  Configuring User Defined Dimensions ...................................................... 4-19
  Editing Window Fonts ............................................................................... 4-24
  Setting Decimal Places ............................................................................ 4-24
  Using Exception Coloring .......................................................................... 4-25
  Setting Dimension Column Options ......................................................... 4-25
  Using URL’s in a Tabular ............................................................................ 4-27
  Splitting Windows ..................................................................................... 4-28
  Cascade Diving .......................................................................................... 4-30
  Missing Data ............................................................................................. 4-31
Chapter 5: Graphs ................................................................................. 5-1

Using Graphs in Diver ......................................................................... 5-1
Creating Graphs .................................................................................. 5-5
  Using Basic Plots ............................................................................. 5-6
  Using Calendar Plots ...................................................................... 5-16
  Using CrossPlots ........................................................................... 5-24
  Using Control Charts ..................................................................... 5-30
  Using Time Graphs/Gantt Charts ..................................................... 5-48
  Using Maps .................................................................................. 5-54
  Using Pie Plots and Doughnut Plots .............................................. 5-57
  Using Radar Graphs ...................................................................... 5-60
  Using Scatter Plots ........................................................................ 5-63
  Using Stack Plots .......................................................................... 5-68
Setting Graph Options ......................................................................... 5-71
  Using the Appearance Tab ............................................................. 5-71
  Using the Text Tab ........................................................................ 5-74
  Using the Scales Tab ...................................................................... 5-76
  Using the Legend Tab ..................................................................... 5-78
  Using the Statistics Tab ................................................................. 5-80
About Graphical Displays ................................................................... 5-82
  Graph Window Characteristics ..................................................... 5-82
  Editing a Graph ............................................................................ 5-82
  Using Live Objects in a Graph ...................................................... 5-83
  Understanding Graph Axes ........................................................... 5-84
  Using the Legend .......................................................................... 5-87
  Using the Graph Toolbar ............................................................... 5-88
  Using the Graph Context Menu ................................................... 5-97
Using Graph Templates ....................................................................... 5-98
  Modifying a Graph after a Template is Applied ......................... 5-98

Chapter 6: Reports .............................................................................. 6-1

Creating a Report ............................................................................... 6-1
Chapter 7: QuickViews

Using QuickViews to Enhance the Diving Experience
  Create a Marker without QuickViews
  Expand the Scope of a Dive with QuickViews

Dimension QuickView Options
  The Data Panel
  The Display Panel
  The Behavior Panel
  Creating a Dimension QuickView
  Creating a Dimension QuickView from a Tabular Window

DiveBook QuickView Options
  Creating a DiveBook QuickView

List QuickView Options
  Creating a List QuickView

Free Entry QuickView Options
  Creating a Free Entry QuickView
  Creating a QuickView Set

Edit QuickView Options
  Building a Report from a Dive Window using QuickViews

Using the QVVal Function in Advanced Find
Chapter 8: DiveBooks

Opening a DiveBook ..............................................................................................................8-1
Selecting DiveBook Areas and Topics ...................................................................................8-2
  Viewing Topic Info...........................................................................................................8-3
Creating a DiveBook ..............................................................................................................8-4
Modifying a DiveBook ..............................................................................................................8-4
  Using the Title and Graphic Dialog.................................................................................8-5
  Using the Areas Dialog....................................................................................................8-6
  Using the Topics Dialog ..................................................................................................8-7
  Closing the Modify DiveBook Dialog Box.....................................................................8-8
Saving A DiveBook ................................................................................................................8-8
Closing A DiveBook...............................................................................................................8-8

Chapter 9: DivePlans & Calculations .................................................................................9-1

Understanding DivePlans .......................................................................................................9-1
Editing The DivePlan ..............................................................................................................9-2
  Using the Add Column Dialog ........................................................................................9-2
  Adding Calculations ........................................................................................................9-13
Editing Columns ....................................................................................................................9-43
Selecting Columns ................................................................................................................9-45
Named Groups .......................................................................................................................9-46
Setting Dynamic Dimensions ..............................................................................................9-53
Adding Date Roll-Up Dimensions .......................................................................................9-55
Adding Info Fields Using a Lookup Table ........................................................................9-63
Setting Console Categories ..................................................................................................9-64
Saving a DivePlan ..................................................................................................................9-64
  Saving a DivePlan as a Stand-Alone File ...........................................................................9-64
  Saving a DivePlan to a DiveBook ....................................................................................9-66
Using External DivePlans .....................................................................................................9-66
Consolidating Internal and External DivePlans .................................................................9-67
Chapter 10: Time Series & Period Comparison ................. 10-1

Using the Time Series Control Panel ................................................................. 10-1
  General Time Series Settings ......................................................................... 10-2
  Time Series Type ............................................................................................ 10-5
  Columns ........................................................................................................... 10-11
Completing the Time Series .............................................................................. 10-12
Creating a Time Series ....................................................................................... 10-12
Deleting the Time Series ................................................................................... 10-19
Using Period Comparisons .............................................................................. 10-20
  Creating a Period Comparison ........................................................................ 10-20

Chapter 11: Report Palettes ................................................................. 11-1

Understanding Report Palettes ........................................................................ 11-1
  Using Report Palettes ...................................................................................... 11-2
  Creating a Report Palette ................................................................................ 11-3
  Editing a Report Palette ................................................................................... 11-4
  Using Report Palette Features ....................................................................... 11-6
  Saving Report Palettes ................................................................................... 11-12
  Viewing Report Palettes in the Console ........................................................... 11-13
Creating Calculation References ..................................................................... 11-13
  Definition and Syntax ...................................................................................... 11-13
  Examples of Calculation Reference Strings .................................................... 11-14
  Copying and Pasting Calculation References .................................................. 11-15
Using Reporter Reference Items ...................................................................... 11-18
  Using the Copy Reporter Reference Item Dialog Box ....................................... 11-18
  Copying and Pasting Reporter Reference Items .............................................. 11-19
Using Window Dive Reference Strings .......................................................... 11-23
  Using Variables in Window Link References ................................................... 11-24
  Setting Report-Specific Attributes .................................................................. 11-24
  Copying and Pasting Window Dive Reference Strings .................................... 11-25
Using Reporter Links ....................................................................................... 11-27
  Using the Link Tab ......................................................................................... 11-28
Chapter 12: Building a Memory Model

Understanding the Basic Model Components ............................................. 12-2
Using the Build Wizard ........................................................................... 12-2

Building a Model Using a Text Data Source ........................................... 12-4
Building a Model Using an ODBC Data Source ....................................... 12-12

Editing a Memory Model ....................................................................... 12-16
Saving a Memory Model ......................................................................... 12-17
Chapter 13: Application Templates & Preferences ......... 13-1

Using Application Templates .................................................................13-1
   Creating an Application Template......................................................13-2
   Saving an Application Template .......................................................13-6
   Activating an Application Template ..................................................13-7

Setting Diver Preferences.................................................................13-8
   Specifying General Preferences......................................................13-8
   Setting Tabular Preferences ............................................................13-10
   Setting Graph Preferences .............................................................13-11
   Setting Map Preferences ...............................................................13-12
   Setting DiveLine Preferences (ProDiver Only)...............................13-13
   Setting Default File Preferences (DI-Diver Only)..........................13-14

Appendix A: Command Line Options .......................... A-1

Diver Command Line Options .........................................................A-1
   Cascade Print Commands ..............................................................A-1
   File Open Commands .................................................................A-6
   Marker Print Commands ..............................................................A-6
   Output Commands .....................................................................A-7
   Permit Commands .....................................................................A-8
   ProDiver Commands .................................................................A-9
   QuickView Commands ...............................................................A-9
   Registration Commands .............................................................A-9

Appendix B: diver.ini File ......................................................... B-1

Diver.ini Options ................................................................................B-2
   Diver Window Options ...............................................................B-3
   File Menu Options ......................................................................B-4
   Chart & Graph Options ..............................................................B-6
   Report Options ........................................................................B-8
DIVER
List of Tables

Technical Support Contact Information .................................................................1-3
Basic Diver File Types ...............................................................................................2-3
The Default Diver Toolbar ..........................................................................................2-36
Additional Toolbar Buttons ......................................................................................2-38
Keyboard Shortcuts ....................................................................................................2-42
Tabular Display Characteristics ................................................................................4-1
Graph Type Usage ......................................................................................................5-1
Date Format Options ..................................................................................................9-59
Diver Cascade Print Commands ...............................................................................A-1
Diver File Open Commands ......................................................................................A-6
Diver Marker Print Commands ................................................................................A-6
Diver Output Commands .........................................................................................A-7
Diver Permit Commands ..........................................................................................A-8
Diver ProDiver Commands ......................................................................................A-9
Diver QuickView Commands ..................................................................................A-9
Diver Registration Commands ...............................................................................A-9
Diver Window .ini Options ......................................................................................B-3
File Menu Diver Options .........................................................................................B-4
Chart & Graph diver.ini Options ............................................................................B-6
Report diver.ini Options .........................................................................................B-8
Map diver.ini Options .............................................................................................B-10
Find diver.ini Options .............................................................................................B-11
Help diver.ini Options .............................................................................................B-12
Miscellaneous diver.ini options .............................................................................B-13
DiveLine Server diver.ini Options .........................................................................B-14
Other Server diver.ini Options .................................................................B-16
Chapter 1
Introduction To Diver

DI-Diver and ProDiver are the core DI Solution applications that allow viewing and analysis of data with a point-and-click graphical user interface. The interface displays, saves, or prints the data in various tabular, report, and graphical formats, allowing the user access to information from varying perspectives.

Using this Manual

This manual is divided into the following sections:

- **Chapter 1, Introduction To Diver** - Discusses manual usage, introduces The Diver SolutionTM suite of software, and provides useful definitions.
- **Chapter 2, Diver Basics** - Discusses how to locate and start Diver, and provides basic information about the Diver interface.
- **Chapter 3, Menus** - Introduces the options available in each Diver menu.
- **Chapter 4, Tabular Displays** - Provides an in-depth look at the Diver Tabular display in its various forms.
- **Chapter 5, Graphs** - Provides detailed information on the graphical displays available in Diver.
- **Chapter 6, Reports** - Details report types and report creation and customization.
- **Chapter 7, QuickViews** - Provides information on the creation and use of QuickViews.
- **Chapter 8, DiveBooks** - Details DiveBook creation and use.
- **Chapter 9, DivePlans & Calculations** - Provides an in-depth look at DivePlans and calculations.
- **Chapter 10, Time Series & Period Comparison** - Details Time Series and Period Comparison creation.
Chapter 11, Report Palettes - Outlines advanced Reporting tools and techniques in Diver.

Chapter 12, Building a Memory Model - Provides steps for creating quick Models in Diver.

Chapter 13, Application Templates & Preferences - Provides administrative information for managing Diver content available to end-users.

Manual Conventions

Many parts of this manual include action items or step-by-step instructions to follow for a specific task. These sections may also include information areas that are related to the steps but are not actions to be taken. Action items are listed in numbered steps, while additional information is separated into other paragraphs.

In addition, note sections in these areas and throughout the manual are indicated by the icon below:

To denote a selection from a menu, the menu will be listed and then the selection, separated by an arrow “>”. For example, File > Open.

Also, <servername> and <portnum> specify the actual server name (or IP address) and port number, if varying from the default port 2130.

Related Documents

Companion manuals for the Diver manual are as follows:

- The Diver Solution Installation Guide- Contains information about the installation of the Diver Solution software suite.

- Diver Solution Licensing - Contains information about the licensing process and requirements for the Diver Solution software suite.

- Data Integrator - Contains information about the data extraction and transformation process.

- Builder - Contains information about the Model building and optimization process.

- DiveMaster - Contains information about DivePlan creation.

- DiveLine - Contains information about Model security and user control.
Technical Support

Customer support is available from 7:00 AM to 5:00 PM (Central Time).

Table 1: Technical Support Contact Information

<table>
<thead>
<tr>
<th>Customer Type</th>
<th>Phone</th>
<th>Fax</th>
<th>Email</th>
</tr>
</thead>
<tbody>
<tr>
<td>Domestic Users</td>
<td>920-436-8299</td>
<td>920-433-2378</td>
<td><a href="mailto:support@dimins.com">support@dimins.com</a></td>
</tr>
<tr>
<td>International Users</td>
<td>+1-920-436-8299</td>
<td>+1-920-433-2378</td>
<td><a href="mailto:interntional@dimins.com">interntional@dimins.com</a></td>
</tr>
</tbody>
</table>
The Diver Solution™

Dimensional Insight’s The Diver Solution™ is a powerful data analysis, reporting and delivery system. It combines data from disparate sources for access by a variety of users. The following components are included:

Administrative software that allows for the extraction and transformation of data:

- Builder
- Data Integrator and Visual Integrator
- DiveMaster and ProDiveMaster
- DI-Production

Client/server software that allows for the centralized administration of users, event scheduling, and client software delivery:

- DiveLine
- DI-Config
- DI-Controller
- DI-Scheduler
- DI-Updater

Tools used for sending data to a large number of users on a scheduled basis:

- DI-Broadcast
- DIAL

Client interface components that allow end-user access to data Models via the Internet or local Intranet:

- CellDiver
- DI-Diver and ProDiver
- DivePort
- NetDiver
- ProReporter
**Builder**

Builder transforms data into a Model to be analyzed using any of the Diver Solution client interface components. The Model is a special, proprietary data structure for which Diver is optimized. Builder transforms the data by summarizing, indexing and preprocessing it. In effect, most of the analysis burden is off-loaded from the client and stored in the Model.

**Data Integrator and Visual Integrator**

Data Integrator is an extraction, transformation, and loading tool that accepts input from various sources, and combines them to form text files that can be used by the Builder module. Data Integrator is controlled by a description file that specifies the source of data, the operations to be performed on this data, and the location of the resulting output. Operations the Data Integrator can perform include joins, filters, and data manipulation. These functions and others are specified in the ASCII description file written in the DI’s Object Language.

**DiveMaster and ProDiveMaster**

DiveMaster is an interface that customizes a Model to the user’s needs. DiveMaster edits DivePlans (defined on page 1-10), which specify to the client software how the Model should be presented. DivePlans contain information such as which columns should be shown, what calculated fields are available, and how to combine multiple Models. Another feature available in the DiveMaster module is the capability to add Categories to the Console.

**DI-Production**

DI-Production simplifies the regularly scheduled process of turning database data into DI-Models. This is done using a number of different processes involving batch scripts initiated by DI-Scheduler or utilizing an operating system-specific scheduler such as CRON or the Windows Scheduler.

**DiveLine**

DiveLine is the server software that enables flexible, scalable, centralized administration to diverse groups and levels (Advanced, General, and Casual) of users accessing company data. DiveLine provides central control of information. All types of users, whether internal, remote, or external, are served secure information customized to their needs. DiveLine provides powerful administration and performance capabilities that enable the administrator to control authentication of users and access to the data. All end-user software, except DI-Diver, communicates with DiveLine.

**DI-Config**

DI-Config allows an administrator to configure DiveLine using a Windows GUI utility. It can be run from any machine that has the ability to connect to the DiveLine server. Through DI-Config, an administrator can set and reset options such as Security level, Authentication, Server configuration, Aliases, Users, Groups, and Permissions.
The Diver Solution™

**DI-Controller**
DI-Controller is used to help the DiveLine administrator keep track of all users connected to the DiveLine server and all Models that are currently open. It allows the disconnection of individual users, or all users accessing a particular Model. Additionally, the administrator can send system-wide messages to connected users.

**DI-Scheduler**
DI-Scheduler allows an administrator to automate events related to Dimensional Insight products. These events include building a Model and running a Data Integrator script. A job can be triggered upon the occurrence of another event. DI-Scheduler allows an administrator to have a complete implementation using The Diver Solution tools.

**DI-Updater**
DI-Updater allows a Server administrator to give a DiveLine administrator the ability to grant access to any file from the DiveLine server for end-users to download for offline use. The file types that a DiveLine administrator might want to allow a user to download include Models, Documentation, Installation files, Release Notes, and Graphics.

**DI-Broadcast**
DI-Broadcast is a DiveLine client that automatically sends e-mails based on a defined set of business rules and parameters. As data is updated, e-mails can be sent, allowing recipients to take action or make decisions based on the data. The DI-Broadcast process runs in an automated and scheduled environment so users do not have to manually repeat e-mail tasks. This automation saves substantial time and resources, and ensures that important information is not lost or overlooked.

**DIAL**
The Dimensional Insight Access Language (DIAL) is a high-level programming language designed to process, analyze, and distribute information contained in Models. DIAL programs are executed through the DIAL interpreter, a Java command line program. When run, DIAL scripts can process Markers, producing the results as e-mail or saved files. It can also access Summary information in Dimensional Insight Models. This capability allows it to perform complex data analysis and exception reporting.

**CellDiver**
CellDiver is a Microsoft Excel® Add-In that allows a DiveLine user with a General or Advanced level of functionality to “dive” from an Excel-based Console, in order to pull data directly from a Marker, DivePlan, Model, or Tunnel file (defined on page 2-8) into an Excel spreadsheet. The user can then perform most Excel-based functions (charts, calculations, etc.) and some basic Diver functions (Dive, MultiTab, CrossTab, Group, etc.) directly in the spreadsheet.
DI-Diver and ProDiver

DI-Diver and ProDiver are business intelligence tools that allow viewing and analysis of data with a point-and-click graphical user interface. They allow cross-functional analysis and reporting solutions that provide the perspective needed to understand the data used, and to allow users to make timely, well-informed decisions. Using DI-Diver or ProDiver, users will be able to view the same data in new ways.

The DI-Diver and ProDiver client products are nearly identical in appearance and use, with major differences between the two lying in how Models (defined on page 1-10) are opened and how security is managed. DI-Diver is a self-contained, fully functional Windows Desktop executable that accesses various file types through the operating system, while ProDiver is a client designed to open files via a server-side application called DiveLine. ProDiver communicates with the DiveLine server, which provides users with only the data they are allowed to access.

The DI-Diver and ProDiver interfaces allow users to obtain more and more detailed levels of information by progressively diving deeper into a Model. The initial dive accesses the entire data set, and retrieves only the data relating to the chosen category or “Dimension”. If a second dive is done, it will only search through the data retrieved for the first dive, and will display only the data which relates to the Dimension selected for the second dive. As a result, users can obtain highly detailed information in a short period of time. In addition, they are able to analyze the data each step of the way, and make decisions based on the displayed data. Thus, they do not need to assume, without verification, that certain trends or factors exist before obtaining the data.

In this manual, when information being explained applies to both DI-Diver and ProDiver, it will be referred to as Diver. Anything specific to one product and not the other will contain a note to that effect.

DivePort

DivePort, a zero footprint client, delivers personalized, aggregated information of business transactions and processes to employees, customers, and business partners through a web browser. DivePort is fully integrated with existing Dimensional Insight (DI) data Models, Markers (defined on page 1-10), and other Diver data sources, and a single point of entry allows access to a variety of reports, charts, and analytical applications. DivePort accommodates the analyst who wants to dive into the depths of the data for analysis, as well as the consumer who simply needs to view a static report. Administrators can provide users with tailored views of Key Performance Indicators (KPI), or with other metrics, presented in a personalized, web-based point of entry.

NetDiver

NetDiver, a zero-footprint client option, provides access to data to users through a web browser interface. Delivering business intelligence over the web with NetDiver provides users with access to a reporting and data analysis solution. It is integrated with existing DI data Models, Markers (defined on page 1-10), and other Diver data sources, and is designed to compliment DivePort. NetDiver functionality is available to the Advanced or General licensed user.
ProReporter

ProReporter is a reporting application that provides a simple, flexible, easy-to-use interface, allowing administrators to broaden their user base with minimal training, as well as to expand controlled access to data for customers and suppliers. ProReporter allows the user to open and save Report files and ReportBook files, or to create reports from existing Models or DivePlans. A ReportBook has a structure similar to a DiveBook - it is essentially a collection of reports arranged into categories called Areas and Topics. ProReporter also allows the user to save a report as a topic within a ReportBook.
Licensing The Diver Solution

Dimensional Insight software is licensed to ensure that only those authorized to use it can do so. DI licensing is by Named Users and applies to production software: DiveLine, Data Integrator, Builder, and DiveMaster, as well as the DI-Diver client in special circumstances. Production components require a license key for each system they are to be installed on. This license allows for the software to be used in perpetuity.

In the server/client environment, client license requirements are dictated by DiveLine for DIAL, DI-Broadcast, DI-Config, DI-Controller, DI-Scheduler, DI-Updater, DivePort, NetDiver ProDiver, and ProReporter.

When your company purchases software from Dimensional Insight, the required software licensing will be articulated. For more information, please refer to the separate document: Diver Solution Licensing.

A Unicode license is required for Diver to properly display unicode-encoded models. A non-Unicode Diver can only display ANSI characters, which are models built with “latin1” encoding.
Diver Glossary

This section describes the Diver vocabulary that will be used throughout this manual.

**Application Template**

Used to restrict the functionality of the Diver client that is available to users.

**Area**

The DiveBook construct that organizes entries, similar to a labeled file folder.

**Cascade**

The process of diving creates a “dive path”, i.e. a series of Dive Windows to reach the current view of the data. A Cascade occurs when you double-click at any level above the lowest window along the dive path and change the data in all subsequent Dive Windows. A Cascade dive can be performed from any type of Dive Window (e.g. tabular, graph, report).

**Category**

An optional folder in the Console used to organize Model Dimensions. Categories are defined using DiveMaster and are stored in the DivePlan.

**Child Window**

As one dives in Diver, each step results in a new Dive Window being displayed with the data retrieved from the Model. Each step depends on the prior step. In a Dive Path, the last displayed Window is the Child Window, while Windows for the intermediate steps are called Parent Windows. Parents have no hierarchy – all Parent Windows are equal.

**Console**

The navigation window through which the diving process is managed. For more information, see [Understanding the Console on page 2-14](#).

**Context Menu**

A popup list of features that changes depending on what the end-user is doing. For example, menus that appear when you right-click in the Console, Dive Window, or Report Palette.
Core Dimension, or Dimension

A classification for Diver to sort and display data. By selecting different Dimensions, you can view the data from different perspectives. A Model’s available Dimensions are listed in the Console. In Diver’s display windows, each value of a particular Dimension is a single item - one bar in a graph, one point in a line or scatter plot, one wedge in a pie, etc. Types of information presented as Dimensions might include Name, Company, Part Number, or Month. Diver has a limit of 200 Core and Dynamic Dimensions per DivePlan. Dimension Value names have a limit of 512 characters.

Core Model, or Model (.mdl)

A file that stores the data that Diver will read and display during a dive. The Model data structure is optimized for Diver. See File Types on page 2-3 for more information.

Detail Dimension

Dimension built into a Model using the special Detail option in the Builder. These Dimensions are accessible from Diver only after the data has been narrowed to 256,000 records or less by first diving on a Core Dimension. Detail Models have a special area in the Model section of the Diver Console for detail-level Dimensions.

Detail Model

A structure used for large data sets where not all the Dimensions, associated Info Fields, and Summaries make sense, or are of interest, summed at the highest level. A Detail Build creates a Dimension hierarchy within the Model, so there are Core-Model Dimensions and Detail Dimensions. By creating this hierarchy, only the Core-Model Dimensions are fully indexed within the Model.

Dive, or Diving

The process of using Diver to filter data in order to create a parent-child relationship. You can dive progressively deeper into the data, creating a more detailed view of a smaller range of information. For more details about diving, see The Diving Process on page 2-9.

Dive Arrows

In the Console, arrows appear to the left of Dimensions names when diving is enabled. These arrows are gray and point down. A gray arrow with a blue boxed-circle indicates a diveable Dynamic Dimension. Green arrows indicate Detail Dimensions available for diving. Right pointing gray or green arrows indicate MultiTabbing is enabled, rather than diving. Red down arrows indicate a Jump is enabled between common Dimensions in two or more open Models.
**Dive Path**

The sequence of steps taken to arrive at the current Dive Window. Up to four different Dive Paths of unlimited depth can be active in a Diver session (Dive A, Dive B, Dive C, or Dive D). The Dive Path is displayed in the History region of the Console.

**Dive Selector**

The series of four tabs presented on the Console (Dive A, Dive B, Dive C, or Dive D), allowing four concurrent Dive Paths.

**Dive Window**

In Diver, the results of diving into the data. Each dive step opens its own window for displaying the data retrieved from a Model or DivePlan. The window displays a Dimension in relation to its Summary values at some intersection in the Model. A Dive Window can be a Tabular, a Graph or a Report.

**DiveBook (.dbk)**

A Diver file that is similar to a file drawer with folders that organizes various types of Reports and Model sets so that they are easier to locate and to access quickly. For more information on DiveBooks, see [File Types on page 2-3](#) and [Chapter 8, DiveBooks](#).

**DivePlan (.dvp)**

A Diver file that does not contain data, but instructions telling Diver how to present the data. See [File Types on page 2-3](#) and [Chapter 9, DivePlans & Calculations](#) for more information.

**Dynamic Dimension**

An Info Field that has been promoted so it is diveable. Dynamic Dimensions can be setup from the Edit menu in Diver or by using DiveMaster, where Dynamic Dimensions are saved in DivePlans. Dynamic Dimensions appear in the Console with a blue circle enclosed in a black box next to the dive arrow. A Dynamic Dimension uses the indexing of the associated Core Dimension.

**Graph**

Standard pictorial representation of data such as bar, line, point, and bubble charts, calendar, cross, stack, scatter, and pie plots, control charts, maps, and radar graphs.

**Group**

When diving, an option that lets the user treat multiple Dimension Values as a single unit for further diving.
Info Field

Any additional information related to a Dimension. For example, in a Model containing sales information, Branch Manager might be an Info Field attached to the Branch Name Dimension.

Numeric Info Fields can be used in calculations, which can be useful for creating extended costs; for example, use Unit Cost as an Info Field on Product. Descriptions or codes are typical types of Info Fields. Info Fields can later be promoted to Dynamic Dimensions in the DivePlan. For more information see Setting Dynamic Dimensions on page 9-53 or refer to the DiveMaster manual.

To function correctly, Info Fields must be unique to their corresponding Dimension Values. In other words, every value in the Dimension can have one, and only one, corresponding value in the Info Field. Every person has one birthday, so “birth date” would be an acceptable Info Field to attach to “employee id”. This is true even if two employees have the same birthday - Diver does not care if Info Fields are repeated, as long as there is only one Info Field per Dimension Value. On the other hand, it would not be acceptable to use “zip code” as an Info Field attached to a “city” Dimension. A city may have more than one zip code, violating the logic Diver uses to connect Info Fields to Dimensions. Attaching a zip code Info Field to a city Dimension would only work if each city had only one zip code.

Jump

A single cascading dive between Models. This is possible when multiple Models are open in Diver and each have a common Dimension. In the Console, dive on one Model and select a common Dimension to display a red down arrow next to the common Dimension in the second Models. Double-click the Dimension with the red down arrow to jump.

Lookup file

An ASCII file with Dimension values and additional data that can be used to create new Info Fields in a Model after the build. These new Info Fields can be promoted to Dynamic Dimensions.

Marker (.mrk)

A multistep dive saved as a bookmark that lets the user return to the data view. A Marker does not contain any data, only the actions taken in a dive. When saved and reopened, it accesses the latest Model data for viewing and allows the dive to proceed from the last saved action.
Markers also save the details of the Dive Window: size, position, selections, fonts, focus, orientation, QuickView order, and DivePlan details. For more information, see File Types on page 2-3.

**Memory Model**
A Model built in memory by DI-Diver. A Memory Model is limited to 128,000 records or fewer, and can be named and saved to disk.

**Named Groups**
A collection of a Dimension’s values that are given a special label. They can be used in QuickViews, or to create a calculated column which displays only some of the data in the Model by filtering on certain values of a Dimension.

**Parent Dimension**
In a dive, each of the higher-level dive Dimensions or QuickViews is a Parent Dimension of all dives below it.

**Parent Window**
Any Dive Windows preceding the final Child Window.

**Period Comparison**
The Diver wizard that uses time-based data in the Model to generate period data such as YTD, Last YTD, the difference, and percent difference between the two.

**QuickView**
A Diver mechanism that presents to the user an easy way to filter the data in the current display. QuickViews can also be created for DiveBooks and Time Series.

**Record**
An entry within a Model. Each record contains a set of data belonging to a specific classification. For example, each record in an address Model might contain the name, street address, city, state, and zip code for an individual or company. A record contains all relationships between fields.

**Report**
A tabular display of data enhanced with titles, column headers, page breaks, and selective coloring.
Report Palette

A cellular structure to hold data definitions that can refer to multiple Models, external data, calculations, or graphics to be included on a single report Page. This is a feature of the Diver component which support highly customizable reporting. Any cell can be configured to link to data Models, allowing the user to dive to more detail. Complete Report Palettes are saved as Markers and can be used in DivePort and NetDiver.

Summary

The numerical value data on which mathematical calculations can be done. These numeric fields may include leading and trailing spaces, as well as a + or - sign before or after the digits. Types of information that might qualify as a Summary are Cost or Quantity Sold.

Tabular

The basic presentation of Model data that resembles a spreadsheet.

Time Series

The functionality that allows creating and modifying columns limited by time based periods.

Topic

The name given to a DivePlan, Marker, or Link saved in a DiveBook Area.

User Defined Dimension (UDD)

A new Dimension defined by a user within a Tabular window. This Dimension is usable for the rest of the session, or can be saved in a DivePlan or Marker and used later.

File Extensions

The following file extensions are associated with Diver:

.dbk

The Diver Solution DiveBook file type. These files are created and maintained with Diver. DiveBooks store Topics (Markers, DivePlans, Links) organized into Areas.

.dlk

Link file associated with ProDiver.
The DI file type for the DivePlan files. These are maintained with DiveMaster and Diver.

A file extension used for Diver Graph templates. Graph templates are used to store custom settings for later use in Graph Markers.

A file extension for configuration files used to store preferences and setting parameters.

For Models greater than 2 gigabytes, a continuation Model file generated by Builder. Continuation Models will have file types of .md0, .md1, .md2, up to .md9.

The file type for Model files, the basic data repository designed for fast access from Diver. Model files contain binary data.

The Update Model file extension, used for incremental builds where new data is added to an existing Model without rebuilding it in its entirety.

The DI Marker file type. Marker files record steps to a dive so it can be easily repeated against updated data. These saved dives can be opened by Diver, DivePort, NetDiver, CellDiver, and DIAL.

Diver QuickView Set files store related QuickViews for later use. Markers can refer to the QuickView Set file, and if the file changes, they will automatically use the new QuickView Set.

Reference Link Files containing Window Dive Reference Strings used with Report Palettes.
.rep
The file type for DI Report Template files with formatting instructions; contain no data or Model reference.

.tnl
Tunnel file that contains a DI Object Language script to link to data through DiveLine. The data accessed can be in text files, Models, or a SQL DB. A .tnl file can be used anywhere a .mdl file is used.

.tpl
A multiple-use file extension used for Diver Application and Report templates as well as Toolbar settings.

- Application templates are used to save custom Diver user settings.
- Report templates are used to store custom settings for later use in Report Markers.
- Customized Diver Toolbar settings, are saved in C:\windows\diver.tpl.
Chapter 2
Diver Basics

Locating Diver

The location of Diver will vary, depending on whether the stand-alone DI-Diver or the server-based ProDiver is being used.

- If using stand-alone Diver, the executable (\diver.exe) will be located in DI_Solution\executables.
- If using ProDiver, the executable (\prodiver.exe) will be located in DI_ProDiver.

Alternatively, the software may be launched from a desktop shortcut if the application resides somewhere other than one of the locations listed above.

Diver is represented by the icon shown below:

Please contact your Diver administrator if you are unable to locate Diver according to either of the methods above.
Starting Diver

Once located, double-click the executable or desktop icon to start using Diver.

When using ProDiver rather than DI-Diver, you may be prompted to enter the DiveLine server name and port number (if running on a port other than the default 2130) the first time the program is run. If this information is unknown, please contact your Diver administrator.

In some environments, running the software for the first time will result in an Open File Security Warning. To prevent this warning in the future:

1. Right-click the Diver executable.
2. Select Properties.
3. Click the Unblock button on the bottom of the General Tab.

These steps do not work on Diver shortcuts. They must be done directly on the Diver executable.

Opening Files

The Open File dialog box in DI-Diver is similar to that of other Windows applications, while opening a file in ProDiver is slightly different.

In Diver, the dialog displays the accessible Windows directory structure, allowing you to browse to and locate the file to open.

In ProDiver, accessible directories and files are controlled by Dimensional Insight’s client/server software, DiveLine. Before you can open a particular file, your DiveLine administrator must configure the server to allow access to that file. If you attempt to open a file you do not have access to, a “Permission Denied” error will be displayed.

Your DiveLine administrator will also assign a top-level directory for each DiveLine server. The desktop application, ProDiver, will only be able to see files that are contained within or under this directory, or those accessible via aliased directories.
File Naming Conventions

The formats of all Diver file types are compatible across all supported platforms. In a mixed environment, the file names should be consistent and you should be aware of upper- and lowercase differences.

Although any letter or number can be used, there are some characters that should be avoided in filenames. These include tabs, more than one period, or any of the following: [] <> / " : | , ? * + . It is not advisable to use a number as the first character of a filename.

The UNIX file system does not allow slashes (/) to appear in filenames, and the maximum length of UNIX filenames will vary with the particular implementation. Spaces in filenames should also be avoided.

File Types

Diver uses the following types of files:

<table>
<thead>
<tr>
<th>Table 2-1: Basic Diver File Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Type</strong></td>
</tr>
<tr>
<td>Models</td>
</tr>
<tr>
<td>DivePlans</td>
</tr>
<tr>
<td>Markers</td>
</tr>
<tr>
<td>DiveBooks</td>
</tr>
<tr>
<td>Reference Links</td>
</tr>
<tr>
<td>Tunnel files</td>
</tr>
<tr>
<td>QuickView Set</td>
</tr>
</tbody>
</table>
If **All Files (*.*)** is selected in the **Files of type** pulldown, the file types currently available for Diver will be displayed.

**Model** - The basic Diver file is a called a Model (.mdl). It contains all the data users will dive on. The Model is created by either the Builder, DI-Diver’s Memory Builder, or a tunnel script using an organization’s collection of data, and will generally be the largest file used by Diver. There may be one large Model based on all company data, or there may be several smaller Models built from the same database or from multiple databases. For more information on building Models in DI-Diver, see **Chapter 12, Building a Memory Model**. For more information on creating Models, refer to the separate **Builder** manual.

There may be additional files in the same directory as the Model(s), bearing names like build.jou, builder.log, bucket0.txt file or *.dic. These files are relevant to building Models, but are not required for using them.
In cases where a Model is very large, there may be additional files with names ending in .md0, .md1, .md2, etc. These are called Continuation Models and are expansions of the original .mdl file. For example, sales.mdl may also have a sales.md0, sales.md1, and sales.md2 file with it. These should not be deleted as they are required to use the original Model.

**DivePlan** - A DivePlan (.dvp) is used to save any additional display settings for viewing a Model. It contains no data, only instructions telling Diver how to present the data. It records the set of columns that is to be displayed in a tabular window, the definitions of calculated fields, Dynamic Dimensions, Named Groups, Lookup Tables, Models, Geocoding, Categories in the Console, and MultiModel merge instructions. See Chapter 9, DivePlans & Calculations for details about editing DivePlans.

Some of the information in a DivePlan may be set in DI’s DiveMaster application, rather than in Diver.

When a saved DivePlan is opened, it is loaded into Diver along with its associated Model(s). If the DivePlan is moved to a different directory, Diver will prompt for the location of the needed Model(s).

If the DivePlan file only references one Model, has the same name as that Model, and is in the same directory as the Model, opening the .mdl file will automatically open the DivePlan.

**Marker** - A Marker (.mrk) saves the specific details of a Dive Window(s), as well as all current DivePlan information. Size, position, selections, fonts, focus, orientation (horizontal vs. vertical), and QuickView order are included in the Marker. In addition, Markers contain a record summarizing all the actions taken in a dive. Later, the Marker can be reopened in Diver to display the saved dive. Markers do not contain actual data; therefore, if the Model is updated, and a previously saved Marker is opened, Diver will show the same dive as before, but with the data from the updated Model.
In versions of Diver prior to 6.0, Markers were designed to save the final state of the dive. This allowed rapid return to data in the final Dive Window; however, that meant that multiple finds, groups, focuses, etc. were not saved in order, causing Markers to be reopened with an occasional difference in the final result. In Diver 6.0 and later, Markers are saved as steps and each step is executed in the exact order that it was done in the original dive, resulting in the expected display of data. Any Markers that were created in version 5.1 or earlier will still open, but must be recreated in 6.0 or later to take advantage of this functionality. Markers created in version 6.0 or later will not open in Diver 5.1 or earlier.

When using multiple dives (Dive A, B, C, or D), all active dives may be saved in the Marker. For more information, see Saving a Marker on page 3-7.

**DiveBooks** - A DiveBook (.dbk) organizes DivePlans and Markers so they are easy to access, and lets users arrange files using titles that are free from the length and character restrictions that filenames impose.

DiveBooks are divided into **Areas**, similar to folders, and **Topics**, similar to files, contained within each Area. When opened, each of the Areas contained within the DiveBook, and the Topics within each Area, are displayed. A Topic can be a DivePlan, Marker, or Link to an external file, and can be opened by double-clicking it, or highlighting it and clicking OK.

When saving a DivePlan or a Marker, you have the option of saving it to a file or saving it as part of a DiveBook. To save the DivePlan or Marker to a DiveBook, select **File > Save Marker > To DiveBook** or **File > Save DivePlan > To DiveBook**, enter a name for the Topic (Topic names do not need to be in the same format as file names), and select the Area in which to put it. If the desired Area does not exist yet, it can be created when the Marker or DivePlan is saved.

The DiveBook must be saved separately to preserve changes such as saving a DivePlan or Marker into it.
Below is a sample DiveBook set up with Markers organized by type. The *Tabulars* Area (shown selected in the left column) contains two Topics (shown in the right column): “Top 10 Salespeople: Revenue” and “CrossTab: Profit”.

In the DiveBook, when a Topic that contains a Marker with a comment is selected (such as in the above example), the information about the Marker will appear in the Topic Info area in the lower portion of the DiveBook Select dialog box.

DI-Diver can be configured to open a particular DiveBook at startup. For instructions on setting a default DiveBook in DI-Diver, see Default DiveBooks on page 13-14.

ProDiver can also open a DiveBook at startup; however, this default must be set by the DiveLine administrator.

Additional information on creating and modifying DiveBooks can be found in Chapter 8, *DiveBooks*.
**Reference Links** - Report Palettes are used to gather data and links from different places into one window, allowing comparisons among Models. Report Palettes are saved as Markers. In addition to saving a full Palette as a Marker, Reference Links from the Palette can be saved to a file. They have a `.ref` extension. Reference Link files allow Diver to read a specified link, open the correct Models, do the specified dives, etc., upon opening the file. For more information, see Setting Reference Link Files on page 11-29.

**Tunnel** - Tunnel (.tnl) refers to a capability of DiveLine to create a memory Model in the client on demand. DiveLine, through a Tunnel script, can filter back-end data based on user selections, and can provide access to real-time data.

When a user invokes a Tunnel file, DiveLine runs a DI Object Language script containing a Tunnel output object. The output object indicates what data should be returned to the client as a memory Model, as well as which columns should be Dimensions, Summaries, and Info Fields. The Tunnel script might access data contained in text files, physical Models, or a SQL database, and can use the same objects as the Data Integrator to process this data.

When opening a Tunnel file, DiveLine executes the given script, reads the data returned by the Tunnel object, and constructs a memory Model that is then opened. A Tunnel file can be used in the same way a Model file can be used; in DivePlans, MultiModels, Markers, or DiveBooks.

**QuickView Sets** - In previous Diver versions, there has been considerable maintenance required to have similar groups of QuickViews in multiple Markers. Adding a QuickView or changing any attribute of a QuickView required changing every Marker.

With QuickView Set files (.qvs) you can store related QuickViews for later use. Markers can refer to the QuickView Set file, and if the file changes, they will automatically use the new QuickView Set.
The Diving Process

Diving is the process of displaying data in progressively more detailed views of smaller ranges of information in a Model. There are no predefined paths or hierarchies: one dives into the data Model with total navigational freedom. There is no limit to the number of steps in a dive. Diving is performed by double-clicking on Dimension names in the Diver, NetDiver or CellDiver Console, as follows:

1. Open a Model, in this example, demo_drl.mdl.
2. In the Console, double-click a Dimension, in this example, Sales Region.

A new window, called a Dive Window, will appear on the left side of the Diver interface. This window contains the data to view.
3. In the Dive Window, single- or double-click any value, for example, “Boston”.

<table>
<thead>
<tr>
<th>Sales Region</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Totals</td>
<td>35,385,685</td>
<td>714,715,545.34</td>
<td>761,795,141.51</td>
</tr>
<tr>
<td>Boston</td>
<td>9,920,822</td>
<td>200,459,544.75</td>
<td>243,736,971.77</td>
</tr>
<tr>
<td>North</td>
<td>4,970,256</td>
<td>85,087,727.43</td>
<td>107,058,254.43</td>
</tr>
<tr>
<td>Rhode Island</td>
<td>6,979,103</td>
<td>140,286,674.34</td>
<td>150,127,475.22</td>
</tr>
<tr>
<td>South Shore</td>
<td>5,818,596</td>
<td>117,418,471.38</td>
<td>125,336,155.71</td>
</tr>
<tr>
<td>Southwest</td>
<td>4,436,868</td>
<td>90,927,318.56</td>
<td>95,360,915.40</td>
</tr>
<tr>
<td>West</td>
<td>3,260,040</td>
<td>66,554,008.39</td>
<td>70,135,457.90</td>
</tr>
</tbody>
</table>

4. In the Console, double-click another Dimension, Product Family, in this example.

<table>
<thead>
<tr>
<th>Product Family</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Totals</td>
<td>9,920,622</td>
<td>200,459,544.75</td>
<td>213,736,571.77</td>
</tr>
<tr>
<td>Butter</td>
<td>1,519,657</td>
<td>32,177,540.07</td>
<td>32,423,356.63</td>
</tr>
<tr>
<td>Cheese</td>
<td>1,852,913</td>
<td>39,345,787.23</td>
<td>43,104,384.20</td>
</tr>
<tr>
<td>Cottage Cheese</td>
<td>135,300</td>
<td>3,354,679.24</td>
<td>4,220,656.01</td>
</tr>
<tr>
<td>Cream</td>
<td>527,577</td>
<td>11,993,779.66</td>
<td>12,335,386.59</td>
</tr>
<tr>
<td>Cream Cheese</td>
<td>124,478</td>
<td>2,540,367.32</td>
<td>2,683,676.80</td>
</tr>
<tr>
<td>Eggnog</td>
<td>456,966</td>
<td>9,742,575.06</td>
<td>10,115,220.98</td>
</tr>
<tr>
<td>Ice Cream</td>
<td>1,209,642</td>
<td>33,293,700.61</td>
<td>39,573,666.55</td>
</tr>
<tr>
<td>Milk</td>
<td>2,424,518</td>
<td>51,328,654.65</td>
<td>52,185,149.27</td>
</tr>
<tr>
<td>Yogurt</td>
<td>930,657</td>
<td>16,012,463.57</td>
<td>20,082,761.74</td>
</tr>
</tbody>
</table>

The result is a two step Dive, in which you have chosen to see Product Family data for the Boston Sales Region. This process is central to using Diver.
How Diving Works

- **An initial set of data from which Diver will retrieve a subset.**

  The first dive is done from the entire Model. Later dives begin with only a subset of the data, determined by the active window at the time of the subset dive (see Using the Dive Selector on page 2-15). For example, an initial Dive Window might contain all data relevant to Salespeople. This data can be further narrowed by selecting one value of the displayed Salesperson data and diving further.

- **The name of the Dimension to dive on.**

  The Dimension that you dive on determines the data that will be displayed in the resulting Dive Window. Continuing the example above, you may wish to dive on Product Name to display only Product Name data relevant to the selected Salesperson value. To choose a Dimension, double-click on the Dimension’s name in the Console window, making sure that it has a downward arrow to the left of it. If there are no arrows next to the Dimensions in the Console, then first narrow the initial data set by clicking a row in the Dive Window.

Below is the two-step dive example represented schematically:
The following figures show the same two dives as in the preceding schematic example; however, they are displayed within tabular windows (the default display type for Diver). The first dive is on Salesperson.

The value Baker is selected, and the second dive is on Product Name. The completed dive below answers the question, “How much of each **Product** was sold by the **Salesperson Baker**?”
Notice the History region in the Console (refer to Understanding the Console on page 2-14 to locate this region). This area displays the Dimensions Salesperson:Baker and Product Name, and the two Dive Windows are titled Salesperson and Product Name. Salesperson was the first dive, which opened an initial Dive Window. Baker was then selected from that Dive Window and a second dive was performed on Product Name.

A Status Bar (shown below) in the lower left of the Diver application provides useful window-specific information based on the current view. For example, the status bar in the example dive above would read 108 Rows (Totals -15). These numbers indicate that there are 108 rows in the active Product Name Tabular window and that rows Totals through 15 are being viewed.

If you scroll down, the status updates as needed. For example, scrolling three rows would show 108 Rows (3-18).

While diving or rendering a report, a progress bar will appear to the left of the status bar, letting you know the percentage of the requested work that is complete.
Understanding the Console

The Console is the main navigational window in Diver. From the Console, you will dive, view information about current dives, and view Dimensions.

The Console is similar to the tree structure of Windows Explorer. Plus (+) and minus (-) signs expand and collapse each heading to show or hide information under that heading. If necessary, the window will have horizontal and vertical scroll bars to display information that extends beyond the right and/or bottom edge of the Console window. If a Dive Window covers the Console, click the Show Console button or select Window > Show Console to redisplay the Console.

Using Console Areas

The Console consists of the following areas:

- Dive Selector - assigns letter values to multiple dive paths, allowing you to switch from one dive to the another
- History - displays all current information and actions taken in a particular dive
- Models - displays the names of all open Models, and the Categories, Dimensions, and Detail Dimensions contained within each Model
- Totals - provides numeric information and other statistics for the selected data
- Info - displays Info Field data corresponding to Dimension Values in the current Dive path
- Time Series Info - provides information about Time Series and Period Comparisons
Using the Dive Selector

Diving is the process of using Diver to filter data in order to create a parent-child relationship. Each Dive path can be associated with a particular Dive letter (A, B, C, D), and the Dive Selector tabs allow you to assign letter values to each dive. Dive A can be used for all dives, as in the examples in this manual, but you may find that you want to perform independent dives from the same Model, or from a different Model. If the Dive Selector tabs are used to assign dive letters to each dive, multiple Dive paths can be present concurrently.

When selecting dives from the Dive Selector tabs, the Console switches among the Dive paths associated with each dive letter and displays the corresponding active Dive Window in the foreground.

When using the Dive Selector, keep the following points in mind:

- Diver allows a maximum of **four** concurrent Dive paths to be open at a time; one in each tab on the Dive Selector (Dive A, Dive B, Dive C, and Dive D). If Dives A through D are all in use, and you try to start a new dive, you will get the error “No Open Dives”.

- Only **one** Model or DivePlan may be used for diving on each Dive Selector tab. You can use either the same Model, or a different one, on each tab.

  The exception is when jumping from one Model to another within the same dive. For more information on Jump functionality, please see Jumping Between Models on page 2-26.

- If Model QuickViews are in use, changing a QuickView value affects all open Dive paths.
**Viewing the Console History**

The History area appears at the top of the Console and displays all the current information and actions taken in a particular dive. In the example above, the parentheses after the word History contain the name of the Model you are diving in. If there is no current dive, the History region will be empty and the parentheses will read “None”.

The History area above shows a two-level dive on **Salesperson** and **Product Name** in `demo_drl.mdl`, as follows:

- The first Dive displays a list of all Salespeople, indicated as Salesperson in the History.
- In the Salesperson Dive Window, Baker is selected, indicated as Salesperson:Baker in the History.
- The second Dive lists the names of all products sold by Baker, indicated as Product Name in the history.

Double-clicking a value in the Product Name Dive Window, such as 1% Milk Gallon, would add Product Name: 1% Milk Gallon just below Product Name in the History.

Double-clicking on a Dimension line in the dive History, such as Salesperson, will activate the corresponding Dive Window and bring it to the foreground.
While multiple Models can be open at once, only one Model name will appear in the History region, because for each Dive Selector tab (Dive A, Dive B, Dive C, or Dive D), only one Model or DivePlan can be used at a time. When using jump, only the name of the starting Model will display in the History.

Diving into Models

Below the History area is the Models area. The Models area consists of the names of all open Models, and the Categories, Dimensions, and Detail Dimensions contained within each Model. Under each Model, Categories may be listed, and within each Category, related Dimensions will be listed. Detail Dimensions are also listed if a Detail Model is open. A plus sign (+) indicates that there is information under a particular Category, while a minus sign (-) indicates that the Category is expanded and all information is visible.

A Model might not contain Categories. If this is the case, only Dimensions will appear under the Model name.
Diving is done by double-clicking Dimension names. In the Console above, if you were to double-click the Dimension **Customer Name**, a new Dive Window would be displayed that would list the names of all customers in the Model.

In this example, Categories have been set in the DivePlan for Sales, Products, Customers, and Time. Categories organize the Model’s Dimensions. Customer and Customer Name are Dimensions in the Customers Category, while Sales Region and Salesperson are Dimensions under Sales, and so on. All Dimensions that are not included in specifically named Categories are contained within a default Category called **Other Dimensions**. In the example above, all Detail Dimensions are included in the Other Dimensions Category.

The **Models** are the “spheres of data”, and are labeled in the Console with red circular icons, as shown here:

Multiple Models can be open at once, however, only you can only dive in one Model for each Dive Selector tab (Dive A, Dive B, Dive C, or Dive D). Additionally, the number of Models that can be simultaneously opened is set as a Diver preference, and may be limited (see the Auto Close setting on page 13-8). The Console above has three open Models: `demo_drl.mdl`, `daily.mdl`, and `sales.mdl`. A single Model can be closed by selecting its name in the Console and using the **File > Close** command, or by right-clicking it and selecting **Close Model**. All Models can be closed at once by highlighting the “Models” header, and right-clicking to select **Close All Models**.
If a Model’s Dimensions are grouped into **Categories**, each will be labeled with a gray folder, as shown in the example below.

Categories are most useful when used to organize a large number of Dimensions. They are an optional feature and are added to a DivePlan using the Diver Solution DiveMaster module.

**Dimensions** contain the values used to answer business questions. If a dive has been performed, the selected Dimension will appear in the History region (Salesperson in the example below).
The Dimensions in the Dive Area of the Console are available for further diving if they have a downward-pointing arrow on the left-hand side of the Dimension name. In this example, all Dimensions are diveable.

After the initial dive on Salesperson, Bailey was selected in the Dive Window with a single click, in order to narrow the data to only that pertaining to Bailey (as indicated in the History area). A double click on Bailey will produce **DimCounts** in the Console, displayed as a number in parentheses to the right of the Dimension name.

A DimCount is the number of unique values that remain for each Dimension, relative to a particular value of another Dimension. For example, Salesperson was the first Dimension selected above. From the Salesperson Dive Window, Bailey was selected. When Bailey is double-clicked, the number of unique remaining items that apply to Bailey for each Dimension are displayed in parentheses next to that Dimension. In the image above, there is information for Bailey on 11 Customers, 9 Product Families, 109 Product Names, etc.

If Access Control Lists (ACLs) are being applied by DiveLine to limit multiple values that you can see, this security is reflected in the Console, and the DimCount changes to “Group”.

When a Model is created using the Builder, data is pre-sorted in such a way that it is easily retrievable using Diver. Detail Builder (an option of Builder) takes this one step further by preparing detail data so you have access to that information through Diver, in a hierarchical manner.
Diver can be used to retrieve detail data from a Model that has been created with the Detail options in Builder. What this means is that once the data has been narrowed to 256,000 records or fewer by diving using the Dimensions listed under the Model name, detail-level information can be accessed. The plus sign (+) next to Detail will also have a green box next to it when the detail level data is available for diving. Click on the plus sign to see all Detail Dimensions in the Model.

Detail-level data can be treated as a regular Dimension, and will behave in the same way, meaning that it is diveable and cascadeable (below 256,000 records) using the Detail area of the Console.
Once a dive has been done on detail-level Dimensions, it is not possible to switch between detail-level Dimensions and non-detail-level Dimensions in the same dive.

When a dive is narrowed to the detail level, double-clicking on the green box next to Detail in the Console will result in a MultiTab window containing all the Dimensions and Summaries of the detail data. This window is often referred to as a Detail Dump (shown below). You cannot dive in this window or change the display type; however, you can sort on any column.
Referencing the Totals Area

The **Totals** area provides numeric information and other statistics for the selected data. For instance, when using a scatter chart, the $x$ and $y$ location of the selected point will be displayed in the Totals area. In the example below, a point on the scatter chart is double-clicked, and the Cost ($x$) and Revenue ($y$) values that correspond to that point are displayed in the Totals section. Totals are calculated when the Model is created.
Obtaining Additional Information

The Info area of the Console displays Info Field data corresponding to Dimension Values in the current Dive path. The sample Console below shows the Info Field “Address1” for the Customer “608 -- JLA Distributors Inc”. If the Model had contained information for any of the other Dimensions in the dive, it would also be displayed. If nothing is selected in the current Dive Window, the Info area will be blank. If there is a single Dimension Value selected in the current Dive Window, it will be displayed as the first line in the Info section.

When a Model is open but no dives have occurred, the Info section of the Console will display each Info Field built into the Model and the Dimension it is associated with. For example, if no dives had been performed in the previous example, the Info area would display Address1: Customer and SIC Code: SIC Description as shown below:

That is, Address1 is an Info Field associated with Customer, while SIC Code is an Info Field associated with SIC Description.

If an underlying Dive Window is brought to the foreground (by clicking on its title bar, or by double-clicking the Salesperson dive in the History region), the Info section will update accordingly.
Viewing Time Series Info

The **Time Series Info** area appears at the bottom of the Console and provides information about Time Series and Period Comparisons. It serves several purposes.

First, the Time Series Info region displays the time-based Dimension the comparison is based on, such as Date, Month, or Quarter. Second, it tells you when a defined Period starts and ends. In this example, the time-based Dimension is Date, and it begins January 1, 2004 and ends June 30, 2004. Third, the Time Series Info region displays the comparison being made, such as Current vs. Prior, Year-to-Date vs. Last Year-to-Date (YTD vs. Last YTD), Month-to-Date vs. Last Month-to-Date (MTD vs. Last MTD), etc. In this example, the periods being compared are **YTD** (Year-To-Date) and **LYTD** (Last Year-To-Date). Lastly, the Time Series Info region lists the Built Columns and Data Columns being compared. For more information on each of these Time Series columns, please see **Chapter 10, Time Series & Period Comparison**.
Using Additional Console Features

In addition to the areas described in the previous section, these additional Console features are available:

- Jump
- Console Docking
- Console Resizing
- Console Context Menu

Jumping Between Models

When two different Models are open within Diver, and both Models have a Dimension of the same name, Diver will indicate this with a red arrow in the second Model listed, and allow you to jump between Models. Use jump to quickly access complimentary data in another Model.

Jump is considered a single, cascading dive (Dive A) (see Cascade Diving on page 4-30), and is saved in the Marker as such. In addition, the chosen Dimension Value is now grouped when the jump is done. Both behaviors are demonstrated below.

1. Open at least two Models that have some or all of the same Dimensions and dive in the first Model (on Sales Region, for example).

2. Select a row (or group).
3. A red “Dive Arrow” appears next to the same Dimension in the second Model, as shown in the Console below.
4. Double-click on the arrow to jump.

The jump now appears in Dive A as a new Dive Window, and the jump value is automatically grouped for further diving. For a jump, the second Model will not filter according to the common Dimension Value selected in the pre-jump Dive.

When using the jump feature, please remember the following:

- The red arrow appears in the first Model, rather than in the second Model, after the jump is performed, to indicate that a jump can be performed back.
- Multiple Models (more than two) can be used for the jump functionality.
Docking the Console

As a Diver user, you can choose whether you would like the Console to appear on the right (default), or the left. The Console can be moved to either the left or right side by clicking in it and holding the left mouse button, dragging, and releasing it on the opposite side of the Diver workspace. While dragging, an indicator will not be displayed. The chosen setting will then be saved in Markers and in the `diver.ini` file for future Diver sessions.

Resizing the Console

The width of the Console window can be changed by positioning the mouse over the edge of the Console until the pointer changes to a resize arrow, clicking and holding the left mouse button, then dragging to the desired width. If the Console is docked on the right side of the Diver interface, the left edge must be dragged. If the Console is docked on the left side of the Diver interface, the right edge must be dragged.

Using Console Context Menu Items

Seven context menu items are available in the Console. These are:

- Close Model
- Close All Models
- Delete Action
- Find Before Dive
- Create Model QuickView
- Edit Model
- Save Model

The Close Model menu item allows you to close a Model without having to use the File menu. In order to close an open Model, right-click on the Model name and select Close Model.
The **Close All Models** menu item allows you to close all open Models without selecting and closing each Model individually. To do so, right-click the word “Models” in the Console and select Close All Models from the context menu.
Delete Action allows you to delete actions performed on any open Dive Window from the dive history. For example, if you wish to remove a Find, Focus, or Group done in the dive path, it can be removed using this context menu item, as shown below:

While rewriting dive history can be useful, please note that deleting any actions early in the Dive path could result in a “Tabular Window Missing Data” message in any child Dive Windows below that action.
Find Before Dive... allows you to open a Find window and specify Find criteria before the dive is performed. To do so, select a Dimension name in the Console, right-click it, and select Find Before Dive...

This is especially useful when diving on Dimensions with several thousands of values as it allows you to narrow your search before the dive, saving valuable time in data display. It also allows for saved Markers that use the functionality to be reopened quickly. The options in Find Before Dive... are a subset of the Find Functionality (see Using the Find Functionality on page 3-26).
Right-click any Dimension and select **Create Model QuickView** to instantly create a QuickView for that Dimension. The pulldown QuickView created contains any Named Groups created on the selected Dimension, and does not have a Go button. For more information on Model QuickViews, see *Chapter 7, QuickViews.*

QuickViews created using this feature do not establish any dependencies. Care must be taken if multiple QuickViews are present, or if you intend to cascade from parent Dive Windows; otherwise empty windows can result.
If a Memory Model has been created, right-click Memory.mdl to access a context menu with 2 additional options.

- **Edit Model** - modify the selected Memory Model
- **Save Model** - save the selected Memory Model.

More information on creating Memory Models can be found in Chapter 12, Building a Memory Model.
Using the Diver Toolbar

The toolbar, shown above, allows for fast access to the most commonly used features of Diver. When a feature is not available for use, it will be grayed out.

If you hover the mouse over each button, in addition to the tool tip, a more extensive functional description of each button appears in the status bar at the bottom of the Diver window. For example, if you hover over the Tabular button, the status bar displays:

```
Tabular - Reverts the current display to the most recent basic Tabular in the dive path.
```

All features on the toolbar can also be accessed from the Diver menus. The list below shows the toolbar buttons, starting from the left side, and lists the matching menu item. Each feature is described in more detail in Chapter 3, Menus.

Diver is delivered with functionality that allows the Diver administrator to customize the interface. This customization may include the deletion of menu items and toolbar buttons. These functions are controlled by Application Templates and QuickViews.
The Default Toolbar Buttons

The following are the buttons that appear on the default Diver toolbar. Each item is further explained in Chapter 3, Menus:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>![Undo Icon]</td>
<td>Allows you to undo the last action. The corresponding menu item is <strong>Edit &gt; Undo</strong>.</td>
</tr>
<tr>
<td>Redo</td>
<td>![Redo Icon]</td>
<td>Allows you to redo the last undone action. The corresponding menu item is <strong>Edit &gt; Redo</strong>.</td>
</tr>
<tr>
<td>Open File</td>
<td>![Open File Icon]</td>
<td>Opens any type of Diver file. The corresponding menu item is <strong>File &gt; Open</strong>.</td>
</tr>
<tr>
<td>DiveBook</td>
<td>![DiveBook Icon]</td>
<td>Opens a DiveBook. The corresponding menu item is <strong>Window &gt; DiveBook</strong>.</td>
</tr>
<tr>
<td>Print</td>
<td>![Print Icon]</td>
<td>Prints the active window. The corresponding menu item is <strong>File &gt; Print</strong>.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>![Print Preview Icon]</td>
<td>Opens the Print Preview dialog. The corresponding menu item is <strong>File &gt; Print Preview</strong>.</td>
</tr>
<tr>
<td>Tabular</td>
<td>![Tabular Icon]</td>
<td>Switches the active window to a Tabular view. The corresponding menu item is <strong>Display &gt; Tabular</strong>.</td>
</tr>
<tr>
<td>MultiTab</td>
<td>![MultiTab Icon]</td>
<td>Allows you to create a MultiTab in the active window. The corresponding menu item is <strong>Display &gt; MultiTab</strong>.</td>
</tr>
<tr>
<td>CrossTab</td>
<td>![CrossTab Icon]</td>
<td>Opens the CrossTab dialog, allowing you to create a CrossTab view using the active window. The corresponding menu item is <strong>Display &gt; CrossTab</strong>.</td>
</tr>
<tr>
<td>MultiCrossTab</td>
<td>![MultiCrossTab Icon]</td>
<td>Opens the MultiCrossTab dialog, allowing you to create a MultiCrossTab view using the active window. The corresponding menu item is <strong>Display &gt; MultiCrossTab</strong>.</td>
</tr>
<tr>
<td>Report</td>
<td>![Report Icon]</td>
<td>Opens the Report dialog, allowing you to create a report from the active window. The corresponding menu item is <strong>Display &gt; Report</strong>.</td>
</tr>
</tbody>
</table>
### Table 2-2: The Default Diver Toolbar

<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphs</td>
<td>![Graphs Icon]</td>
<td>Opens the Graphs dialog, allowing you to create a graph from the active window. The corresponding menu item is <strong>Display &gt; Graphs</strong>.</td>
</tr>
<tr>
<td>Flip Axes</td>
<td>![Flip Axes Icon]</td>
<td>Flips the x and y axes of the active window. The corresponding menu item is <strong>Organize &gt; Flip Axes</strong>.</td>
</tr>
<tr>
<td>Focus</td>
<td>![Focus Icon]</td>
<td>Allows you to select multiple items in the active window, and focus attention on just those items. The corresponding menu item is <strong>Organize &gt; Focus</strong>.</td>
</tr>
<tr>
<td>Group</td>
<td>![Group Icon]</td>
<td>Allows you to select multiple items in the active window, and view those items as a single group. The corresponding menu item is <strong>Organize &gt; Group</strong>. Once Focus or Group has been used, clicking the Focus or Group buttons again will undo the action. At that point, the corresponding menu items would read <strong>Organize &gt; Stop Focus</strong> or <strong>Organize &gt; Stop Group</strong>.</td>
</tr>
<tr>
<td>Sort Up</td>
<td>![Sort Up Icon]</td>
<td>Allows you to sort up on the selected column. The corresponding menu item is <strong>Organize &gt; Sort Up</strong>.</td>
</tr>
<tr>
<td>Sort Down</td>
<td>![Sort Down Icon]</td>
<td>Allows you to sort down on the selected column. The corresponding menu item is <strong>Organize &gt; Sort Down</strong>.</td>
</tr>
<tr>
<td>Find</td>
<td>![Find Icon]</td>
<td>Opens the Find dialog, allowing you to specify find criteria for the active window. The corresponding menu item is <strong>Edit &gt; Find</strong>.</td>
</tr>
<tr>
<td>Time Series</td>
<td>![Time Series Icon]</td>
<td>Opens the Time Series dialog, allowing you to create a Time Series on a date Dimension. The corresponding menu item is <strong>Edit &gt; Time Series Control Panel</strong>.</td>
</tr>
<tr>
<td>Period Comparison</td>
<td>![Period Comparison Icon]</td>
<td>Opens the Period Comparison dialog, allowing you to create a Period Comparison on a date Dimension. The corresponding menu item is <strong>Edit &gt; Period Comparison</strong>.</td>
</tr>
<tr>
<td>Hide/Show Console</td>
<td>![Hide/Show Console Icon]</td>
<td>Displays or hides the Console from view. The corresponding menu item is <strong>Window &gt; Hide/Show Console</strong>.</td>
</tr>
</tbody>
</table>
The toolbar may be configured by each user to position the tool buttons in a preferred order. These settings are stored in the file \C:\Windows\diver.tpl.

## Additional Toolbar Buttons

The following are buttons that are not included on the default toolbar, but are available through the **Window > Toolbars...** Modify Toolbar dialog box:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Excel</td>
<td><img src="image" alt="Save Excel Icon" /></td>
<td>Opens the <strong>Save window as...</strong> dialog with the CSV option already selected, allowing you to save the current dive window as a .csv file. Corresponds to the <strong>File &gt; Save Window...</strong> CSV option.</td>
</tr>
<tr>
<td>Save PDF</td>
<td><img src="image" alt="Save PDF Icon" /></td>
<td>Opens the <strong>Save window as...</strong> dialog with the PDF option already selected, allowing you to save the current dive window as a .pdf file. Corresponds to the <strong>File &gt; Save Window...</strong> PDF option.</td>
</tr>
<tr>
<td>Build Model</td>
<td><img src="image" alt="Build Model Icon" /></td>
<td>Opens the Build Source - New Model dialog, allowing you to build a memory Model. The corresponding menu item is <strong>File &gt; Build Model...</strong>. If this button is grayed out, the Build function in DI-Diver has been disabled. This option is not available in ProDiver.</td>
</tr>
<tr>
<td>Bar Plot</td>
<td><img src="image" alt="Bar Plot Icon" /></td>
<td>Opens the Graph dialog directly to the Bar Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Basic Plots &gt; Bar Plot</strong>.</td>
</tr>
<tr>
<td>Cross Bar Plot</td>
<td><img src="image" alt="Cross Bar Plot Icon" /></td>
<td>Opens the Graph dialog directly to the Cross Bar Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Basic Plot &gt; Cross Bar Plot</strong>.</td>
</tr>
<tr>
<td>Line Plot</td>
<td><img src="image" alt="Line Plot Icon" /></td>
<td>Opens the Graph dialog directly to the Line Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Basic Plot &gt; Line Plot</strong>.</td>
</tr>
</tbody>
</table>
Table 2-3: Additional Toolbar Buttons

<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cross Line Plot</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Cross Line Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Basic Plot &gt; Cross Line Plot.</strong></td>
</tr>
<tr>
<td>Stack Plot</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Stack Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Stack Plots.</strong></td>
</tr>
<tr>
<td>Scatter Plot</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Scatter Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Scatter.</strong></td>
</tr>
<tr>
<td>Pie Graph</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Pie Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Pie Plots.</strong></td>
</tr>
<tr>
<td>Map</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Map option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Maps.</strong></td>
</tr>
<tr>
<td>Calendar</td>
<td>![Icon]</td>
<td>Opens the Graph dialog directly to the Calendar Plot option. The corresponding menu item is <strong>Display &gt; Graphs &gt; Calendar Plots.</strong></td>
</tr>
<tr>
<td>Show/Hide Info Window</td>
<td>![Icon]</td>
<td>Displays or hides the Info Window from view. The corresponding menu item is <strong>Window &gt; Show Info Window.</strong></td>
</tr>
</tbody>
</table>

If any of the additional buttons described above have been added to the Toolbar, and you no longer want those buttons to appear, they can revert to the default Toolbar. To reset the toolbar to default, right-click an open area of the Toolbar to open the Toolbar context menu and select the “Revert to Default” option.
Rearranging Dive Windows

The active Dive Window is the front-most window displayed, and is not necessarily the one most recently created. The example below shows a two-level dive, first on Salesperson, then on Product Family, where Salesperson has been brought back to the foreground.

By rearranging these Dive Windows, you can dive from an older window in order to “back up” before continuing the Dive path (unless the Group function is being used). In this example, you can select a new Salesperson to update the Product Name data for the newly selected value. This is called a cascade.
There is more than one way to choose a new active window. First, you can double-click on the appropriate line in the Console History area. Notice the top section of the Console window shown below.

![Console window with Dive history]

The History Area of this Console includes the window **Salesperson** and the window **Product Family**. By double-clicking on the Salesperson line, the Salesperson Dive Window is brought to the foreground, as shown on the previous page and becomes the active window. To make Product Family the active window again double-click the Product Family line in the History. Another way to bring a previous, or “parent” Dive Window to the front is to click in the Dive Window title bar with the mouse. More recent, or “child” Dive Windows may need to be moved to uncover the desired window title bar.

The final way to activate a previous window is to close all newer windows. Click the red “x” in the upper-right corner of any Dive Window to close it and to clear it from the Console History area. If any window but the most recent is closed, all child windows that came later in the Dive path will also be closed.
Many selections in Diver can be performed using the keyboard:

### Table 2-4: Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>down arrow (↓)</td>
<td>If no row label is selected, selects the top row label. Also moves the selection down to other row labels or down within cells.</td>
</tr>
<tr>
<td>up arrow (↑)</td>
<td>Moves the selection up to other row labels, or up within cells.</td>
</tr>
<tr>
<td>right arrow (→)</td>
<td>If no cell is selected, elects the next-to-left column’s label. Also moves the selection to other column labels or cells to the right.</td>
</tr>
<tr>
<td>left arrow (←)</td>
<td>Moves the selection to other column labels or cells to the left.</td>
</tr>
<tr>
<td>Shifted + (arrow key)</td>
<td>Extend a selection to include multiple row labels, column labels, row cells, or column cells.</td>
</tr>
<tr>
<td>Enter</td>
<td>Acts as a double-click on the selected label.</td>
</tr>
<tr>
<td>Shift+click</td>
<td>Selects multiple adjacent labels or cells.</td>
</tr>
<tr>
<td>Ctrl+click</td>
<td>Selects multiple non-adjacent labels or cells.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copies the selected text or cell</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Pastes the copied text or cell</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cuts the selected text or cell</td>
</tr>
</tbody>
</table>
Customizing the Diver Interface

ProDiver is delivered with functionality that allows the administrator to customize the interface from the server. They can also apply customization to a user’s stand-alone DI-Diver interface. This customization may include the deletion of menu items or toolbar buttons. In addition, the behavior of the software may be altered by the administrator in the following ways:

- A DiveBook may open automatically.
- User preferences may be overridden.
- Dive Windows may be locked so they cannot be moved or resized.
- When opening a Marker, Diver may request that a value be selected before it displays information.

These functions are controlled by Application Templates, prompted QuickViews, and DiveLine security. Additional information on Application Templates can be found in Chapter 13, Application Templates & Preferences, and more information on QuickViews can be found in Chapter 7, QuickViews. More on DiveLine security can be found in the DiveLine manual.
Using ProDiver and DiveLine

ProDiver is the client/server version of the Diver application. When you log into ProDiver, all security settings configured in DiveLine apply to that ProDiver session. The lower-right corner of the ProDiver application shows **Logged in as** information, which indicates the user name you are logged in as, as well as the DiveLine server name and port number you are connected to.

![Logged in as admin (sunflower:6100)](image)

This feature is especially helpful when using the **Proxy login as...** File menu option. For more information on Proxy login, see page 3-21.

Please note that there is a feature that allows your administrator to hide your login information. If you do not see this information, please ask your DiveLine administrator if this is the case.

DiveLine is Dimensional Insight’s server software component that enables flexible, scalable, centralized administration and security features for all users. It handles different levels of security so administrators can efficiently limit access to sensitive information.

When the administrator sets up user names in DiveLine, there may be properties specific to an individual user. For example, you may have the following settings:

- **A home directory** - a location where you will start when **File Open...** is selected.
- **A default search path** - the first path that DiveLine will use to look for Models referred to in Markers and DivePlans.
- **A default DiveBook** - a DiveBook that will open automatically when you successfully log into ProDiver.

DiveLine may monitor the version of ProDiver being used to connect to the server. If it is out of date, it may allow you to do one of the following:

- Connect using the older version.
- Update your version (using the provided update link) before allowing you to connect.
- Exit ProDiver without connecting to the server.
This chapter explains each of the items available from the six Diver menus:

- File
- Edit
- Organize
- Display
- Window
- Help

Some items may be explained in further detail in later chapters. In such cases, a reference to the detailed explanation will be provided.
Using the File Menu

The File menu, shown below, is similar to many File menus used in standard Windows applications. This menu controls the basic functions of the Diver application.

Actions performed from the File menu include:

- Opening, saving, and closing files
- Printing windows and reports
- Saving templates and QuickView Sets
- Setting user preferences
- Building Models (Diver only)
- Logging in to DiveLine (ProDiver only)
- Downloading Models (ProDiver only)
- Exiting the application
Opening Files

The **File > Open...** option opens supported file types in Diver. To display a different file type other than what is currently shown, choose the desired type from the **Files of type** pulldown. For a more detailed explanation of each type of file, refer to **File Types on page 2-3**.

Because ProDiver uses DiveLine’s security, if you try to open a Model or DivePlan you do not have access to, a “Permission Denied” error is displayed.
Using the Open File Dialog

The following standard Windows buttons can be found in the Open File dialog:

- Go To Last Folder Visited
- Up One Level
- Create New Folder
- View Menu (Change File List View in ProDiver)

In addition to the standard buttons, there is an Info button that activates when you highlight a Model or Marker in the files list. Click this button to display the Model Info dialog box:

If the selected file is a Model:

- The first line displays the name of the Model, `demo_drl.mdl` in this example.
- Build Time indicates the date and time that the Model was built.
- Comments displays any comments that were included in the Model at build time. Not all Models will have comments, but all will have a name and a build time.

If the selected file is a Marker, clicking the Info button will present a dialog that says “No info exists for this file”, unless optional text was entered when the Marker was saved. If text was saved in the Marker, it displays under Comments.

Click OK to close the Model Info dialog box and return to the Open File dialog box.

The ProDiver application has an additional Home button that replaces the Go To Last Folder Visited button found in DI-Diver. This button returns you to your Home directory (configured in DiveLine).

In DI-Diver, hover over a file name in the Open File dialog to display its Type, Date Modified, and Size.

Once a file has been selected, click Open to view it in Diver. Be aware of the following points when opening a file.
• When a file is opened, Diver will check the DivePlan related to that file to see if it is identical to any currently open DivePlans. If it is, the new DivePlan will use the same Console heading as the currently open DivePlan. If it is different, Diver will create a new Console heading and open the new DivePlan under that heading.

• If you open a Marker and get the message “Too Many Models”, check to see if the number of open Models allowed in the Console has been exceeded. This number is specified in the File > Preferences dialog box. More information can be found in Chapter 13, Application Templates & Preferences.

• If a Marker is stored in a different directory than its associated Model (particularly if the Model has been moved), the Marker may not automatically open its Model. Instead, you will be prompted to specify the location of the Model.

Deleting and Renaming Files in the Open Dialog
A file may be deleted or renamed by right-clicking it and selecting Rename, or Delete from the context menu. In ProDiver, the proper privileges are required in order to delete or change a file.

Closing Models
The File > Close option closes any open Model, DivePlan, and Marker files. All Dive Windows and all lines in the Console relevant to a file will be cleared upon close. Close works in a number of ways:

• If only one file is open, Close will return Diver to its startup state.

• If more than one file is open, and you wish to close only one file, the file must be highlighted in the Console before selecting File > Close. Only the selected file will be closed - all others will be unaffected.

• To close all open Models or DivePlans, highlight the “Models” header in the Console. The menu option will change to File > Close All Models. Select to close all open Models.

In addition to the using the Close menu option, Models can be closed directly from the Console using right-click context menu options. For more information, see Using Console Context Menu Items on page 2-29.

The Close command cannot be used to close an individual Dive Window. To close a Dive Window, click the “X” in the upper-right corner.
Saving a DivePlan

File > Save DivePlan... saves either a newly created, or a modified, DivePlan. For more information refer to Saving a DivePlan on page 9-64.

Saving a Window in Various Formats

The File > Save Window option saves the data in the current Dive Window to the local hard drive.

Available formats include:

- A delimited format ASCII file suitable for use in a spreadsheet, e.g. TAB (Tab delimited) or CSV (Comma Separated Variable).
  - TAB and CSV formats are only available with Tabular Dive Windows.
  - Each row in the Tabular display will be a new line in the file, and each column after the first will be separated by a tab or a comma.
  - The first line of the file will contain the names of the columns.
  - The second line will contain the totals or subtotals row from the Dive Window (if Save Totals is checked).
  - All rows and columns present in the Tabular Dive Window will be included.
- A DBF (Database) file.
- An HTML (Hypertext Markup Language) file suitable for browser-based viewing.
  - Saving a Report window as an HTML file allows you to display a report in a browser.
- An Adobe Acrobat PDF (Portable Document Format).
  - A PDF is a proprietary Adobe Acrobat file type. Saving a window as a PDF will allow the file to be opened on any computer with access to Adobe Acrobat Reader, available...
for free from Adobe (www.adobe.com).

— When saving to PDF, you have the option to **Embed Fonts**. If this check box is selected, font information will be included in the file being created. This option is useful if you plan to send the file to someone else who, due to regional settings, may not have the same font styles. Since this will dramatically increase the file size, it is not checked by default.

- An XML (Extensible Markup Language) file.
  
  — XML format is only available with a Tabular window.

The Save Window option includes a **Save Totals** check box. This gives you the option to save the totals (or subtotals) line in the output file. It is checked by default. If saving to Excel, uncheck this box if the totals row should be included as a number, rather than a sum.

In order to save only the desired rows and/or columns, focus on them before selecting Save Window.

### Saving a Marker

The **File > Save Marker** option records each step of the dive in a proprietary Marker (.mrk) file that can be reopened later to display the data in its saved state. Saved dives can be multiple levels in depth, and can have multiple paths (using the Console Dive Selector).

Although a Marker can save multiple Dive paths, DivePort will only open Dive A. Diver opens to the Active Dive Window at the time the Marker was saved, and NetDiver automatically opens to Dive A, but can be switched to other dives. More information can be found under **Using the Dive Selector on page 2-15** and under **Setting Marker Options on page 3-10**.

If a DiveBook is not open, the menu option will appear under the File menu as **File > Save Marker**, and will open the **Save Marker as:** dialog shown in the next section.

If a DiveBook is open, the menu option will have both **To File...** and **To DiveBook...** options, as shown in the previous image.
Saving a Marker as a Stand-Alone File

To save a Marker as a stand-alone file:

1. Select File > Save Marker (or File > Save Marker > To File...) to open the Save Marker as: dialog box.

2. Enter the desired file name. The .mrk extension is automatically appended to the filename upon saving.

3. Click Save.
Saving a Marker to a DiveBook

If a DiveBook is open, a Marker can be saved into it as follows:

1. Select **File > Save Marker > To DiveBook...** to open the Store Marker in DiveBook dialog.

2. Select the **Area** in which to save the Marker from the pulldown menu. This list will consist of the Areas defined in the DiveBook. (See **Adding a DiveBook Area on page 8-6** for more information.)

3. Enter the **Topic** name as it should appear in the DiveBook. “Top 10 Salespeople: Revenue” in this example.

4. Click **Options**, to configure additional Marker settings. (See **Setting Marker Options** in the next section).

5. Click **OK** to add the Marker to the DiveBook, or **Cancel** to exit the Store Marker in DiveBook dialog without adding the Marker.

6. Select **File > Save DiveBook...** to save the newly added Marker to the DiveBook. This step is essential to saving the Marker. If the DiveBook is closed before this step is completed, the new Marker will not appear in the DiveBook when it is reopened.
Setting Marker Options

When saving a Marker, click the **Options...** button (in the upper-right corner of the Save Marker as: dialog box, or in the lower-right corner of the Store Marker in DiveBook dialog box), to save the Marker with additional settings. Each setting is described below.

Configuring Dives in a Marker

When saving a Marker, the Dive path(s) in that Marker can be set to open in Any Dive, open in a specific Dive (A, B, C, or D), or not saved at all.

When a Marker is being saved, the Dive A option is set to Dive A, the Dive B option is set to Dive B, etc. by default. At least one dive must be saved in the Marker (i.e., they cannot all be set to Don’t Save). In addition, multiple dives cannot be saved to the same Dive letter.

The example above shows Dive A opening in Any Dive. If the Dive A, B, C, or D option is used, any currently open windows in Dive A, B, C, or D will be closed when the Marker is opened, and the saved Marker will open in the dive letter in which it is saved.
The Don’t Save option is used if there are multiple dives open, but not all of them should be saved in the Marker. For example, if Dive A and Dive B are both open, but only Dive B should be saved in the Marker, set Dive A to Don’t Save.

It may be useful to save a dive to open in Any Dive, rather than in a specific Dive letter. If a Marker is saved to open in Any Dive, it will open in the next unused dive, if there is one. For example, if Dive A is being used and a Marker saved as Any Dive is opened, the Marker will open into Dive B and Dive A will still be available.

Each Marker saved contains a DivePlan so that Diver knows how to display the stored dives when the Marker is reopened. Using the External DivePlan option, DivePlans can be saved external to a Marker rather than being included in the Marker file. This means that when the Marker is opened, it will automatically open the linked DivePlan file. The advantage of this option is that when a number of Markers use the same DivePlan (e.g., in a DiveBook) and a change is made to that DivePlan, all Markers referencing that DivePlan will automatically reflect the change. More information can be found under Using External DivePlans on page 9-66.

Columns added to a Marker using an external DivePlan will not be saved until they have been saved to the external DivePlan.

**Configuring a Marker to use Extra DivePlans**

The Extra DivePlans option allows you to save the Marker so that when it is opened, additional DivePlans that were not used to create the Marker will also be opened. This feature is useful when using Jump, as it allows you to save the DivePlan to Jump to in the Marker, along with the initial dive. For more information on Jump, see Jumping Between Models on page 2-26.

**Setting Application Templates in a Marker**

The Application Template option allows you to save a Marker with the selected Application Template file so you can control exactly how the screen looks, and which toolbar and menu items are available. The template must be created and saved prior to saving the Marker. For more information on creating Application Templates, see Chapter 13, Application Templates & Preferences.
Closing All Models When Opening a Marker
The Close All Models when opening check box allows you to tell Diver to close any currently open Models when the Marker is opened. This option helps prevent a “Too Many Models” error if you frequently work with a large number of Models. It is checked by default.

This close action applies to Model QuickViews as well. If this option is not checked, opening a second Marker with the same Model QuickView as the first Marker, then the selected value remains.

Removing Redundant Actions From a Marker
The Remove Redundant Actions check box allows you to save a Marker without saving unneeded actions in it. Diver attempts to recognize and remove unnecessary steps so that the Marker can be re-opened in a more efficient manner than that in which it was created. This option may help speed Marker open time on large dives. It is checked by default.

Setting a Report Template in a Marker
The MultiTab Dive Report Template and MultiCrossTab Dive Report Template check boxes allow you to specify a saved Report Template to be applied to the resulting Tabular Dive Window, when diving from a MultiTab or MultiCrossTab Report Marker. This allows a Tabular dive from the MultiTab or MultiCrossTab Report to inherit the formatting specified in the saved Template, rather than display using the default Tabular Report formatting. Additional information on Report Templates can be found on page 6-61.

Setting a DiveBook Area and Topic in a Marker
The Area Name and Topic Name text boxes allow you to specify a DiveBook Area and Topic in which to save the file.

Configuring Comments in a Marker
The Marker Info area allows you to save a comment in the Marker. Up to four lines of text can be stored in the Marker file, and can be viewed in one of two ways:

- Highlight the Marker file in the Open File dialog box, and click the Get Info button.
- Select a DiveBook Marker topic that contains a comment. Information about the Marker, including the comment, will appear in the DiveBook’s Topic Info area. More information can be found on page 8-3.
Saving a Report Template

Once a Report is formatted exactly as needed, the format can be saved as a Report Template using the File > Save Report Template... option. The saved template can then be used to apply the same formatting to another Report window. More information is available under Saving Report Templates on page 6-61.

Saving a Graph Template

Once a Graph has been formatted, use the File > Save Graph Template... option to save the format for later use with other graphs. More information can be found under Using Graph Templates on page 5-98.

Saving a DiveBook

File > Save DiveBook... saves the DiveBook currently in use, if any modifications have been made. More information can be found under Saving A DiveBook on page 8-8.

Saving a Model

The File > Save Model... option, available only in DI-Diver, allows you to save a Model built by DI-Diver’s Memory Builder. For more information please see Chapter 12, Building a Memory Model.

Saving a QuickView Set

After configuring QuickViews, use the File > Save QuickView Set... option to save the QuickViews for use in other Markers. More information can be found under Creating a QuickView Set on page 7-45.
Previewing a Window for Print

The **File > Print Preview...** dialog box, similar to those in other Windows applications, is shown below.

This dialog allows you to perform any of the following actions before printing:

- Preview a specific page, by entering the desired page number in the **Page: “n” of “n”** text box.
- Move up or down within the document preview using the **Page Up** and **Page Down** buttons.
- **Zoom In** or **Zoom Out** on a specific page.
- **Print** from the preview window or **Close** the print preview.

Setting Print Options

The **File > Page Setup...** option allows you to set common print options using Diver’s embedded print driver. All specified settings, are saved in the Marker for all users.

On the Page tab, you can control settings such as **Orientation** and **Paper Size**, including custom paper **Width** and **Height** settings, measured in **Centimeters** or **Inches**.
The Margins tab allows you to specify **Top**, **Bottom**, **Left**, and **Right** margins for the printed page.

The Headers tab is used to set a **Header** and/or a **Footer** to appear on the printed page.
Printing Files

File > Print... opens the Print dialog box shown here.

The following options are available:

- **Properties...** displays the properties dialog of the printer being used. This dialog is specific to the selected printer, and overrides any Diver-embedded print driver options you may have set.

- **Page setup...** opens the Page Setup dialog described on page 3-14.

- **Print to file** allows you to print to a file, if appropriate drivers are installed. For example, you can print to PDF if a PDF print driver is available.

- **Page range** allows you to print all pages, or a range of pages using the All or Page(s) options. From and To text boxes specify the range of pages to print when using the Page(s) option.

- **Number of copies** specifies how many copies to print.

- **Collate** arranges pages in their proper sequence when making multiple copies.

- **Preview...** displays the Print Preview dialog, described on page 3-14.

The File Print... option will open the dialog box shown above, while the Print toolbar button will send the print job directly to the default printer.
When printing, Diver treats certain types of data differently. The following should be considered:

- When printing a Tabular or a Report, the entire table (not just the visible rows or columns) is printed. Resizing and scrolling the Dive Window will not alter the printed output. To print just a section of the data, you must first Focus on the columns and rows of interest.

- When printing a Graph, only the contents of the window and the legend are printed. The graph toolbar is omitted from the printed page.

- Diver will always force a map to print on one page. The legend will also be printed.
Cascade Print

File > Cascade Print... cycles through the values in a parent Dive Window relative to the child Dive Window(s), and sends the result to your default printer. That is, rather than diving and using a MultiTab to print Reports for all possible combinations, a simple multi-level dive can print all combinations in batch mode using the cascade functionality. For example:

1. Dive on Salesperson and select any value.

2. Dive on Customer.

3. Create a default Report for Customer (click the Report button and accept all default selections).

4. Select File > Cascade Print.

5. Choose which values to cycle through in the QuickViews and Windows area of the Cascade Print dialog, double-clicking on the required QuickView(s) or Window(s) in the Available list to move them to Selected.

Alternatively, click Select All and use the >> button to move all Available windows to Selected.
To remove a selection, highlight it and use the << button.

The output for all possible Salesperson/Customer combinations are printed, one combination per page. Any Named Groups set on parent Dimensions will also be printed.

Saving the Cascade to PDF

Rather than sending Cascade Print output to a printer, you can save it to PDF, which can be read using Adobe Acrobat Reader on any platform. (Acrobat Reader can be downloaded for free at www.adobe.com.)

Click the check box next to **Save to PDF** to indicate that the output should go to a file rather than to a printer. The following options become available when saving to a PDF file:

- **Use Dimension Values for filenames** - When using this option, the output files will be given the same names as each of the Dimension Values, and will have a .pdf file extension. The path for the files should be specified in the **PDF Output Directory** text box (e.g., c:\DI_Users\Markers\Output), and any characters that should precede the filename should be entered in the **PDF Filename Prefix** text box. In a Cascade Print on a Sales Region window or QuickView, the Use Dimension Values for filenames option creates files with names like *Sales Region=South.pdf* and *Sales Region=Boston.pdf*.

- **Use Dimension Index for filenames** - With this option, the output filenames will be the Dimension Name followed by a number, beginning with 001, and will have a .pdf file extension. The path for the files should be specified in the **PDF Output Directory** text box (e.g., c:\DI_Users\Markers\Output), and any characters that should precede the filename should be entered in the **PDF Filename Prefix** text box. In a Cascade Print on a Sales Region window or QuickView, the Use Dimension Index for filenames option would create files with names like *Sales Region001.pdf* and *Sales Region002.pdf*.

- **Specify Filename** - This option allows you to use Dimension names to specify filenames. The Dimension name is used as a variable, preceded by a dollar sign ($), in order to use the values of the Dimension as the filenames. Any Dimension name that contains spaces or characters other than letters, numbers, or the underscore character (_), must be enclosed in parentheses. For example, in a Cascade Print on a Sales Region window or QuickView, entering $(Sales Region).pdf in the **PDF Filename** text box yields files with names like *South.pdf* and *Boston.pdf*.

- **Skip “All Values”** - By default, Pulldown QuickViews show “All Values” of the Dimension until a particular value is selected. Cascade Print will not cycle through the “All Values” QuickView value if this box is checked.
Cascade printing does NOT allow you to print an “all values” file for Tabulars or Reports. It is for use with QuickViews only.

- **Skip Empty Windows** - Models may contain Dimension Values that are blank. Cascade Print will not cycle through the blank values or failed cascade windows if this box is checked. It is recommended that this option be checked.

- **Embed Fonts** - As with the Save Window PDF option, if this check box is selected, font information will be included in the PDF file created, thereby increasing the file size. Embedding fonts is recommended only when saving a PDF which may be used by someone with different localized settings.

Cascade Print cannot be used with Report Palettes.

**Logging in to ProDiver**

ProDiver, as a client of DiveLine, has security features that may require you to log in for access to data. The **File > Login**... menu item opens the DiveLine Login... screen, allowing you to enter your assigned user name and password for data access.

![DiveLine Login...](image)

Depending on the level of security set by the administrator, you will be given access to some or all of the data.
To change the server you are connecting to, click **Cancel** on the login dialog to view the **Select DiveLine Server...** dialog shown here:

![Select DiveLine Server](image)

Enter the Server Name and port number that you wish to connect to and click **Select**, or click **Exit** to close the dialog without changing servers.

To set the default DiveLine Server to connect to, or to change your password, see **Setting DiveLine Preferences (ProDiver Only)** on page 13-13.

### Using the Proxy Login

The **File > Proxy Login As...** option, available after logging in to ProDiver as a DiveLine administrator, allows the administrator to temporarily log in as a different user.

![Proxy Login as...](image)

When using this option, all open Models will close and the new user’s permissions will become active. When the Proxy Login As... option is in use, it is replaced with a **Revert to <username>** option on the File menu, allowing the administrator to switch back to his or her own username. Reverting to the previous username will close all Models opened under the proxied user name, and switch back to administrator permissions.
Downloading a Model

The File > Download Model... option allows you to download the currently opened Model to the local machine. To do this, you must have Download permission on the DiveLine server. Upon selection, the Browse For Folder dialog displays, prompting you to select the Download Directory in which to save the Model.

Select an existing directory, or click Make New Folder to create a new one. Click OK to download the Model to the selected directory, or Cancel to close the dialog and return to ProDiver.

Setting Preferences

Diver allows you to set a number of different options using the File > Preferences dialog box. For more information, see Setting Diver Preferences... on page 13-8.

Building and Editing Models

DI-Diver is capable of building and editing its own Models. Instructions for building a Model within DI-Diver can be found in Chapter 12, Building a Memory Model.

If a Model created in DI-Diver’s Memory Builder is selected in the Console, the File > Build Model menu item will change to Edit Model, allowing you to make changes to the Model structure by reopening the Build Model wizard.
Opening Recently Used Files

In Diver, a list of up to five of the most recently used files appears in the File menu. Clicking any of these items will open that file. If the selected file has been moved since the last time it was used, you will be prompted for its location.

Exiting Diver

File > Exit closes the Diver application. If an open DivePlan and/or DiveBook has been edited, Diver will prompt you to save before exiting.
Using the Edit Menu

The Edit Menu, shown below, is used primarily to make changes to the Dive Window or DivePlan.

<table>
<thead>
<tr>
<th>Edit</th>
<th>Organize</th>
<th>Display</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy Console</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy into Window</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Dimensions...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Modify DiveBook...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close DiveBook</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Font...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Report Style...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit Detail Info...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit Window Info...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add QuickViews...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application Templates...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dive Series Control Panel...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Period Comparison...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit Columns...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select Columns...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Actions controlled through the Edit menu include:

- Undoing and Redoing steps
- Copying, Pasting, or Deleting information
- Making changes to a DiveBook
- Configuring settings such as Font or Report Style
- Configuring QuickViews
- Applying Application Templates
- Configuring Columns

Undoing and Redoing Actions

Diver supports the **Edit > Undo** command after certain actions are performed in a Dive Window, such as a Group, Find, or Focus. After the supported action is taken, the Undo button will become available. Upon undoing an action, the **Edit > Redo** command will become available.
Cutting Text

The **Edit > Cut** command is not supported in the Edit menu, since Diver is primarily a read-only application; however, in some cases it is possible to cut text from a dialog box (such as the Add Column Definition dialog) using **CTRL-X**, or by right-clicking and selecting **Cut** from the context menu.

Copying Text

The **Edit > Copy** command saves a copy of everything in the active window to the system clipboard for pasting into another application.

If the active window is a Tabular, CrossTab, MultiTab, or MultiCrossTab display, the Copy command puts all row and column labels on the clipboard, along with the contents of all cells that correspond to those rows and columns, without formatting. If a focus has been done, only the items in focus will be copied to the clipboard.

The white space at the beginning of the first line, and each space between the columns in later lines, is one tab character. The tab characters will be interpreted by whatever application the text is pasted into.

If the active window is a graph display, the Copy command puts the entire graph into the clipboard, complete with labels, axes, scale numbers, add-on labels, comments, and legend. The window frame and the label and comment source boxes are not copied. The entire graph will be copied onto the clipboard, regardless of the current selection. A graph can not be pasted into a text editor.

Copying Console Contents

The **Edit > Copy Console** option saves a copy of all the Console’s text in the clipboard, but without formatting. Selections, dividing lines, and hidden text (such as any beneath a collapsed category or area) are absent.

Copying Info Window Contents

**Edit > Copy Info Window** saves a copy of all text from an Info Window onto the clipboard, but without formatting. For more information on the Info Window, see *Hiding and Showing the Info Window on page 3-52.*

Pasting Text

The **Edit > Paste** command is supported in Report Palettes and User Defined Dimensions. In some cases, such as in the Add Column Definition dialog box, it is possible to paste text using **CTRL-V**, or by right-clicking and selecting **Paste** from the context menu.
Deleting Columns

The **Edit > Delete** option removes the selected column(s) from a display. The Delete command is only used to edit the appearance of a Dive Window, therefore, it does not remove actual columns from the DivePlan.

The Delete command is disabled if the display is not a Tabular, or if no column is selected.

Selecting All Items

**Edit > Select All** highlights items in an unlocked Report display, or selects all rows in any type of Tabular display. Only the row labels will be highlighted when Select All is used; however, all items in the window are actually selected, and will be copied if Edit > Copy is used. Item selection can be saved in a Marker.

Add/Edit Dimensions...

Dynamic Dimensions can be added to a DivePlan using **Edit > Add/Edit Dimensions**. For more information, see *Setting Dynamic Dimensions on page 9-53*.

Using the Find Functionality

The **Edit > Find** interface allows you the convenience of various Find dialog boxes, described in the following sections. Find settings are saved as preferences in the **diver.ini** file and are therefore maintained across sessions.

Using Search Parameters

Below is a comprehensive list of the search parameters available in the four variations of the Diver Find dialog box. Some of the parameters appear in the basic Find dialog box, while others are displayed by clicking the **Options >>** button. In addition, some may appear in only one or two of the dialog boxes, while others appear in all four dialog box variations. Clicking Options >> to expand any of the four Find dialogs will also cause the Options area to be automatically expanded in the other three Find dialogs.

**Basic Find Parameters**

- **Find All** - Finds all items that meet the specified find criteria.
- **Find Next** - Finds the next item that meets the specified find Criteria.
- **Focus** - Removes all values that DO NOT meet the Find criteria.
Find Next does not work with Focus, as it cannot continue with the Find criteria once a Focus is applied. As a result, the Find Next button is disabled when the Focus check box is checked. To enable Find Next, uncheck the Focus check box.

- **Group** - Collects all rows meeting the Find criteria into a single, diveable group in the Dive Window.
- **Group with Others** - Collects all rows meeting the Find criteria into a single, diveable group in the Dive Window, and groups all rows not meeting the Find criteria into a single, diveable group named “Others”. Note: Group with others is not supported for Crosstabs or MultiTabs.
- **Match case** - Finds only values matching the letter case (upper case or lower case) specified in the Find string.
- **Match exactly** - Finds only the rows which exactly match the entered Find criteria. Match exactly is case sensitive.
- **Match beginning** - Finds all rows that match the beginning of the specified Find criteria.
- **Find others** - Displays only the values that DO NOT match the Find criteria. The opposite of Focus.

**Additional Find Options**

- **Find by Expression** - Allows you to find by the criteria entered in the Find text box, the period range box, or the logical arithmetic expression box.
- **Find by Non-Empty** - Allows you to find only rows that contain a value. Rows with spaces or the text <Null> are not considered empty.
- **Find by First N Items** - Allows you to find the first “N” number of items in the column, based on the current sort.
- **Find by Last N Items** - Allows you to find the last “N” number of rows in the column, based on the current sort.
- **Find by First N %** - Allows you to find the rows, that when added together, meet the uppermost “N” percent of the total value of the selected column, based on the current sort.
**DIVER**

- **Find by Last N %** - Allows you to find the rows, that when added together, meet the lowermost “N” percent of the total value of the selected column, based on the current sort.

**Find Dialog Box Variations**

There are four variations of the Diver Find dialog box, based on the type of column selected in the Dive Window: **Find String**, **Find Numbers**, **Find Date Range**, and **Find Period Range**, each of which is described below.

If no column is selected in the Dive Window when the Find option is selected, the Find functionality will automatically determine the type of data in the left-most column, and will use that column in the find.

**Finding a String**

The **Find String** dialog box appears when a column of text, such as “Sales Region”, is selected in the current Dive Window, and the Find button is clicked in the toolbar, or **Edit > Find** is selected. You can then enter the desired criteria in the Find box, or use the pulldown to find previously entered criteria (the pulldown saves the last 10 strings used.).
Finding Numbers

The **Find Numbers** dialog box appears when a numeric column, such as “Revenue”, is selected in the current Dive Window, and the Find button is clicked in the toolbar, or **Edit > Find** is selected. There are three logical options (None, And, Or) and five operator options (>=, >, =, <, <=) that allow for a wide range of numeric find possibilities. When using the And logic option, both conditions must be met, and when using the Or logic option, only one of the conditions must be met. The Find pulldown saves the last 5 numbers in both the “from” and “to” pulldowns. Please note that these pulldowns are not labeled, but appear next to the operator pulldowns in the image below.

If both input dialogs are grayed out, make sure Find by Expression is selected. The second input box will not be activated unless “And” or “Or” is selected in the logic option pulldown.
Finding a Date Range

The **Find Date Range** dialog box appears when performing a find on a date column, such as “Date”. There are three date find options:

- Find a range of Dates by entering the desired range in the boxes. Find Date logic can be set using a from-to range, and can include both symbols and logic. You can set greater than (>), greater than or equal to (>=), equal to (=), less than or equal to (<=), and less than (<) symbols, and include the second date term with “And” or “Or” logic, as part of the Find criteria. The example below returns all dates from January 2, 2011 through June 30, 2011.

- Find “today” only, by checking both **Today** check boxes.

- Find “today” with a date offset. The Offset checkbox is used when you only need to see today, plus or minus “n” number of days. If today’s date is June 30, 2011, you can select the Today checkbox, enter an offset of -1, select Or from the operator pulldown, and check the select Today checkbox with an offset of 0. The result would be a tabular that contains both June 29, 2011 and June 30, 2011.

Today is based on the system date of the client machine.
If the Find Date Range dialog does not display, Diver may not recognize the column as a date because it needs to be identified as a date during the Model build. For more information, see Setting Dimension Column Options on page 4-25.

Finding a Period Range

The Find Period Range dialog box appears when performing a find on a period column, such as “YearMonth” or “Quarter”. Using this dialog, you can search a from-to range such as from 2011/1 to 2011/2.

If the Find Period range dialog does not display, Diver may not recognize the column as a Period because it is not formatted as such. Please see Setting Dimension Column Options on page 4-25 for more information.
Advanced Find

In addition to the each of the above Find dialog boxes, there is also an Advanced Find dialog box, common to all four of the Find variations. It is accessed by clicking on the **Advanced Find...** button in the lower right corner of the Find dialogs. This dialog box provides:

- Full functionality of each of the four individual dialog boxes described above, in one interface.
- The ability to combine multiple simple find strings into a complex find string across multiple columns.
- A pulldown menu that contains a history of finds previously performed. The last 5 strings are saved.
- Additional Find criteria, each described in further detail below.

![Advanced Find dialog box](image)

**Contains** - Allows you to specify a particular value within the Find string. For example, Sales Region Contains “South” would find only values within Sales Regions containing the string “South”.

**Begins with** - Allows you to specify a letter value within the Find string. For example, Sales Region Begins with “S” would show all Sales Region values beginning with the letter “S”.

**Not Empty** - Allows you to find all values in a column that are Not Empty. This option is used on Summaries that have some empty cells, in order to filter only those cells that contain data.
**Paste String** - Allows you to paste into a Find window either a previously used Find string or a list of Dimension Values from the system clipboard. This list may come from a previous dive or from Excel. If there is an active Dive Window, Diver will assume Paste String refers to the Dimension in the Dive Window, and will include the appropriate “Or” syntax.

**N Items (First, Last, First %, Last %)** - The Advanced Find dialog box has the ability for you to find the First “N” or Last “N” items within each set of a subset of Dimensions in a MultiTab. An example of how this would be used is:

1. Dive on Sales Region.

2. MultiTab with Product Family to create the following Dive Window:
3. In the Advanced Find dialog box, type \texttt{First(2,Product Family)} and click Find All.

4. The first two Product Families of each Sales Region will be found, and the resulting dive will look like this:

The Find string can take any number of dependent columns. For example, if you want to find the first or last two Products by Sales Region, Month, Salesperson, and Business Type, you can do so.

When only one column is specified in the string, it will use the column just to the left of that column in the window as the one dependent column. For example, in the two-column MultiTab of Sales Region and Product Family, the find strings “First (2, Product Family)” and “First (2, Product Family, Sales Region)” are equivalent.

If the MultiTab instead contained Sales Region, YearMo, and Product Family, “First (2, Product Family)” would find the first two Product Families for each YearMo, for the first Sales Region. You can also use \texttt{Last(2,Product Family)} to find the last Product Families listed.
The Find is independent of sort order. It does not consider how the value of the dependent columns change, it only tracks the number of times each unique combination of those values has been seen.

All the columns used with the “N” Find functionality MUST be Dimensions (core or dynamic) because the Find depends on having key values. In addition, any columns used must be present in the current Dive Window. This functionality will work in MultiTabs and MultiCrossTabs, but will not work in Tabulars or CrossTabs.

**QVVal** - Inserts a term in the edit area QVVal( ) and sets the cursor to highlight the area in the parentheses. The QVVal term accepts the name of a QuickView and uses the value of that QuickView when processing the find. The name of the QuickView should not be in quotes. This term should be used in an equation with another term, such as a column. For example:

```
“Units>=QVVal(Threshold)”
```

If the QuickView by the used name does not exist, it will return an error to that effect.

If the column to which it is being compared is a number, it will convert the string returned by the QuickView into a number. If the string can not be converted into a number, it will return the type mismatch.

**Today** - Enter Today’s date, as defined by the client system, into the Find string.

**Date** - Enter a specific date into the Find string.

**Period** - Enter a specific period into the Find string.

Find Strings in the Console

A description of any finds performed can be found in the Console. Each Find that is done in a given Dive Window, or series of Dive Windows, can be viewed by expanding the History section of the Console. An example of this functionality can be seen below:

Here, you can see that an initial dive was done on Sales Region, followed by a find on Sales Region for the string “So”, with the focus option selected in the Find String dialog box.
Modifying a DiveBook

The **Edit > Modify DiveBook...** command opens a dialog box allowing you to alter the current DiveBook. This menu option is deactivated (grayed out) if no DiveBook is open. For information, see **Modifying a DiveBook on page 8-4**.

Closing a DiveBook

The **Edit > Close DiveBook** option allows you to close the open DiveBook without closing any associated Marker, Models, or DivePlans. For more information on DiveBooks, please refer to **Chapter 8, DiveBooks**.

Changing the Dive Window Font

The **Edit > Font...** option allows you to change the font used for all text in a Tabular, CrossTab, MultiTab, or MultiCrossTab window. The dialog box sets the Font to be used by the active window and all subsequent Dive Windows. Font can also be used to change the style, font, and size of any Tag or Label on a graph. (For more information, see **Using Add-On Labels on page 5-93**.)

To set a default font for all Tabular format windows (Tabular, CrossTab, MultiTab, or MultiCrossTab) see **Setting Tabular Preferences on page 13-10**.

Editing Report Styles

When a Dive Window is in Report format, you can edit the style of any item in the Report using the **Edit > Report Style...** option. Styles are used to give a uniform look to the format of a Report. For details on using Styles see **Editing Report Styles on page 6-63**.

Editing Detail Model Information

When using a Detail Model, you may not need or want all fields that are available in the Detail section. **Edit > Edit Detail Info...** allows you to select which fields should be included when entering the Detail portion of the Model (after narrowing the data to 256,000 or fewer records). These selections can then be saved in a DivePlan for later use.
All possible fields are shown in the **Columns Available** list on the left. All fields appearing in the **Columns Selected** list, on the right, will be included in the Detail portion of the Model. Clicking an item in either list and using the left or right arrow will move the item to the opposite list. The up and down arrows are used to order selected columns from top to bottom.

**Editing Window Information**

The **Edit > Edit Window Info...** options allows you to change some of the settings used in Dive Windows.
Enter new text in the **Window Name** area of the dialog box to change the text that appears in the title bar of a Dive Window. For example if a Window Name is “YearMo”, you may want to change it to “Year & Month”. This new title will be saved in the Marker file. Subsequent Dive Windows WILL NOT inherit this new name.

The QuickViews portion of the Edit Window Information dialog box is used to set up window associations for QuickViews.

**Adding and Editing QuickViews**

QuickViews enable you to see, and change, the currently selected value in parent dives without the need to switch back and forth among several Dive Windows. The **Edit > Add QuickViews...** option allows you to define QuickViews to use in the current dive. Once QuickViews have been created, this option changes to **Edit > Edit QuickViews...**, allowing you to make changes to the QuickView configuration. More information can be found in **Chapter 7, QuickViews**.

**Using Application Templates**

The **Edit > Application Templates...** option allows the administrator to create or modify templates that provide full control of the functionality available to Diver end users. Application Templates also define uniform customized appearance and preference settings so they are easy to transfer from one Diver to another. For more information, see **Using Application Templates on page 13-1**.

**Creating Time Series Columns**

**Edit > Time Series Control Panel...** allows you to define periods and customize Time Dimension columns. With this functionality you can create multiple Time Dimension columns based on the criteria entered into the Time Series Control Panel wizard. The columns can then be saved in a specific Marker or in a DivePlan for later use. For more information, see **Using the Time Series Control Panel on page 10-1**.

**Creating Period Comparison Columns**

**Edit > Period Comparison...** allows you to quickly create simple time-based Dimension columns. There must be a period or date Dimension in the Model in order to use this option. For more information, see **Using Period Comparisons on page 10-20**.
Editing Columns

The **Edit > Edit Columns...** menu item allows you to Edit or Delete existing columns or Named Groups, or add new columns and Named Groups to the DivePlan. For more information, see **Editing Columns on page 9-43**.

Selecting Columns

The **Edit > Select Columns...** menu item allows you to choose which columns should appear in the Dive Window. Please refer to **Selecting Columns on page 9-45** for additional information.

Using the Organize Menu

The **Organize** menu provides various data organization methods, allowing you to see your data in different ways.

Actions controlled through the Organize menu include:

- Flipping Axes in a Dive Window
- Focusing on certain rows and columns of data
- Grouping rows of data
- Sorting data up or down

Flipping Axes

The **Organize > Flip Axes** menu item swaps the vertically displayed information with the horizontally displayed information and is available for most Tabular and Graph Views.

All selections are preserved when axes are flipped. If the items are sorted, their sort order will also be preserved.

Each use of this command flips the axes again, so an even number of uses will put the display back the way it started.
Flipping Tabulars

In the case of a Tabular or CrossTab display (not available for MultiTab or MultiCrossTab), the columns become rows, and the rows become columns. This has several uses:

- Efficient display of data. Since the labels and cells are all wider than they are tall, many more rows than columns can be displayed at once.
- Diving on the horizontally displayed Dimension in a CrossTab. Normally in a CrossTab window, you can only dive on the Dimension that is listed down the left-most column. If the CrossTab is displaying sales of Product by Month, you can dive on Product if the products are the row labels (on the left side), or you can flip axes and dive on Month if the months are the row labels. If you have already dived past a CrossTab window, flipping the old CrossTab’s axes will not affect the Dive path. Only if the flipped CrossTab is the last dive in the path will the flip change how another dive can be done.
- In a CrossTab, Focus can be used to eliminate columns, then flipped back.

Flipping Graphs

Graphical displays (except pie charts, control charts, and maps) can be flipped. Flipping a scatter chart simply displays the same data with the axes reversed. Other graph types change significantly when the axes are flipped.

The default plot below is a vertical graph. The Dimension (Sales Region) is on the horizontal axis, while the Summaries (Cost and Revenue) are on the vertical axis.
The vertical axis shows the scale of the graph.

When the axes are flipped, the result is a horizontal graph. The graph below is the flipped version of the graph above.

If there were more Dimension Values to plot, they would not fit on the screen and you would need to change to scrolling mode (See Using the Scroll Tool on page 5-89).

**Focusing Rows of Interest**

The Organize > Focus option allows you to look closely at desired items by removing unwanted items from view. To Focus in Diver means to bring attention more clearly to something of interest. This is accomplished by allowing you to remove anything that is not of interest from the display.

For example, to see the first three Salespeople in the Dive Window below:

1. Select the row labels of interest.
Rows and columns cannot be selected simultaneously.

2. Choose **Organize > Focus**, to remove the unneeded values from the Dive Window. The result is shown here.

![Table Example](image)

When using the Focus functionality, remember the following key points:

- When a Focus is in effect and no rows or columns are selected, Focus is replaced by **Stop Focus**. Stop Focus will undo any focusing already in effect. Alternatively, you can continue to focus further by selecting additional rows or columns, and using the Focus option again, if a smaller data subset is desired.

- When a focus is in effect, “Subtotals” is displayed in the top row, whereas the unfocused window shows “Totals.” This is because the Summary row at the top of the table is no longer totaling the entire Dimension, rather, the subtotals are computed only from the items in focus.

- In a large scrolled Tabular, when focusing on many rows, Diver scrolls to the top after clicking the Focus button.

**Using Focus in Various Window Types**

The Focus functionality varies depending on the type of Dive Window open.

Focusing in a CrossTab display is the same as in a Tabular; however, there are Totals columns in both directions, so there are two labels changed to “Subtotals” after the focus.

Focusing in a plot or map works in a way analogous to the Tabular windows. For example, selecting the bars, points, or areas of interest and then choosing Focus will display the plot or map with only the desired values of the displayed Dimension (only several months of the year, for example).
If the graph contains more than one Summary, such as the graph below (which contains both Cost Total and Revenue Total), the selection must include more than one bar for Focus to be enabled. Those bars can be two of the same Dimension Value, but there must be at least two bars.

![Graph showing Cost and Revenue for different products]

![Graph showing Cost and Revenue for a subset of products]
Focusing in a Scatter does not change the chart except to make the unselected points become invisible.

Focusing in a Pie chart is different. Unlike the other displays, the pie can focus on the Other pie wedge. In the pie chart shown below, pie slices are displayed for the revenue share of 15 out of the 21 SIC Descriptions. The other ten SIC Description values are lumped into the Other category.

Selecting the Other wedge and clicking Focus, or double-clicking the “Other” value in the Legend window, displays the pie slices of the remaining 6 SIC Descriptions.

Notice that the percentages add up to 100%, but they now indicate the percentages of the “Other” slice. If there were more than 12 products in the original Other slice, we would again have an Other pie slice and could focus once more.
If you focus on several items before changing to a pie chart, the percentages will not total 100%, due to the fact that all items are not included in the pie. If, however, you use the Group function to group a number of items before entering a pie, the percentages will total 100%, and you will not be able to Focus or double-click on the Other wedge of the pie.

To return to the full pie, click on the Focus button in the toolbar or select Organize > Stop Focus.

Grouping Values in a Dive Window

The Group option treats multiple Dimension Values as a single unit. To use this functionality, select the desired Dimension Values from the left column of a plain Tabular window, then choose Organize > Group.

When grouping, the following points should be considered.

- The “Totals” label will change to “Group” at the top of the left column.
- Selecting the “Group” label selects the group as a whole, and enables another dive on the entire group of Dimension Values, rather than on only one value.
- Double-clicking the “Group” label will update the Console for the entire group, as though it were one Dimension Value.
- In a large scrolled Tabular, when grouping on many rows, Diver scrolls to the top after you click the Group button.
- It is possible to have multiple Groups in different Dimensions at one time, which means that once you dive past a group, it is possible to make another group in the same Dive path.
- Once a group has been created, the Group menu item will change to Stop Group. If chosen, Stop Group will undo the grouping but will keep the group members in focus (until the Stop Focus option is used).

If you dive deeper than the grouping, in the Dive path, Stop Group will be disabled until you return to the window in which the Group was defined, and close all associated child windows. Group is disabled in a MultiTab.

The Named Groups feature of Diver differs from Groups in that Groups are created for diving on a specific set of items, whereas Named Groups are used in calculations and CrossTab Dimension Values. To create Named Groups, see Named Groups on page 9-46.

Multiple selections in a Picklist with a Go button also operates as a group.
Grouping with Others

**Organize > Group with Others** puts all selected rows into a single, diveable group in the Dive Window, and groups all non-selected rows into a single, diveable group named “Others”. This option leaves no rows ungrouped, and both groups are available for further diving. Use the **Stop Group** menu item to revert to the ungrouped Tabular display. Group with Others requires a Tabular display, therefore it is not available in CrossTabs or MultiTabs.

Sorting Values

The **Organize > Sort Up** option sorts the Dive Window in ascending order by the values in the column, maintaining row relationships. If sorting a Summary, the minimum value will move to the top row and the maximum value will move to the bottom row. Sorting text works the same as sorting numbers, but the ordering is based on ASCII. Since Sort Up is an ASCII sort, text beginning with capital A to Z will appear before lower case a to z. The example below shows the Revenue Column sorted up:

<table>
<thead>
<tr>
<th>Product Family</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tots</td>
<td>35,395,695</td>
<td>71,471,584,64</td>
<td>731,765,141,51</td>
</tr>
<tr>
<td>Cream Cheese</td>
<td>474,122</td>
<td>9,759,797,76</td>
<td>10,204,551,24</td>
</tr>
<tr>
<td>Cottage Cheese</td>
<td>570,272</td>
<td>13,556,713,43</td>
<td>14,403,679,00</td>
</tr>
<tr>
<td>Egg</td>
<td>1,650,042</td>
<td>34,520,173,07</td>
<td>36,653,086,67</td>
</tr>
<tr>
<td>Cream</td>
<td>2,009,097</td>
<td>42,371,510,38</td>
<td>43,567,634,60</td>
</tr>
<tr>
<td>Yogurt</td>
<td>3,402,977</td>
<td>58,089,549,02</td>
<td>72,585,544,64</td>
</tr>
<tr>
<td>Butter</td>
<td>5,378,553</td>
<td>11,471,520,46</td>
<td>115,767,222,83</td>
</tr>
<tr>
<td>Ice Cream</td>
<td>6,410,929</td>
<td>116,288,015,12</td>
<td>138,028,466,96</td>
</tr>
<tr>
<td>Cheese</td>
<td>6,528,452</td>
<td>140,308,586,74</td>
<td>142,773,885,50</td>
</tr>
<tr>
<td>Milk</td>
<td>6,734,027</td>
<td>165,021,051,83</td>
<td>197,941,751,07</td>
</tr>
</tbody>
</table>

Some points to consider when using Sort include:

- If an Alternate Sort was defined when the Model was built, Sort will use the sort order defined, rather than alphabetical order or numeric order. This can be useful for column values such as 2011_JAN, 2011_FEB, 2011_MAR, etc., where you want them ordered by the numeric month rather than the alphabetical month.
- If two columns are selected, the Sort options will be disabled (grayed out and inactive).
Multi-Sort Using the Organize Menu

- If no columns are selected, the Sort will operate on the Dimension Values in the far left column.
- If no column is selected, and the left column does not contain Dimension Values (e.g., if the window is a flipped Tabular), the Sort option will be disabled.
- A child window in a dive will inherit the sort order from its parent window.
- Organize > Sort Down sorts Dive Windows in the same manner as Sort Up, but in the opposite direction.

Sorting in Graphs

In a graph window, sort behavior depends on the selections and on the specifics of the graph. If only one item is displayed (only one bar or point per Dimension Value), sorting will be enabled regardless of any selections. Sorting a vertical graph “up” will make it slope up to the right (the largest number at the right). Sorting up on a horizontal graph will make it slope down toward the bottom (the largest number at the bottom).

If the graph window has more than one element displayed (two or more plots), the behavior is different. You must select a single bar in order to specify an element by which to sort. With exactly one bar selected, Sort Up is enabled in the Organize menu. With more than one bar selected, Sort Up is disabled again and will be grayed out.

Neither the Scatter nor the Pie display can be sorted.

Sorting in Reports

To sort a Report, it must be in its default locked state. In a MultiTab Report, using Sort Up on a Summary or Dimension will sort the values within breaklevel divisions. For example, if the Sales Branch breaklevel contains the Product breaklevel, and you select Product and Sort Up, the list of Products under each Sales Branch name will be sorted, but Products in different Sales Branches will not be sorted relative to each other.

Multi-Sort

Using the Organize > Sort... option allows you to sort a Dive Window using more than one column. Any Tabular format may be sorted by multiple columns at a time, therefore, when selecting more than one column to sort by, rows with the same entry for the first sort column will be sorted again by the second column, and duplicates from this sort will be sorted again by the third column, and so on.
All columns in the active Dive Window are available for sorting and are listed under **Columns** in the **Sort Columns** dialog box.

The columns appearing in the **Sort Columns** list are those to be sorted by. Displayed sequentially, the topmost is the first column to be sorted, the next down is the second, etc. Each of the columns in the Sort Columns list has an arrow to its right, specifying whether the column will be sorted up in ascending order (up arrow) or sorted down in descending order (down arrow).

To move a column between the left and right lists, highlight it and click on the >> or << buttons, or simply double-click the column’s name. To change the sort order of a column in the Sort Columns list from ascending to descending, or vice-versa, single-click on the arrow to the right of the column name.

In the example above, Sales Region, Salesperson, and Revenue have been selected and moved to the Sort Columns list. The entries in the Dive Window will be sorted first by Sales Region in ascending order, second by Salesperson in ascending order, and third by Revenue in descending order.

In a MultiTab Report, Dimensions and Summaries will be grouped in the order specified by the Sort... command, even if this means disrupting the original breaklevel divisions. However, the categories (in upper breaklevels) to which each item belongs will still be indicated, as in the unsorted Report.
Creating a Tabular Using the Display Menu

The **Display** Menu allows you to change the view of an existing Dive Window to a new view, in order to see the data from a different perspective. The new window will have the same size, shape, location, and DivePlan as it had before the conversion, but will display your data in the selected format.

Actions controlled through the Display menu include:

- Changing a Window to a Tabular, CrossTab, MultiTab, or MultiCrossTab from a different display type
- Changing a Window to a Graph
- Changing a Window to a Report

Creating a Tabular

The **Display > Tabular** option converts the current Dive Window back to the Basic Tabular view. For more information on Tabulars, see **Chapter 4, Tabular Displays**.

Creating a CrossTab

The **Display > CrossTab...** option converts the current Dive Window to a CrossTab view. For more information on CrossTabs, see **Understanding the CrossTab Display on page 4-3**.

Creating a MultiTab

The **Display > MultiTab** option converts the current Dive Window to a MultiTab. For more information about MultiTabs, see **Understanding the MultiTab Display on page 4-5**.

Creating a MultiCrossTab

**Display > MultiCrossTab...** displays the current dive as a MultiCrossTab. For more information on MultiCrossTabs, see **Understanding the MultiCrossTab Display on page 4-7**.
It is possible to make a combination MultiTabMultiCrossTab display. To do this, you must create the MultiTab first, and then perform the MultiCrossTab. This display is particularly useful for creating Reports.

Graphs...

The **Display > Graph**... menu item allows you to change the display to a graphical view. More information about each graph type and graph creation can be found in *Chapter 5, Graphs*.

Report...

Selecting the **Display > Report**... menu item, automatically generates a default Report view from any Dive Window. For more information on Report view creation, see *Creating a Report on page 6-1*.
Using the Window Menu

The Window menu allows you to control the display of certain areas and windows in the Diver interface.

Actions controlled through the Window menu include:

- Displaying or hiding the Console, Toolbar, Info Window, QuickViews
- Opening a Report Palette
- Displaying a DiveBook
- Customizing the Toolbar
- Resetting the Toolbar to Default
- Splitting Dive Windows

Hiding and Showing the Console

Window > Hide Console hides the Console from view. Window > Show Console returns the Console to view if it has been hidden. The Console automatically becomes visible if the last display (Dive) window is closed. Hide Console does not close any open Models or DivePlans. For more information on the Console, see Understanding the Console on page 2-14.

Hiding and Showing the Toolbar

Window > Hide Toolbar removes the toolbar from view. Window > Show Toolbar returns it to view if it has been previously hidden.
Hiding and Showing the Info Window

If there is a large amount of text in the Model’s Info Fields, it may be difficult to read in the Console or column. Info Fields can be displayed in a separate window by using the Window > Show Info Window. Fields in the Info Window will be displayed in the order they appear in the Console. The Info window can be closed using the close icon in the upper-right corner, or by selecting Window > Hide Info Window.

The current Hide/Show Info Window setting is saved in the Marker. Be sure to select the desired setting before the Marker is saved.

Hiding and Showing QuickViews

Window > Hide QuickViews removes QuickViews from the display. Window > Show QuickViews returns them to view if they have been previously hidden.

Opening a New Report Palette

The Window > New Report Palette option opens a blank Report Palette. Report Palettes are available to hold data cell definitions, which can point to multiple Models, and can display multiple Tabulars or graphics on one page. More information about Report Palettes is available in Chapter 11, Report Palettes.

Opening a DiveBook...

If there is no DiveBook currently open, one can be opened by selecting Window > DiveBook... or by clicking the DiveBook toolbar button. More information about creating and using DiveBooks is available in Chapter 8, DiveBooks.
Customizing the Toolbar

Window > Customize Toolbar... allows you to personalize the toolbar using the following dialog box.

To add a tool to the toolbar, click on it and hold down the mouse button, then drag it to the desired location on the toolbar, or use the Add and Remove buttons to move the tool between the Available toolbar buttons list and Current toolbar buttons list.

Tools that are already on the toolbar can be rearranged using the Move Up and Move Down buttons. Once a tool is listed as Current, it is removed from the Available list. A separator can be added multiple times, and provides a space between groups of buttons. New toolbar settings are saved in the C:\Windows directory to a file named diver.tpl.

Click Reset to reset the current session. See Using the Diver Toolbar on page 2-35 for information about the functionality of each available item.

Resetting the Toolbar to Default

The Windows > Reset the Toolbar to Default option allows you to revert the Toolbar back to the default settings.

Splitting and Unsplitting Windows

The Split Window feature allows you to look at two different views of the same data (e.g., Tabular and Pie) at the same time. To return the window to a single display, select Window > Unsplit Window. For more information, see Splitting Windows on page 4-28.
The Help menu displays options for PDF Help documentation (if configured in the diver.ini file; see Help Options on page B-12 for more information) as well as information about DI-Diver and ProDiver.

Selecting Help > About DI-Diver... or Help > About ProDiver... shows the Version and Copyright text, license information for lease versions of Diver, and whether Diver is unicode-enabled. The About dialog box for ProDiver also displays information about the current DiveLine Server. Each dialog is shown below.
Splitting and Unsplitting Windows Using the Help Menu

About DI-ProDiver...

Dimensional Insight, Inc.
DI-ProDiver 6.4 (b7)

Copyright 1991-2011 Dimensional Insight, Inc

DiveLine Information:
Server sunflower:6400
DiveLine Version: 6.4 (b7)

OK
DIVER
Chapter 4
Tabular Displays

Using Tabular Displays

Tabular displays in Diver look very much like spreadsheets. The row and column labels specify what information you are looking at, while the cells of the table show the specific values of the data.

Tabular display options available in Diver include:

- Tabulars
- CrossTabs
- MultiTabs
- MultiCrossTabs
- MultiTabMultiCrossTabs

The table below shows the column and row characteristics of each Tabular display type. Display types that allow 1 or more Dimensions or Summaries to be viewed are limited only by the number of Dimensions and Summaries present in the DivePlan.

<table>
<thead>
<tr>
<th>Display Type</th>
<th># of Dimensions</th>
<th># of Summaries</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tabular (page 4-2)</td>
<td>1 (vertical)</td>
<td>1 or more</td>
</tr>
<tr>
<td>CrossTab (page 4-3)</td>
<td>2 (1 vertical, 1 horizontal)</td>
<td>1</td>
</tr>
<tr>
<td>MultiTab (page 4-5)</td>
<td>1 or more (vertical)</td>
<td>1 or more</td>
</tr>
<tr>
<td>MultiCrossTab (page 4-7)</td>
<td>2 (1 vertical, 1 horizontal)</td>
<td>1 or more</td>
</tr>
<tr>
<td>MultiTabMultiCrossTab (page 4-9)</td>
<td>3 or more (2 or more vertical, 1 horizontal)</td>
<td>1 or more</td>
</tr>
</tbody>
</table>
Using Tabular Displays

Understanding the Tabular Display

The default window display shown in an initial dive is a Tabular display. It has the familiar row-and-column layout of a spreadsheet, as shown below. A Tabular displays one Dimension (Salesperson in this example) and as many Columns (Summaries or Info Fields) as are selected in the DivePlan.

![Tabular Display Example]

Using the Tabular Menu Item

The **Display > Tabular** menu item (or the Tabular toolbar button) converts the current Dive Window to a Tabular. The current display type influences the characteristics of the resulting Tabular display:

- When reverting from a CrossTab or a MultiCrossTab to a Tabular, the vertical Dimension does not change, and the horizontal Dimension is replaced with all data columns selected in the current DivePlan.
- When reverting from a CrossPlot, the original vertical Dimension of the graph (before conversion to CrossPlot) will become the Dimension of the Tabular, with the data columns displayed to the right.
- If the original window is a MultiTab, the Dimension at the far left becomes the Dimension displayed in the Tabular.
- If the window is a Plot, Scatter, Map, or Pie, the single Dimension of the graph becomes the Dimension of the Tabular, with all columns selected in the current DivePlan shown, even though only some of the columns may have been displayed in the graph.
Understanding the CrossTab Display

The CrossTab display allows you to combine two Dimensions in one graph or table, while showing a single Summary. For example, the following is a CrossTab display that shows Revenue Total broken down by Salesperson (Assil, Austin..., etc.) and by Product Family (Butter, Cheese...etc.).

<table>
<thead>
<tr>
<th>Salesperson</th>
<th>Butter</th>
<th>Cheese</th>
<th>Cottage Cheese</th>
<th>Cream</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2,306,091.72</td>
<td>4,051,650.70</td>
<td>4,706,303.66</td>
<td>1,354,631.48</td>
</tr>
<tr>
<td></td>
<td>2,174,814.77</td>
<td>1,325,961.73</td>
<td>133,894.50</td>
<td>521,876.37</td>
</tr>
<tr>
<td></td>
<td>984,066.50</td>
<td>1,325,961.73</td>
<td>133,894.50</td>
<td>521,876.37</td>
</tr>
<tr>
<td></td>
<td>1,200,140.42</td>
<td>1,856,602.70</td>
<td>165,406.38</td>
<td>450,708.91</td>
</tr>
<tr>
<td></td>
<td>3,802,046.06</td>
<td>5,517,498.18</td>
<td>584,277.12</td>
<td>1,523,286.26</td>
</tr>
<tr>
<td></td>
<td>1,955,975.21</td>
<td>2,180,561.54</td>
<td>177,456.69</td>
<td>675,739.63</td>
</tr>
<tr>
<td></td>
<td>1,910,357.81</td>
<td>2,602,461.96</td>
<td>291,609.70</td>
<td>616,172.66</td>
</tr>
<tr>
<td></td>
<td>2,407,692.32</td>
<td>2,734,318.22</td>
<td>326,155.34</td>
<td>526,408.27</td>
</tr>
<tr>
<td></td>
<td>1,301,917.49</td>
<td>1,711,054.77</td>
<td>92,469.45</td>
<td>527,189.47</td>
</tr>
<tr>
<td></td>
<td>1,225,757.76</td>
<td>1,522,210.36</td>
<td>161,546.10</td>
<td>519,920.08</td>
</tr>
<tr>
<td></td>
<td>1,430,547.58</td>
<td>1,433,103.58</td>
<td>175,082.04</td>
<td>483,902.01</td>
</tr>
<tr>
<td></td>
<td>1,516,596.69</td>
<td>1,759,089.71</td>
<td>214,546.06</td>
<td>546,005.46</td>
</tr>
<tr>
<td></td>
<td>1,955,427.55</td>
<td>1,756,390.00</td>
<td>91,323.70</td>
<td>450,639.84</td>
</tr>
<tr>
<td></td>
<td>2,323,512.16</td>
<td>1,944,545.75</td>
<td>131,107.23</td>
<td>549,652.39</td>
</tr>
</tbody>
</table>

The title of the CrossTab window is the name of the vertical Dimension (Salesperson). Although the name of the horizontal Dimension does not appear in the CrossTab, the name of each of its values appears. The horizontal Dimension in this example is Product Family; its values are Butter, Cheese, Cottage Cheese, Cream, etc. The Summary name (Revenue) appears in the upper-left corner of the CrossTab. A cell represents the combined relationship of the vertical Dimension row value and horizontal Dimension column value.

In the CrossTab display you can view only one data column or Summary at a time (Revenue), rather than all of the Summaries per record. It is possible to add a calculated field or an Info Field to a completed CrossTab; however it will refer only to the original vertical Dimension that was dived on before creating the CrossTab.

You can dive on a CrossTab cell. When doing so, the following behaviors should be considered:

- Selecting a column or row will automatically deselect any selection in the other (i.e., selecting a row will deselect any selected column and vice-versa).
- Single-clicking on a cell in a CrossTab or MultiCrossTab will allow you to dive by generating dive arrows in the Console. This will also select both the column and the row.
- Double-clicking on a cell in a CrossTab or MultiCrossTab will display the proper counts for the combination of row and column selected in the Totals region of the Console.
Using Tabular Displays

Understanding the CrossTab Display

- Diving from a CrossTab cell results in a plain Tabular window, while diving off of a CrossTab row still results in a new CrossTab. Cascading from one to the other will keep the child window the same (that is, if you dive off the CrossTab into another CrossTab and double-click on a cell while the child is open, the new child that results from the cascade will still be a CrossTab).
- A CrossTab dive is equivalent to a Dive path that contains both the vertical Dimension Value and the horizontal Dimension Value.

Diving off a CrossTab is limited to a Tabular view and is not available in Reports or Graphs.

Using the CrossTab... Menu Item

The Display > CrossTab menu item (or CrossTab toolbar button) converts the current Dive Window to the CrossTab display, or allows you to edit an existing CrossTab. When you choose this command or click the CrossTab button in the toolbar, the CrossTab dialog box shown below will open.

- **Horizontal Dimension**: Sets the second Dimension of the CrossTab. The vertical Dimension is the first Dimension listed.
- **Column**: Sets the column whose values will be displayed in the cells of the CrossTab. If a Summary or Info Field label was already selected when Display > CrossTab was chosen, the Element setting will default to that column. This list will include all columns defined in the DivePlan.
Understanding the MultiTab Display

The MultiTab display allows you to view multiple vertical Dimensions at a time, with all data columns visible.

With the MultiTab display, the data is not being narrowed or limited, rather, it is being combined by Dimensions for a more detailed view, resulting in many new rows. In the example below, the Dimensions are Product Family and Product Name, and the Data columns are Units, Cost, and Revenue, allowing you to view the Units, Cost, and Revenue of each Product Name, by Product Family.

![Table Example]

**Table Example**

<table>
<thead>
<tr>
<th>Product Family</th>
<th>Product Name</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>Total</td>
<td>25,395,065</td>
<td>71,471,067 94</td>
<td>761,764,485 51</td>
</tr>
<tr>
<td>Butte</td>
<td>Butter - Whipped - 12 oz Tub</td>
<td>710,004</td>
<td>15,429,545 13</td>
<td>15,502,448 25</td>
</tr>
<tr>
<td>Butte</td>
<td>Butter - Salted - 1 Stick - 1 Pound</td>
<td>611,721</td>
<td>14,003,452 46</td>
<td>14,712,741 09</td>
</tr>
<tr>
<td>Butte</td>
<td>Butter - Unsalted - 1 Stick - 1 Pound</td>
<td>713,372</td>
<td>15,101,033 06</td>
<td>15,232,346 50</td>
</tr>
<tr>
<td>Butte</td>
<td>Butter - Whipped - 8 oz Tub</td>
<td>690,021</td>
<td>14,621,950 63</td>
<td>15,899,500 38</td>
</tr>
<tr>
<td>Butte</td>
<td>Margarine - 16 oz Tub</td>
<td>736,364</td>
<td>15,389,023 46</td>
<td>15,579,017 70</td>
</tr>
<tr>
<td>Butte</td>
<td>Margarine - 4 oz Tub</td>
<td>203,264</td>
<td>4,236,618 17</td>
<td>4,946,026 74</td>
</tr>
<tr>
<td>Butte</td>
<td>Margarine - 8 oz Tub</td>
<td>936,663</td>
<td>10,003,609 22</td>
<td>20,127,187 74</td>
</tr>
<tr>
<td>Butte</td>
<td>Margarine - Stick - 1 Stick - 1 Pound</td>
<td>716,960</td>
<td>15,178,617 07</td>
<td>15,868,187 36</td>
</tr>
<tr>
<td>Cheese</td>
<td>American Cheese 16 oz Sliced</td>
<td>421,826</td>
<td>8,983,883 92</td>
<td>8,176,483 76</td>
</tr>
<tr>
<td>Cheese</td>
<td>American Cheese 5 Pound</td>
<td>424,009</td>
<td>9,138,454 28</td>
<td>9,525,453 62</td>
</tr>
<tr>
<td>Cheese</td>
<td>American Cheese 8 oz Sliced</td>
<td>404,108</td>
<td>8,536,390 27</td>
<td>8,875,730 86</td>
</tr>
<tr>
<td>Cheese</td>
<td>American Cheese Half-Pound</td>
<td>427,676</td>
<td>9,033,257 81</td>
<td>9,152,875 21</td>
</tr>
<tr>
<td>Cheese</td>
<td>American Cheese Pound</td>
<td>436,153</td>
<td>5,865,876 18</td>
<td>5,831,814 29</td>
</tr>
</tbody>
</table>
Using the MultiTab Menu Item

After the initial dive on any Dimension, select **Display > MultiTab** or click the MultiTab toolbar button to use the MultiTab functionality, and select a Dimension in the Console. The Console now displays all other Dimensions available for a MultiTab with a right-facing pointing to them, as shown below:

![Console with MultiTab]

The MultiTab can display as many Dimensions as there are in the Model; however, a MultiTab with many Dimensions can become cumbersome, and will involve trade-offs in computer speed, as each sum is performed by Diver. The time it will take to create a MultiTab can be decreased by focusing on the items of interest before switching to a MultiTab. For details on focusing, see **Focusing Rows of Interest on page 3-41**.
Understanding the MultiCrossTab Display

The MultiCrossTab combines two Dimensions, displaying one vertically and one horizontally, with the value of one or more Summaries at a time.

The title of the MultiCrossTab window is the name of the vertical Dimension. As with a CrossTab, the name of the horizontal Dimension does not appear in the MultiCrossTab, although each value of the horizontal Dimension does appear. In the preceding MultiCrossTab, Product Family is the vertical Dimension, and Sales Region (which includes Boston, North, etc.) is the horizontal Dimension. Each Summary name also appears in the column header for the appropriate columns; in this example, Revenue and Cost.
Using the MultiCrossTab... Menu Item

Select **Display > MultiCrossTab** or click the MultiCrossTab toolbar button to open the MultiCrossTab dialog box.

![MultiCrossTab Dialog Box]

Diver automatically uses the Dimension you dove on as the vertical Dimension. A **Horizontal Dimension** can be chosen from the pulldown list.

The **Summaries** list on the left shows the names of the Summaries not being used in the MultiCrossTab. The **Selected** list shows the Summaries that will appear in the MultiCrossTab. A Summary can be moved from one list to the other by selecting it and clicking the >> or << button. Click the **OK** button to close the dialog box and display the MultiCrossTab view of the data.
Understanding the MultiTabMultiCrossTab Display

The MultiTabMultiCrossTab combines three or more Dimensions and one or more Summaries. In order to create a MultiTabMultiCrossTab, you must first create a MultiTab, and then perform the MultiCrossTab, even for a single Summary. In this display, all Dimensions from the initial MultiTab will be displayed vertically, and the MultiCrossTab Dimension will be displayed horizontally.

This display is particularly useful for creating Reports because you can view finite relationships within the data. In the following example, data in the SalesPerson/Customer MultiTab is narrowed by Product Family. You can quickly see the Cost of, and Revenue generated for, each Product Family by a particular Salesperson for a particular Customer.

<table>
<thead>
<tr>
<th>SalesPerson</th>
<th>Customer</th>
<th>Cost</th>
<th>Revenue</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tellec</td>
<td>Tablets</td>
<td>1,664.94</td>
<td>761,765,141</td>
<td>114,762,240</td>
<td>115,762,240</td>
</tr>
<tr>
<td>Acct</td>
<td>Corning/Nestle Food Co</td>
<td>843,742.48</td>
<td>1,086,327.21</td>
<td>77,395.30</td>
<td>76,527.99</td>
</tr>
<tr>
<td>Acct</td>
<td>General Foods</td>
<td>58,827.12</td>
<td>5,297,664.02</td>
<td>569,041.72</td>
<td>611,304.12</td>
</tr>
<tr>
<td>Acct</td>
<td>Genentech Inc.</td>
<td>49,464.17</td>
<td>1,643,965.76</td>
<td>397,841.89</td>
<td>279,744.76</td>
</tr>
<tr>
<td>Acct</td>
<td>Powell/Day Care Service</td>
<td>51,529.81</td>
<td>3,444,115.95</td>
<td>407,399.60</td>
<td>450,163.19</td>
</tr>
<tr>
<td>Austin</td>
<td>Margaret Foods</td>
<td>88,074.40</td>
<td>6,862,091.49</td>
<td>1,395,470.74</td>
<td>1,031,951.90</td>
</tr>
<tr>
<td>Austin</td>
<td>InFightFood Inc</td>
<td>737,093.59</td>
<td>614,570.68</td>
<td>105,935.35</td>
<td>107,360.18</td>
</tr>
<tr>
<td>Austin</td>
<td>Dairy Fresh Foods</td>
<td>882,658.82</td>
<td>843,311.76</td>
<td>105,877.77</td>
<td>147,068.38</td>
</tr>
<tr>
<td>Austin</td>
<td>Quaker Foods International</td>
<td>76,602.90</td>
<td>1,885,631.53</td>
<td>204,537.25</td>
<td>197,027.84</td>
</tr>
<tr>
<td>Austin</td>
<td>Starship Foods</td>
<td>39,291.00</td>
<td>2,383,694.90</td>
<td>352,285.87</td>
<td>212,362.34</td>
</tr>
<tr>
<td>Bailey</td>
<td>Mighty Mart Foods</td>
<td>593,797.73</td>
<td>893,689.08</td>
<td>153,552.41</td>
<td>164,595.82</td>
</tr>
<tr>
<td>Bailey</td>
<td>Pino Foods</td>
<td>1,808,066.02</td>
<td>1,086,664.44</td>
<td>103,697.87</td>
<td>160,155.34</td>
</tr>
<tr>
<td>Bailey</td>
<td>Jansen Distributors Int'l</td>
<td>72,714.15</td>
<td>1,268,119.29</td>
<td>210,069.60</td>
<td>267,211.68</td>
</tr>
<tr>
<td>Bailey</td>
<td>Alexander Distributing O'Deaan Mix</td>
<td>54,557.00</td>
<td>2,916,095.00</td>
<td>306,920.67</td>
<td>415,562.63</td>
</tr>
</tbody>
</table>

Tabular Displays
General Characteristics of Tabular Displays

Each of the Tabular displays behave identically in most respects. Window characteristics are described in the following sections.

Using Basic Window Functions

Each of the five display types has a Standard Windows menu button in the upper-left corner. When clicked, this button displays a list of actions that can be used on the active window: Restore, Move, Size, Minimize, Maximize, Close, and Next.

Each window also has Standard Windows buttons in the upper-right corner.

Using these button, a window can be minimized to a task bar icon, maximized to full-screen, or closed.

A window can be resized by dragging its borders.
Understanding Row and Column Behavior

Each of the displays in Diver consists of a series of rows and columns. Behavior depends on the selected display type. Each are described in the following sections.

Row Behavior

The left-most column of a Dive Window contains row labels. The rest of the row contains data. If there are more rows than can be contained in the window, a vertical scroll bar will be enabled. This scroll bar moves all rows except for the Column headers row (this is the top two rows in a MultiCrossTab).

When the vertical scroll bar is dragged, a label keeps track of the scroll position, displaying the row label that would be at the top if the mouse button were released.

There is also a status bar located at the bottom of the Diver window to indicate which rows are being viewed once the mouse button is released. For example, if you dive on a Dimension with 200 values, and the current Dive Window is showing rows “totals through 17”, the status bar would read 200 rows (Totals-17).

Selecting row values may result in different behavior, depending on the type of selection, or subsequent actions performed. When selecting values in a row, please consider the following points:

Only this area can be scrolled
• When a single Dimension Value row label is selected, the History area of the Console is updated with arrows to the left of those Dimensions available for another dive, and the Dive History area of the Console is updated to show the selected row value.

• If the selection is double-clicked, the Console will show additional information, as explained in Viewing the Console History on page 2-16.

• If Organize > Flip Axes has been chosen, the Dimension Values will be in the column labels rather than in the row labels of a plain tabular window. The values of another Dimension will be in the other set of labels in a CrossTab window. In either case, it is not possible to dive from a column label, even if it is a Dimension Value. The solution is to flip the axes so that the desired Dimension is in the left column again, and then dive.

Column Behavior

The top row contains column labels or headers. Below the headers of each column (except for the left-most one) is the data. If there are more columns than can be contained in the window, the horizontal scroll bar will be enabled. This scroll bar moves all columns except for the left-most row labels, at a rate of one column per step.

Builder limits the length of Dimension, Info Field, and Summary names. However, once in Diver, columns can be aliased (select Edit > Edit Columns and change the Name field) with up to 256 characters.

Selecting column headers may result in different behavior, depending on the type of selection, or subsequent actions performed. When selecting columns, please consider the following points:

• Select any column and use the Sort Up and Sort Down commands on the Organize menu to sort that column. A MultiTab can be sorted by multiple columns. For details, see Multi-Sort on page 3-47.

• To remove a column in a Tabular or a MultiTab window from the display, select the column label and choose Edit >Delete.

• Double-click on a column label in a plain tabular window to display the Edit Column dialog box, for the purpose of editing the current column in more detail.

In a CrossTab or a MultiCrossTab, only calculated fields or Info Fields may be removed.
Rearranging Columns

With the exception of the left-most one, columns in a plain Tabular window may be rearranged. Columns in a MultiTab can also be rearranged, or moved to either side of the thick vertical line. Columns in a CrossTab or a MultiCrossTab cannot be rearranged. To move a column, press and hold the mouse button for several seconds. Drag the outline to a different location between the two column headers where it should be inserted, as shown below:

The column must be dropped (the mouse button released) with the mouse cursor on another column label. If the cursor leaves the top row, by drifting either too far up or down on the screen, the column outline will disappear; however it will reappear when the mouse cursor re-enters the top row, as long as the mouse button has not been released.

When the mouse button is released over a column label, the dragged column is removed from its original location and inserted at the column border nearest to the cursor. To move multiple columns, use the Select Columns dialog described on Editing Columns on page 9-43.

Resizing Columns

Any column in a tabular window may be resized. To resize a column, place the mouse over the right boundary of the column header. The mouse cursor will change to the column-resize cursor. Stretch or compress the column by moving the mouse right or left. The mouse cursor must be kept within range for the outline to remain visible and for a resize to take effect. The allowable range is from the opposite (left) border of the column to the right end of the window. (The window will not scroll to make more room on the right.) The resize cursor will remain until the mouse is moved away, making it easy to fine-tune the column width by adjusting it several times in a row.

Tabular Displays 4-13
When the mouse button is released (the column border is dropped), the column to the left of that border will snap to its new size, and all columns to the right of the resized one will shift as needed to accommodate the size change.

A resized column’s position width is fixed for the entire session. The Edit Column Options must be used to set the column width and save it in the DivePlan.

The height of the column headers row can be changed to a single line or expanded to more than two (default). To resize a header row, place the mouse over the bottom boundary of the header. The mouse cursor will change to the column-resize cursor. At this point the header row can be stretched or compressed by moving the mouse up or down.

When a tabular window is created, each column is made just wide enough to fit the widest of its contents. The widest row label determines the size of the left column; the widest of the data or its column headers determines the size of a data column. Column resizing is usually not necessary, but is available as a convenience.

Extra width due to widening a column will be filled with white space. If the new column size is too narrow for the contents, ellipses will appear to indicate truncated text or numbers. Numbers (data cells) will always be right-aligned, and will lose their most significant digits (the left end) if they are too wide for the column. Text (column labels and info cells) will always be left-aligned, and will lose the right-most characters if too wide for the column.

A column’s name can be changed by double-clicking on the column label, typing the new name into the Name area of the Edit Column dialog box, and clicking OK. The column name text will already be highlighted when the dialog box appears. See Chapter 9, DivePlans & Calculations for details about the Edit Column dialog box. In a CrossTab, only calculated fields or Info Fields may be renamed.

In a CrossTab window, the columns may be resized but they cannot be rearranged, removed, renamed, or otherwise edited (except for calculations). You must instead rely on Sort Up, Sort Down, and Organize > Focus to change the order of the headers and hide unwanted columns.

Double-clicking a Dimension column header will open the Edit Column - Dimension Options dialog box. See Setting Dimension Column Options on page 4-25 for more information.
Making Selections in a Tabular Display

There are two types of selections in tabular windows: single-click and double-click.

A single-click on the left mouse button is a basic selection, highlighting the chosen label or cell and enabling further diving.

A double-click highlights the chosen label or cell and updates the Console with more detail, or presents a dialog box allowing for further customization. A special case of double-clicking in a tabular window is the cascade, which is described on page 4-30.

Any single row label, column label, or data cell can be selected by single-clicking on it. A range of labels or cells may be selected by either dragging the mouse across the range, or by clicking at one end of the range, then Shift-clicking at the other end. Non-adjacent labels can be added to a selection using the Ctrl key and a mouse click on each desired label. Any row label can be deselected by selecting a different row label, or by clicking on the already-selected label. The same is true of column labels, although this action is independent from row labels. A single selection can be undone by a Ctrl-click on the selected item.

In general, selecting items by single- or double-clicking on them with the mouse is called “hard selecting”. When selecting information that should be updated the next time Diver is used (such as looking at the “top 10 salespeople”), Find should be used rather than a hard select. The Find option is capable of saving the logic behind the selection rather than just the actual values the hard select does. More information is available under Using the Find Functionality on page 3-26.
Using the Tabular Window Context Menu

Each Tabular window type shares a common Context Menu, allowing for several additional functions. This menu can be accessed by right-clicking in any blank area of the tabular, and is shown and described below.

- **Copy Window** copies the entire contents of the active Dive Window to the clipboard.
- **Add Column...** opens the Add Column dialog box to create columns and add them to the display. For more information, see Adding Calculations on page 9-13.
- **Select Columns...** opens the Select Columns dialog box to select previously created columns, and add them to the display. For more information, see Selecting Columns on page 9-45.
- **Select All** selects the entire contents of the active Dive Window.
- **Flip Axes** switches the x-axis with the y-axis in the current Dive Window. This item corresponds to the Organize > Flip Axes menu item. For more information, see Flipping Axes on page 3-39.
- **Sort Up** sorts the contents of the selected column in ascending order, and corresponds to the Organize > Sort Up menu item. For more information, see Sorting Values on page 3-46.
- **Sort Down** sorts the contents of the selected column in descending order, and corresponds to the Organize > Sort Down menu item. For more information, see Sorting Values on page 3-46.
**Find...** opens the Find String dialog for the left-most Dimension in the active Dive Window. For more information, see *Using the Find Functionality on page 3-26*.

**Edit Info Window...** displays the *Edit Window Information* dialog box to change some settings used in Dive Windows. Select the Dive Window to be changed as the active window, right-click and select Edit Window Info.

The first setting that can be changed is the name of the window shown in the title bar. Entering new text in the Window Name area of the Edit Window Information dialog box will change the text in the title bar of the Dive Window.

The QuickViews portion of the Edit Window Information dialog box is used to set associations for QuickViews.

**Convert to QuickView...** creates a pulldown QuickView of the active Dive Window. For more information, see *Creating a Dimension QuickView from a Tabular Window on page 7-18*.

**Convert parents to QuickViews...** converts all parent Dive Windows of the active window to QuickViews, setting appropriate dependencies based on the order of the dive.

**Copy Calculation Reference** is used when creating Report Palettes. For more information, see *Copying and Pasting Calculation References on page 11-15*.

**Copy Reporter Reference Item** is used when creating Report Palettes. For more information, see *Using Reporter Reference Items on page 11-18*.

**Copy Window Dive Reference String** is used when creating Report Palettes. For more information, see *Copying and Pasting Window Dive Reference Strings on page 11-25*.
• **Create User Defined Dimensions...** is used to create new Dimensions in the display. For more information, see *Creating a User Defined Dimension on page 4-19*.

• **Edit User Defined Dimensions...** allows you to make changes to User Defined Dimensions. For more information, see *Editing a User Defined Dimension on page 4-23*.

• **Commit User Defined Dimensions...** confirms and adds the User Defined Dimension to the window. For more information, see *Committing a User Defined Dimension on page 4-22*.

• **Close User Defined Dimensions...** Removes the User Defined Dimension from the display. For more information, see *Closing a User Defined Dimension on page 4-23*. 
Configuring User Defined Dimensions

A User Defined Dimension (UDD) allows you to define your own new Dimensions within a Tabular window. This Dimension is then usable for the rest of the session, or can be saved in a DivePlan or Marker and used later. This functionality provides a dynamic Diver lookup tool.

For example, with a UDD, you can create a new column relative to a Dimension while still within the Diver session. You can specify what the value of that new column should be for each value of the original Dimension. Values that you choose not to define, or that get added later, will use a special placeholder value that you also define; for example, consider a Dairy Cooperative that wants to track a current promotion. You will need to define the promotion in terms of the Product Name Dimension in the Model.

Creating a User Defined Dimension

1. Dive on the Dimension with which you want to associate the User Defined Dimension. Please note that creating a UDD against a Dynamic Dimension is not recommended. If you attempt to do so, the UDD is automatically associated with the underlying Core Dimension rather than the Dynamic Dimension under which it was created, which may cause later confusion.

2. Right-click an empty area of the Tabular window to open the context menu.

3. Select **Create User Defined Dimension...** to open the Create User Defined Dimension... dialog box.
4. Enter the name of the Dimension to be defined in the Name: box. In this example, “Cream Promotion”. The Undefined Values: box specifies what to display for those values not yet defined. Leave this blank and click OK.

![Create User Defined Dimension dialog box]

After clicking OK, a new column appears in the tabular window labeled “Cream Promotion”. It is shaded differently to indicate that new values can be entered into the column. The window is still a Tabular window – you can Sort, Find, Focus, and Dive.

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Cream Promotion</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cheddar Cheese Pound</td>
<td>441,252</td>
<td>9,320,693.20</td>
<td>9,443,150.74</td>
<td></td>
</tr>
<tr>
<td>College Cheese - Half-Pint</td>
<td>219,190</td>
<td>4,452,854.07</td>
<td>4,748,401.06</td>
<td></td>
</tr>
<tr>
<td>College Cheese - Pint</td>
<td>226,009</td>
<td>4,536,962.55</td>
<td>4,826,407.38</td>
<td></td>
</tr>
<tr>
<td>College Cheese - Quart</td>
<td>225,073</td>
<td>4,556,078.51</td>
<td>4,930,910.56</td>
<td></td>
</tr>
<tr>
<td>Cream Cheese - 10 oz</td>
<td>230,373</td>
<td>4,673,215.52</td>
<td>5,144,193.79</td>
<td></td>
</tr>
<tr>
<td>Cream Cheese - 14 oz</td>
<td>235,749</td>
<td>4,699,451.94</td>
<td>5,150,357.45</td>
<td></td>
</tr>
<tr>
<td>Egg Nog - Half-Gallon</td>
<td>233,210</td>
<td>4,614,435.54</td>
<td>4,985,411.56</td>
<td></td>
</tr>
<tr>
<td>Egg Nog - Light - Quart</td>
<td>260,189</td>
<td>5,477,818.54</td>
<td>5,819,687.91</td>
<td></td>
</tr>
<tr>
<td>Egg Nog - Quarts</td>
<td>231,405</td>
<td>4,637,235.41</td>
<td>5,017,375.17</td>
<td></td>
</tr>
<tr>
<td>Milk Substitute - Pint</td>
<td>253,720</td>
<td>5,309,342.22</td>
<td>5,578,981.26</td>
<td></td>
</tr>
<tr>
<td>Milk Substitute - Quart</td>
<td>224,454</td>
<td>4,674,523.18</td>
<td>4,905,670.37</td>
<td></td>
</tr>
<tr>
<td>Gouda Cheese 12 oz.</td>
<td>454,901</td>
<td>9,050,075.71</td>
<td>9,745,670.91</td>
<td></td>
</tr>
<tr>
<td>Gouda Cheese 6 oz.</td>
<td>411,920</td>
<td>8,030,007.02</td>
<td>9,015,090.31</td>
<td></td>
</tr>
</tbody>
</table>

— Click a cell in the new column to select it; it highlights.
— Click again to activate the text box for data entry.
— Enter the value, then click outside the box.
5. Enter “Cream Promo” into a cell (based on the Product Names) and right-click to copy and paste it into the remaining cells, as needed.
Committing a User Defined Dimension

Once the values in the Cream Promotion column are complete, right-click to open the context menu, and select **Commit User Defined Dimension**. This creates a new Info Field called “Cream Promotion” with the specified values, and automatically promotes it to a diveable Dynamic Dimension. It can then be demoted to an Info Field using the **Edit > Edit Dimensions...** dialog. More on Dynamic Dimensions can be found on page 9-53.
Editing a User Defined Dimension

If, after reviewing the User Defined Dimension, you decide that Dimension Values were classified incorrectly, you can make changes to the Dimension.

1. Return to the Product Name Dive Window (this could be the same Dive or a new Dive).
2. Right-click an empty cell to open the context menu.
3. Select **Edit User Defined Dimension...**
   
   This will open a dialog box similar to the Create User Defined Dimension dialog box, except that the text box used to name the Dimension has changed into a Pulldown Combobox, with a list of all User Defined Dimensions.
4. Select “Cream Promotion” from that list and click **OK**. The column Cream Promotion will reappear in the Product Name Tabular with the values that were previously entered.
5. Select and edit the values in all desired cells. All relevant dives will automatically update to reflect the changes that you made.

If you forget to commit your changes and click on the Close box in the corner of the tabular window, Diver will prompt you to save the changes. This will also happen if you attempt to exit the Diver before saving your UDDs.

Closing a User Defined Dimension

To Close a User Defined Dimension, right-click an empty area in the Tabular to open the context menu, and select **Close User Defined Dimension**. The UDD is then removed from the Tabular.
General Characteristics of Tabular Displays

**Editing Window Fonts**

**Edit > Font** allows you to change the font used for all text in tabular windows. The dialog box sets the font to be used by the active window, and by all child windows of the active window.

The following dialog box allows you to choose Font, Size, and Style. **Using the Add Column Options Tab on page 9-9**

---

### Setting Decimal Places

The number of decimal places displayed in a tabular column can be set in the **Decimal places** area of the Edit Column dialog box Options Tab. If the selected number of decimal places is lower than the default, the decimal will be rounded up or down to the nearest digit. Decimals less than .5 are rounded down; decimals greater than .5 are rounded up. If the decimal is exactly .5, and the next higher digit is odd, it is rounded down; if the next higher digit is even, it is rounded up.

Rounded values are not used in calculations or in the Find dialog, but rather the original values are used.

For more information on the Decimal places setting, see **Using the Add Column Options Tab on page 9-9.**
Using Exception Coloring

The cells in a column can be color-coded using an Exception Column in the Edit Column dialog box Options Tab. For more information, see Using the Add Column Options Tab on page 9-9.

Setting Dimension Column Options

If the column header of any Dimension that appears in a tabular-type display is double-clicked, the Edit Column - Dimension Options dialog box appears.

- **Column Name field** reflects the current name of the Dimension that was chosen. To rename the column, type the desired name in this field. Any new name given is reflected in the DivePlan and Marker Dive Window, but not in calculations, Console, parent windows, etc.

Builder limits the number of characters in a Dimension name, but this limit can be overcome by renaming the column in Diver, up to a maximum of 256 characters. It is best to avoid names containing the following characters: [ ] , : + - * / $. Also avoid using a numeric value as the first character.
The **Column Size** area allows you to change the size of the selected Column. If Fit to Data is chosen, the column will be resized to fit the longest data field that exists in that Dimension. This is the case even if the data has been focused. For example, if the field McCarthy is the longest entry in the Dimension “Salesperson”, and the data has been focused to include only entries that begin with A, the column will still be sized to fit McCarthy.

To specify the exact size of the column, click on the radio button next to **Set Size** and enter the number of pixels for the width of the column. The default value is 100 pixels. The absolute size of a pixel varies, as does the size of the characters displayed, due to variations in monitor resolution.

The **Format** area is used to set the format of data in the column. The options available vary based on the type of data in the Dimension. “**None**” is always available. “**Number**” and “**Date**” are available only if the data is completely numeric; otherwise, the option “**Period**” will be available.

For example, the Dimension “Quarter” might include data like 2011/1; this is not completely numeric, and the only available options would be “**None**” and “**Period**”. The Dimension “Order Date” might include data like 37892, which is entirely numeric, so available options would include “**None**”, “**Number**”, and “**Date**”.

---

When creating a Model, the Builder converts date columns into an internal date format (an integer). This integer represents the count of days since Dec. 31, 1899.

Changing the Format of a Dimension changes how Diver treats the Dimension. “**Number**” and “**Date**” cause Diver to change how data appears. Formatting a column to “**Date**” or “**Period**” makes that column available for time-based functions in other features of Diver, such as adding Time Series columns using the Time Series Control Panel.

— If **None** is chosen, Diver presents the data exactly as it appears in the Model.

— If **Number** is chosen, you can specify the number of decimal places that Diver will present, to a maximum of ten.

— If **Date** is chosen, Diver will reformat the Date. You can choose which date format to use from the pulldown menu next to Format, or type in a new format. Diver calculates the date based on the number of days starting from December 31, 1899. For example, the date value 2 corresponds to January 1, 1900. Only dates from March 1, 1900 forward are valid in Diver. If the Model has a Dimension that includes date-representative numbers, such as 38357, it can be formatted as a typical date. In
Using URL’s in a Tabular

Diver supports the use of URLs in Tabular cells. If the data contains a URL, it will appear in blue and be underlined. You can click on a URL and Diver will launch the default web browser to the page. This action can open files stored locally on the computer or network, or connect to them over the Internet.

Data can be formatted in any of three ways for URLs to work:

- http://thisismyurl.com
- https://thisismyurl.com
- <a href="http://thisismyurl.com">This Is My Document</a>

In the first two, the full URL would be visible in the tabular window. In the third, only the blue and underlined words “This Is My Document” would be displayed.
Splitting Windows

It is possible to display two different Dive Window views at one time using the Split Window feature of Diver. Once the Dive Window is split, both screens are based on the same dive and therefore display the same data. Any change to one screen is reflected in the other. To activate this feature:

1. Dive on a Dimension.
2. Select **Window > Split Vertical** or **Window > Split Horizontal**.

The window will split into two identical screens. You can choose which screen to work in by clicking in it with the mouse. The active screen is distinguished by a blue border around it. The display of the active screen can then be changed.
Selections or changes in content of one screen will be reflected in the other, since they are both based on the same data and are the same dive.

Some display types will be unavailable (grayed out on the toolbar or menu) if the number of Dimensions required for the display does not match the number of Dimensions in the active window. Once the display is returned to a single window, those options will become available again. In addition, columns may not be removed from any tabular display while the window is split.

When cascading from a split window, the child will inherit its display type from the active screen and will be unsplit.

When printing a split Dive Window, the Multi-Page Split Window dialog box appears, giving you an option to Split every page, which shows both views on every page, or Print the two parts separately, which shows each view on a separate page. When diving from a split window, the child will inherit its display type from the active screen. When printing a split window from batch mode, however, Diver defaults to the split-window printing method which is most likely to be good for that particular combination of windows.

To return the window to a single display, select Window > Unsplit Window.
Cascade Diving

Cascading is the ability to double-click at any level along the Dive path and change the data in all subsequent dives. A Cascade dive can be performed from either a tabular or a graphical window.

As you dive, you are creating a “Dive path”. A Dive path is a history of open dives, displayed in the History region of the Console. In the following example, the top of the path is Sales Region and the bottom is Product Family.

Cascading is achieved by double-clicking on any Dimension Value along the Dive path. In the example below, the selected Sales Region value is North, and all subsequent Dive Windows are based on the North Sales Region. If Boston were chosen in the first Dive Window, the data in all subsequent Dive Windows would be updated relative to the Boston Sales Region.
Missing Data

Sometimes changing Dimension Values at one level in a Cascade dive will cause lower levels along the Dive path to contain missing data. When this happens, all the windows that have no data will show a “Tabular Window Missing Group Data” error message like the following:

Diver displays this error message because the Salesperson, Carroll, belongs to the North Region, not to Boston. When the Boston region was selected, Carroll no longer related to the Sales Region Dimension. All subsequent dives that were based on Carroll, therefore, have no meaning and no such data exists in the Model. Reselecting a value with data will result in Dive Windows with data.
DIVER
Chapter 5
Graphs

Using Graphs in Diver

Diver allows you to view Tabular data in various graph formats, to help discover new information, trends, or variances that otherwise might not be apparent. The table below lists each type of graph available in Diver, and how that graph is used.

**Table 5-1: Graph Type Usage**

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Purpose</th>
<th>Dim</th>
<th>Sum</th>
</tr>
</thead>
</table>
| Basic Plots ([page 5-6](#)) | • Displays data for a single Dimension and multiple Summaries in a linear format.  
• Useful for Period Comparisons.  
• Can be configured as Bar, Line, Point, Area, Spline, or Linear Bubble (see below for Area, Spline, and Linear Bubble descriptions).  
• Line and Point plots are most commonly used to display movement of quantitative data across time.  
• A Point plot is a Line plot without the connecting lines. | 1 | Up to 16 |
Table 5-1: Graph Type Usage

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Purpose</th>
<th>Dim</th>
<th>Sum</th>
</tr>
</thead>
</table>
| Area & Line Plots         | • Area plots fill in the area below a Line plot, providing a visual representation of volume or area.  
                           | • Line plots are most commonly used to display movement of quantitative data across time. | 1   | Up to 16  |
| Spline Plots              | • Smoothed variation of a Line plot.                                    | 1   | Up to 16  |
|                           | • Should only be used when a polynomial relationship exists in the data series being plotted. |     |           |
| Linear Bubble Plots       | • Linear plot with an extra data column, displayed as bubble diameter.  | 1   | Up to 16  |
| Calendar Plots (page 5-16)| • Displays Summary data for a single Dimension in Calendar format.     | 1   | Up to 16  |
|                           | • Visualize trends by day-of-week and week-over-week.                   |     |           |
| Cross Plots (page 5-24)   | • Displays 1 Dimension’s values across a second Dimension, for a single Summary.  
                           | • Bubble variation displays value of third Dimension.                   | 2   | 1         |
| Control Charts (page 5-30)| • Standard statistical background charts used to observe data trends and variance. | 1   | Varies    |
### Table 5-1: Graph Type Usage

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Purpose</th>
<th>Dim</th>
<th>Sum</th>
</tr>
</thead>
</table>
| Time Graphs/Gantt Charts (page 5-48)    | • Type of Bar plot that illustrates tasks that comprise the work breakdown structure of a project, over time.  
• Effective visual project management tool.  
• Understand project dependencies at-a-glance. | 0 (Info Fields used instead) | 2    |
| Maps (page 5-54)                        | • Displays data over a geographical location.                                                | 1   | 1    |
| Pie Plots & Doughnut Plots (page 5-57)  | • Compares all values of a single Dimension.                                                | 1   | 1    |
| Radar Graphs (page 5-60)                | • Radially displays 1 or more Summaries of a single Dimension.  
• Radar graphs can be configured as Area, Line, or Point. | 1   | Up to 16 |
| Scatter Plots (page 5-63)               | • Compares 2 Summaries across 1 Dimension.  
• Used to display the relation between two continuous valued data series.  
• Bubble variation displays value of third Dimension. | 1   | 2    |
Using Graphs in Diver

Table 5-1: Graph Type Usage

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Purpose</th>
<th>Dim</th>
<th>Sum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stack Plots (page 5-68)</td>
<td>• Stacks 1 Dimension’s Values over a second Dimension, for a single Summary.</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>• Used for showing relative contribution.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Useful for displaying a common metric (revenue) across two data Dimensions Product Family and Sales Region.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Stack Plot Example](image_url)
Creating Graphs

Regardless of the type of graph selected, these steps are common to the creation of all graphs.

1. Select **Display > Graph**, or click the Graph toolbar button, to open the Select Graph Type dialog box shown below:

![Select Graph Type Dialog](image)

2. Expand the appropriate graph type header, and select the type of graph to create under that header. By default, Basic Plots is expanded, and Bar Plots is selected.

   Toolbar buttons for some graph types are available using **Window > Customize Toolbar**... If these are used to select a Graph Type, the dialog box will have that type already highlighted.

3. Click **Next >**, and the Wizard will walk through the steps of creating the graph. The Wizard varies with each graph type, and each are shown in the following sections. To exit the Wizard at any time, click **Cancel**.
Using Basic Plots

Basic Plots include Bar Plots, Line Plots, Point Plots, Area Plots, Spline Plots, and Linear Bubbles. Bar, Line, Point, Area, and Spline Plots each display a series of plotted points that correspond to the Summary Values being plotted. Each unique Summary, Calculated Column, or DimCount being plotted is referred to as an “element”. Bar Plots contain a bar from each value to an axis, showing the magnitude of that particular value. Line Plots connect values with a series of line segments. Point Plots display a single point for each value.

All five types of graphs can be displayed and scrolled in either horizontal or vertical orientation, and have identical labeling and tagging support. Bar and Line Plots can be displayed in either 2-D or 3-D. All elements (bar, line, and point) in a Basic Plot are fundamentally the same, and may be mixed freely, up to a maximum of 16 elements per graph.

The Linear Bubble Plot is used to display the relationship between two Summaries as they relate to a specific Dimension Value; one on the Y-axis and the other as the diameter of a bubble. Each Dimension Value is positioned along the X-axis. Dimension Values are represented as vertical distance from the origin (0,0) in one Summary Value, and as a larger bubble in the other Summary Value.
Creating Bar, Line, Point, Area, and Spline Plots

After one of the Basic Plot types has been selected from the Select Graph Type dialog box, Diver will step you through the Wizard to create the plot.

1. To add the Summaries to be graphed, double-click on the (Add Column) text.

2. Select the desired Summary from the pulldown. The pulldown will only list those Summaries that appear in the active Tabular display.

3. Repeat steps one and two until all desired columns have been added.

The selection and order of Summaries to be displayed in the plot must be set when creating the plot. To rearrange the order in which Summaries are displayed, use the up and down arrows on the right side of the dialog box.
Items can be deleted by selecting them and using the Delete Column button.

4. To change the **Display Type** of a Summary, double-click on the current setting and select a different type from the pulldown. The Display Type can be set to Bar, Line, Point, Area, Spline, Area Spline, Bar - Sum, Line - Sum, or Point - Sum.

The Sum option types display data in the same manner as setting the cumulative option on a Summary column, except that the actual data column is not changed in the tabular. It is only changed in the graph window for display purposes.
5. Double-click on the current **Scale** setting and change the Scale from Left to Right or vice-versa, to display a column on a different Y-Axis (Left or Right).
6. If a Line Plot is being displayed, change the **Line Width** by double-clicking the Line Width setting and selecting a new width. You can choose between one and six pixels. The default selection is three.
7. If a Point Plot is being displayed, change the **Point Shape** and **Size** by double-clicking the Point Shape and Size settings respectively. Point shapes include: Dot, Square, Triangle (Up), Triangle (Down), Diamond, Cross, and X-Mark. The default selection is Dot. Point Sizes can be set to 6, 8, 10, 12, 14, 16, 18, or 20 pixels in width. The default selection is 12.

The **Fill empty items with available rows upon opening graph**, available for several graph types, will automatically populate the first 16 graph elements with the first 16 available Dimension values in the Dive Window. This option is especially useful when QuickViews are being used, because it will automatically update the first 16 graph elements with the Dimension values associated with the selected QuickView value. This feature is available for use in Linear Plots and CrossPlots.

8. Click **Finish** to display the basic plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

Below are finished examples of each type of Basic Plot.
Bar Plot Example

Line Plot Example
Point Plot Example

![Point Plot Example](image1)

Area Plot Example

![Area Plot Example](image2)
Spline Plot Example

Area Spline Plot Example
Creating Linear Bubble Plots

Linear Bubble plot creation is slightly different than the steps previously described for other basic plots. After Linear Bubble has been selected from the Select Graph Type dialog box, create a Linear Bubble Plot as follows:

1. Double-click on the **Add Column** pulldown to select which Summary or Summaries the bubbles should represent. Select the desired column(s) (Cost and Units, for example).

2. Double-click under the Scale heading to change the scale from Left to Right, if desired. Left is the default selection.

3. Select the desired column in the **Bubble Column** pulldown (for example, Revenue) to set the Summary that should be used to represent the width of the bubble.

4. Click **Finish** to display the Bubble Plot, or click **Graph Options...** to change the Graph attributes as described under *Setting Graph Options* on page 5-71.

Below is a completed Linear Bubble Plot:
Using Calendar Plots

Calendar Plots include Calendar View with Bar Plots, Calendar Active View, and Calendar Sorted View. To create a Calendar Plot, you must dive on a Dimension that contains data formatted as a date (double-click on the Dimension header to reformat it, if desired). Calendar Plots are the only display type that shows all Calendar days even if data is not present. It is important to note that the Previous, Next and Zoom out buttons work in DivePort, and are available to the casual and higher user. When sending a calendar plot to Excel, it is sent in its tabular form.

Creating a Calendar View with Bar Plots

In a Calendar View with Bar Plots, a bar for each selected Summary (Element) is placed inside the calendar square for each date. It represents the magnitude of the Summary Value for each particular date in the Calendar.

After Calendar View with Bar Plots has been selected from the Select Graph Type dialog box, Diver will step through the Wizard to create the plot.

1. Select the Summary columns to display in the Calendar, up to 16 columns. You can double-click the Display Type and select Bar or a Point. If Point is selected, you can set the desired shape and size of the displayed point by double-clicking under each heading.
2. To change the **Display Type** of a Summary, double-click on the current setting and select a different type from the pulldown. The Display Type can be set to Bar or Point.

---

The Scale and Line Width columns are not used in Calendar Plots.

---

3. If Points are being displayed, change the **Point Shape** and **Size** by double-clicking the Point Shape and Size settings respectively. Point shapes include: Dot, Square, Triangle (Up), Triangle (Down), Diamond, Cross, and X-Mark. The default selection is Dot. Point Sizes can be set to 6, 8, 10, 12, 14, 16, 18, or 20 pixels in width. The default selection is 12.

4. Select the **Zoom Level** at which the Calendar should begin when it is first drawn.
   - **Day** - displays the earliest date in the selected Dimension.
   - **Month** - displays the earliest month in the Dimension.
   - **Year** (default) - displays the earliest year in the Dimension.
   - **All** - displays all days, months, and years in one plot. This setting can be easily changed later, while viewing the Calendar Plot.

5. Select the **Starting Position** for the Calendar. This setting specifies which Day, Month, or Year Diver should show the first time it draws the Calendar.
   - **Current Viewed** - shows whatever date range you are currently viewing. The date range being shown does not change when the underlying data set changes.
   - **First day of set** (default) - shows the first available row of data, using the current zoom level (year, month, day).
   - **First selected day** - shows the first selected row of data, using the current zoom level (year, month, day).
   - **Last day of set** - shows the last available row of data, using the current zoom level (year, month, day).

6. Click **Finish** to display the Calendar plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.
Creating a Calendar Active View

The Calendar Active View tells only whether there is data available in any of the chosen Summaries for each date. All Summary Fields in the active Dive Window are used to determine if a day is Active or Inactive. In the calendar produced by the steps below, all dates shown in dark gray have Active data, while those in light gray do not. In this Model, all weekend dates, and all months after June 2004 have no data, so those are displayed as Inactive.

After **Calendar Active View** is selected in the Select Graph Type dialog box:
1. Click **Next >** to display the Set Data Attributes dialog box. Note that when creating a Calendar Active View plot, you are **NOT** prompted to select data columns, because all Summaries in the active Dive Window are used by default.

2. Select the **Zoom Level** at which the Calendar should begin when it is first drawn.
   - **Day** displays the earliest date in the selected Dimension.
   - **Month** displays the earliest month in the Dimension.
   - **Year** is the default setting, and displays the earliest year in the Dimension.
   - **All** displays all days, months, and years in one plot. This setting can be easily changed later, while viewing the Calendar Plot.

3. Select the **Starting Position** for the Calendar. This setting specifies which Day, Month, or Year Diver should show the first time it draws the Calendar.
   - **Current Viewed** is the default setting, and shows the most recent date in the Dimension.
   - **First day of set** shows the earliest date in the Dimension.
   - **First selected day** shows the date that is currently selected in the Tabular view.
   - **Last day of set** shows the last date in the Dimension. It can be easily changed later,
while viewing the Calendar Plot.

4. Click **Finish** to display the Calendar plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

A completed Calendar Active View is shown here:
Creating a Calendar Sorted View

The Calendar Sorted View displays clusters of the same value or range of values. In the Calendar on the next page, all dates that had between 150 and 200 customer purchases appear in purple, all dates where 100-149 customers made purchases appear in dark blue, etc. Only the first four value ranges will be displayed.

After **Calendar Sorted View** is selected in the Select Graph Type dialog box:

1. Click next to Data Attribute 1 to select a **Data Attribute**. This is the Summary column to be displayed in the Calendar.

2. Select the **Zoom Level** at which the Calendar should begin when it is first drawn.
   - **Day** displays the earliest date in the selected Dimension.
   - **Month** displays the earliest month in the Dimension.
   - **Year** is the default setting, and displays the earliest year in the Dimension.
   - **All** displays all days, months, and years in one plot. This setting can be easily changed later, while viewing the Calendar Plot.

3. Select the **Starting Position** for the Calendar. This setting specifies which Day, Month, or Year Diver should show the first time it draws the Calendar.
Current Viewed is the default setting, and shows the most recent date in the Dimension.

First day of set shows the earliest date in the Dimension.

First selected day shows the date that is currently selected in the Tabular view.

Last day of set shows the last date in the Dimension. It can be easily changed later, while viewing the Calendar Plot.

4. Click Finish to display the Calendar plot, or click Graph Options... to change the Graph attributes as described under Setting Graph Options on page 5-71.

A finished Calendar Sorted View is shown below:
The Calendar Sorted view also offers the option of using a Color Range for value shading. If the “Use Color Range” radio button is selected in Graph Options dialog Legend tab, the resulting calendar would look like this instead:

You can change the Start and End Colors of the color range, resulting in a color gradient for the values displayed in the plot. For more information, see Using the Legend Tab on page 5-78.

If an increasing or decreasing trend of values is present, this graph type will clearly indicate that trend.
Using CrossPlots

Cross Plots include Bar CrossPlots, Line CrossPlots, Point CrossPlots, Bar Summary CrossPlots, Line Summary CrossPlots, Point Summary CrossPlots, Bubble CrossPlots, 3-D Bar CrossPlots, 3-D Line CrossPlots, 3-D Bar Summary CrossPlots, and 3-D Line Summary CrossPlots.

The Cross Plot is the graphical equivalent of the CrossTab, showing the intersection of two Dimensions with one data element. Each individual bar, line, or point represents a Dimension Value. There may be up to 40 lines/bars/points for Cross Plots for each of the vertical Dimension’s values (the Dimension dove on). The first dive should be on the Dimension the bars/lines/points should represent. For example, to plot how individual salespeople are doing over time, you would dive on Salesperson, and do a Cross Plot with the data element Revenue Total, and the horizontal Dimension Quarter.

Creating Bar, Line, and Point CrossPlots

After selecting one of the Cross Plot types from the Select Graph Type dialog box:

1. Select the Summary columns to display.
2. For each selected Row Value, double-click under **Display Type** to specify whether to display it as a Bar, Line, or Point. Other column headers will become available for editing, depending on the selected display type. Edit these as needed.

3. Under Additional Data Attributes, select a **Cross Dimension** from the pulldown list. This Dimension will be the one that appears on the X-Axis.

4. Select a **Data Column** from the pulldown list. This will be the Summary that is graphed on the Y-Axis.

5. In the Column Name area, select up to sixteen values of the original Dimension dove on, from the **Add Column** pulldown list.

6. Click **Finish** to display the Cross Plot, or click **Graph Options...** to change the Graph attributes as described under Setting Graph Options on page 5-71.

Examples of each type of Cross Plot appear on the following page.
Bar CrossPlot Example

![Bar CrossPlot Example Image]

Line CrossPlot Example

![Line CrossPlot Example Image]
Creating a Summary CrossPlot

Summary CrossPlots allow you to show multiple Dimension values for multiple Summary columns. The Summary CrossPlot created in the following steps is based on a Dive on “Sales Region”, containing the Summary columns “Cost” and “Revenue”.

After one of the Summary CrossPlot types is selected from the Select Graph Type dialog box:

1. Under **Column Name**, select the Dimension values to display in the graph. In this example, “Boston”, “North”, “Rhode Island”, “South Shore”, “Southwest”, and “West”.

2. Double-click under **Display Type** to change the display, if desired. Additional headers will become available for editing, depending on the selected Display Type.
Creating a Bubble CrossPlot

Bubble CrossPlot creation is slightly different from the steps previously described for Bar CrossPlot, Line CrossPlot, and Point CrossPlot creation because it adds an additional Summary represented by the bubble diameter. To create a Bubble CrossPlot, the following additional steps should be taken:

1. After the Cross Plot Graph Row Values (column names) have been selected, choose the desired Summary that the bubbles should represent from the Data Column pulldown (Revenue, for example).

2. Select the desired column in the Bubble Column pulldown to specify the Summary that should be used to represent the width of the bubble (for example, Units).

3. Click Finish to display the Bubble CrossPlot, or click Graph Options... to change the Graph attributes as described under Setting Graph Options on page 5-71.
A Bubble CrossPlot example is shown below:
Using Control Charts

Control Charts represent a basic statistical analysis of a set of data. Different statistical information will be displayed for different types of charts. Overall, Control Charts are used to display the expected range of variation in a data set, or are used to recognize trends within data. When data values vary in a set of samples, particularly when measured from a process that should theoretically have the same output every time, the chart will indicate when one of these samples is too far apart from the others. This discrepancy may be a signal that there is something wrong with that sample, or that its particular source is not operating within its specifications. By generating a control chart, you can see a set of expected limits that has been statistically calculated, based on the data variation itself. This is the UCL (Upper Control Limit), LCL (Lower Control Limit) and CL (Center Line) display. CL tells us where our expected “middle ground” is supposed to be, and UCL and LCL tells you what the acceptable “high end” and “low end” results are. From these results, you can visually discern anomalies in the data. The Control Charts supported in Diver can be divided into two categories, **Variable** and **Attribute**:

**Variable**

- X-chart
- MR-Chart
- Individual MR-Chart
- Custom Data Control Chart

**Attribute**

- P-Chart
- NP-Chart
- C-Chart
- U-Chart

It is important to note that with all Control Charts, the sort option will be disabled, because sorting a data set of observations effectively ruins the ability to track observations over time in a control chart setting. Focus and Find still work, as with all other charts. Once it is displayed, you will be able to interact with the graph in ways similar to other charts. Each displayed point will represent the row value for the current data point.
Creating an X-Chart

X-Charts are used to present variable data, that is, data that is measured. Each data point is the average (statistical mean) of a subgroup of values. Subgroup size can vary.

The statistical principles used in calculating the Upper and Lower Control Limits (UCL and LCL) are based on the normal distribution. UCL and LCL are assumed to be three standard deviations from the mean. The sample standard deviation is used.

The UCL and LCL can be revised using the Statistics Tab of the graph options dialog box. See Using the Statistics Tab on page 5-80.

To create an X-Chart:

1. Select the Dimension to use in the Observation pulldown, and the Summary to use in the Data Column pulldown. The data sample used in the example below has a Dimension “Hour” with a Summary of the Measurement Average for each hour:

   ![Step 2 - Set Data Attributes](image)

   The data set must contain a Dimension that represents the subgroups, as well as a unique identifier for each observation. In the example presented, “Hour” is used as the subgroup Dimension, while “Measurement Average” is the unique identifier.

2. Click Finish to display the X-Chart, or click Graph Options... to change the Graph attributes as described under Setting Graph Options on page 5-71.
The finished X-Chart appears as follows:
Creating a P-Chart

P-Charts can be used to present fraction nonconforming, percent nonconforming, fraction conforming, or percent conforming data. The example in this description uses fraction nonconforming. Fraction nonconforming is the ratio of the number of nonconforming items in a sample to the total number of items in that sample. P-Charts are used for data that is counted, rather than measured, and each data point is a ratio of its own discrete sample set. The sample set size can be uniform or variable. There are two required Summaries for P-Chart creation: number nonconforming, and a sample size column. The statistical principles for calculating the Upper and Lower Control Limits (UCL and LCL) are based on the binomial distribution. If it is necessary to view the UCL and LCL for a specific sample set (that is, subgroup), the “Show Numerical Values on Data Objects” check box should be checked on the Text Tab of the graph options. For more information on changing this setting, see Using the Text Tab on page 5-74.

To create a P-Chart

1. Under **Column Name**, select the Summary Values to use.

2. Select the **Sample Size Column** to use in the P-Chart. The data sample used below has a Dimension “Day” with the number of Rejected values for each day and the total Number Tested used as the Sample Size.
3. Click **Finish** to display the P-Chart, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

The resulting P-Chart appears as follows:
Creating an NP-Chart

NP-Charts can be used to present the number of either nonconforming items or conforming items. While presenting the same data as in a P-Chart, this chart is often easier to interpret. The sample subgroup size is, however, required to be uniform. The two required items for an NP-Chart are the number nonconforming column and the sample size. The statistical principles for calculating the Upper and Lower Control Limits (UCL and LCL) are based on the binomial distribution.

To create an NP-Chart:

1. Under **Column Name**, select the Summary Values to use.

2. Select the **Sample Size** to use in the NP-Chart. The example shown below has a Dimension “Days” with a Summary of the total number of Non-conforming values, and an overall Sample Size of 100.

3. Click **Finish** to display the NP-Chart, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.
The resulting NP-Chart appears as follows:
Creating a C-Chart

C-Charts are used to display a count of nonconforming (or conforming) items within a “unit”, or the probability of a specific number of occurrences within a period of time. While appearing to display the same type of data as an NP-Chart, a C-Chart’s control limits are calculated based on the Poisson distribution. The unit size should be constant. The assumption of a Poisson process here is that the number of possible occurrences of nonconforming items is very high relative to the probability of it occurring being small, and that this probability is constant (independent). In other words, the average count of defects must be much smaller than the total possible count, and the chance of another defect must not be increased or decreased by the presence of a defect. Only one Summary is required for display: the number of nonconforming items.

To create a C-Chart:

1. Select the Summary to use in the C-Chart under Column Name. The data sample used below has a Dimension “Day” with a Summary of the number of Non-conforming Errors.

2. Click Finish to display the C-Chart, or click Graph Options... to change the Graph attributes as described under Setting Graph Options on page 5-71.
The resulting C-Chart is shown here:
Creating a U-Chart

U-Charts are used to display the average count of nonconforming per “unit”. This type is especially useful when a situation is encountered similar to that described for the C-Chart, yet the definition of “unit” is of variable size and not constant. The sample size therefore can be uniform or variable. There are two required Summaries for U-Chart creation: number nonconforming and a sample size column. As with the C-Chart, the statistical principles used for calculating the Upper and Lower Control Limits (UCL and LCL) are based on the Poisson distribution. If it is necessary to view the UCL and LCL for a specific sample set (that is, subgroup), the Show Numeric Values on Data Objects check box should be checked on the Text Tab of the Graph Options dialog box.

To create a U-Chart:

1. Select the Summary values to use under **Column Name**.

2. Select the Summary to use for the **Sample Size Column**. The following example has a Dimension “Day” with Summaries of the Number Non-conformities and the Sample Size Column set to Number Inspected:

3. Click **Finish** to display the U-Chart, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.
The resulting U-Chart is shown below:
Creating an MR-Chart

An MR-Chart, or a Moving Range chart, measures the absolute range of variation between two subsequent observations of a process. The UCL and LCL represent the acceptable range of differences in values. The normal distribution is assumed.

While not common, up to eight different columns of data can be used for the MR display. Each will be displayed independent of the other, but will share the same graph space. The graph will measure the difference between each data point and the previous one. That difference, or range, will be displayed on the graph. In Control Chart terms, an MR-chart will have an observation group size \( N = 2 \). As a result, the first data point will be empty, as a range cannot be calculated.

To create an MR-Chart:

1. Select the Summary values to use under **Column Name**. This data sample has a Dimension “Observation” with a Summary “Measurement”.

2. Line is the only available Display Type for an MR-Chart. To change the **Line Width**, double-click on the current setting and select a different width from the pulldown. Options include 1, 2, 3, 4, 5, or 6 pixels. The default is 3 pixels.
The Scale, Point Shape, and Size columns are not used in MR-Charts.

3. If Points are being displayed, change the **Point Shape** and **Size** by double-clicking the Point Shape and Size settings respectively. Point shapes include: Dot, Square, Triangle (Up), Triangle (Down), Diamond, Cross, and X-Mark. The default selection is Dot. Point Sizes can be set to 6, 8, 10, 12, 14, 16, 18, or 20 pixels in width. The default selection is 12.

4. Click **Finish** to display the MR-Chart, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

The resulting MR-Chart follows:
Creating an Individual MR-Chart

Individual MR-Charts are used to plot individual measures, rather than the average, or result, from measuring a group of values. Like the X-Chart, MR-Charts are based on the normal distribution. The UCL and LCL are calculated using the Moving Range (MR N=2) between two consecutive observations, rather than the estimated standard deviation of the data set. Because the Control Limits are based on individual observations, the variation can not be predicted as precisely as with the X-Chart, and the Individual MR-Chart limits will be spaced further apart.

To create an Individual MR-Chart:

1. Set the Summary values to use under Column Name. The data sample below uses 130 individual measurements of the Weight of beverage fill on a bottling line (one bottle is measured every hour). The goal in the resulting chart is shown as 16 oz., but the actual fill varies and is the plotted observation. See Using the Statistics Tab on page 5-80 for information on adding a goal line to a chart.

2. Click Finish to display the Individual MR-Chart, or click Graph Options... to change the Graph attributes as described under Setting Graph Options on page 5-71.
Creating Custom Data Control Charts

Custom Data Control Charts can also be created in Diver.

1. Click the **Graph** button in the toolbar to open the **Select Graph Type** dialog. Select **Custom Data Control Charts** and click **Next>**.

2. You will need to manually provide four data columns: Control Data, UCL, LCL and CL. Once specified, the control chart will be generated.

   These four columns should have the corresponding data for the UCL, LCL, CL and the basic control data. If the data column is not defined, the graph will not draw. However, if the CL, UCL and LCL columns are not defined, those control limits will not be displayed.

3. Click **Finish** to display the Custom Data Control Chart.
Control Chart Formulas

The following standard abbreviations are used in the formulas for each type of Control Chart below:

- **CL**: Centerline
- **SQRT**: Square Root (all rooted values are positive numbers)
- **UCL**: Upper Control Limit
- **LCL**: Lower Control Limit
- **xN**: Data values for Row N
- **N**: Number of Data rows
- **UCL-V AR**: Upper Control Limit multiplier
- **LCL-V AR**: Lower Control Limit multiplier

### X Chart Formulas

An X-Chart has two Dimensions associated with it. The first is a list of observations. The second is a list of observation subgroup IDs. When you generate a MultiCrossTab of both Dimensions, there are columns of observations divided by their corresponding subgroup ID.

The first step is to calculate the mean of each subgroup. These means will become the display points plotted on the X-Chart.

The second step is to calculate the standard deviation for each subgroup. This formula equals:

\[
STD\_DEV = SQRT\left[\frac{(O_1-\text{mean})^2 + (O_2-\text{mean})^2 + \cdots + (O_i-\text{mean})^2}{i-1}\right]
\]

The third step is to then calculate the mean for both the subgroup means (\(\text{Mean\_Bar}\)) and the subgroup standard deviations (\(\text{StdDev\_Bar}\)).

Once we have these values, we calculate the UCL, LCL and CL as follows:

\[
\begin{align*}
\text{CL} &= \text{Mean\_Bar} \\
\text{UCL} &= \text{CL} + A3 \times \text{StdDev\_Bar}; \\
\text{LCL} &= \text{CL} - A3 \times \text{StdDev\_Bar};
\end{align*}
\]

A3 is a variable that is constant for any subgroup size, which means that display points of the same subgroup size will have the same value for A3, and thus the same UCL, LCL and CL.

Thus:

\[
A3 = 3.0 / (c4 \times SQRT(i))
\]

Where:

- \(i\) = subgroup size
- \(c4 = (4 \times (i-1)) / ((4*i)-3)\)
Creating Graphs Using Control Charts

**P Chart Formulas**

\[ v_N = \frac{x_N}{s_N} \]
\[ CL = \frac{(v_1) + (v_2) + \ldots + (v_N)}{N} \]
\[ UCL(N) = CL + (UCL\_VAR \times \sqrt{CL \times (1 - CL)/s_N}) \]
\[ LCL(N) = CL - (LCL\_VAR \times \sqrt{CL \times (1 - CL)/s_N}) \]

**KEY:**

\( v_N \): Displayed Row Value for Row N
\( s_N \): Subgroup Column value for Row N
\( UCL(N) \): Upper Control Limit for Row N
\( LCL(N) \): Lower Control Limit for Row N

**NP Chart Formulas**

\[ pbar = \frac{x_1 + x_2 + \ldots + x_N}{N \times \text{SIZE}} \]
\[ CL = pbar \times \text{SIZE} \]
\[ UCL = CL + (UCL\_VAR \times \sqrt{\text{SIZE} \times pbar \times (1 - pbar)}) \]
\[ LCL = CL - (LCL\_VAR \times \sqrt{\text{SIZE} \times pbar \times (1 - pbar)}) \]

**KEY:**

\( \text{SIZE} \): Subgroup size
\( pbar \): Subgroup Unit Mean for P Chart

**C Chart Formulas**

\[ CL = \frac{x_1 + x_2 + x_3 + \ldots + x_N}{N}; \]
\[ UCL = CL + (UCL\_VAR \times \sqrt{CL}) \]
\[ LCL = CL - (LCL\_VAR \times \sqrt{CL}) \]

**U Chart Formulas**

\[ v_N = \frac{x_N}{s_N} \]
\[ CL = \frac{(v_1 + v_2 + \ldots + v_N)/(s_1 + s_2 + \ldots + s_N)}{N} \]
\[ UCL(N) = CL + (UCL\_VAR \times \sqrt{CL/s_N}) \]
\[ LCL(N) = CL - (LCL\_VAR \times \sqrt{CL/s_N}) \]

**KEY:**

\( v_N \): Displayed Row Value for Row N
sgN: Subgroup Column value for Row N
UCL(N): Upper Control Limit for Row N
LCL(N): Lower Control Limit for Row N

**MR Chart Formulas**

\[ v_N = x_N - x(N-1) \]
\[ CL = v_1 + v_2 + \ldots + v_N / N \]
\[ UCL = CL + (D_4 * CL) \]
\[ LCL = 0 \]

**KEY:**

\( v_N \): Displayed Row Value for Row N
\( D_4 \): Statistics Variable \( D_4 \), \( d_4 = 3.267 \)

**Individual MR Chart Formulas**

\[ v_N = x_N - x(N-1) \]
\[ CL = v_1 + v_2 + \ldots + v_N / N \]
\[ UCL = CL + (UCL\_VAR\_MR * CL) \]
\[ LCL = CL - (LCL\_VAR\_MR * CL) \]

**KEY:**

\( v_N \): Displayed Row Value for Row N
\( D_4 \): Statistics Variable \( D_4 \), \( d_4 = 3.267 \)

**UCL\_VAR\_MR:** Same as UCL\_VAR, except suggested value is \( E_2 = 2.660 \)

**LCL\_VAR\_MR:** Same as LCL\_VAR, except suggested value is \( E_2 = 2.660 \)
Using Time Graphs/Gantt Charts

A Gantt chart is a type of bar plot that illustrates Tasks that comprise the work breakdown structure of the project. Gantt charts can be used to show current schedule status using percent-complete shadings and a vertical “Today” line. Gantt charts allow you to display the following:

- Task span, from a start point to an end point.
- Dependency, linking the end of one task to the start of another.
- Legend Category, allowing you to lump various tasks into different color-coded categories.

Gantt charts require a very specific Model layout. Models should be created as follows:

- One Dimension, which describes a list of task names.
- Two Summaries, one for task start and one for task end. These should be either numbers or dates.
- Optionally, you can also include the following Info Fields:
  - Dependency - lists the task name that connects from its end to the current row’s beginning. For synchronization purposes, these two task values should be the same.
  - Legend Category - lists a name that will appear on the legend. If this Info Field is defined, tasks will be color-coded to match the list of names included in this Info Field.

The Info Fields used for Dependency and Legend must be present in the underlying Tabular.
Creating a Gantt Chart

To create a Gantt Chart:

1. Perform the desired dive. The example below shows a dive on Task Name, with Summary columns for Task Start and Task End, and Info Fields for Dependency and Category.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Task Start</th>
<th>Task End</th>
<th>Dependency</th>
<th>Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Totals</td>
<td>01/28/2010</td>
<td>07/01/2010</td>
<td></td>
<td></td>
</tr>
<tr>
<td>High Level Analysis</td>
<td>01/01/2010</td>
<td>02/01/2010</td>
<td>High Level Analysis</td>
<td>Analyst Resource</td>
</tr>
<tr>
<td>Core Module Analysis</td>
<td>02/01/2010</td>
<td>04/01/2010</td>
<td>Core Module Analysis</td>
<td>Analyst Resource</td>
</tr>
<tr>
<td>Analysis of Supporting Modules</td>
<td>04/01/2010</td>
<td>06/01/2010</td>
<td>Analysis of Supporting Modules</td>
<td></td>
</tr>
<tr>
<td>Programming of Supporting Modules</td>
<td>05/01/2010</td>
<td>05/01/2010</td>
<td>Programming of Supporting Modules</td>
<td></td>
</tr>
<tr>
<td>Quality Assurance of Supporting Modules</td>
<td>06/01/2010</td>
<td>10/01/2010</td>
<td>Programming of Supporting Modules</td>
<td></td>
</tr>
<tr>
<td>Detailed Training</td>
<td>10/01/2010</td>
<td>11/01/2010</td>
<td>Quality Assurance of Supporting Modules</td>
<td></td>
</tr>
<tr>
<td>Develop and QA Accountancy Reports</td>
<td>06/01/2010</td>
<td>07/01/2010</td>
<td>Analysis of Supporting Modules</td>
<td>Programming/QA Resource</td>
</tr>
<tr>
<td>Develop and QA Management Reports</td>
<td>07/01/2010</td>
<td>08/01/2010</td>
<td>Develop and QA Accountancy Reports</td>
<td>Programming/QA Resource</td>
</tr>
<tr>
<td>Develop Management Information System</td>
<td>08/01/2010</td>
<td>09/01/2010</td>
<td>Develop and QA Management Reports</td>
<td>Programming/QA Resource</td>
</tr>
<tr>
<td>Programming of Core Modules</td>
<td>04/01/2010</td>
<td>06/01/2010</td>
<td>Core Module Analysis</td>
<td>ProgrammingResource</td>
</tr>
<tr>
<td>Quality Assurance of Core Modules</td>
<td>06/01/2010</td>
<td>07/01/2010</td>
<td>Programming of Core Modules</td>
<td></td>
</tr>
<tr>
<td>Core Module Training</td>
<td>07/01/2010</td>
<td>07/07/2010</td>
<td>Quality Assurance of Core Modules</td>
<td></td>
</tr>
<tr>
<td>Selection of Hardware Platform</td>
<td>02/01/2010</td>
<td>02/08/2010</td>
<td>Selection of Hardware Platform</td>
<td></td>
</tr>
<tr>
<td>Installation and Commissioning of hardware</td>
<td>02/08/2010</td>
<td>03/08/2010</td>
<td>Selection of Hardware Platform</td>
<td></td>
</tr>
</tbody>
</table>

2. Click the Graph button to launch the Select Graph Type dialog.
3. Select **Time Graphs > Time Chart - Gantt Charts**. Click **Next >**.
4. Set the **Task Start Column**, **Task Finish Column**, **Dependency Info Field** (optional), and **Legend Info Field** (optional) data attributes as desired.
5. Click **Graph Options** to change additional graph attributes. In this example, the first 3 legend colors have been changed on the Legend tab, to represent the colors of the 3 categories defined in the data.
6. Click **OK** to return to the Set Data Attributes dialog, and **Finish** to display the completed Gantt Chart, shown here.

This Gantt Chart shows each Task in the project, the start and end date for that Task, which Tasks are dependent on another Task (indicated by the connecting solid lines), and the resources required for each Task. Those tasks indicated in gray do not have an associated Category in the underlying data.
Using Maps

Diver has the ability to display geographic data in the form of either a Boundary Map or a Point Map.

Creating a Map

If a dive contains geographic data (e.g., zip code, country, or state). After selecting **Boundary Map** or **Point Map**:

1. Select the Map Folder to use for your map. US_Map_Files in this example.
   The **Map Folder** determines which map set to use, and should match the data being mapped. In this example, US_Map_Files is the correct data set for the State ID Dimension. Each Dimension or Dynamic Dimension can use a different map folder, if desired. Be sure to save the DivePlan, since that is how Diver records which settings to use for each Dimension to be mapped.

   If the proper Map Folder is not shown, the Map Directory may need to be set. This is described in **Setting Map Preferences on page 13-12**.

2. Select a Geographic Type on which to base the map, in this case, State.
   The **Geographic Type**, known as a “layer”, will vary depending on the country being mapped. For the United States, available layers are State, County, MSA (Metropolitan Statistical Area), MCD (Metro Civil Division), and Zip Code. The Geographic Type will automatically default to the geographic Dimension in the active Dive Window, State in this example.
3. Select a Column to use, in this case, Count.

**Column** specifies the Summary column to be mapped.

4. Click **Finish** to display the Map, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71.**
Each of the completed map types appear below.

**Boundary Map Example**

![Boundary Map Example Image]

**Point Map Example**

![Point Map Example Image]
Using Pie Plots and Doughnut Plots

Pie Plots and Doughnut Plots are used to demonstrate the division of a finite quantity (such as a paycheck) among a number of items (such as the mortgage, food, clothing, etc.).

These plots assign the first color element to the first row in the displayed Tabular. This allows the plots to maintain colors across cascades and time periods. For example, if the initial dive is on Sales Region, and the second dive is on Product Family, a Pie or Doughnut Plot is drawn for the second dive, attaching colors to values. When a different Sales Region is selected and the cascade is reflected in the plot, the Product Family labels are still assigned to the same colors as the previous selection. This allows easy visual comparison of plots, for example, between years where the largest value changes. For this reason, Pie and Doughnut Plots are best used to plot Dimensions with value counts between two and sixteen.

To create a Pie Plot of the top values, be sure to select the Summary and Sort Down in the Tabular before creating the plot.

In a Pie or Doughnut Plot, all values beyond the first fifteen wedges or sections are lumped together into the “Other” wedge or section. To view the breakdown of those values within the Other area (always gray), double-click on it; or select it and choose Organize > Focus, and a new plot will appear. This new plot focuses on the remaining wedges or sections, displaying the next “x” number of items, and lumping any remaining areas into a new “Other” area. To select the Other area, click it or hold and move the left mouse button to use the lasso tool to select it. To de-select it, choose Organize > Stop Focus, click on the Focus button in the toolbar, or use the Undo/Redo buttons.

By clicking in the legend, the Pie or Doughnut legend window can be used to select individual wedges or sections. This approach is especially useful when trying to select very small (< 1.0%) wedges.
Creating a Pie or Doughnut Plot

After selecting a Pie Plot or Doughnut Plot as the type of graph to create:

1. Select a Summary from the **Column** pulldown, Revenue Total in the example below.

   ![Step 2 - Set Data Attributes](image)

   - Click **Finish** to display the plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.
Pie Plot Example

![Pie Plot Example](image)

Doughnut Plot Example

![Doughnut Plot Example](image)
Using Radar Graphs

Radar Graphs include Radar Area, Radar Line, and Radar Point Graphs. Radar Graphs are another way of viewing linear data, just like bar, line, and point plots.

Instead of plotting the data along a horizontal axis, a Radar Graph plots the data radially from a central point. Individual data points still have a “vertical” component, which is the distance from the center, or the radius. Radar Graphs can display up to 64 data labels on a single graph.

Creating a Radar Graph

After selecting the desired Radar Graph in the Select Graph Type dialog box.

1. Select the Columns to be used for the Radar Graph, as shown below. Double-click under each header to see and change the options.

![Step 2 - Set Data Attributes dialog box]

2. To change the Display Type of a Summary, double-clicking on the current setting and select a different type from the pulldown. The Display Type can be set to Area, Line or Point.
The Scale column is not used in Radar Graphs.

3. If a Line Plot is being displayed, change the **Line Width** by double-clicking the Line Width setting and selecting a new width. You can choose between one and six pixels. The default selection is three.

4. If a Point Plot is being displayed, change the **Point Shape** and **Size** by double-clicking the Point Shape and Size settings respectively. Point shapes include: Dot, Square, Triangle (Up), Triangle (Down), Diamond, Cross, and X-Mark. The default selection is Dot. Point Sizes can be set to 6, 8, 10, 12, 14, 16, 18, or 20 pixels in width. The default selection is 12.

5. Click **Finish** to display the Radar Graph, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

**Radar Area Graph Example**

A Radar Area Graph is a Line Plot where the area between the lines and the center is colored with a fill color.
Radar Area Graphs are not transparent, so if more than one Summary is being graphed, make sure that the “top” area contains lower values than the “bottom”; otherwise the bottom area graph will be hidden behind the top area graph.

**Radar Line Graph Example**

Radar Line Graphs are just like Line Plot graphs, in that the points are connected by lines.
Radar Point Graph Example

Radar Point Graphs are just like Point Graphs, in that the data is plotted as a point, a certain distance away from the center.

Using Scatter Plots

Scatter Plots include Scatter, Scatter (Point), Scatter (Line), and Scatter (Bubble) Plots. Often it is not the absolute value of a number that is important, but rather its value relative to other numbers (e.g., Revenue vs. Cost, Height vs. Weight, Profit vs. Sales). In such cases, a Scatter Plot is ideal.
In the case of a performance comparison, all points above the diagonal line represent items with incoming revenue exceeding cost, while all points below the line represent the items bringing in less revenue than the cost of the item. The schematic below shows these relationships more clearly.
Creating a Scatter (Point) and Scatter (Line) Plot

After selecting Scatter Plot as the type of graph to create:

1. Select an **X-Axis Column** (Cost in this example).

2. Select a **Y-Axis Column** (Revenue in this example).

3. Click **Finish** to display the Scatter Plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

Finished examples of each type of Scatter Plot are shown on the following page.
Scatter (Point) (with Diagonal Reference Line) Example

Scatter (Line) Example
Creating a Scatter (Bubble) Plot

A Scatter Bubble Plot is a type of Scatter Plot with a third data column that is represented as the scatter point diameter. The Bubble Plot is used to compare three sets of numerical values per data point. The first and second value in every sequence specify the X and Y coordinates of the bubble. The third value, or Z-Axis, is displayed as the size of the bubble. Bubbles are sorted descending, then drawn in order of diameter, such that larger bubbles are displayed in the background, while smaller bubbles are displayed in the front.

To create a Scatter Bubble Plot, the following steps should be taken:

1. Select the X- and Y-Axis columns as previously described for other Scatter Plot types.
2. To select the Summary that should be used to represent the size of the bubble, select the desired column in the **Z-Axis Column** pulldown (for example, Profit).
3. Click **Finish** to display the Scatter Bubble Plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

A completed Scatter Bubble Plot is shown here:
Using Stack Plots

Stack Plots include Bar Stack Plots, 3-D Bar Stack Plots, Percentage Stack Plots, 3-D Percentage Stack Plots, Summary Stack Plots, and 3-D Summary Stack Plots.

Creating Bar and Percentage Stack Plots

A Stack Plot is used to demonstrate the portions that make up the whole of a particular value within a bar. As with Bar Plots, Stack Plots display a series of plotted points on a quantitative axis. Stack Plots display only one Summary at a time, and may be horizontal or vertical.

The first dive needed for a Stack Plot should be on a Dimension that you want the bar height of the Stack Plot to represent. After selecting a Stack Plot as the type of graph to create:

1. Select a **Cross Dimension** (Data Attribute 1 - parts that make up the whole).

2. Select a **Data Column** (Data Attribute 2 - Summary). When choosing the Cross Dimension, it is recommended to choose a Dimension with only a few values; otherwise the Stack Plot may not be readable (only 16 colors are available).

3. Click **Finish** to display the Stack Plot, or click **Graph Options**... to change the Graph attributes as described under **Setting Graph Options on page 5-71**.
Finished examples of each type of Stack Plot are below:

**Bar Stack Plot Example**

![Bar Stack Plot Example](image)

**Percentage Stack Plot Example**

![Percentage Stack Plot Example](image)
Creating Summary Stack Plots

Summary Stack Plots vertically stack more than one Summary value for each Dimension value. The Summary Stack Plot created in the following steps, is based on a Dive on “Sales Region”, containing the Summary columns “Revenue YTD” and “Revenue LYTD”.

After selecting either **Summary Stack Plot** or **3-D Summary Stack Plot**:

1. Select the Summary columns to display, in this example “Revenue YTD” and “Revenue LYTD”.

2. Double-click Display Type to set the Summary display as Bar or Line (Bar is the default).

3. Click **Finish** to display the Stack Plot, or click **Graph Options...** to change the Graph attributes as described under **Setting Graph Options on page 5-71**.

Reference lines in the plot do not stack, so if you set all elements to Line, you are effectively drawing a Line Plot.
Setting Graph Options

In addition to the basic graph options available in each graph’s Set Data Attributes dialog box, there are additional attributes that can be configured. Some or all of the Graph Options dialog box tabs discussed below will be available for each graph type. Furthermore, the attributes on each tab may differ from one type of graph to another.

Using the Appearance Tab

The Appearance Tab allows you to alter the overall look and feel of graphs.

- **Use Skin** - allows you to apply an overall look and feel, or “skin” to the graph. When a skin is selected, the graph will update according to the settings used in the selected skin. Skin options include: Arizona, Blue Steel, Classic, Ember, Forest, Heritage, Noir, and Twilight.
When it is not checked (the default selection upon graph creation), graph settings will display according to those set in the Diver Preferences, Graphs Tab (File > Preferences > Graphs).

• **Show Graph Toolbar** - specifies whether or not the graph tools (pointer, zoom, scroll bar, lasso, etc.) should be displayed in the graph window.

• **Background Color** - specifies the background color of the graph window. The default color is white. Double-click on the color square to select a new color value. This is only available if a skin is not in use.

• **Graph Area Color** - specifies the background color of the actual graph. The default color is white. Double-click on the color square to select a new color value. This is only available if a skin is not in use.

• **Data Color** (available only for Scatter Plots) - indicates the color of the points in a Scatter Plot. The default color is dark gray. Click on the color square to select a new color value.

• **Borders** - allows you to display or hide the Left, Top, Right, or Bottom graph edges from view.

• The **Shadow Effects** area offers two options:
  — **Show Shadows on Legend Box** - creates a shadow around the Legend Border (when Show Legend Border is checked on the Legend Tab).

  — **Show Shadows on Graph Border** - creates shadows around the Graph Border (when Graph Borders are set). Shadow effects will make the graph appear more three-dimensional.

• **Use Ambient Shading on Data Objects** - allows you to apply gradient shading to objects within the graph; for example, in a Bar Plot this option will apply shading to each bar representing a data value in the plot. There are four shading options to select from which will appear after the text box is checked: light top to dark bottom, dark top to light bottom, dark left to light right, or light left to dark right.

• **Scatter Reference Lines** (available only for Scatter Plots) are used as a guide to indicate where scatter point values fall in reference to the defined line. The options available are:
  — **Diagonal Line (Ratio)** - when selected, a line is drawn on the completed graph. The slope of the line is determined by the value of “n” in the Ratio n:1 setting. The default 1:1 is a diagonal line. This is adjusted by entering a number in the box to the right of the Show Diagonal (Ratio) checkbox.

  — **X Intercept Line** - when selected, a line is drawn on the completed Scatter Plot at the specified Horizontal (X) Axis.

  — **Y Intercept Line** - when selected, a line is drawn on the completed Scatter Plot at the
specifying Vertical (Y) Axis.

When creating a Pie Plot, these additional Appearance tab options are available:

- **Number of Wedges Shown** allows you to specify the number of wedges to display in the initial Pie Plot, up to 15 wedges. The default behavior is to assign 15 possible colors, referred to as elements, to the values in the order the data is stored in the Model. The colors will repeat if there are more than 15 rows of data values. This color assigned does not change even if the rows are sorted. This behavior is useful if QuickViews are filtering the pie display, as the wedge color will not change between filters, but it can result in the duplication of colors within the pie plot after a sort.

- **Link Colors to Discrete Data Values** will override this behavior if it is unchecked, and the 15 color elements will be used for the pie plot.

When creating a Calendar plot, the following Appearance tab options are also available:

- **Title Bar Color** allows you to select the color of the Calendar title bar,
- **Calendar Options** allows you to choose the calendar’s **First Day of Week**. The default setting is Sunday.
Using the Text Tab

The Text Tab allows you to control and customize the display of all text objects within a graph.

- **Current Skin** - shows the skin currently in use, as specified on the Appearance Tab.
- **Graph Font** - specifies the font to be used for all text appearing in a graph window. The default font is Verdana, 8 pt., and can be changed by clicking the **Select...** button in the Graph Font line, or in the **File > Preferences** Graph Tab.
- **Show Main Title** - indicates whether a title should be displayed in the finished graphed. It is checked by default.
- **Title entry** - indicates the Title that should appear in the finished graph. Click **Select...** to change the default Font.
- **Horizontal Alignment** and **Vertical Alignment** - indicates the location of the Title within the graph.
• **Font** - allows you to change the font of Labels and Tags. The default is Verdana, 8pt. Use the **Select...** button to change the default selection.

If Labels or Tags have been manually added to a completed graph via the graph tool Palette, their borders can be toggled on or off using the **Show Drag-and-Drop Label Borders** check box. Borders are displayed by default.

The Graph Toolbar and Graph Label Borders are not copied or printed. They are only displayed on the screen.

• **Show Auxiliary Subtitle** - toggles the display of the “N=<Column Name>” subtitle in a graph, when the Attach Additional Column Values (N-String) check box is in use.

• **Show Parent(s) as Subtitle** - indicates that the dive’s Parent Dimension information should be displayed as a Subtitle under the main Graph Title. Click **Select...** to change the default Font.

• **Show Data Column Label Title** - toggles the display of Data Column labels in the graph. Click **Select...** to change the default Font.

• **Show Numeric Values on Data Objects** - adds labels to each element, indicating an abbreviated Summary Value of that element (for example, 200.5m). Click **Select...** to change the default Font.

  **Placement** - indicates how numeric values should be displayed.
  — **Vertical** - displays numeric values with a vertical orientation.
  — **Horizontal** - displays numeric values with a horizontal orientation.
  — **Slanted** - displays numeric values with an angled orientation.

• **Show Data Column Labels** - indicates whether labels should be displayed for each Dimension Value element in the graph.

  **Placement** - indicates how Data Column Labels should be displayed on the graph. Vertical displays labels in a vertical orientation.
  — **Single Row** - displays element labels horizontally in a single row.
  — **Double Row** - staggering label values horizontally into two rows, alternating top row to bottom row with each successive label.
  — **Slanted** - displays labels below each element at a 45 degree angle to the X-Axis. The Label Stacking options are unavailable when the Flip Axes feature is in use in a graph.

  **Select** - allows you to change the default Label Font.
Intersperse Data Labels as space permits - allows data labels to disappear or display as space in the graph window is available.

Substitute Info Field Values - replaces Dimension Value labels with their corresponding Info Value for the selected Info Field.

Abbreviate - limits labels to the number of characters specified.

Attach Additional Column Values (N-String) - displays the full Summary Value for each element (N=200,159,511.75, for example) of the indicated Data Column.

Using the Scales Tab

The Scales Tab is used to set variables for the various scales available.

- **Current Skin** - shows the skin currently in use, as specified on the Appearance Tab.
Depending on the type of graph being used, Diver presents many different options for scale display in a graph.

- Horizontal (X-Axis)
- Vertical (Y-Axis)
- Left
- Right

The options described below are available for all Scale Types:

- **Show Scale Title** - indicates whether a title for each scale in the graph should be displayed. It is checked by default. Click **Select...** to change the default Font.

  When a graph is created, a default scale is automatically determined based on the range of numeric values found for the Summary Fields being graphed. This default scale can be overridden by specifying new values to be used for the scale.

    - **Minimum** - indicates the lower limit of the scale, for example 100m. For Gantt charts, this check box applies to dates.

    - **Maximum** - indicates the upper limit of the scale, for example, 500m. For Gantt charts, this check box applies to dates.

    - **Increment** - indicates the rate at which values on the scale should increase, for example 50m. This example would result in a scale that displays: 100m, 150m, 200m, 250m, 300m, etc..., up to a maximum value of 500m. For Gantt charts, values are Day, Week, Month, 3 Months, 6 Months, and Year.

- **Show Scale Lines** - displays a solid grey line on the graph at each increment on the scale.

- **Show Zero Line** - displays a thick black line at zero if the Minimum Fixed Value of the scale is less than zero.

- **Show Scale Text** - allows you to display or hide the label for each increment on the scale. Click **Select...** to change the default font.

- **Decimal Places** - displays the specified number of decimals for each scale value. The default is zero.

- **Abbreviate Scale Text** - toggles each scale increment between an abbreviated number (100m) and a full number (100,000,000).
Using the Legend Tab

The Legend Tab allows you to control the display and settings of the graph’s Legend.

- **Current Skin** - shows the skin currently in use, as specified on the Appearance Tab.
- **Legend Color Boxes** - indicates what color should be used for each value or range of values in the graph Legend. The colors can be changed by single-clicking the color box and selecting a new color, or by resetting to the default colors using the **Reset Colors** button.
- **Use Color Range** - specifies that an array of colors, beginning with **Starting Color** and finishing with the **End Color**, should be used in place of the default Legend Colors. The Red and Blue default colors of the range can be changed by single-clicking the Start or End color boxes and selecting a new color.
- **Number of Range Steps** - allows you to specify the number of colors used in the range. The default is 16. Additional options are three, four, six, and eight.
Use Color Range is not available in a Calendar View with Bar Plots.

- **Show Legend** and **Placement** - indicates whether the Legend should be displayed, and whether it should appear at the **Left**, **Top**, **Right**, or **Bottom** of the graph window. The default placement is Top. Click **Select...** to change the default font.

- **Number of Columns** - indicates the number of columns that should be used in the Legend to list Legend values. For example, if 1 is selected, Legend values will be listed in a single column from top to bottom; if 2 is selected, Legend values will be listed in two columns, etc.

- **Show Legend Border** - indicates whether a border should be displayed around the Legend area.

- **Show Legend Row Details** - allows you to display, or remove from the display, each Dimension Value’s percentage of the total.
  - **Show Percentages** - Displays Summary Values as a percentage of the whole pie.
  - **Show Data Values** - Displays actual Summary Values of each pie wedge.
Using the Statistics Tab

- **Current Skin** - shows the skin currently in use, as specified on the Appearance Tab.

- **Show Least-Squares Fit** - allows you to display a simple first-order regression line in Basic and Scatter Plots. This line is calculated using Least Squares. Additionally, Pearson’s Coefficient of Regression (R-squared) is displayed as a measure of how well the line fits the data. A perfect fit is one.

- **Show Linear Equation** - displays the Least-Squares Fit equation used. Use the pulldown to change the Summary; single-click on the color box to adjust the color.

- **Show Statistical Mean/Center Line (MEAN/CL)** - allows you to specify whether or not to display the Center Line on a Control Chart or Basic Plot, and the color that line should be. It shows the average of all focused values in the Dive Window.

- **Show Median (MEDIAN)** - allows you to specify whether to display the Median Line on a Control Chart, and the color that line should be. Median is the value lying half-way through the rank order of all Summary Values. Zero is counted as a value.
• **Show Goal Line (GOAL)** - allows you to specify whether to display the Goal Line on a Control Chart, the color that line should be, and where it should be displayed.

• **Caption Placement** - allows you to specify where on the graph the label for any displayed Statistics lines appears. Options are Left, Right, and None. Left is the default selection.

• **Abbreviate Caption Text** - when toggled on, displays Control Limit, MEAN/CL, MEDIAN, and GOAL line values as abbreviated values (11.00m) or full values (11,000,000.00).

• **Show Upper & Lower Control Limit** - indicates whether the Upper & Lower Control Limit lines should be displayed, what color they should be, and whether or not they should be shown at the “x” number of increments using the **Use Standard Deviations Increments** setting or at a **Fixed Value**.

• By default, the control limits for a Control Chart are calculated and displayed for a full set of data; that is, the whole data set is used to create one UCL and one LCL. However, control limits are modifiable over time, and the limits may incorporate only a logical range of data around the data points (for example, 25 days). In that case, you would select 25 in the **Divide Control Limits into Observation Sets** pulldown. Doing so would allow each group of 25 data points to be used to create a different UCL and LCL. For 125 rows of data, five sets of limits would display.
About Graphical Displays

The following sections detail the attributes of all completed graphical display windows.

Graph Window Characteristics

Graph windows have a close box in the upper-right corner, and may be resized by dragging any edge of the window. They also have a box in the upper-right corner that allows toggling the window’s size among Minimized, the default window size, and Maximized.

If a single item in a graph is selected (excluding maps), Diver will display the name and Summary Value for that item in the History area of the Console.

Editing a Graph

Unlocked graph editing behavior allows you to easily locate and change the properties of graph items. Double-click individual elements in the graph, to open the Graph Options dialog to the tab corresponding to the selected graph element. For example, double-clicking the graph title or Dimension values opens the Graph Options Text Tab, double-clicking the graph scale will open the Scale Tab, and double-clicking the graph legend will open the Legend Tab.
Using Live Objects in a Graph

A graph object is considered “live” if clicking on it has some effect on the graph or on the Console. For example, in a Plot, Scatter Plot, or CrossPlot, the plotted point is live. In a Bar graph, the bars are live. Clicking on one of these objects will select it and update the Dive History region in the Console. Double-clicking it will provide detail in the Console. All graphs contain live objects.

Graph windows also have live objects which affect only the graph format and not the dive. The graphic below describes all the objects in a graph window. Most objects that are not live can be changed by double-clicking the window background to open the Graph Options dialog box.
Understanding Graph Axes

Plots and CrossPlots display data as a list of items, each of which has a numerical quantity associated with it (for example, the number of sales made by a given Salesperson). Therefore, Plots and CrossPlots have one quantitative axis, which defines the range for the numerical quantities (vertical y-axis). The second axis lists the items evenly displayed, but has no numerical range, since the items themselves are not numerical quantities (horizontal x-axis).

Scatter Plots display data as a relationship between two quantities. Each data point has two numerical values associated with it, one for each quantity. The plot has two quantitative axes, each of which defines a numeric range for one of the quantities. The data points are plotted along these axes according to their specific values for the quantities. For example, you could find out the values for Cost Total and Revenue Total for each Salesperson. One axis of the Scatter Plot would then represent Cost Total, while the other would represent Revenue Total. The data point for a given Salesperson would be placed at the point corresponding to its value on each axis (the Cost Total and Revenue Total numbers for that Salesperson).

A Pie Plot has no axes. Both numerical and non-numerical items are contained within the pie.

A quantitative axis of a graph is automatically labeled with a scale showing numbers at its ends, numbers wherever convenient along its length, and hashmarks with each number (see below).
This scale can be changed by clicking on the border of the graph to open a dialog box that allows you to edit the **Graph Attributes** once the graph is created. It is not available prior to window display. These attributes vary depending upon the type of graph being displayed. Some of the attributes are Graph Colors (for Background and for point, bar, or line colors), Reference Line (in a scatter plot), Axes (scale displayed, gridlines, and zero line), Legend details (placement and colors), Data labels, Headers, and Title.

**Using Multiple Axis Scales for Plots**

Bar and Line Plots include the option of having scales on both sides of the graph. For each element plotted, you may specify which side of the plot should have the axis scale for that element. This feature is useful when plotting elements whose values tend to be very different from each other, as shown in the following example:
Right and Left axes are selected when first creating the graph, in the dialog box shown below. To change the axis of a Summary, click the icon in the Scale column to change it from Left to Right. The axis **MUST** be changed at the time of graph creation. It cannot be changed once the graph is displayed, without recreating the graph.

The Scale settings are saved in the local diver.ini and must be changed back to the default before creating other graphs.
The resulting plot labels the axis for Cost Total (gray) on the left side, and the axis for Units Total (green) on the right. It is easier to see the values of both elements this way.

Using the Legend

The legend appears in the completed graph window, as shown below:
In some graphical displays, the legend can be used to select values. In a Stack Plot, vertical column values can be selected for focusing using the legend. Similarly, the legend window in a Pie chart can be used to select individual wedges. This feature is especially useful when trying to select very small wedges. The legend is included when printing a graph.

**Using the Graph Toolbar**

The Graph Toolbar, shown below, is located in the header of all graph windows. Some icons, such as the Radius tool, are only available for use in certain graph types.

![Graph Toolbar Icons]

**Locking and Unlocking a Graph**

The Lock Graph button toggles the graph between locked and unlocked modes. When a graph is locked, it cannot be edited.

**Using the Selection Tool**

Basic selection capability in graph windows is similar to that in other Windows applications. A mouse click within the graph area will select a graph item that is underneath or near the cursor, and will highlight that item appropriately. If a single item is selected in a graph window, Diver will display the name and Summary Value for that item at the top of the Console window.

A selection is indicated by turning the selected item white. When a bar is selected, a pattern appears within the bar. When a pie wedge is selected, it moves outward from the rest of the pie. When any graph item is de-selected, it will revert to its previous state.

Holding down the Shift key while selecting an item will add to the current selection, rather than replacing it. A Ctrl-click on an already selected item will de-select that item.

**Using the Lasso Tool**

If the mouse button is held down when selecting an item in a pie graph, or outside any data items in any graph, the cursor changes to a lasso.

The lasso can be used to select multiple graph items by moving around them with the mouse button still held down. All graph items within the shape defined by the lasso’s path will be selected. The lasso path need not be closed—it may be U-shaped. Each of the selected items will be highlighted until another (unshifted) mouse click occurs in the window, or until Organize > Focus is chosen.
Using the Zoom Tool

In addition to the Selection tool, graphical displays include a zoom button that looks like a magnifying glass. When you click on the zoom button, the cursor will change. Click once with the left button to zoom in on a region of the Dive Window. When the cursor appears as the magnifying glass, a right-click will zoom out again. To be able to select items again, you will need to click on the selection button, which looks like an arrow and is to the left of the Zoom Tool. It is important to note that zoom does not provide focus. It simply changes the aspect ratio of displayed data. This feature is useful in most cases of zooming, to view a subset of the data within the context of the entire data set.

Using the Scroll Tool

Graphs have two possible modes, scrolling mode and selection mode. The screen shot below shows a bar chart in selection mode. In this mode, no scroll bars are displayed, the arrow cursor is selected in the Graph Toolbar, and the axis may only be labeled every few lines instead of being labeled on every single item.

The fourth button in the Graph Toolbar changes the graph to scrolling mode. Click on the arrow or Select tool to return to selection mode.
Once you have switched to scrolling mode, fewer items will be shown on the graph, and scroll bars will appear when they are needed. The screen shot below shows the above graph in scrolling mode.

### Using the Radius Tool

The Radius Tool is available when a map has been created. The Radius Tool can be used to select all of the data points that are within the specified circle.

1. Select the Radius Tool in the map window.
2. Click and hold the left mouse button on the part of the map that is to be the center of the circle. This point can be anywhere on the map; it does not have to be in the colored areas that contain data.
3. Drag the mouse until the circle is the desired size. In the lower-right corner of the map screen, a counter displays the length of the radius of the circle in miles or kilometers. The zoom level of the map may need to be changed so that the circle includes all the desired data.

4. When the circle is the desired size, release the mouse button. All the mapped data that falls at least partially within that circle will be selected.
If **Organize > Focus** is then used, the map will look like this:

You may then want to use the Zoom tool.
Using Add-On Labels

Often, more detailed labels on a graph are required for a presentation. To communicate graphical information concisely and quickly, graphs can be annotated. For this purpose, Diver supports Labels and Tags. By default, these Labels have borders. These can be removed by unchecking the Show Drag-and-Drop Label Borders checkbox on the Graph Options Text Tab. For more information, see Using the Text Tab on page 5-74.

Using Labels

A Label is not associated with any data. The Label begins as a blank text box, to be filled in by you. The Label below shows the text “Cheese Revenue is above cost”.

To create Labels, the graph must first be unlocked. Unlocking is accomplished by single-clicking the lock button on the left end of the graph toolbar.

Boxes for Labels may be inserted from the Graph Toolbar by clicking the Create Label button and clicking on any location on the screen. Right-click to turn the tool off. If Labels are moved, they do not extend an arrow to their original location, and if a graph is scrolled, the Label will not scroll with it, but will remain at the same location in the window.

Labels have no initial text. When created, they are empty and ready to edit. Double-click inside the box, and then type the desired text. The size of the box changes to accommodate the text. If editing is disabled due to a mouse click outside the Label box, the text will not be editable again until double-clicked. The Label tool remains active until there is a right-click.
Using Tags

A Tag, which can be applied to a graph element using the button shown above (located second from the right on the Graph Toolbar), is a box containing text and extending an arrow to a point of interest in the graph, as shown below:

To create Tags, the graph must first be unlocked. Unlocking is done by single-clicking the lock button on the left end of the graph toolbar.

To insert a Tag:

1. Click the Create Tag button.
2. Click an item (bar, point, pie wedge, etc.) on the graph.
3. Right-click to turn off the Create Tag tool.

The Tag will be affixed to the graph location under the cursor point at the time the mouse button is released. The Tag can be moved by clicking on it with the mouse and dragging it to the desired location. It will extend a line to the graph at the point that the mouse was first released. As long as the Tag remains, it will adjust with the graph and will maintain an anchor line to its point of attachment on the graph. Multiple tags can be added. The Tag tool remains active until a right-click is done, or until the tag button is clicked again.
The text in the Tag will initially display the same Dimension and Summary Value as the graph item. The name of the graph item, in a tabular display, would be the row (Cheese) and column (Cost) Tags of the relevant data cell. The numeric value of the item would be the number in the relevant cell of a tabular display, as shown below.

![Tabular Display](image)

To edit the Tag text, double-click in the Tag box. Basic editing capabilities are available in the box. Once text is selected, the Font command in the Edit Menu allows the font style and font size to be changed. Clicking outside of the box will freeze the text of the Tag.

**Deleting a Label or Tag**

To delete a Label or Tag, click the Delete Label/Tag button (eraser), and then click the Label or Tag to be deleted. Right-click to turn off the tool.
Changing Font and Font Color

The Font and Font Color buttons allow you to select the Font and Font Color to use for the selected graph element. Each dialog is shown below.
Using the Graph Context Menu

A right-click on the mouse when positioned on a graph will display the following context menu:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Reverts a newly created graph back to the Tabular view, or back to the previous state of the graph if other actions, such as Sort or Flip Axes, have been applied.</td>
</tr>
<tr>
<td>Copy Window</td>
<td>Copies the active Graph window to the system clipboard. It can then be pasted into a third-party application.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all Dimension Values in the active Graph window.</td>
</tr>
<tr>
<td>Flip Axes</td>
<td>Switches the x- and y-axes of the graph.</td>
</tr>
<tr>
<td>Sort Up</td>
<td>Arranges Dimension Values in ascending order. This is reflected in the Legend.</td>
</tr>
<tr>
<td>Sort Down</td>
<td>Arranges Dimension Values in descending order. This is reflected in the Legend.</td>
</tr>
<tr>
<td>Find</td>
<td>Allows you to open the Find dialog appropriate for the primary graphed Dimension. For more information, see Using the Find Functionality on page 3-26.</td>
</tr>
<tr>
<td>Edit Window Info</td>
<td>Allows you to associate the Graph window with any or all available QuickViews.</td>
</tr>
</tbody>
</table>

Please see Copying and Pasting Window Dive Reference Strings on page 11-25 for additional information.
Using Graph Templates

Diver allows you to save a predefined Graph Template (.gtpl), to be used to apply uniform appearance options to your graph Markers.

Not all Graph Options saved in the template apply to each Graph type available in Diver. If a Graph Option that does not apply to the selected Graph type has been saved in the Template, that option will be ignored when the Template is applied.

Any custom settings that are changed after a Graph Template is applied, will override the Graph Template settings.

To create a Graph Template:

1. Create any type of Graph and set each of the required Graph elements.
2. Click the Graph Options... and set all Graph attributes as desired.
3. Select File > Save Graph Template....
4. Name the template as desired, and click Save.

To use a Graph Template:

1. Create any new Graph and set each of the required Graph attributes as desired.
2. Click Graph Options....
3. On the Appearance tab, browse to the saved Graph Template you wish to apply to the current graph. Click Open.
4. Click OK on the Graph options dialog.
5. Click Finish to display the Graph with the applied Template.

Modifying a Graph after a Template is Applied

If you unlock a graph to which a template has been applied, and try to change the settings, you will not be able to make any changes. Notice that the graph template path is still listed in the Apply Graph Template edit box. Clear this box to make changes.
Reports in Diver allow for an alternate view of Tabular data. Reports can range from a simple spreadsheet-like layout, to a fully customized view. This chapter covers features of a regular Report View in Diver. For information on Report Palettes, please refer to Chapter 11, Report Palettes.

When creating a Report, Diver will create a Default Report, containing the data from the performed dive, as a starting point to work with. Once in a Default Report, you can change everything from font sizes and colors to the location of items on the screen, as well as the actual data being displayed. Once the Report appears exactly as needed, a Report Template (File > Save Report Template) can be saved, which can then be used to apply the same formatting to another dive, either from the same Model, or from a different Model. The exact Report can be saved in a Marker (see Saving a Marker on page 3-7).

Creating a Report

It is easiest to understand Reports if you begin with one of the Diver Tabular displays, since a Report is essentially a formatted Tabular window. From any Dive Window:

1. Select Display > Report, or click the green Report button on the toolbar.

2. The Default Report dialog box will appear, allowing you to change the Default Report attributes. Make changes as necessary to achieve the desired report. Each option is described in the next section.

3. Click the OK button to display the Report.
Setting Default Report Attributes

The default Report Style depends upon the type of Diver window being used to create the Report. If the display is a Tabular, the default style will be a Tabular report, if the display is a 2 Level MultiTab, the default style will be an Indented 2 Level MultiTab, etc.

If the display is a Bar, Line, or Point Plot, a Pie Plot, a Map, or a Scatter Plot, the default Report will be based on the Tabular window used for graph creation.

The best way to discover which default Report is best for your data is to try several different Report styles.

When the Report button in the toolbar is selected, the Default Report dialog box appears, allowing you to change many attributes of the Report such as the display of gridlines, the calculation of totals, or the addition of a title. Each option is described in further detail below.
Setting Default Report Attributes

Creating a Report

Selecting the Report Style

The **Report Style** pulldown in the Default Report dialog box lists the available style choices for the Report. The available styles are determined by the Dive Window format used before switching to the Report view.

**Tabular Report Style**

The Tabular Report style displays the dive information in the same arrangement as the Tabular view, with the Dimension Values listed on the left (Salesperson in the example below), the Summary headings listed across the top (for example, Units, Cost, and Revenue), Summary Values displayed in table format, without gridlines, and Totals displayed at the bottom.

![Tabular Report Style Example](image)

There is also an option to include “Others” in the Report, by selecting the Tabular with Others Report style. This style is only applicable if the “” feature is in use.
CrossTab Report Style
The Basic CrossTab Report style displays dive information in the same arrangement as the CrossTab window, with the Dimension Values displayed in the left column and across the top, and the Summary Values in table format.

MultiTab Report Styles
MultiTab Reports can be thought of as having several levels, one for each Dimension. These levels are called “breaklevels”.

A breaklevel is like a hierarchical set of folders. Each value of a particular Dimension has its own folder, with a second set of Dimension values below it. The MultiTab values are displayed one by one, with a breaklevel between each value. The breaklevel may be a page break, a change in indentation, or some other indicator, depending on which display format is being used for the Report. Each of the values of the highest-level Dimension has a list of values of the next Dimension within it (the second level of the Report), and its values are, in turn, separated by breaklevels. Changing the order of the MultiTab will change the order of the breaklevels in the Report. The advantage of breaklevels is that subtotals can be displayed by value within the Report.
For example, a Report could contain three breaklevels: Sales Region, Year Mo, and Product. All Year Mos containing sales will be listed within each Sales Region, and all Products that have been sold will be listed within each Year Mo. Each Sales Region might be on a separate page, each Year Mo for a particular Sales Region listed below that, and an indented list of Products under each Month, as shown here:

In a MultiTab Report, using Sort Up or Sort Down on a Summary or Dimension will sort the values within breaklevels. A MultiTab Report sorted by more than one column will display Dimensions and Summaries grouped in the order specified, even if this means disrupting the original breaklevel divisions. However, the Dimensions to which each item belongs will still be indicated, as in the unsorted Report.
Two Dimension MultiTab Reports
When there are only two Dimensions in the MultiTab, three Report types are available:

- **Tabular MultiTab** - Similar to a Tabular window, with one important distinction. Instead of repeating the parent Dimension Values, Tabular MultiTab Reports only list each value once. For example:

![Tabular MultiTab Example](image1)

- **Paged MultiTab** - Places one value of the top-level Dimension in the header of each page. The remaining data is placed below that header. For example, page 1 would have “Butter” as the header, page 2, “Cheese”, and so on.

![Paged MultiTab Example](image2)
- **Indented 2 Level MultiTab** - Places the top-level Dimension at the left of the page, the second Dimension slightly indented below that, the third below that, and so on. There are also totals displayed for each breaklevel. For example:

![Multi-Dimension MultiTab Reports](image)

**Multi-Dimension MultiTab Reports**

For MultiTabs with three or more Dimensions, there are three additional default styles. These are:

- **Paged MultiTab: Bottom** - In this Report Style, the first Dimension is used as the header, and subsequent Dimensions are indented in the body of the Report, as shown below:

![Paged MultiTab: Bottom](image)
- **Paged MultiTab: Top** - All Dimensions except for the last are used as page headers, and the last Dimension is listed in standard tabular format on each page. In this example, each combination of Sales Region and Salesperson will have its own page, and each Customer for that combination is listed on that page.

- **Indented Subtotal MultiTab** - Similar to a standard indented Report in appearance, but actually quite different. The subtotal values are displayed on the same row as the Dimension Value. In the example below, the Subtotal for Sales Region “Boston” is displayed horizontally next to it, as it is for Salesperson Bailey, and then for each Company under him. All the Companies listed under Bailey total the Subtotal Summary Values seen for Bailey. Likewise, all Salesperson values in the report total the Subtotal Summary Values seen for Boston.
MultiCrossTab Report Styles

MultiCrossTab Reports are available in one style: Basic MultiCrossTab.

Basic MultiCrossTab

A Basic MultiCrossTab is a two-Dimension report, and is similar to the MultiCrossTab Tabular view, but without gridlines.

The Summaries in a Basic MultiCrossTab report can also be stacked, as seen below.

More information on Summary Stacking can be found on page 6-13.
MultiTabMultiCrossTab Report Styles

There are three report styles available for MultiTabMultiCrossTab Dive Windows. Each report style is shown below:

- **Paged MultiCrossTab** - In this Report Style, the child Dimension in the MultiTab (Product Family, for example) and the MultiCrossTab Dimension (Quarter) and Summary (Revenue) create a report that looks very similar to a Basic MultiCrossTab report. However, in a Paged MultiCrossTab, one value of the parent Dimension in the MultiTabMultiCrossTab Dive Window appears as the Header of each page, with a new Dimension Value starting on a new page.

![Paged MultiCrossTab Example](image_url)
• **2 Level Indented MultiCrossTab** - Similar to an Indented MultiTab report. The Parent Dimension in the MultiTab (Sales Region) appears at the left of the page, with the child Dimension in the MultiTab (Product Family) slightly indented below that. However, in this report type, the MultiCrossTab Dimension (Quarter) and Summary (Revenue) also appear across the top of the page. This format shows that the Summary Values in the report are broken down by Quarter and Revenue for each Sales Region/Product Family combination in the MultiTab. All values are totaled at each Sales Region breaklevel.

![Image of report data]
Creating a Report

Setting Default Report Attributes

- **2 Level Tabular MultiCrossTab** - Similar to a Tabular MultiTab report. The parent and child Dimensions (Sales Region and Product Family) in the MultiTab are the two left-most columns, as in the Tabular MultiTab. However, in this report type, the MultiCrossTab Dimension (Quarter) and Summary (Revenue) also appear across the top of the page, indicating that the Summary Values in the report are broken down by Quarter and Revenue for each Sales Region/Product Family combination in the MultiTab.

Each of the three options above allows Summary Stacking by checking the Stack Summaries check box in the Default Report dialog. For more information, see the Editing Summary Column Layout section below.
Editing Summary Column Layout

The **Edit Summary Layout** dialog box is used to control how Summaries will be placed in a report. Most Report Styles display each Summary in its own column; however, the Edit Summary Layout option allows you to:

- Stack multiple Summaries in a column
- Add row labels for each Summary
- Rename columns
- Hide columns from view
- Change column formatting
- Delete columns from the report
- Remove blank columns

For Summary Stacking in a CrossTab, MultiCrossTab, or MultiTabMultiCrossTab, the Edit Summary Layout dialog is not available. To stack summaries in these reports, you must instead check the Stack Summaries check box in the Default Report dialog.
The Edit Summary Layout dialog box, shown in the series of figures below, allows you to easily customize the columns in a report to your specifications:

1. **Check Include Row Labels** to add row labels to a report. The row labels are added to, or removed from this area by clicking the **Add** or **Delete** buttons. This feature is useful when using Summary stacking options.
2. Double-click a new row label to open the Select Label Style dialog box. This option allows you to specify whether you want to use specific Text, Column Name, Group Name or Group Value (if Named Group columns were used), or Summary Name for the row labels.

3. Double-click on any column name in any of the Report Positions areas to open the Edit Format dialog box and format the selected column. This dialog box is the same as the Format tab that appears in the Edit/Add column dialog box in the Report View (see Using the Format Tab on page 6-36).
4. Single-click on the words **<Column Names>** in the desired **Report Positions** area to access the **Select Label Style** dialog box and select the label style to use for the selected column. Options that can be used for column label style include **Text**, **Column Names**, **Group Name**, or **Group Value** (if Named Group columns are being used), and **Summary Name**. The words **<Column Names>** will be replaced with whichever option is selected.
5. Specify the way you wish to stack the report columns to achieve the desired layout by selecting the required stacking option from the Default Stacking pulldown list shown below.

6. Click **OK** to accept the Summary Layout settings and return to the Default Report Palette dialog to continue creating your Report.

**Defining a Report Title**

Text entered in the **Title** text box is used as a title for each page of the Report, and will be put in the left-hand side of the Head section of the Page Breaklevel.

**Displaying Totals in a Report**

The **Totals** section allows you to display totals in the **Top** or **Bottom** of the Report. For a CrossTab, top means “left” and bottom means “right”.

**Displaying Subtotals in a Report**

**Subtotals** allows you to decide if subtotals for each breaklevel should appear in the report, and whether they should appear at the **Top** or **Bottom** of the subsection. Select **None** if you do not wish to display Subtotals.
Displaying Page Numbers in a Report

**Page Numbers** are included in the Report if this box is checked. The style of page numbering is set in the Report Preferences dialog box. See **Setting Report Preferences on page 6-22** for further information.

Adding the Current Date to a Report

The current **Date** is included in the Report if this option is checked. This function uses the client computer’s system date, meaning a locally installed Diver will use the local machine’s date, while DivePort and NetDiver will use the Web Application Server system date since they reside on the Web Application Server.

Displaying Gridlines in a Report

If this check box is checked, the Report will include **Gridlines** around the data, as well as between rows and columns. It creates a look very much like a Tabular window or spreadsheet, but headers and row labels exist outside the gridlines.

Displaying a Report on a Single Page

When using the Default Report dialog box to convert the display to a Report, **Fit to Page** makes the Report fit into one page width (when the Report is set to Printed Reports). See **Using the Report Screen Tools on page 6-20**.

Including a Print Header or Footer in a Report

The **Include Print Header** and **Include Print Footer** options allow you to display the print header, as set in the Page Setup dialog box in the Report. See **Setting Print Options on page 3-14** for more information.
Including Parent Info in a Report

Include Parent Info displays the names and values selected in all parent windows in the Report (circled below). By default, Parent Info is displayed on the left side of the Report header.

![Image of report with Parent Info circled]

Loading a Report Template

The Load Template... option allows you to format a Report with a previously created and saved Report Template. More information can be found under Saving Report Templates on page 6-61.
Understanding Reports

Once a dive is displayed as a Report, there are two different modes that you can access: **Locked** or **Unlocked**. When a Report is locked, it can be used as if it were a Tabular window, including the ability to sort, find, focus, or dive. When unlocked, the Report can be modified.

Note that the Report window has its own toolbar, with tools specific to modifying and navigating through a Report.

Using the Report Screen Tools

If the Report is locked, many of the other tools, designed to modify the Report, will not appear. Some tools work regardless of the lock status of the Report. These tools are **Page Up** and **Page Down**, which move the Report up or down one full page, and the **Page Number** window, which tells you which page of the Report is being displayed.

Locking and Unlocking a Report

The **Lock Box** (as labeled above) allows you to lock and unlock a Report. When first switching to a Report display, the Report will be locked. While the Report is locked, double-clicking on a single item will allow you to sort or dive further into the data. Clicking on the Lock Box will unlock the Report. When the Report is unlocked, its appearance can be altered using the other tools in the Report toolbar. A Marker opens in locked mode.

When a Report is unlocked, any cells or placeholders containing data that is not displayed (due to Skip Repeated Values, for example) will be surrounded with a grid.

Viewing an On-Screen Report in Printed Format

The **Printed Report** option allows you to view the Report on-screen as it would look printed. Item selection is not displayed on the printed Report.
Adding an Item to a Report

The **Add Item** button is used to insert a new field, or item into a Report. Click this tool to create an empty item, and open the Add/Edit Item dialog box. See **Editing or Adding a Report Item on page 6-23** for information about types of items that can be added, and about how to place and configure them.

If an item is already selected when the Add Item tool is clicked, the new item will inherit the properties of the selected item. This feature is useful when adding an item which is similar, and has only a few differences.

Deleting an Item from a Report

The **Delete Item** button will remove the selected field from a Report.

Adding an Empty Column to a Report

The **Add Column** button will add an empty column to the Report. If a column is already selected when the Add Column tool is clicked, the new column will be added to the left of the selected column. If no column is selected when the Add Column tool is clicked, the new column will be added to the right of all existing columns.

Deleting a Column from a Report

The **Delete Column** button will remove the selected column from the Report (including all items in the column). Any data in a column removed from a Report is still present in the tabular view. The column must be selected by character in the edit toolbar.

Formatting Report Items

The **Font** button opens the Font dialog box, which allows you to select a font, a style, and a size to use for the selected item. This dialog box can also be accessed through the Style tab of the Add/Edit Item dialog box.

The **Color** button opens the Color dialog box, which allows you to select a color to use for the selected item. This dialog box can also be accessed through the Style tab of the Add/Edit Item dialog box.

The **Bold** button applies bold formatting to the selected item, or removes bold formatting if the item is already in bold print. It can also be accessed through the Style tab of the Add/Edit Item dialog box.

**Italics** applies italics formatting to the selected item, or removes italic formatting if the item is already italicized. It can also be accessed through the Style tab of the Add/Edit Item dialog box.
**Underline** applies underlining to the selected item, or removes the underlining if the item is already underlined. It can also be accessed through the Style tab of the Add/Edit Item dialog box.

The **Left, Center, and Right Justify** buttons control the alignment of a selected item within a column or cell. In a default Report, headers are centered within a column, text is left-justified and numbers are right-justified. Justification can also be changed on the Style tab of the Add/Edit Item dialog box.

### Setting Report Preferences

Report **Preferences** are set using the dialog box shown below, and many are saved in the diver.ini file.

![Report Preferences Dialog Box]

**Space between Columns** allows you to set the size of the gap between the columns in a Report. The units used are in pixels. The default is ten pixels.

Click the check box next to **Grid Lines** to separate the rows and columns in the default Report body by lines.

Click the check box next to **Default to Screen Reports** to revert to the default Screen layout.

Click the check box next to **Fit to Page** to fit the Report on one page width, if possible, when the Report is set to Printed Reports.

Click one of the radio buttons below **Page Numbers** to specify which format to use for numbering the pages in the Report that is not using the Fit to Page option.

**Page Size** allows you to choose the resolution of the Report screen display, in pixels. The options are “Default” (current screen resolution), “500x400”, “700x500”, and “900x700”. This feature is provided for Legacy browsers that do not auto size. Default is the recommended setting.
**Background Color** allows you to change the color of the Report background from white to the selected color.

The **Breaklevel Threshold Lines** is the number of lines from the bottom of the page after which the Report window will not start another breaklevel. The default is five lines.

**Viewing Page Numbers in a Report**

The number in the small box of the **Page Number** box indicates the number of the page currently in view.

**Paging Through a Report**

**Page Up** and **Page Down** will move through the pages of the Report.

**Editing or Adding a Report Item**

Add a new item or double-click on an item in a Report (when it is unlocked) to open the Add/Edit Item dialog box. If editing an item, the information under the Data tab will match the type of item selected.

**Using the Data Tab**

The **Item Type** pulldown will allow you to select or change the type of item being added or edited. The Data tab portion of the Edit dialog box changes according to the selected Item Type.

The following items may be added.
Each Report item is discussed in detail below.
• **Dimension Name** - Allows you to select which Dimension name should be added to the Report. In the example below, an item containing “Quarter” will be added to the Report. Available Dimensions are limited to those in the current Dive Window.

![Dimension Name Image]

• **Dimension Value** - Allows you to select which Dimension values should be added to the Report.

![Dimension Value Image]

— **Skip Repeated Values** - In a Tabular MultiTab Report, if the same value of a Dimension is repeated, checking this box will cause the Report to display the value only once until the value has changed. In a report for a MultiTab with Quarter and Salesperson, the first value for the Quarter Dimension should be 2003/1. Using Skip Repeated Values, 2003/1 will not be repeated for each Salesperson. Instead, the value for the Quarter Dimension will only be displayed once it has changed to 2003/2, etc.

— **Start on New Page** - If this box is checked, each time the value of the Dimension changes, a new page will be started. Using the example above, after all data for 2003/1 is displayed, 2003/2 will begin on a new page.

— **Skip Others Row** - If this box is checked, the Others row will not be displayed in the report. This checkbox is only applicable when the “” functionality is in use.

• **Summary Name** - Allows you to select which Summary’s name should be added to the Report. In this example, a new item containing “Units” will be added.

![Summary Name Image]
— **Use Summary Name from Model** takes the Summary’s name from the original Model. This option may be the desired one, since, by default, report headers are often different from Tabular headers. Available Summaries are limited to those in the current Dive Window.

- **Summary Value** - With the Summary Value item type, the box next to **Summary Name** allows you to tell Diver which Summary’s values to include in the item being added.

- **Summary Breaklevel** allows you to tell Diver whether to display the overall total of the Summary that has been selected, or to display Dimension Value subtotals for the selected Summary.

- **Ignore Focus/Group** allows you to show the grand total of all values, rather than only the focused or grouped values.

- **Others** - Allows you to display the “Others” value for the specified Summary column. This item type is only available when the “” feature is in use.

- **Info Name** - Allows you to select which Info Field name should be added to the Report. In the example above, a new item containing “Address1” will be added to the Report. Available Info Fields are limited to those in the current Dive Window.
• **Info Value** - Info Value allows you to add an item containing the value of the specified Info Field, and will change throughout the Report for each value of the Info Field.

![Info Value Item Type](image1.png)

• **Text** - Allows you to enter a string of text to display in the Report.

![Text Item Type](image2.png)

Optionally, you can use the Text Variables shown in the scroll box to the right, either by themselves or in combination with the entered text. These Text Variables change when other factors such as today’s date or the number of pages in the Report change.

• **Parent Dimension Name & Parent Dimension Value** - In a dive, each of the higher-level dive Dimensions is a parent Dimension of all dives below it. For example, if you dive on **Salesperson**, select a value, and dive on **Product Family**, Salesperson is the parent Dimension of Product Family. If you were to dive from one of the Product Family values on **Product**, Product Family would be the parent Dimension of Product.
Setting the type of item to Parent Dimension Name displays the name of the top-level parent Dimension in the current dive (for the dive above, Salesperson and Product Family are parent Dimensions). Setting the item type to Parent Dimension Value displays the selected value of the top-level parent Dimension.

Additional settings are also available:

- **All Parents** includes information for all parent Dimensions. This information includes all QuickViews that are associated with the active window.

- **All Windows** displays a list of all Dive Windows in the path of the current Dive Window, and the values selected in them, into the Report. QuickViews associated with the window will not be included.

- **All QuickViews** displays a list of all of the QuickViews associated with the Dive Window into the Report. Other Dive Windows in the path will not be included.

- **One Parent** allows you to select a single parent of this sequence of Parent Dimensions by choosing the desired Dimension from the pulldown list beside the check box.

- **Skip All Values Parents** is used in conjunction with the All QuickViews radio button option. If this option is unchecked, the Parent Dimension Value header will display as “All Values” when “All Values” is selected in the corresponding parent QuickView. However, if this option is checked, nothing will be displayed in the Report when “All Values” is selected in the QuickView. This option is unchecked by default.

- **Parent Dimension Name & Value** - Allows both the Name of the Parent Dimension and the Value of the Parent Dimension to be placed in the Report, separated by a colon, as a single item. The available options are explained in the section above. In a
dive example where the Parent Dimension Name is “Sales Region” and the selected Parent Dimension Value is “West”, the Parent Dimension Name + Value item would place “Sales Region: West” into the Report.
• **Parent Info Name & Parent Info Value** - Allows you to access the information stored in Info Fields related to a dive’s Parent Dimensions. For example, in a dive where **Customer** and **Product Family** are Parent Dimensions, the Parent Dimension Customer has an Info Field **Address1** related to it.

You can add an item to the Product Family Report, choosing **Parent Info Name** for the item type and **Address1** as the Parent Info. This item displays the text “Address1”. If, instead, **Parent Info Value** is selected as the type and **Customer** as the Parent Dimension, “2118 Dallas St.” is displayed, since Address1 is related to the specific Customer value used for the dive.

• **CrossTab Data** - Specifies the columns of data to be used, spanning from the **Start Column** to the specified **End Column** (either the **Last Column**, or the Column number entered in the **Column #** text box).
• **CrossTab Header** - Allows you to use the names of the columns from the CrossTab, spanning from the **Start Column** to the specified **End Column** (either the **Last Column**, or the Column number entered in the **Column #** text box).

  ![CrossTab Header](image1)

• **CrossTab Totals** - Displays the totals for each of the columns selected, spanning from the **Start Column** to the specified **End Column** (either the **Last Column**, or the Column number entered in the **Column #** text box).

  ![CrossTab Totals](image2)

• **CrossTab Row Totals** - totals each row only for the columns specified in the dialog box, spanning from the **Start Column** to the specified **End Column** (either the **Last Column**, or the Column number entered in the **Column #** text box).

  ![CrossTab Row Totals](image3)
DIVER

Understanding Reports

Editing or Adding a Report Item

- **MultiCrossTab Dimension Value** - Allows you to select a particular Dimension Value for a subcolumn. The **Subcolumn** pulldown specifies where the data will be placed in the Report.

![MultiCrossTab Dimension Value](image)

- **MultiCrossTab Summary Name** - Lets you put the selected Summary’s name in all of the subcolumns. In the example above, a new item containing “Cost” will be added to subColumn 1, or the currently selected Subcolumn will be changed to “Cost”. The **Subcolumn** pulldown specifies where the data will be placed in the Report.

![MultiCrossTab Summary Name](image)
• **MultiCrossTab Cell Value** - Allows you to add an item containing the value of the selected cell to the Report. **Summary Name** allows you to tell Diver which MultiCrossTab cell values you want in the item. **Summary Breaklevel** allows you to tell the Diver where to put the subtotal for the values in the Summary. It can be put in the Report as an overall total, or on any breaklevel. The **Subcolumn** pulldown specifies where the data will be placed in the Report.

![MultiCrossTab Cell Value](image)

• **MultiCrossTab Row Total** - Allows you to total the numbers for any given MultiCrossTab row. The **Summary Name** pulldown allows you to tell Diver which Summary Values you want in the item.

![MultiCrossTab Row Total](image)

• **MultiCrossTab Column Total** - Allows you to add an item totaling the numbers for any given MultiCrossTab column. The **Summary Name** pulldown allows you to tell Diver which Summary Values you want in the item. The **Subcolumn** pulldown specifies where the data will be placed in the Report.

![MultiCrossTab Column Total](image)
**Group Name** - Allows you to display the name of a Named Group associated with a particular Summary, if there is one. For example, if a column was created in the Time Series Control Panel and named “Units YTD”, then “Units” would be the Summary Name listed in the pulldown, and “YTD” would be the Group Name placed in the Report.

![Image of Group Name](image1)

**Group Dimension Name** - Displays the name of the Dimension of the Named Group associated with the specified Summary (Units in this example). In the example below, if the Named Group were “YTD”, then the Dimension Name would be “Date” or “YearMo”.

![Image of Group Dimension Name](image2)

**Group Value** - Displays the actual value for either the first or the last value in the group. For example, if there is a column that uses a group named January 2003, and the January 2003 group contains the value 01/2003, then Group Value will return 01/2003. This item is useful for Reports where the column may be based on some arbitrary date that changes from month to month.

![Image of Group Value](image3)

There are two different options for this item:

- **First** will return the first value for the group, in whatever order the group Dimension is sorted. For example, if a group is named “Last Three Months”, then “First” might return 2004/04
- **Last** returns the last value for the group, in whatever order the group Dimension is
sorted. Using the example above, if a group is named “Last Three Months”, then “Last” would return 2004/06.

- **Graphic**

Any png file (.png), jpeg (.jpg), or bitmap (.bmp) image can be placed in a Report by specifying the URL or the path and filename of the graphic to be included. The recommended size for a graphic is less than an eighth of the page in the Report. Graphics must be resized in a program other than Diver. Markers and Report Templates will store a pointer to the graphic file so that it can be included the next time the Marker or Report Template is opened. However, this means that the graphic file should not be moved.

The image shown above includes an area allowing you to enter the location of the desired Graphic. In addition to a static URL to a graphic, report Text Variables like $COMMENTS and $MODEL_FOOTER can be used in the URL. This feature will allow you to dynamically change the graphic that appears on the top of the report. For example, http://<servername>:<portnum>/graphics/$COMMENTS.jpg.
Using the Format Tab

The Format tab, shown below, allows you to specify formatting for the selected Report item.

![Add Item Form](image)

The following options are available.

- **Use Default Format** - Preserves the format of the Report in its default state. Uncheck to enable format changes.

- **Number of Decimal Places** - Specifies the number of decimals to use in formatted Summaries. Columns in a Report cannot have more decimal places than the columns in the underlying Tabular.

- **Do not display Zeroes** - Removes zeroes from the formatted column, resulting in a blank cell.

- **Include Group (1000s) Separator** - Displays or removes 1000s separator from the formatted column. In US locale, this option includes the comma in numbers.

- **Display Blanks as Zeroes** - Displays blank cells as zeroes in a report, and still allows for additional formatting in the cell. For example, if you wish to display blanks as zeroes, but also want percentage columns formatted as percentages, using this and the Percentage formatting options together will return a zero with a % sign.

- **Special Formats**
  - **None** - No special formatting is assigned.
  - **Accounting** - Shows negative numbers in parentheses.
— **Currency** - Shows the selected Currency by country. Use the pulldown to select from the list.
— **Percentage** - Shows a percent symbol after the value.

**Using the Breaklevel Tab**

When a Report is displayed from a MultiTab, a MultiCrossTab, or a MultiTabMultiCrossTab dive, it can have multiple breaklevels. By default, the breaklevels are in the same order that the Dimensions were dove on. Breaklevels can be configured further using the Breaklevel tab, shown here.
The example report below contains three breaklevels: Sales Region, Salesperson, and Product Name.

For each Sales Region, all Salespeople will be listed and all Product Names sold will be listed within each Salesperson.

Aside from each Dimension of the Report being a Breaklevel, there is also a Page Breaklevel. The Page Breaklevel is used for items that should appear on each page, either at the top of each page (in the head of the Page Breaklevel), or at the bottom of each page (in the tail of the Page Breaklevel). Rather than having a Body, the Page Breaklevel has a portion called Head2. Any item put into the Head2 portion of the Page Breaklevel will appear just below any items in the Head of the Page Breaklevel, but before the next Breaklevel begins. In a Default Report, Summary Headers are in the Head2 portion of the Page Breaklevel, so that when a title is inserted in the Head of the Page Breaklevel, the Summary Headers do not need to be moved down. They will automatically appear right below the title.

As a general rule, any items that need to change within the Report, such as Summary Values and Dimension Values, must be in the Body of a Breaklevel. Dimension and Summary names and other text items can go in the Head or Tail of a Breaklevel. Subtotals are usually found in the Head or Tail of the Breaklevel being totaled.

- **Breaklevel** - Allows you to select the breaklevel in which an item should be placed: in the Page Breaklevel or the Breaklevel for one of the Dimensions. There is also an option that specifies that the Report window not start a breaklevel if it is currently too close to the bottom of a page. Called a Breaklevel Threshold, it is the number of lines from the bottom of the page after which the Report window will not start another breaklevel, but will instead begin the Breaklevel on the next page.

- **Location** - Allows you to select whether the item should be placed in the Head, Head2, Body, or Tail of the page Breaklevel selected. The Index text box will render Items at a given Breaklevel, position, and row in the order of their indices. That is, items with a position index of 1 will render above items with a position index of 2, and so on. The default value is 1.
• **Attributes** - There are three Breaklevel attributes. They are:
  
  — **Don’t display only one row**: This attribute is used for Head and Tail items. It causes Diver to not display an item when there is only one row within the breaklevel. It is useful for avoiding giving subtotals when there is only one row to subtotal.
  
  — **Repeat on Page Break**: This displays the current value if a new page is started before changing to a new value. In other words, the item will render again when a page break occurs at a lower breaklevel. For example, in a dive on Sales Region, if the Rhode Island Sales Branch was not complete by the end of a page (through the Subtotal) when the end of a page was reached, then “Rhode Island” would be printed at the top of the new page.
  
  — **Skip Blanks**: This will cause an item to not render (or take up any space in the Report) if it is blank.

**Using the Position Tab**

The position tab allows you to determine where, on the report, the item being added should appear.

- **Column** - Allows you to select whether an item should be placed in an existing column, and where to place it. You can also add a new column, or place a column at Page Left, Page Right, or Page Center.
• **Offset** - Relocates an item horizontally and vertically by the number of pixels specified. A positive number in the vertical offset box will add space above an item. A positive number in the horizontal offset box will add space to the left of a left-justified item and to the right of a right-justified item. Dragging an item vertically will change the vertical positioning. When dragging and dropping an item horizontally, it will either affect the horizontal positioning and/or relocate the item to another column.

Items that are Positioned to Page Center should be set to Center-Justified on the Style Tab. Items that are Positioned to Page Right should be set to Right-Justified, and Page Left items should be set to Left-Justified on the Style Tab.

• **Column Fit** - Determines how to handle an item if it does not fit within a column.
  — **Wrap Words in Column** - Wraps the item to the next line within the column.
  — **Truncate in Column** - Cuts off a portion of the item.
  — **Fit to Page** - Forces text in a column to fit across the length of the column, whether or not all text is visible. This option is different from Truncate in Column because words are not cut off, they are simply hidden. Hidden words can be displayed by increasing the width of the column.
  — **Wrap Characters in Column** - Breaks long fields by wrapping characters rather than entire words.
Using the Style Tab

Styles are used to give a uniform look to the format of Reports. Styles include font, size, color, spacing, alignment (Justify), and top and bottom lines. Each component of the Report can have a preset Style. There are several pre-named Styles to choose from, or new Styles can be created by choosing Add Style in the Style Name pulldown.

- **Justify** - Specifies whether an item should be justified.
  - **Horizontal** - Choose Left, Center, or Right.
  - **Vertical** - Choose Top, Center, or Bottom.
- **Type** - Allows you to make an item in a Report appear in **Bold**, **Italic**, or **Underlined** text.
- **Apply To** - Offers two options:
  - **This Item** will change only the selected item.
  - **This Style** will change all items that use the currently selected style.
- **Line Spacing** - Adjusts the amount of space in between each line when an item contains multiple lines of data. It is useful for adding space below each instance of an item. To add space above an item, see the Offset option under **Using the Position Tab on page 6-39**. **Top** and **Bottom** line boxes allow you to set lines above and below an item. Choices include: Normal, Bold, Grey, Dashed, Double, and Double Dashed. This option does not apply to all Report types or to Report Templates.
• **Fonts...** - Opens the Font dialog and allows you to choose the font, size, and style for the selected item.

• **Color...** - Opens the Color dialog and allows you to specify a color for the item. If the desired color is not displayed, click the Define Custom Colors >> button to define a new color.

• **Style Editor** - If Add Style... in the Style Name pulldown is selected, the Style Editor dialog box will appear. The Style Editor is used to create and format new Styles. After a new Style is created, it will be added to the Style Name list, and can be easily applied to the Report for the session.

Using the Text Tab

The Text Tab allows you to add text to the beginning or end of the item being added.
• **Preceding Text** - Places the specified text at the beginning of an item. For example, a value of the Month Dimension with Preceding Text of “Total for” would be displayed in the Report as “Total for January”, “Total for February”, “Total for March”, etc. ASCII characters can be entered here.

• **Trailing Text** - Places the specified text at the end of an item much the same way as Preceding Text places text before the item.

Preceding and Trailing text in a Report item can include variables. More information can be found under Using the Data Tab on page 6-23.

Using the Border Tab
The Border Tab gives you several options for placing a Cell Border around the data in a cell, or around an entire cell.

- **Cell Border** - Borders can be added to an entire cell by selecting the desired row, and then checking **Row Top** and/or **Row Bottom**. Individual data borders are added by selecting the desired cell, and then checking **Top**, **Left**, **Right**, and/or **Bottom**.

- **Background Color** - A Background Color can be added by selecting one of the position options, and clicking the **Select...** button to select a color from the Basic Colors options. You can create a custom color, if desired.
  — **Color Entire Background** - Adds the color to the entire report background.
Every Other Row - Colors every other row in the report.

The default color for every other row is white. Color starts on row two.

Using the Link Tab

The Link tab options cause Report Items to behave in a particular way when clicked. These behaviors include opening HTML links and Diver files, running executables, and using Window References.

- **Link Activation Type** - Determines how a link should be activated. The options are Single Click and Double Click.
- **Link Type** - Determines the type of link triggered in the report. Options include:
  - **HTML Link Column** - Opens HTML Links defined in the column selected in the pulldown. See Creating and Triggering an HTML Link in a Report below for more information
  - **Command Line** - Runs the specified command on the command line.
  - **Window Reference** - Opens a window to a Model using the Dive path and the values specified. (For more information on Window References, see Using Window Dive)
Creating and Triggering an HTML Link in a Report

To create and trigger an HTML Link, these steps must be taken:

1. Create an Info Field (via Builder as an Info or DiveMaster as a Lookup) containing the desired URL links, being sure to associate it with the correct Dimension. (A link can launch a web page, a graphic, or document such as a PDF, as long as it is a valid URL.)

2. Open the Model or DivePlan containing the new Info Field and dive on the Dimension for which the Info Field was created.

3. Add the Info Field as a new column (see The Model Columns area allows you to create a basic column from any Summaries built into the Model. To add a column, select the desired available column type: Total, Min, Max, Average, % Total, or Std Dev, and select the Summary to be used from the list to the right (in this example, Units, Cost, or Revenue). on page 9-6 for details on adding Info Columns). For this example, the column will be named “Document Links”.

4. Create a Report with the desired settings.

5. Unlock the Report and double-click any value in the “Document Links” Info Column to open the Edit Item dialog.

6. Click the Link Tab.

7. Check Use Link and select the appropriate Link Activation Type.

8. Select the radio button next to HTML Link Column.

9. Select Link from the pulldown and click OK.

The “Document Links” will now be activated in the Report. You may wish to edit the style of the Info Values so that they are underlined and blue, indicating that they are clickable links. For more information see Using the Style Tab on page 6-41.

Report Palettes do not use the HTML Link Column option.
Any paths used in command line links must be local paths when used with ProDiver.

Using the Exception Tab

Exception reporting allows you to see variances in your data that might otherwise go unnoticed. An exception can be defined for an individual column, the exception column, and is typically defined as a range of Bad, Neutral, and Good values. The Exception tab can be used to set colors for exception reporting in both Reports and Report Palettes.

- **Exception Source** - Allows you to define how an exception column is defined. Options include:
  - **Use Column Exception Values** - Allows you to use the exception settings from a Tabular if they were already set in the Edit Column > Options Tab.
  - **Define Range Below** - Allows you to define a new exception range.

- **Neutral Range** - Defines the start and end points of an Exception range, with “Good” and “Bad” on either side of the defined range.
• **Direction** - Allows you to define “Good” as everything greater than the higher number in the Neutral Range (**Good > Neutral Max**) or as everything less than the lower number in the Neutral Range (**Good < Neutral Min**).

• **Skip Neutral Range** - Allows you to ignore the Neutral Range and treat everything as either good or bad.

• **Up/Down Arrows** can be selected by clicking on the check box. If selected, arrows indicating “Good” or “Bad” will display in the report. Below is an example using a Neutral range.

<table>
<thead>
<tr>
<th>Exception</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>213.382/571.77</td>
</tr>
<tr>
<td></td>
<td>-107.065/264.43</td>
</tr>
<tr>
<td></td>
<td>-150.129/475.22</td>
</tr>
<tr>
<td></td>
<td>-125.336/156.71</td>
</tr>
<tr>
<td></td>
<td>-85.360/816.40</td>
</tr>
<tr>
<td></td>
<td>-70.135/467.98</td>
</tr>
<tr>
<td></td>
<td>781.765/141.51</td>
</tr>
</tbody>
</table>

— The **Direction** pulldown in the Ranges area of the tab allows you to change the direction of the arrows.

— **Location** allows you to specify the location of the arrows, either the left or the right side of the column.

— **Neutral** allows you to specify if an Up-, Down-, or Side-facing arrow should be used for neutral values

— The **Style** pulldown allows you to specify the appearance of exception arrows. Choices include Arrow, Triangle, and Circle.

• **Color Background** colors the background of each Summary Value according to whether that value is “Good” or “Bad” and appears as follows:

<table>
<thead>
<tr>
<th>Exception</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>213.382/571.77</td>
</tr>
<tr>
<td></td>
<td>-107.065/264.43</td>
</tr>
<tr>
<td></td>
<td>-150.129/475.22</td>
</tr>
<tr>
<td></td>
<td>-125.336/156.71</td>
</tr>
<tr>
<td></td>
<td>-85.360/816.40</td>
</tr>
<tr>
<td></td>
<td>-70.135/467.98</td>
</tr>
<tr>
<td></td>
<td>781.765/141.51</td>
</tr>
</tbody>
</table>

• **Color Foreground** colors the font of each Summary Value according to whether that value is “Good” or “Bad” and looks like this:

<table>
<thead>
<tr>
<th>Exception</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>213.382/571.77</td>
</tr>
<tr>
<td></td>
<td>-107.065/264.43</td>
</tr>
<tr>
<td></td>
<td>-150.129/475.22</td>
</tr>
<tr>
<td></td>
<td>-125.336/156.71</td>
</tr>
<tr>
<td></td>
<td>-85.360/816.40</td>
</tr>
<tr>
<td></td>
<td>-70.135/467.98</td>
</tr>
<tr>
<td></td>
<td>781.765/141.51</td>
</tr>
</tbody>
</table>
Any combination of Arrows, Color Background, and Color Foreground may be used, although it is not recommended to use Foreground and Background at the same time. At least one option must be selected.

Single-clicking on the color square next to Good, Bad, or Neutral in the Display area will open a dialog box allowing you to select a new color for it.

Style Column Handling

Style Columns allow you to update the appearance of a Report without recreating the underlying Marker file. Format changes are saved in an external lookup file that can be added to the Model as an Info Field. The Info Field is then used to add a **Style Column** to a Report item, that refers to another column in the Report window containing a string value.

Each value in the lookup file describes one or more ways in which the default style for the Report item (the “Base Report item”) is overridden. For example, you may want to view each value in the Base Report item differently.

In the example below, the Style column is applied to the columns Company Name and Plan Units. The style column is included in the report for illustration purposes, that is, you would not normally include it as part of the saved Report Marker.
If a style column exists, it will be checked for a string specifying overrides to the style specified in the Edit Item dialog itself. If conflict exists, the string in the Style Column will take precedence.
Style Column Formatting

Style information is stored in a single string, as a combination of name/value pairs separated by commas. For example:

```
FontFace="Arial",FontSize="8",FontStyle="Bold"
```

Specific information for each value in the Report Item will be listed by the corresponding name/value pair in the Style column.

The following information is available for formatting:

- **Font Formatting**
  
  **Name:** FontFace  
  **Value:** The name of the Font. Examples include “Arial”, “Courier”, and “Times New Roman”.

  **Name:** FontSize  
  **Value:** The size of the specified font, in “Points”, for the font. For example, “8”, “10”, or “12”.

  **Name:** FontStyle  
  **Value:** The style to add to the font. Possible Values are: “Normal”, “Bold”, “Italic”, or “Underline”

Each style is additive, that is, each style argument is added to the others specified in the same line. The example below would produce Bold, Italic fonts:

```
FontStyle="Bold",FontStyle="Italic"
```

Using the Style “Normal” will reset all flags, including pre-existing ones. For example, if the base item is already bold, the following value would create non-bold, italic text:

```
FontStyle="Normal",FontStyle="Italic"
```
- **Spacing** - Sets the various spacing attributes of report items. All values are in Pixels.
  Valid values are:

  **Name:** HorizontalSpacing  
  **Value:** Padding added to the left or right of the text. For Left and Center Justified items, Positive Horizontal offsets add space to the left of the item. For Right Justified items, adds space to the right. Negative numbers are not supported.

  **Name:** VerticalSpacing  
  **Value:** Space added above the item.

  **Name:** LineSpacing  
  **Value:** Space added below the item, before the next row.

- **Number Formatting** - Affects the various aspects of number formatting. Note that if the item being formatted is not a number, there will be no visible effect (and no error message will be given).

  **Name:** NumDecimals  
  **Value:** Number of decimals to display. If -1 is given, the default value based on the data type of the underlying column is used. (0 for integers, 4 for floating point types, 2 for currency types). Note that just like the regular Report item formatting, this is limited by the number of decimal places on the underlying column.

  **Name:** SkipZeroes  
  **Value:** If “true”, zeroes will be displayed as blanks. If “false”, zeroes will still be displayed as zeroes. This can override the base item formatting.

  **Name:** BlankZeroes  
  **Value:** If “true”, blank values will be displayed as zeroes. If “false”, blank values will remain blank. This can override the base item formatting.

  **Name:** GroupSeparator  
  **Value:** Changes the group separator in numbers to match that of the current locale on the machine. If “true”, a group separator is used based on local settings. If “false”, no separator is used.
**Name:** FormatType  
**Value:** Defines the type of number formatting. Valid values include: “None” (No special formatting is done; the value is treated as a number), “Accounting” (Negative numbers are placed in parentheses), “Percentage” (A Percent sign is added, but no other formatting is done), “PercentageAdjust” (A Percent sign is added, and the number is multiplied by 100), or “Currency” (By default, the number is treated as an amount of US Dollars. See CurrencyType for other currencies).

**Name:** CurrencyType  
**Value:** If FormatType is set as “Currency” (either through a Style column, or in the Base Item), this will affect the currency type that is displayed. This will properly handle where the currency symbol is displayed (left or right of the number) as well as the actual symbol displayed. Possible values include:

- United States, Australia, Belgium, Brazil, Canada, Chile, China, China - Hong Kong, Colombia, Denmark, Finland, France, Germany, Ireland, Italy, Japan, Mexico, Netherlands, New Zealand, Norway, Portugal, Singapore, Spain, Sweden, Switzerland, Taiwan, United Kingdom

**Justification**

**Name:** VerticalJustification  
**Value:** The type of vertical Justification. Possible values include: “Top”, “Center”, and “Bottom”.

**Name:** HorizontalJustification  
**Value:** The type of horizontal Justification. Possible values include: “Left”, “Center”, and “Right”.

**Name:** ForcePage  
**Value:** If “true” this item will force a new page (assuming it is not the first row). If “false” it will not. This attribute can override values in the base item.
• **Borders, Foreground, and Background color**

**Borders**

Name: Border  
Value: The name of the border to include on the Base Item. Possible values include: "None" (Removes all borders. Borders can be added after), "Left", "Top", "Right", "Bottom", "RowTop" (Border added at the very top of the row), or "RowBottom" (Border added at the very bottom of the row).

**Colors** - Colors can be formatted as one of 8 predefined colors, or as RGB pairs, as described below.

**Foreground Color**

Name: TextColor  
Value: The Color to use for the Base Item text. Valid values are: "Black", "White", "Grey", "DkGrey", "LtGrey", "Blue", "Red", and "Green".

Name: TextColorR  
Name: TextColorG  
Name: TextColorB  
Value: The integer value from "0" to "255" for each of the three components of the text color (Red, Green, Blue).

**Background Color**

Name: BackColor  
Value: The color to use for the Base Item background. Valid values are: "Black", "White", "Grey", "DkGrey", "LtGrey", "Blue", "Red", and "Green".

Name: BackColorR  
Name: BackColorG  
Name: BackColorB  
Value: The integer value from "0" to "255" of the three components of the background color (Red, Green, Blue).
Style Column Handling

Name: BackColorSkipRows
Value: If “true”, the background color will only appear on even numbered rows.

Name: BackRowFill
Value: If “true”, the background color will fill the entire logical cell or the Base Item. If “false”, the background color will only fill the space immediately behind text.

• Preceeding and Trailing text

Name: PreceedingText
Value: The desired text, in quotes, to proceed the Base Items actual text.

Name: TrailingText
Value: The desired text, in quotes, to trail the Base Items actual text.

• Excluding Values

Name: Skip=True
Value: If “true”, the value displayed in that row will be excluded from the report display.
Style Column Example

To define a new style for each Report item, follow these steps.

1. Create and save a tab-separated lookup file (in this example, “styles_lookup.txt”), that includes:
   - One column for the Dimension you wish to format. The column header should be the name of the Dimension you are formatting, and column values should correspond to values in that Dimension.
   - A second column for the style formatting. The column header should be named something that indicates the purpose of the column (in this example, “Style”), with each value being the style required for the corresponding Dimension value. For example:

<table>
<thead>
<tr>
<th>Header Row</th>
<th>Sales Region</th>
<th>Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>Values</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Boston</td>
<td></td>
<td>FontFace=“Courier”,FontSize=“8”,FontStyle=“Italic”</td>
</tr>
<tr>
<td>North</td>
<td></td>
<td>HorizontalJustification=“Right”</td>
</tr>
<tr>
<td>Rhode Island</td>
<td></td>
<td>TextColor=“Blue”</td>
</tr>
<tr>
<td>South Shore</td>
<td></td>
<td>BackColor=“LtGrey”</td>
</tr>
<tr>
<td>Southwest</td>
<td></td>
<td>PreceedingText=“Sample preceeding text”</td>
</tr>
<tr>
<td>West</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In most cases, the Style Column will be built into the Model as an Info Field against the Dimension used to format the Report, or joined to the Dimension via a lookup file. Alternatively, it can be added as a calculated column, with the values concatenated together, or created as a User Defined Dimension.

2. Create a DivePlan (in this example, styles.dvp) that joins styles_lookup.txt to the desired Model via the common Dimension (in this case, Sales Region). For more information on joining a lookup to a Model, please refer to the DiveMaster manual.

3. Open the DivePlan in Diver.

4. Dive on the Dimension associated with your lookup. In this example, Sales Region.
5. If you wish to see the Styles column in the report (not typical, but useful to demonstrate these steps), add it to the Sales Region Tabular by double-clicking an empty column header and selecting it from the list of **Info Columns**.

![Sales Region Table](image)

6. Click the **Report** button, accept the default settings, and click **OK**.

7. Unlock the report.

8. Double-click a Dimension Value to open the Edit Item dialog.

9. Click the Style Tab.
10. In the **Style Column** pulldown, select the name of the column that contains the new style formatting for each Dimension item, in this case “Style”. Click **OK**.
Each value in the Sales Region column should now reflect the styles specified in styles_lookup.txt.

**Inserting Graphics Using a Secure URL**

Graphics with HTTPS addresses can be used in standard Diver Reports, for example:

https://www.companyname.com/graphics/logo.jpg

or

https://<servername>:<portnum>/graphics/logo.jpg
Diving Off MultiTab Subtotals in Reports

Diver and NetDiver allow you to dive from a subtotal in MultiTab Reports. To do so:

1. Create or open any MultiTab report that contains subtotals (for example, Indented 2 Level MultiTab)

2. Double-click the Dimension value to dive from. The example below shows a dive from the Sales Region “Boston”.

![Sales Region Table]

<table>
<thead>
<tr>
<th>Boston</th>
<th>Units</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boston Total</td>
<td>9,000,522</td>
<td>200,459,544.75</td>
</tr>
<tr>
<td>Buttermilk</td>
<td>1,515,657</td>
<td>32,177,540.67</td>
</tr>
<tr>
<td>Cheese</td>
<td>1,682,910</td>
<td>39,345,787.23</td>
</tr>
<tr>
<td>Cottage Cheese</td>
<td>195,000</td>
<td>3,984,579.24</td>
</tr>
<tr>
<td>Cream</td>
<td>557,577</td>
<td>11,993,775.68</td>
</tr>
<tr>
<td>Cream Cheese</td>
<td>124,478</td>
<td>2,540,367.32</td>
</tr>
<tr>
<td>Egg</td>
<td>496,063</td>
<td>9,742,575.66</td>
</tr>
<tr>
<td>Ice Cream</td>
<td>1,038,942</td>
<td>33,363,700.61</td>
</tr>
<tr>
<td>Milk</td>
<td>2,424,310</td>
<td>51,020,054.85</td>
</tr>
<tr>
<td>Yogurt</td>
<td>930,657</td>
<td>16,012,463.87</td>
</tr>
<tr>
<td>North</td>
<td>4,973,256</td>
<td>99,087,727.63</td>
</tr>
<tr>
<td>North Total</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buttermilk</td>
<td>717,655</td>
<td>15,074,848.65</td>
</tr>
<tr>
<td>Cheese</td>
<td>945,574</td>
<td>19,939,260.04</td>
</tr>
</tbody>
</table>
3. Notice the Console updates with dive arrows, indicating that a dive into any Dimension is now available. Dive on another Dimension.
The resulting Dive Window is displayed as a Tabular report.

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Units</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>2003/1</td>
<td>1,494,456</td>
<td>30,234,479.24</td>
</tr>
<tr>
<td>2003/2</td>
<td>1,591,190</td>
<td>32,277,317.59</td>
</tr>
<tr>
<td>2003/3</td>
<td>1,797,193</td>
<td>36,550,766.00</td>
</tr>
<tr>
<td>2003/4</td>
<td>1,780,775</td>
<td>36,054,066.39</td>
</tr>
<tr>
<td>2004/1</td>
<td>1,573,919</td>
<td>31,690,646.50</td>
</tr>
<tr>
<td>2004/2</td>
<td>1,603,290</td>
<td>33,652,246.00</td>
</tr>
<tr>
<td>Total</td>
<td>8,820,322</td>
<td>200,459,544.75</td>
</tr>
</tbody>
</table>

**Saving Report Templates**

Once a Report has been created and formatted, the formatting can be saved in a Report Template by selecting **File > Save Report Template**. Report Template files use the extension `.rep`.

The Report Template does not save dive steps or data, just the set of Report formatting instructions.

To save the actual Report window rather than just the formatting information, select **File > Save Marker**. More information is available under **Saving a Marker on page 3-7**.
Using a Saved Report Template

If a Report has previously been defined, and its Report Template saved, this Template can be used to create a Report from a different dive. The Report Template can be selected by clicking the **Load Template** button on the bottom left side of the Default Report dialog box. The resulting window is displayed below:

![Image of Open File window]

When a Report Template is selected, the **This Dive:** area indicates the properties of the current dive. The **Selected Report:** area shows the type of window, the number of Breaklevels, Summaries, and Info Fields in that Report, and indicates whether it is compatible with the current dive.

In order to be Compatible, the current dive and the Report Template must have the same number of Dimensions.

- If a Report Template is listed as **Mostly Compatible** with the current dive, Diver allows you to use the Template even though it does not have the same number of Summaries or the same number of Info Fields. However, Reports that are mostly compatible may look different because the data does not fully match. Summaries may not be displayed because there are not enough items for them in the Template, or Info Fields may display at the wrong Breaklevel because the Template was constructed with Info Fields based on Dimensions at different Breaklevels.

- A Report Template will be listed as **Partially Compatible** if it is derived from the same type of tabular (plain Tabular, CrossTab, MultiTab, etc.) but has a different number of Dimensions than the current dive. You may need to select a different Template if the current dive contains more Dimensions than the selected template.
Editing Report Styles

Report Styles are a group of item formats used to give a uniform look to a Report. These differ from column styles in that Report Styles apply to a group of items, while Column Style refers to a specific item within a specific column. When the current Dive Window is displayed as a Report, the style of any item within that Report can be edited. All items that use the same style will have identical formatting including font, size, color, spacing, alignment (justification), and top and bottom lines. Editing the Report Style only applies to the current dive, and settings are stored in the Marker file.

To edit a Report Style:

1. Select Edit > Report Style to open the Style dialog box. This option will only be active if a Report is currently being displayed.

2. Select the Style to edit and click Modify to open the Style Editor dialog box shown below.

When the Style Editor dialog box appears, specify the formatting choices for the selected item by using the check boxes, radio buttons, and text boxes for each edit. The Fonts and Color buttons open dialog boxes that allow you to select a different font or color. Click OK to return to the Style Editor dialog box. Click the Close button to close the Style dialog box and update the Report with the style changes.
To create a new style, click the Add button in the Style dialog box. The Style Editor opens, allowing you to choose a name for the new style, and to set the format options as you would when editing an existing style.

Style changes apply only to the current Report. You can save the Report, complete with the new styles. Any new Report view will have the default styles. The current dive will as well, if you switch to another display mode and then back to a Report.

The new style will be available for use in any report in the current Diver session, however, Report Styles can not be saved for use in future Diver sessions.
QuickViews are a Diver feature that provide different ways to filter and display data in the current Dive Window. QuickViews are presented to users as picklists, pulldowns, and comboboxes.

Diver supports the following types of QuickViews:

- Dimension QuickView
- DiveBook QuickView
- List QuickView
- Free Entry QuickView

In addition to the above, Diver enables you to create and save a set of eligible QuickViews in a file that you can apply to future dives.

QuickViews provide you with instant access to several Dimensions at once in a Dive Window enabling you to make multiple selections before displaying the final result. QuickViews let you “design” a Dive Window with flexible options for filtering and displaying your data. Further, once created, you can save a QuickView in a Marker for future use or convert the Dive Window into a report.

Administrators can use QuickViews to simplify and control access and management of information displayed in a window by configuring pre-defined screen options for specific users or groups of users.

Using QuickViews to Enhance the Diving Experience

Diving is the practice of using a Console populated with Dimensions (or Dimensions grouped into Categories) to filter and display the data contained in a Model. The figure below shows an expanded Console for a Sales Model.
Using QuickViews to Enhance the Diving Experience

Create a Marker without QuickViews

The down arrows next to the Dimensions in the above figure indicate that the Dimensions are enabled for diving. As an example, you have been asked to create a quarterly report for the VP of Sales that tracks wine sales by Case and Revenue for Sales Team and Sales Manager.

To create this report, you need to dive into the data for your Model (e.g., Sales 2 Years) and create a Marker that will produce the expected results.

Create a Marker without QuickViews

You have a rough idea of how to create the sales report for the VP. First, you open the “Sales 2 Years” Model and complete the following steps:

1. If desired, expand the Time, Customers, Company, and Product Categories in the Console so that you can view all Dimensions.
2. Double-click “Sales Team” to open the first Dive Window as shown below:

Note that “Sales Team” is the Parent Dimension.

3. To add the Sales Manager Dimension to the Dive Window, select “Team Alpha” and double-click “Sales Manager”. The Dive Window appears below:
The Dive Window above is known as a “cascading” dive where Sales Team is the “parent” window and Sales Manager is the “child” window. Stated differently, the data displayed in the child window is dependent on the value selected in the parent window. So, for example, if you change the Dimension value in the parent from “Team Alpha” to “Team Beta”, the child window “refreshes” with values belonging to “Team Beta”.

4. To introduce the time element to the analysis, select “Benett, Keith” in the child window and double-click “Ship Quarter” to add another window to the cascade dive.
The VP is only interested in looking at the Cases and Revenue numbers by Ship Quarter for the members of his Sales Team.

5. Right-click in one of the Dive Windows and choose “Select Columns” to open a dialog. Double-click Bottles, Decimal Cases, and Cost in the Selected panel, and click OK to display the following window:
To interpret the results in the final Dive Window, you have to look back at the cascading windows or the History section of the Console to know that the Cases and Revenue numbers are for Keith Benett, a Sales Manager for Team Alpha. You can also convert the final Dive Window to a report as shown in the following figure:

While informative, the final Dive Window is limited in scope because it only shows the sales results for a single Sales Manager. To expand the analysis and generate a more comprehensive view of the sales results for the VP, you need to employ Quickviews.
6. Save the final dive as a Marker (e.g., kbenett_sales), which you will use in the next topic.

Expand the Scope of a Dive with QuickViews

Continuing from the previous topic, you have created a Marker that provides the final format you are looking for, however, it represents a very limited view of your sales team performance. The QuickViews feature enables you to apply a single or a group of filters to alter the results in the final Dive Window. Instead of choosing a single Dimension value, you can pick one or more values in combination that provide a more robust and complete analysis of sales team performance.

Complete the following steps to apply the Marker created in the previous topic.

1. Open the Marker (e.g., kbenett_sales) created in the previous topic as shown below:
The above illustration also shows the conversion of the final Dive Window into a tabular report. Notice that the final Dive Window of Ship Quarter has Sales Manager and Sales Team as parents.
2. Right-click in the Ship Quarter window, and select **Convert Parents to QuickViews** to display the following:

As shown above, QuickViews enable you to dynamically populate the final Dive Window (showing Cases Sold and Revenue by Ship Quarter) for any combination of Sales Team and Sales Manager values, including “All Values”.

3. To enhance the format for management, click the **Report** icon and accept the Default Report settings by clicking **OK** to display the following figure:
4. In Report mode, the Sales Team and Sales Manager QuickViews are active and your choices will update the report totals shown in the above figure.

There are many different ways to enhance the above report before you forward it to the VP of Sales. See the Report Writing chapter for more information.

**Dimension QuickView Options**

You can add or edit a Dimension QuickView using the Edit Dimension QuickView dialog (i.e., Edit > Edit QuickViews > Add/Edit Dimension QuickView). An example of the Edit Dimension QuickView dialog appears below:
Note that the above figure shows that the dialog contains three separate panels for configuring a Dimension QuickView: Data, Display, and Behavior. The following topics will discuss the options present in each of the panels.

**The Data Panel**

The Data section of the Edit Dimension QuickView dialog contains a number of configuration options related to where the Dimension QuickView gets and manages its data. This panel contains the following options:

- Source
- Dimension
- Dependencies
- Population Order
- Limits
The **Source** field is a pulldown that offers the following selections: Standard, Model, and External. Depending on which option you choose, Diver may present other fields related to your choice. If you choose **Standard**, for example, Diver uses whichever Model is listed first in the Console as the data source for the QuickView.

If you choose **Model** as the source option, Diver presents a Model pulldown that enables you to specify any open Model or DivePlan file as the data source for the QuickView. Diver associates the QuickView with all new Dive Windows opened from the specified Model or DivePlan. If you close the specified Model or DivePlan, Diver closes any associated QuickViews.

If you choose **External** as the source option, Diver enables the Browse button which you can use to navigate to the desired Model or DivePlan.

The **Dimension** pulldown presents a list of Dimensions from the specified Model or DivePlan. If you selected External as the data source, Diver presents a Refresh button that repopulates the Dimension pulldown with Dimensions from the selected External data source.

Diver automatically populates the Name field with the name of the Dimension selected in the Dimension pulldown. You can edit the Name value.

Clicking the Edit **Dependencies** button opens a General dialog where you can configure a QuickView as “dependent” by moving it to the Selected panel. When using multiple QuickViews at a time, you can create a “dependency” so that the values available in a specified QuickView depend on the value you select in another QuickView (or Dive Window). Note that the Window pulldown is only available when “Standard” is specified as the data source.

Clicking the Edit **Population Order** button opens the Edit Population Order dialog that enables you to specify what values and in what order the values appear in the QuickView. You can, for example, toggle the “All Values” option on or off, and you can choose to sort Dimension values Up, Down, or skip entirely. Additionally, you can skip or specify whether Named Groups appear First or Last in the QuickView. If multiple Named Groups appear in the QuickView, the order of appearance in the DivePlan determines the presentation order in the QuickView. You cannot sort Named Groups Up or Down like Dimension values.

Clicking the Edit **Limits** button to open the Edit Quickview Limits dialog where you can include or exclude a Dimension value(s) in the QuickView. For an administrator, this feature enables you to customize what data a user can see with the QuickView. To remove limits, toggle off the Limit Values option.
The Display Panel

The Display section of the Edit Dimension QuickView dialog contains configuration options for how to display the QuickView in the Dive Window (i.e., a pulldown, picklist, or combobox) and how to label or name the QuickView. A pulldown QuickView enables you to select one Dimension value from a list. One of the options can be “All Values”. A picklist enables you to select one or more Dimension values from a clickable list. A combobox displays attributes of both a pulldown and picklist.

The Label Type pulldown provides three options for configuring the name of the QuickView in a Dive Window. Selecting “Dimension” inserts the name of the selected Dimension as the name of the QuickView and disregards whatever you have typed in the Name field. Selecting “Name” uses whatever text you have type in the Name field as the QuickView label. Selecting “None” modifies the QuickView so that it does not have a label.

The Behavior Panel

The Behavior section of the Edit Dimension QuickView dialog contains configuration options that control how the Dimension QuickView behaves when accessed in the Dive Window. The Activation pulldown, for example, has two options for activating the QuickView. Choosing “Selection Change” activates the QuickView whenever you make a value selection. The “Go Button” activates the QuickView after you select a value AND click the Go Button icon. For example, the Go Button is most useful when there are multiple QuickViews and you do not want the Dive Window to update before selecting a value in each of the QuickViews.

The Load Value pulldown contains the following options:

- **Saved** – loads the previously saved QuickView value(s) when you open the Marker.
- **First** – loads the first value in the QuickView regardless of what value was previously saved with the Marker.
- **Last** – loads the last value in the QuickView minus the optional offset. If you enter “1” for the offset, then Diver selects the QuickView value minus the offset of 1 (i.e., the QuickView value in the position before the last value). This option is useful in a Date Marker where the data in the current date may be incomplete.
- **Prompt Dialog** – displays a dialog that prompts you to select a QuickView value. Diver initializes the QuickView with the selected value.
- **Prompt Value** – displays a temporary label called “<Select a Value>” in the QuickView header. Once you select a value, Diver removes the “Select a Value” label.

The above options enable you to manage the values that are initially loaded for a Dimension QuickView when opened from a Marker.
The **Automatically associate with new Dive Windows** option, which is enabled by default, associates new Dive Windows with configured Dimension QuickViews. Uncheck this option if you wish to disassociate a Dive Window from any configured QuickViews.

**Creating a Dimension QuickView**

Use the Add/Edit QuickView dialog (**Edit > Edit QuickViews**) to create or modify a Dimension QuickView. This feature enables you to display or modify any Dimension in a Model or DivePlan as a QuickView in a Dive Window.

Complete the following steps to create a Dimension QuickView:

1. Open a Model or Marker. As an example, you might want to open the Marker created previously (e.g., kbenett_sales) as shown below:

![Image of a Dimension QuickView](image)

2. To add a new Dimension QuickView or edit one of the existing QuickViews, choose **Edit > Edit QuickViews** to display the following dialog:
Note that arrows in the above dialog point to the QuickViews that already exist in the Marker, plus the button you can click to add another Dimension QuickView.

3. Click **Add Dimension QuickView** to open the Edit Dimension QuickView dialog shown below:
See Dimension QuickView Options on page 7-10 for an overview of the different QuickView dialog options.

4. Select “Salesperson” from the Dimension pulldown, and click OK to add Salesperson to the Select QuickView list shown below:

5. Click Close to add the Salesperson QuickView to the header in the Dive Window as shown in the following figure:
6. To further filter the Cases and Revenue results shown above, select “Agate, Paul [001]” from the Salesperson pulldown to display the following Dive Window:
Creating a Dimension QuickView from a Tabular Window

The right-click or Context menu contains an option called “Convert to QuickView” that enables you to convert any tabular window in a Dive into a Dimension QuickView. Diver associates any QuickViews created using this option with other QuickViews and any open child or parent Dive Windows.

Complete the following steps to create a Dimension QuickView:

1. Open a Model. This example uses sales_2.mdl as shown below:

2. Dive on Company > Sales Team to open the following Dive Window:
3. Select “Team Alpha” and dive on **Company > Sales Manager** as shown next:
4. As shown in the previous figure, right-click in the Sales Manager window and select **Convert to QuickView** to open the Edit Dimension QuickView as shown below:
Notice that Diver automatically populates the Dimension QuickView dialog with default selections for the Sales Manager Dimension.

5. Click OK to create the Sales Manager QuickView as shown in the following Dive Window:
Note that the History section of the Console in the above figure uses a pulldown icon to identify the Sales Manager as a QuickView with “All Values” selected. Also, because Sales Team is positioned after the Sales Manager QuickView, it indicates that the Sales Team Dive Window is dependent on the values selected in the Sales Manager QuickView.
DiveBook QuickView Options

You can add or edit a DiveBook QuickView using the Edit DiveBook QuickView dialog (i.e., Edit > Edit QuickViews > Add/Edit DiveBook QuickView). There are two types of DiveBook QuickViews: DiveBook Area and DiveBook Topic. This dialog enables you to convert a DiveBook Area or Topic into a QuickView. An example of the Edit DiveBook QuickView dialog with default values appears below:

![Edit DiveBook QuickView dialog](image)

Depending on whether you choose “DiveBook Area” or “DiveBook Topic” as the DiveBook type, Diver defaults the Name to “Area” or “Topic”. You can manually overwrite the default value. You can create a DiveBook Area QuickView independently of a DiveBook Topic QuickView, however, it is a best practice to create DiveBook QuickViews in pairs to maintain the Area and Topic relationship. Additionally, set the Activation field to “Go Button” for the Topic QuickView so that you can make selections in both the DiveBook Area and Topic QuickViews before activation. If you select a DiveBook Area first, the Topic QuickView updates with the topics specific to that Area.

The **Type** pulldown enables you to choose either a DiveBook Area or Topic as the QuickView type. The **Display Type** pulldown enables you to configure the DiveBook QuickView as a pulldown (i.e., can only select a single QuickView value, including “All Values”) or a picklist (i.e., select one or more QuickView values).

Click the **Browse** button to locate a DiveBook file. Once selected, the name of the DiveBook displays in the DiveBook field.

See **The Behavior Panel on page 7-13** for a description of the Activation and Load fields.
Creating a DiveBook QuickView

Diver enables you to convert elements of a DiveBook (i.e., both the Area and Topic) into QuickViews. Use the Add/Edit QuickView dialog (Edit > Edit QuickViews) to create or modify a DiveBook QuickView.

You might, for example, create a DiveBook QuickView to simplify access to reports that might otherwise be stored in a DiveBook Area.

Complete the following steps to create a DiveBook QuickView that allows you to switch between reports without going back to a DiveBook:

1. Open a DiveBook, such as demo_drs.dbk (see sample tutorial data).
2. Click Edit > Modify DiveBook to open the following dialog.

As shown above, select the Reports Area and click the Up Arrow to move Reports content to the top of the Area list. Note that the Reports Area contains two Topics that you reference frequently in your job. Using the DiveBook QuickView feature, you can convert the Topics into QuickView values available in a pulldown from a Dive Window.
3. Once you have moved Reports to the top of the Areas list, click **OK** to save the position change. When prompted to “Save Changed DiveBook?”*, click **Yes** and then **Save**. If prompted to overwrite demo_drs.dbk, click **OK**. (We will not save the DiveBook when finished with this example.)

4. Click the DiveBook icon in the toolbar to open the following figure:

![DiveBook Select](image)

Note that the Reports Area now appears at the top of the list.

5. Double-click **Revenue** to open the following Dive Window:
Using the DiveBook QuickView feature, you can convert the Reports Topics into QuickView values available from a Dive Window.

6. To create the DiveBook QuickView, click Edit > Add QuickViews to open the Edit QuickViews dialog.

7. Click the Add DiveBook QuickView button as shown in the following figure:
8. Enter the following values in the Edit DiveBook QuickView dialog:

   **Name** – Reports
   **Type** – DiveBook Topic
   **DiveBook** – <path>\demo_drs.dbk

   The following figure shows the populated dialog:
9. Click **OK** to add “Reports” to the Select QuickView list, and click **Close** to add the DiveBook QuickView to the Dive Window as shown below:
10. In the QuickView pulldown, click **Cost of Product by Quarter** to display that report in Dive Window as shown below:

![QuickView Example](image)

As shown above, a DiveBook QuickView enables you to directly open multiple topics without going back and forth to a DiveBook.

**List QuickView Options**

You can add or edit a List QuickView using the Edit Dimension QuickView dialog (i.e., **Edit > Edit QuickViews > Add/Edit List QuickView**). The List QuickView enables users to define the values contained in a QuickView. You can, for example, manually enter values in the List Values text box, or configure the QuickView to use a .txt file that contains the values. An example of the Edit List QuickView dialog appears below:
List QuickView Options  

Creating a DiveBook QuickView

Note that the above figure shows that the dialog contains three separate panels for configuring a List QuickView: Values, Display, and Behavior. See The Display Panel on page 7-13 and The Behavior Panel on page 7-13 for descriptions of the Display Type, Activation, and Load Value fields.

By default, Diver enables the List Values field so that you can manually enter the desired QuickView values in the provided text box. Additionally, for manually entered or values contained in a .txt file, you can check the Include All Values field to add the “All Values” option to the List QuickView. To insert values into the QuickView from a stored .txt file, click the Values File field and the Browse button to navigate to the file. Note that if you update the values in a text file used by a List QuickView, Diver will automatically update any Markers that contain the List QuickView.

Diver does not automatically populate the Name field for a List QuickView as it does with a Dimension or DiveBook QuickView. When you create a List QuickView, be sure to enter a name. Also, when deciding on a Name, be aware that the Edit Window Info dialog will not display a List QuickView name that does not coincide with a Model Dimension for that Dive Window.
Creating a List QuickView

A List QuickView allows you to specify a list of values for the QuickView, rather than using the values contained in a Model. You might, for example, use a List QuickView to drive calculations in columns that are based on parameters. The example in this topic populates a new column called “Revenue times Delta” using a List QuickView with a set of numbers (e.g., 0.25, 0.5, etc.)

Use the Add/Edit QuickView dialog (Edit > Edit QuickViews) to create or modify a List QuickView.

Complete the following steps to create a List QuickView:

1. Open a Model or Marker. As an example, open a “Sales 2 Year” Model as shown below:

2. As shown above, Dive on the Sales Team and Sales Manager Dimensions to display a Dive Window similar to the following:
Note that the final Dive Window has column headings that are not needed.

3. Right-click in the Dive Window and choose “Select Columns” to open the Select Columns dialog.

4. Leave “Revenue” in the Selected panel and move all of the other columns to “Available” as shown below:
5. Click OK to display the final Dive Window with only the Revenue column visible:

6. Click Edit > Add QuickViews to open the Edit QuickViews dialog.

7. Click the Add List QuickView button to open the Edit List QuickView dialog as shown next:
8. Type “Delta” in the Name field and the following values in the List Values box: 0.25, 0.5, 0.75, 1, and 1.25.
9. Click **OK** to display the Edit QuickViews dialog.

10. Click **Close** to display the List QuickView in the header of the Dive Window as shown next:
11. Right-click in the above window, and choose “Add Column” to open the Add Column dialog.

12. Type “Revenue times Delta” in the Name field, and enter the following calculation in the Definition field:

\[ \text{Total [Revenue]} \times $(\Delta) \]

The Add Column dialog appears as follows:
13. Click **OK** to display the following Dive Window:
Note that the values displayed in the “Revenue times Delta” column equal the value in the Delta List QuickView times the Revenue value.

14. Choose **File > Save Marker** to save the file (e.g., list_qv_example).

**Free Entry QuickView Options**

You can add or edit a Free Entry QuickView using the Edit Dimension QuickView dialog (i.e., **Edit > Edit QuickViews > Add/Edit Free Entry QuickView**). The Free Entry QuickView enables users to define a Default Value for the QuickView that Diver can use as a parameter in column calculations. The Free Entry QuickView can be used for test values or to facilitate “What-If” types of analysis.

An example of the Free Entry QuickView dialog appears next:
Creating a Free Entry QuickView

A Free Entry QuickView allows the end user to manually enter a QuickView value(s). Similar to the List QuickView, this type of QuickView enables you to drive calculations in columns that are based on parameters. A Free Entry QuickView is especially useful for “What If” types of analysis. You can enter a default value that always appears in the QuickView or manually enter different values while in a Dive Window. As an example, open the Marker saved in the previous topic (e.g., list_qv_example) and add a new column that calculates your state tax (as the default) using the QuickView. The example populates a new column called “Revenue plus Tax” using a Free Entry QuickView with a default value of 0.05 (i.e., your state tax).

Complete the following steps to create a Free Entry QuickView:

1. Open the Marker created in the following topic (i.e., list_qv_example) as shown below:
2. Click **Edit > Edit QuickViews** to open the Edit QuickViews dialog.

3. Click the **Add Free Entry QuickView** button to open the Edit Free Entry QuickView dialog as shown next:
Note that the above figure contains the values entered in Step 4 below.

4. Type “Tax” in the Name field and the following value in the Default Value field: 0.05.

5. Click **OK** to display the Edit QuickViews dialog.

6. Click **Close** to display the Free Entry QuickView in the header of the Dive Window as shown next:
7. Right-click in the empty column header space, and choose “Add Column” to open the Add Column dialog.

8. Type “Tax on Revenue” in the Name field, and enter the following calculation in the Definition field:

   \( \text{Total [Revenue]} \times $(\text{Tax}) \)

   The Add Column dialog appears as follows:
9. Click **OK** to display the following Dive Window:
10. To see what the Tax expense would be if the Tax Rate were 7%, type “.07” in the Tax QuickView field, and click GO to display the following Dive Window:
11. Choose **File > Save Marker** to save the file (e.g., free_entry_qv_example).

### Creating a QuickView Set

A QuickView Set file (.qvs) allows you to store related QuickViews in a file for later use. Similar to a template-type of file, any Markers you save that refer to the QuickView Set file, will automatically inherit any changes you make to the QuickViews held in the QuickView Set file. QuickView Sets can expedite the creation of new reports.

You can save the following types of QuickViews in a QuickView Set file:

- External Model QuickViews
- List QuickViews
- DiveBook QuickViews

If a Time Series QuickView is present when you save a Marker that contains a QuickView Set file, that QuickView will also be saved and appear in the order defined in the Marker. However, the Time Series QuickView will not be saved in the QuickView Set file. QuickView Sets contain QuickView “order objects” (i.e., just like Markers) that preserve the presentation order of the QuickViews in the set.
As an example of how to create and apply a QuickView Set, use the Sales 2 Years Model and complete the following steps:

1. Open the Sales 2 Yrs Model.

2. Dive on **Company > Sales Team** to open the following Dive Window:

3. Select “Team Alpha”, and dive on **Time > Ship Year** to display the following:

4. Select “2014” as the Ship Year value, and dive on **Time > Ship Month** to display the following:
5. Select “2014-01” as the Ship Month value, and dive on **Product > Product Class** to display the following:
6. Right-click in the Dive Window and select **Convert Parents to QuickViews** to display the following:
7. Choose **Edit > Edit QuickViews** to open the following dialog:

8. Select “Sales Team”, and click the **Edit** button to open the Edit QuickView dialog shown next:
9. Make the following changes to the Edit Dimension QuickView dialog: (a) Change the Data Source to “External”; (b) Update the Model field to “/Franklin Dist/sales_2y.dvp”; (c) Select the “Go Button” in the Activation pulldown.

10. Click **OK** to display the following:
11. Repeat Steps 8-10 for the Ship Year and Ship Month QuickViews.

12. Click **Close** after you update the Ship Month QuickView to display the following Dive Window:
13. Choose **File > Save QuickView Set** and enter a name (e.g., QVSet_Ex.qvs).

14. Close any open Models and open the Sales 2 Years topic.

15. Select **File > Open** and open the saved QuickView Set file as shown below:

Note that if Diver does not populate the QuickViews (as shown above), select “populating” from one of the pulldowns.

16. Dive on **Company > Sales Manager** to display the following Dive Window:
Creating a QuickView Set

To change the filtering, select a different combination of QuickView values and click **GO**. Diver will store the above QuickView Set with the Marker. Note that you cannot have a Marker use QuickViews from more than one QuickView Set.

Additionally, you can change one or more QuickView values and Diver will recalculate row values based on the existing combination of all QuickView values in the set (if you do not break the logical dependency between QuickViews). For example, in the above figure, you can choose an individual Sales Team value (e.g., Team Alpha), click **GO**, then Diver will recalculate row values based on the following pairs: Sales Team: Team Alpha, Ship Year: 2014, and Ship Month: 2014-01. However, if you change the Ship Year value to “2013”, then Diver recalculates row values as follows: Sales Team: Team Alpha, Ship Year: 2013, and Ship Month: All Values. Because a Ship Month of “2014-01” is invalid for a Ship Year of “2013”, Diver resets the Ship Month to “All Values” (i.e., Ship Month value is dependent on Ship Year selection.)

**Edit QuickView Options**

The Edit QuickView Options dialog enables you to add/edit and manage QuickView options for a Dive Window. Clicking the **Edit > Add/Edit QuickViews** option in a Dive Window, for example, may open a dialog similar to the following:
Note that the above example contains a number of QuickViews created in prior topics: Sales Team, Ship Year, and Ship Month are Dimension QuickViews. Area and Topic are DiveBook QuickViews.

The buttons that appear on the right-hand side of the dialog enable you to do the following:

- **Add Dimension QuickView** – opens a new dialog that enables you to configure a Dimension QuickView. For more information, see *Creating a Dimension QuickView on page 7-14.*
- **Add DiveBook QuickView** – opens a new dialog that enables you to configure a DiveBook QuickView. For more information, see *Creating a DiveBook QuickView on page 7-24.*
- **Add List QuickView** – opens a new dialog that enables you to configure a List QuickView. For more information, see *Creating a List QuickView on page 7-31.*
- **Add Free Entry QuickView** – opens a new dialog that enables you to configure a Free Entry QuickView. For more information, see *Creating a Free Entry QuickView on page 7-39.*
The Edit button becomes active whenever you select a QuickView name in the Select QuickView text box. Clicking **Edit** opens a dialog that enables you to update the selected QuickView. The **Delete** button, when active, enables you to delete the selected QuickView. The **Move Up** and **Move Down** buttons enable you change the position of a selected QuickView within the Select QuickView list. Click **Close** to close the Edit QuickView dialog.

Click the **Auto-Set Top-to-bottom Dependencies** button to automatically set dependencies for listed QuickViews from the least to the most dependent. Diver then sets QuickView dependencies from top to bottom, with the first QuickView in the list having no dependencies and the last QuickView dependent on all prior QuickViews.

Check the **Picklist Width** field to configure the default size (in pixels) for all QuickViews you create with a picklist display type. Enter the default width of the picklist in the Pixels field.

Enabled by default, the **Optimize Dive Order** field enhances the speed in which Diver processes QuickViews. In some instances, an administrator or power user may wish to disable this option.

### Building a Report from a Dive Window using QuickViews

The VP of Sales at Acme company has asked the IT department to give him a report that tracks Salesperson performance specific to Decimal Cases sold and Revenue generated over a period of time. The IT manager passes the assignment to his DI Administrator.

This topic starts with a Two-Year Sales Model dive on Sales Team, adds Dive Windows that are converted to QuickViews, and ends with an Indented 2 Level MultiTab report that highlights Salesperson performance using Decimal Cases and Revenue Summary Columns.

The figure below shows the initial Dive Window after a dive on **Company > Sales Team**:

![Initial Dive Window](image)
The following figure shows how the Console appears after the initial dive on Sales Team:

By looking at the History section of the Console, you can see that the initial Dive Window is a Marker with a single dive on the Sales Team Dimension.

Notice that the initial Dive Window contains both the Decimal Cases and Revenue Summary Columns that are part of what the VP of Sales wants to study. However, the initial Dive Window does not display the data in a format that is optimized for analysis. The VP wants to view revenue and cases sold results by Salesperson within Sales Manager with the added value of filtering the results by selected time periods (i.e., Ship Year and Ship Month). Finally, it is important to the VP to output the results in the final Dive Window using a report template.

To accomplish the above goals, the DI Administrator responsible for generating Markers within the organization must design a final Dive Window that meets the business need by completing the following steps:

1. Using Diver, open the “Sales 2 Years” Marker using File > Open. Alternatively, the Marker could reside as a topic in a DiveBook.

   The opened Marker displays a single dive on the Sales Team Dimension. From here, it is important to understand the dive steps required to satisfy the request made by the VP of Sales. The final Dive Window should appear similar to the following Dive Window:
Notice that the final Dive Window above contains the following pulldown QuickViews in the header of the page: Sales Team, Ship Year, and Ship Month. The tabular contains two Dimensions as column headers, Sales Manager and Salesperson, and two Summaries, Revenue and Decimal Cases.

The History section of the Console should look similar to the following figure after you reach the final Dive Window:
2. To construct the final Dive Window with Cascading QuickViews, start by removing the Summary Columns that are not needed by the VP. Right-click in the Dive Window and choose “Select Columns”.

3. From the Select Columns dialog, move Cases, Bottles, and Cost to the Available panel. In the Selected panel, move Revenue before Decimal Cases, and click OK. The Dive Window is shown below:
4. At this point, Sales Team is the first Parent Dimension in the Dive. To create the second Parent Dimension, select “Team Alpha” in the Sales Team column and “Ship Year” (in the Time category) as the second Parent Dimension in the Console. Dive on “Ship Year”. The Dive Window is shown below:

5. To create the next parent in the Dive, select “2013” and select “Ship Month” (in the Time category) as the third Parent Dimension in the Console. The Dive Window is shown below:
6. Before converting the Parent Dimensions into a Cascading QuickView, select a “Ship Month” (e.g., 2013-01) then Dive on “Sales Manager” within the Company category.

This is the final step before you create the Cascading QuickView. The Dive Window is shown below:
You have now built a foundation where you can convert the Parent Dimensions shown in the above figure into a Cascading QuickView of Sales Team, Ship Year, and Ship Month. The pulldown QuickViews give you flexibility to view Revenue and Decimal Cases results for Sales Managers and their Salespersons for any combination of QuickView values. You have also laid the foundation to build out the final Dive Window by creating a MultiTab that can be converted to a report.

7. To convert the Parent Dimensions into QuickViews, right-click in the last Dive Window and select “Convert Parents to QuickViews” to create the following Dive Window:
Notice that Diver converts the Parent Dimensions for the Dive Window shown in Step 6 into a set of QuickView pulldowns. The VP can now select any combination of QuickView values to view Revenue and Decimal Cases results for a group of Sales Managers. Go to Step 8 to expand the Dive Window to include the analysis of Salespersons reporting to their respective managers.

8. Click the MultiTab icon in the toolbar and then dive on “Salesperson” in the Console to create the following Dive Window:
9. After diving on “Salesperson”, select the “Revenue” column and “Sort Down” to create the final Dive Window as shown below:
The above Dive Window displays sorted Revenue results for Sales Managers and Salespersons on Team Alpha for January 2013. To expand the analysis to include “all” Sales Teams, Ship Years and Months, use your QuickViews as shown in Step 10.

10. For each QuickView, select “All Values” to generate the Dive Window shown below:
Note that the Ship Month has a total of 17 months for “All Values” because the Model only contains data for the first five months of 2014. The figure below is a picture of the Console before converting the MultiTab to a report:
Go to Step 11 for instructions on converting the final Dive Window into a report format.

11. Click the Report icon in the toolbar to open the Default Report dialog shown in the following figure:
12. Click **OK** to convert the final Dive Window into an Indented 2 Level MultiTab report as shown in the following figure:
Using the QVVal Function in Advanced Find

Diver enables you to use a QuickView value in an Advanced Find string. The QVVAL function will accept the name of a QuickView and then use the current value of that QuickView when processing the find. The QVVal button appears in the Advanced Find dialog as shown below:

Notice that the report provides a more readable format than the final Dive Window, including indenting Salesperson under Sales Manager and subtotaling. Be sure to enable the “Include Parent Info” option.
The following procedure provides two examples of using the QVVAL function to filter the results in a Dive Window using different QuickView values. This procedure uses the Sales_2.mdl.

Complete the following steps:

1. Open the Sales-2 Model.
2. Dive on **Company > Sales Team** to open a Dive Window similar to the following:
3. Select “Team Alpha” and choose **Company > Sales Manager** to open the following Dive Window:
4. Select “Bennett, Keith” and choose **Company** > **Salesperson**.

5. Next, select a Salesperson and choose **Product** > **Product Class** to open the following Dive Window:
6. To deepen the analysis, right-click in the Product Class window and click **Convert Parents to QuickViews** to display the following Dive Window:
Notice that this step converts the three Parent windows into QuickViews in the Dive Window. To deepen the analysis, add a Free Entry QuickView named “Beer” with a default value of <Insert>.

7. Choose Edit > Edit QuickViews to open the Edit QuickViews dialog shown next:
8. Click the **Add Free Entry QuickView** to open the Edit Free Entry QuickView dialog. Enter “Beer” in the Name field and “5000” in the Default Value field as shown below:
9. Click OK and then Close to add the Free Entry QuickView to the Dive Window as shown in the following figure:

![Dive Window with QuickViews](image)

Note that Dimension and the Free Entry QuickViews provide a number of options for viewing and filtering data in the final Dive Window. To further refine the analysis and illustrate the power of using the QVVAL function, continue to Step 10.

10. Click the Find icon to open the “Find String in Product Class” dialog.

11. Click the Advanced Find button to open the Advanced Find dialog.

12. Click the QVVal button to insert the function into the Find text box as shown in the following figure:
13. Enter the name of the Free Entry QuickView created in Step 9 (i.e., Beer) between the parentheses in the QVVal string as shown below:
You need to create an expression using the QVVal function and the QuickView name/value pair to further filter results in the Dive Window. For example, you might configure the following expression to have the Dive Window display Revenue values for a Salesperson that are greater than or equal to $100,000:

\[
\text{Revenue} \geq \text{QVVal(Beer)}
\]

14. Enter the expression from Step 13 into the Find field as shown below:

15. Click the **Find All** button to display the following Dive Window results:

What did we find out? Is this Dive Window different than the results shown in Step 9? What did we expect? Notice that the Dive results have not changed because all of the values in the Revenue column exceeded the “5000” value for the Beer QuickView and QVVal expression.
16. Enter “50000” into the Beer QuickView and review the results below:

Note that the revenue numbers for both Beer and Non Alcoholic were less than the “50,000” threshold and omitted from the final Dive Window.

The final Dive Window reflects the following QuickView choices as shown in the Console above:

- QuickView 1 (Sales Team); QuickView Value (Team Alpha)
- QuickView 2 (Sales Manager); QuickView Value (Bennett, Keith)
- QuickView 3 (Salesperson); QuickView Value (Agate, Paul)
- QuickView 4 (Beer); QuickView Value (50000)

The following figure shows the interrelationship between the QuickViews, the QVVal find, and the final Dive results in Steps 15 and 16:
Building a Report from a Dive Window using QuickViews

Using the QVVal Function in Advanced Find

<table>
<thead>
<tr>
<th>QV1</th>
<th>QV2</th>
<th>QV3</th>
<th>QV4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: Sales Team</td>
<td>Name: Sales Manager</td>
<td>Name: Salespersons</td>
<td>Name: Beer</td>
</tr>
<tr>
<td>Dependency: None</td>
<td>Dependency: QV1</td>
<td>Dependency: QV1/QV2</td>
<td>Dependency: QV1/QV2/QV3</td>
</tr>
<tr>
<td>Type: Dimension</td>
<td>Type: Dimension</td>
<td>Type: Dimension</td>
<td>Type: Free Entry</td>
</tr>
</tbody>
</table>

Advanced Find Search String:

Revenue >= QVVal(Beer)
Chapter 8
DiveBooks

A DiveBook is like a file drawer with folders that organizes various types of Reports and Model sets so that they are easier to locate and to access quickly.

DI-Diver may be set to open a DiveBook as soon as you start the software, by setting a Default DiveBook in the Preferences dialog box (see Setting Default File Preferences (DI-Diver Only) on page 13-14). ProDiver can be set to automatically open a DiveBook by an administrator, using the DiveLine administrator tools.

Opening a DiveBook

If Diver is not set to open a DiveBook automatically, you can open one.

1. Select Window > DiveBook, or click on the DiveBook button in the toolbar to launch the Open DiveBook dialog box. The pulldown menu labeled Files of type will already be set to DiveBook Files (*.dbk).

![Open DiveBook dialog box](image-url)
Selecting DiveBook Areas and Topics

A DiveBook allows Reports and files to be arranged into categories called **Areas** and **Topics**. **Areas** are similar to folders, in which you can store data in the chosen format. The Areas list in the DiveBook below includes Tabulars, Charts, and Reports. Within each Area, **Topics** contains a list of the saved files. These names can be modified as needed (see the next section for details).

1. Select an **Area** by clicking on it once.

2. Find the desired DiveBook in the list, highlight it, and click the **Open** button. No other file types are available from the Open DiveBook dialog box. To open other file types, use the **File > Open** menu option.
2. Select a Topic within the Area, and click **OK**.

Topics may contain Markers, DivePlans, other DiveBooks, or links to other files. They are Area-specific. If a new Area is selected, a corresponding list of Topics will be displayed in the DiveBook window.

Each time a Marker or DivePlan Topic is opened from a DiveBook, the associated Model appears in the Console. To return to the DiveBook, click the DiveBook button in the toolbar.

From the DiveBook you can continue opening other Markers and DivePlans, or dive further into the data to retrieve more detailed information.

**Viewing Topic Info**

In the DiveBook, if a Marker Topic that contains a comment is selected, information about the Marker will appear in the gray area labeled **Topic Info** at the bottom of the dialog, as shown in the graphic below:
Creating a DiveBook

If you wish to create a new DiveBook, rather than open an existing one, you may do so with the following steps:

1. Select **Window > DiveBook**, or click on the DiveBook button in the toolbar to launch the Open DiveBook dialog box.

2. Click the New button in the upper right corner of the dialog box to create a new DiveBook.

3. Click **OK** and close the new empty DiveBook.

Proceed to the next section, **Modifying a DiveBook** to add details and content to the new DiveBook.

Modifying a DiveBook

The **Edit > Modify DiveBook...** command opens a dialog box that allows you to change the current DiveBook. This menu option is deactivated (grayed out) if no DiveBook is open. The Modify DiveBook dialog box is shown below:
Using the Title and Graphic Dialog

In the Modify DiveBook dialog box, you can add up to three lines of **Title** text. The text in the Title area will autowrap accordingly.

There is also a section titled **DiveBook Image** that allows you to add a custom bitmap image to the DiveBook. To add and configure an image:

1. Click the **Add Bitmap...** button to browse to the desired image.

2. Specify the size of the graphic using the **Fixed Size** check box.

   The graphic size should be set in an external graphics editing program when using the Fixed Size option, to a maximum of 110 pixels wide and 99 pixels tall. If the Fixed Size check box is unchecked, the graphic will be stretched to the maximum size of 110 x 99. A hidden graphic will not seem to be hidden until the DiveBook is saved and redisplayed.

3. Hide the graphic using the **Hide Bitmap** check box, as shown in the image above.
4. Click **Default Bitmap** button to revert to the default DiveBook graphic (dive buoy).

**Using the Areas Dialog**

As previously described, the **Areas** list shows the Areas contained within the DiveBook. Areas are like folders or general subject headings; specific Topics are stored within them. Selecting an Area in the **Areas** list displays the Topics belonging to that Area.

**Adding a DiveBook Area**

1. Click **Add...** to open the New Area Name: dialog box.

![New Area Name dialog box]

2. Enter the name for a new Area, and click **OK**.

**Reordering DiveBook Areas**

The buttons to the right of the Areas column allow you to reorder the Areas. The currently selected Area can be moved by clicking the **Up** or **Down** arrow buttons. See the Modify DiveBook dialog on the previous page.

**Renaming a DiveBook Area**

To rename an Area:

1. Select the Area to be changed.
2. Click **Edit...**
3. Type the new name in the text box.
4. Click **OK** to accept the new name.

**Deleting a DiveBook Area**

Clicking the **Delete** button removes the currently selected Area. Care must be taken when deleting Areas, as all Topics within the Area will also be removed from the DiveBook.
Using the Topics Dialog

The Topics list shows the Topics contained in the currently selected Area. Topics can be Markers, DivePlans, other DiveBooks, or Links. When a topic is saved, you can choose to add it to an open DiveBook; or, if no DiveBook is open, you have the option of opening one. Topic names are not subject to the same length restrictions as filenames.

Adding a DiveBook Topic

To Add a Topic to a DiveBook, save a Marker (when a DiveBook is open), by selecting the Save Marker > To DiveBook... File menu option.

When a Marker is created and saved to the DiveBook as a new Topic, Topic Info, or information about what the Marker is showing, can be added by clicking the Options in the Store Marker in DiveBook dialog box, and entering text into the Marker Info area.

Adding Topic Links

The Add Link... button allows you to create a DiveBook Topic that is a link to a file or a URL. The file may be an HTML file, a PDF file, a DivePlan, a Marker, or another DiveBook. When that Topic is selected, Diver opens the file and displays its contents through Diver, through the default Web browser, or through another application local to the client.

To add a link to a DiveBook:

1. Create a new DiveBook, or open an existing DiveBook.
2. Select Edit > Modify DiveBook.
3. Click the Add Link... button to open the Add DiveBook Link dialog box:

Select the name of the Topic Area to which the link should belong, enter the Topic Name of the link (the name that will appear in the DiveBook), and the path and name of the file or the URL being linked (use the Browse... button to find the file, if desired).
Reordering, Renaming, and Deleting DiveBook Topics

- The buttons to the right of the Topics column allow you to reorder the Topics. Select a Topic and move it using the Up and Down arrows.
- To change the name of the Topic select it and click the Edit... button. Change the name and click OK.
- To remove a Topic from the DiveBook select it and click Delete.

Closing the Modify DiveBook Dialog Box

Clicking the OK button on the Modify DiveBook dialog (shown on page 8-4) applies changes to the DiveBook and closes the DiveBook Modify dialog box. The DiveBook remains open. You must still save the DiveBook to permanently save the applied changes. Clicking the Cancel button closes the dialog box without saving any changes.

Saving A DiveBook

Once all modifications have been made in a DiveBook, it must be saved to reflect these changes. To save a DiveBook, go to File > Save DiveBook..., name the file (or use the existing filename), and click Save. Alternately, clicking OK on the Modify DiveBook dialog will cause Diver to prompt to save the DiveBook.

Closing A DiveBook

The Edit > Close DiveBook option allows you to close an open DiveBook without closing any associated Marker, Models, or DivePlans.
Understanding DivePlans

In Diver, once a data Model is built, the information remains the same until the Model is rebuilt. You can, however, change the way in which Diver displays data from the Model, and record these adjustments in a DivePlan for future use.

A DivePlan (.dvp) does not contain data, just instructions telling Diver how to present the data. It records things like:

- Definitions of calculated fields
- Columns to display in Dive Windows
- Named Groups
- Dynamic Dimensions
- Lookups
- Console Categories
- Map Geocoding
- Names of Models being merged
- Instructions for merging multiple Models

Every Model has a basic, default DivePlan which requires no editing, and contains only the Dimensions, Summaries, and Info Fields built into the Model. There are two special cases of the default DivePlan:

- If a Model has no Summaries, the default DivePlan will contain a single Summary called Count, which represents the number of data records summarized in a row.
• If a Model contains a special Geographic key field that is used with mapping, Diver will automatically Geocode the Model when it is opened, that is, it will add Info Fields representing geographic fields in the map data set being used. For more information, see Setting Map Preferences on page 13-12.

Editing The DivePlan

Diver presents every Model with its default DivePlan until that DivePlan has been changed. All DivePlan editing starts with the default DivePlan, and progresses from there. Any changes, such as adding calculations, adding and editing columns, or setting Dynamic Dimensions, will apply to all dives using that DivePlan. When the original Model is updated with new data, the saved DivePlan uses the new data. DivePlans can be edited within Diver and/or within The Diver Solution DiveMaster or ProDivemaster modules.

Using the Add Column Dialog

Editing a DivePlan often begins with the Add Column dialog. To access this dialog, double-click a blank column header in any Dive Window, or select Edit > Edit Columns... and click the Add button.

Alternately, you can access this dialog by editing an existing column. Double-click the column header, or go to Edit > Edit Columns..., and click the Edit button.
The Add Column dialog box is divided into two tabs: **Definition** and **Options**. The contents will vary with the Model and current DivePlan, but will look similar to the one shown here.
Using the Add Column Definition Tab

On the **Definition** tab you can create or edit calculations, and display columns using data which already exists in the Model.

![Add Column Dialog](image)

The **Name & Definition** area consists of the following elements:

- **Name** - If an existing (non-blank) column is selected for editing, the current name of that column will be displayed here. To change the name of a selected column, type a new name and click **OK**. If a new calculation is being created, a new name must be entered, otherwise Diver will not allow the calculation to be added.

Column names should not contain special characters other than an underscore. Doing so could adversely affect the creation of calculations using this column.
• **Label is different from name** - If checked, an edit box appears, allowing you to specify a new Column Label. This label can include prohibited characters, and $(<\text{quickview\_name}>)$, which will expand with the selected value of the named QuickView.

If the checkbox is not checked (the default behavior, and the state for all old columns), the Column Name is used for all labels.

Two points should be considered when using Column Labels:

— The Column Label is only used in Tabular column headers, Report items, and Graphs labels.

— The Column Name is still used for calc references, Time Series, etc.

• **Definition** accepts the syntax of the calculation being defined. Click on Columns and symbols in various areas of the Definition tab to add these elements to the definition, or you can type directly into the Definition field.

The operator buttons to the right of the Definition field allow you to use basic math operators in a calculation: addition (+), subtraction (-), multiplication (*), and division (/). Parentheses are provided to specify the order of operations.

The **Other Columns** area lists any calculations that were previously created.

To use one of the Other Columns in the creation of a new column, click on it, and it will be added in the Definition text box.
Right-click any calculation in the Other Columns dialog box to display its definition in a separate window, as shown below.

This definition can be copied and pasted, if desired.

The **Model Columns** area allows you to create a basic column from any Summaries built into the Model. To add a column, select the desired available column type: Total, Min, Max, Average, % Total, or Std Dev, and select the Summary to be used from the list to the right (in this example, Units, Cost, or Revenue).

Min, Max, and Std Dev are not available unless they were specifically included in the Model build. They are automatically included in the build when using DI-Diver’s Memory Builder. Contact the Model developer to add these options to production Models.

The Name of the new column will automatically be filled into the Name text box. If this name is acceptable, click **OK**; otherwise, type the preferred name and then click **OK**.

- **Total** - displays the actual row value from the Model.
- **Min** - displays the lowest value among all the records associated with the row value in the Model.
- **Max** - displays the highest value among all the records associated with the row value.
- **Average** - defined as Total [Summary Name]/Count, where Count is the number of records associated with the row value in the Model. If the Model Designer requests the SUM Sum Type in Builder, Average is available.

- **%Total** - shows the percent of the total represented by each Summary Value, and is defined as Total[Summary]/parent(Total[Summary])*100.

- **Standard Deviation** - used by Diver as the calculation for “Sample Standard Deviation”. The current calculation is shown below. For a set of one value, the Standard Deviation will return a null value.

\[
\sqrt{\frac{1}{\text{count} - 1} \left[ \text{Sum} \left( X^2 \right) - \frac{1}{\text{count}} \left( \text{Sum} \left( X \right) \right)^2 \right]}
\]

If the Std Dev was included in the Model build, the special Summary “X Squared” was also created. It contains the squares of the values in the column, and is only available by manually typing it into a calculation definition as Totalx2 [summaryname].

- **Info Columns** - lists Info Fields built into the Model. **Display All** lists all Info Fields in the Model, rather than just those related to the Dimension in the current Dive Window. In the example below, a dive was done on Customer, which has the Info Field Address1 associated with it. The Model has an additional Info Field, SIC Code, associated with SIC Description.

When Display All is unchecked, SIC Code is not shown or available for use because it is not associated with the Customer Dimension.

When Display All is checked, SIC Code is also shown, and can be added as a column, however, it will not appear in the Dive Window until you dive on its associated Dimension (SIC Description).

To add an Info Field column to the display, click on it in the Info Columns list. If needed, the column name at the top of the dialog box may be changed.

Numeric and Date Info Fields can be used in calculations.
• **Count** - displays a count of the number of records matching the current row’s Dimension Value. For example, in `demo_drl.mdl`, there are 116,481 records. If a Count column is present, the first dive on any Dimension will always have a total count of 116,481. A dive on Sales Region will show that Boston has the greatest number of records at 35,956.

• **%Count** - displays the percentage of the count of the number of records matching the current row’s Dimension Value. If a Model had ten sales records, five of which represented sales that took place in January, the %Count value for January in a Month Dive Window would be 50 (since January accounts for 50% of the represented records). The sum of all the %Count values (shown in the Total cell in the Dive Window) will always be 100.00.

The **Other Data** area allows you to select various Functions, Dimension Counts, and Named Groups for use in calculations. New Named Groups can also be created here.

The **Other Data** area allows you to select various Functions, Dimension Counts, and Named Groups for use in calculations. New Named Groups can also be created here.

• **Functions** are used to create any number of calculations using a range of mathematical expressions, using the fields built into the Model. See Using Diver Functions on page 9-13 for usage examples of each function.

• **Dimension Counts** (also called DimCounts) display the number of unique values for all Dimensions based on a selected Dimension Value. For additional information, see Adding a Dimension Count Column on page 9-26.

• **Named Groups** are a collection of a Dimension’s values that are given a special label. They are used to add a calculated column which displays only some of the data in the Model. See Named Groups on page 9-46 for more information.
Using the Add Column Options Tab

The Add Column dialog Options tab provides several ways to control the appearance of a column, and to make the data easier to analyze.

In the Column size you can set the width of a column.

- **Fit to Data** sizes the selected column to fit the largest field in the data.
- **Set Size** lets you set the size manually. To do so, enter the desired width of the column, in pixels, in the text box. Care should be taken when choosing Set Size as data may not display fully, and values may be truncated with preceding or trailing ellipses.
Using the Format you can set the format of a column.

There are four formatting options:

- **None** displays the data exactly as it appears in the Model.
- **Number** adds thousands separators and allows for the specification of the number of **Decimal Places** that will appear in numerical data. The default value is fixed as two decimal places, with a maximum of six.
- **Date** sets the way date fields will appear. There are seven available formats:
  - MM/DD/YYYY
  - YYYYMMDD
  - MMDDYYYY
  - YYYY/MM/DD
  - YYYY-MM-DD
  - DD.MM.YYYY
  - DDMMYYYY
- **Time** sets the way time fields will appear. There are two possible formats:
  - HH:MM:SS
  - HH:MM.

Use the Other area to define certain characteristics of the column.

- **Always Sum Total** is used when a calculated field should be totaled. It can also be used to sum an Info Field.
- **Wrap on any Character** is used to make the header text of a column continue onto another line, breaking at any character rather than only at a space.
- **Display Blanks as Zeros** displays any blank cells as a zero.
It does not always make sense to total a calculated field. An example of when a sum total would not be appropriate is in a Model where Unit Price is an Info Field of Product. It would not be logical to sum the Unit Prices of all the different Products.

- **Cumulative Column** displays the sum of a row, plus all prior rows for a Summary or a calculated column.

Below is an example where the Cumulative Column options has been used with an existing Total[Revenue] column, to create a new Cumulative Revenue column.

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
<th>Cumulative Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Totals</td>
<td>35,356,885</td>
<td>71,4,715,545</td>
<td>761,765,141,51</td>
<td>761,765,141,51</td>
</tr>
<tr>
<td>2003/1</td>
<td>6,308,837</td>
<td>109,374,975</td>
<td>116,303,473,42</td>
<td>116,303,473,42</td>
</tr>
<tr>
<td>2003/2</td>
<td>5,823,732</td>
<td>117,806,738,79</td>
<td>125,064,823,80</td>
<td>241,369,287,22</td>
</tr>
<tr>
<td>2003/3</td>
<td>6,309,808</td>
<td>127,893,457,90</td>
<td>135,660,775,80</td>
<td>377,059,073,02</td>
</tr>
<tr>
<td>2003/4</td>
<td>6,383,036</td>
<td>139,087,002,17</td>
<td>137,231,986,11</td>
<td>514,291,032,13</td>
</tr>
<tr>
<td>2004/1</td>
<td>6,459,454</td>
<td>110,724,769,47</td>
<td>118,839,659,73</td>
<td>633,130,697,86</td>
</tr>
<tr>
<td>2004/2</td>
<td>5,981,218</td>
<td>120,016,571,68</td>
<td>128,834,443,55</td>
<td>781,765,141,51</td>
</tr>
</tbody>
</table>

Cumulative Columns are not available for use in other calculations, and will not appear in the **Other Columns** list of the Add/Edit dialog box. In addition, Find is not available in a Cumulative Column.

- **Don’t Show Total** leaves the Totals row blank for the column being edited. This option applies to Tabular displays only.
In the Exception Column section you can color-code the cells in a column of data. Positive values are represented in green, negative values in red, and zeros in blue. Exception Colors are available in a CrossTab, MultiTab, and MultiCrossTab, but should initially be set in a plain Tabular.

- **None** uses no Exception Column coloring.
- **Self** determines colors by the values in the column currently being edited or added.
- **Other Column** colors each cell in the column being edited or added according to the column chosen in the Other Column pulldown.

Exception coloring carries over from any type of Tabular (except for a CrossTab), to the Report display format, although Reports offer more Exception coloring options. See **Using the Exception Tab on page 6-46** for more information on Exception coloring in Reports.

**Required Dimensions** are used to define whether a column should be displayed under certain conditions. Diver contains four Required Dimensions options. Each option is described below. Changing this setting can speed the display of data.

- **Display Always** (default Setting) displays the column in all Dive Windows. The column still may not appear if it is an Info column.
- **In Window Only** displays the column ONLY in the Dimension window(s) specified. For example, if the required Dimension is set as YearMonth, then any Dive Windows containing YearMonth will display the column. Any parent or child dives will not display the column.
• **In Parent Only** displays the column in the Dive Window AFTER the required Dimension Dive Window. For example, if Year Month is set as the required Dimension, then the column will only appear in Dive Windows that occur after the Year Month dive.

• **In Window or Parent** is a combination of the previous two options, and means the required Dimension column will appear in both the required Dimension Dive Window and in all subsequent Dive Windows. For example, if Year Month is set as the required Dimension, then the column will appear in both the Year Month Dive Window and in all subsequent Dive Windows.

Once one of the four options above is selected, the Available Dimensions list becomes active. Using the arrow buttons, move as many Dimensions as needed from Available to Required to set the Dimension requirement criteria.

### Adding Calculations

Calculations can be added to a DivePlan using basic arithmetic signs or Diver Functions. Below is a list of available function.

### Using Diver Functions

The following lists all available Diver functions. Examples of the functions follow their descriptions.

### Logic Functions

The logic functions IF...THEN...ELSE and AND, OR, NOT, can be used in calculations. Below is the explanation of, syntax for, and examples of each of these functions. These may be nested in any combination.

<table>
<thead>
<tr>
<th><strong>Function</strong></th>
<th><strong>Syntax</strong></th>
<th><strong>Purpose</strong></th>
<th><strong>Example</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AND</strong></td>
<td><code>and(bool_expr1, bool_expr2)</code></td>
<td>Used with if. This function returns the logical “and” of the two boolean expressions. It will return True if both expressions are True. Otherwise, it will return False.</td>
<td><code>if(and(Total[Revenue]&gt;100000000,Total[Revenue]&lt;200000000),1,0)</code></td>
</tr>
</tbody>
</table>

This calculation says that if the Total[Revenue] is both larger than 100,000,000 and smaller than 200,000,000 the value of the calculation will be 1. For example, summing this column will give a count of cases that meet the condition.
**Function:** IF

**Syntax:**

if(condition, then expression, else expression)

**Purpose:**

The condition argument of an “if” function is a comparison of expressions using the < (less than), > (greater than), <= (less than or equal to), >= (greater than or equal to), = (equals), and != (does not equal) operators.

If any of the expressions is non-numeric, the comparison will be a case-sensitive string comparison. Otherwise, it will be a numeric comparison.

**Examples:**

Create a new calculation containing:

```
if(Total[Revenue]>100000,1,0)
```

In this example, the condition is Total Revenue >100000. If that condition is met, the value returned will be 1. If it is less than or equal to 100000, the value returned will be 0.

The following is also acceptable:

```
if(Total[Revenue]>100000,"Goal Met","Goal Not Met"
```

In this example, the condition is Total Revenue >100000. If that condition is met, the value returned will display “Goal Met”, otherwise the result is “Goal Not Met”.

The expression below is not acceptable:

```
if(Total[Revenue] > 100000,"Goal Met","N/A")
```

This is not acceptable because the “/” character cannot be used in a calculation.

Optionally, an “if” calculations can be nested within one another, as follows:

```
if(Total[Revenue]=1000,"Threshold Met",
   if(Total[Revenue] >=5000,"Goal Exceeded","Goal Failed"))
```

There are two conditions in this example. The first condition says if Total Revenue=1000, then the value returned will be “Threshold Met”, but if the first condition is not met, then the second condition says if Total Revenue >=5000, then the value returned will be “Goal Exceeded” if it is met or “Goal Failed” if it is not met.

**Function:** ISNAN

**Syntax:**

isnan(<field>)

**Purpose:**

Stands for “is not a number”. Returns 1 if there is a blank value in a field due to a mathematical error; otherwise, returns a 0.
A tabular value may be blank for the following reasons: the result of a calculation is undefined due to division by zero, using a function with invalid arguments (like \( \log_{10}(-1) \)), or hitting a blank “else” clause in an if() function. If a value is the result of a mathematical error or a blank “else” clause in a calculation, then the function isnan() of that value will return a 1; otherwise it will return a 0.

**Function:** ISNULL  
**Syntax:** isnull()  
**Purpose:** If a field is blank, returns a 1; otherwise, returns a 0.

A Tabular value may be blank if the underlying data does not exist (this happens only in a CrossTab or in a MultiModel DivePlan). If a value does not exist in the Model, isnull() of that Summary field will return a 1 for the blank value; otherwise it will return a 0.

**Function:** NOT  
**Syntax:** not(bool_expr)  
**Purpose:** Used with if. This function returns the logical “not” of the boolean expression. If bool_expr is True, it will return False. If bool_expr is False, it will return True.

**Example:**
```
if(not(Total[Revenue]=100000000),1,0)
```

This example demonstrates that if Total[Revenue] is not exactly 100,000,000, the value in the calculation will be 0. If Total[Revenue] is exactly 100,000,000, the value in will be 1.

**Function:** OR  
**Syntax:** or(bool_expr1, bool_expr2)  
**Purpose:** Used with if. This function returns the logical “or” of the two boolean expressions. It will return True if either expression is True. Otherwise it will return False.

**Example:**
```
if(or(Total[Revenue]<100000000,Total[Revenue] >2000000000),1,0)
```

In this example, if the Total[Revenue] is either less than 100,000,000 or greater than 200,000,000, but not in between, the value of the calculation will be 1.

**Function:** SIGN  
**Syntax:** sign(X)  
**Purpose:** The sign function returns 1 for positive numbers, -1 one for negative numbers, and 0 for zeros.
Character Functions

Character functions can be used in calculations on non-numeric data, including Info Fields and Dimensions.

**Function: CONCAT**

**Syntax:** `concat(str1, str2,...)`

**Purpose:** Combines any number of textual arguments, all of which are strings, and combines them into one new column.

**Example**

```
concat("ab", "c", " ", "defg")
```

will return “abc defg”.

An example of the usefulness of this function would be to combine a column containing the Info Field “First Name” with the column containing the Dimension “Last Name”, in order to create a new column containing “Full Name”. The syntax used would look like this:

```
concat(Info[First Name], " ", Dimension[Last Name])
```

**Function: INDEX**

**Syntax:** `index(str1, str2)`

**Purpose:** Returns the starting position (index) of string2 in string string1. If string1 does not contain string2, it returns 0. If string2 is null, it returns 1. This function is case sensitive. For example:

**Example**

```
index("New York, NY", "n") returns 0
index("NewYork, NY", "N") returns 1
index("New York, NY", ",") returns 9
index("New York, NY", "NY") returns 11
index("New York, NY", "NV") returns 0
index("New York, NY", """ returns 1
```

Index can also be used to substr an inexact string (or scan).

```
substr(city_state, 1, (index(city_state, ",") - 1))
substr("Boston, MA", 1, (index("Boston, MA", "",")
1)) returns Boston
```
Function: **MODELVAR**

Syntax: `modelvar(<var_name>)`

Purpose: This function outputs the value of the specified variable. Note that these variables are all strings. Therefore, if the value is numeric, it will need to be converted to a number using the `value()` function.

Example: If there is an Exchange Rate calculation in a Model, using the Model variable “exchange”, a “local currency” column can be created with the definition:

```
dollars * value(modelvar(“exchange”))
```

Please note that Model variables do not appear in the list of available functions, and therefore must be typed manually. Furthermore, they are only available if the Model designer included them during the build process.

---

Function: **REGEXP**

Syntax: `regexp(string, regexp, options)`

Purpose: Performs a search of string based on regular expression, `regexp`. This function returns 1 (true) if a match is found, and 0 (false) if no match is found or the regular expression is invalid. A description of regular expressions is given in the Data Integrator manual.

Example:

```
regexp(“Joe Smo”,“^jo”) returns 0
regexp(“Joe Smo”,“^jo”,“ignore_case”) returns 1
```

---

Function: **REGEXP_VALUE**

Syntax: `regexp_value(string, regexp, options)`

Purpose: This function performs a search of a string based on regular expression, `regexp`. This function returns the portion of the string that matches the given regular expression.

Example: If the Dimension “Company” looks like:

- Wholesale, Inc. (182)
- Elvis Lives, Inc. (299)
- Neverland 123 (0321)
- Dumbells & Company ( )

Then `regexp_value(Company, “([0-9]+)” )` returns:

- (182)
- (299)
- (0321)
Function: SCAN  
Syntax: `scan(string, token_number, delimiters)`  
Purpose: Parses the string into separate segments based on the set of characters in delimiters, and returns the segment indicated by token_number, with the first segment identified by 1. It will also accept negative segment numbers, and interpret them as segments from the end of the string: -1 would indicate the last segment, -2 would indicate the next-to-last segment. If the number is so negative that it identifies a segment before the first segment, a null string is returned. If delimiters is omitted, it defaults to spaces.

Example:
- `scan("first, second, third", 2,"",")` returns second
- `scan("first, second,,fourth",4,"",")` returns fourth
- `scan("foo bar",4)` returns (null string)
- `scan("foo bar",1)` returns foo
- `scan("foo|bar/baz",3,"|/")` returns baz
- `scan("c:\models\data\sales.mdl", -1, ")") returns sales.mdl
- `scan("c:\models\data\sales.mdl", -2, ")") returns data
- `scan("c:\models\data\sales.mdl", -4, ")") returns c:
- `scan("c:\models\data\sales.mdl", -5, "") returns (null)
- `scan("c:/models/data\sales.mdl", -2, "/") returns data`

Function: SUBSTR  
Syntax: `substr(string, start_pos, num_chars)`  
Purpose: The "substr" function allows you to separate a portion of a string from the rest of it. It accepts two or three arguments: the string (from the input column), the position of the character in the string to begin with (the first character is 1), and the number of characters to return (this argument is optional). If `num_chars` is given, up to that number of characters is returned. If it is not included, substring will return all characters in the string beginning with the starting position.

Examples:
- `substr("this is a test",2,5)` returns “his i”
substr("this is a test",3)
returns “is is a test”

The substring function would be useful if Part Number and Part Description were already concatenated in the input file in a column named “Parts”. If the part number were the first 4 characters, the function `substr(Parts, 1, 4)` would create a new column containing just part numbers.

**Function:** VALUE

**Syntax:** value()

**Purpose:** The “value” function allows you to treat a column containing string values as if it contained numeric values.

**Example:** Suppose Quarter contains just the number of the quarter; however, it was set up in the Model as a string. Attempting to add one to the value in Quarter gives an error of “Bad Type”:

```
Quarter + 1
```

The following example, using the value function, will allow the addition to be done without error:

```
Value(Quarter) + 1
```
Numeric Functions

Function: ABS
Syntax: abs(X)
Purpose: The “abs” function returns the absolute value of a number.
Example: abs(10)
Returns 10.

Function: PARENT
Syntax: parent()
Purpose: The “parent” function returns the Total value from the Totals row in the parent Dimension.
Example: In the image below, “Annual Revenue Total” repeats the column total for “Revenue Total by Region” using the Parent function.

\[
\text{parent(Total[Revenue])}
\]
This display allows you to visually compare the Revenue Total by Region with Annual Revenue Total.

Function: PCT_VAR
Syntax: pct_var()
Purpose: Percent Variance is used to express the difference between two values as a percentage.
Example: \[
pct\_var(a,b)=((a-b)/\text{ABS(b)}*100)
\]
For example:
pct_var(Total[Cost], Total[Revenue])

Function: STRING
Syntax: string()
Purpose: The “string” function allows you to treat a column containing numeric values as if it contained string values.
Example: If you want to concatenate a field that contains numbers (such as Units Total), with some text, the concatenation will fail with a “Bad Type” error. Using the string function as follows will allow the concatenation:

```
concat(string(Units Total), "sometext")
```

Function: TRUNC
Syntax: trunc()
Purpose: The “trunc” or truncate function, removes all digits to the right of the decimal point without rounding.
Example: TRUNC(Total[Actual Dollars])
where (Total[Actual Dollars]) is 63.75 would be 63. Setting decimal places in the Options tab rounds the result.

Statistical Functions

Function: EXP
Syntax: exp(X, Y)
Purpose: Exponential (raise X to the Y power).

Function: LN
Syntax: ln(X)
Purpose: Natural Logarithm(e) of “X”.

Function: LOG10
Syntax: log10(X)
Purpose: Log base 10 of “X”.

Function: SQRT
Syntax: \( \sqrt{X} \)
Purpose: Standard Square Root of “X”.

Trigonometric Functions

Function: ARCCOS
Syntax: \( \text{arccos}(X) \)
Purpose: Standard trigonometric ArcCosine of “X”.

Function: ARCSIN
Syntax: \( \text{arcsin}(X) \)
Purpose: Standard trigonometric ArcSine of “X”.

Function: ARCTAN
Syntax: \( \text{arctan}(X) \)
Purpose: Standard trigonometric ArcTangent of “X”.

Function: COS
Syntax: \( \cos(X) \)
Purpose: Standard trigonometric Cosine of “X”.

Function: SIN
Syntax: \( \sin(X) \)
Purpose: Standard trigonometric Sine of “X”.

Function: TAN
Syntax: \( \tan(X) \)
Purpose: Standard trigonometric Tangent of “X”.
Date Functions

Function: DATE_VALUE
Syntax: date_value(date, “input_format”)  
Purpose: The date_value function accepts a date and a string describing the date format (e.g., yyyy/mm/dd), and returns the number of days since December 31, 1899.  
Example: date_value(“20110807”, “yyyymmdd”) will return the value 40762.  
To find the number of days between two dates, subtract the date_value of one from the date_value of the other.  
Date_Value uses the following characters as placeholders to indicate values:  
\[
\begin{align*}
y & \text{ - represents a year digit} \\
m & \text{ - represents a month digit} \\
d & \text{ - represents a day digit}
\end{align*}
\]

For dates after February 1900, this function will return the same serial number returned by Microsoft Excel’s 1900 date system. Note that Microsoft Excel incorrectly uses 1900 as a leap year.

Function: FORMAT_DATE
Syntax: format_date(date, “output_format”)  
Purpose: The format_date function accepts an integer which is the number of days beginning December 31, 1899 and a string describing the desired format, and returns the same date in the specified format.  
Example: format_date(40762, “mm-dd-yyyy”)
would return “08-07-2011”. Its purpose is the reverse of the Date_Value function above.

Format_date uses the following characters as placeholders to indicate values:

- y - represents a year
- m - represents a month
- d - represents a day

January 01, 1900 is the date value 2 and is the earliest date Diver will display.

The equivalent function in Builder and Data Integrator is format_date_value.

---

**Function:** TODAY  
**Syntax:** today()  
**Purpose:** The “today” function returns the system date from the DiveLine server as a date value.  
**Example:** If the system date is August 7, 2011:

```python
    today ()
```

returns 40762
**Time Functions**

Similar to the date value/format date pair of functions, these functions provide a way to convert between a time and an integer.

**Function**: FORMAT_TIME  
**Syntax**: format_time( )  
**Purpose**: The “format_time” function converts a number of seconds to a time format as specified by a format string ("HH:MM:SS" or "HH:MM").  
**Example**:  
format_time(5000,"HH:MM:SS")  
returns 1:23:20

**Function**: TIME_VALUE  
**Syntax**: time_value( )  
**Purpose**: The “time_value” function converts a time format in the form of HH:MM:SS to the number of seconds.  
**Example**:  
time_value("1:23:20","H:MM:SS")  
returns 5000

**Distance Functions**

**Function**: MILES  
**Syntax**: miles(lat1, long1, lat2, long2)  
**Purpose**: The “miles” function calculates the distance in miles between two points on Earth. Latitude and longitude should be specified in decimal degree format.  
**Examples**:  
miles(latitude1,longitude1,latitude2,longitude2)  
miles(latitude1-longitude1,latitude2-longitude2)

**Function**: KILOMETERS  
**Syntax**: kilometers(lat1, long1, lat2, long2)  
**Purpose**: The “kilometers” function calculates the distance in kilometers between two points on Earth. Latitude and longitude should be specified in decimal degree format.  
**Examples**:  
kilometers(latitude1,longitude1,latitude2,longitude2)
kilocentimeters(latitude1-longitude1, latitude2-longitude2)

**Dimension Functions**

The following Dimension functions are available.

- DimAverage
- DimGeoMean
- DimMax
- DimMedian
- DimMin
- DimPercentile
- DimStdDev

For more information on using these functions, see *Creating Dimension-Based Statistical Calculations on page 9-32*

**Adding a Dimension Count Column**

A Dimension Count (also called a DimCount) is a numeric value displayed in parentheses next to each Dimension in the Console, indicating the unique number of values for each Dimension, for the selected Dimension Value. You can add a DimCount column to the Dive Window to display the breakdown of the total DimCount across the entire Dimension.

In the following example, a dive is done on the Dimension **Sales Region**, and a Dimcount for **Customer** is added. You can see at a glance that **Boston** has 88 unique Customers, **North** has 59 unique Customers, etc. These Dimcounts are the same as the numbers that appear in parentheses (after the Dimension name) in the Console if a Dimension Value is double-clicked in the Dive Window.

The DimCount Totals row represents the sum of all rows, that is, the total number of *unique* values for the Dimension displayed.
The DimCount differs from the Count function (described under **Using the Add Column Definition Tab on page 9-4**) in that it tells how many unique values of another Dimension there are for the current Dimension, or the selected Dimension Value. Count, on the other hand, displays how many rows of data were combined to form the totals shown.

To insert a DimCount column:

1. Click on the desired Dimension in the **Dimension Counts** box in the Add Column dialog (see **Using the Add Column Dialog on page 9-2** for its location). This will automatically enter “dimcount[<Dimension>]” in the Definition field. For example:

   \[
   \text{dimcount[Customer]}
   \]

   will count the number of unique customers in the data for each row of the Dive Window.

2. Name the Column in the Name text box, for example, Dimcount Customer.

3. Click **OK**.
If you then select a sales Region such as Rhode Island and dive on Customer, you can verify the results. See screen capture below.

DimCounts for Info Fields can also be added as dimcount[Info Field], although they are not shown in the Dimension Counts list.

DimCount is a powerful tool which delivers a large amount of information with very little work. It is very computation intensive, however, and can be slow if the data set is big and there are a large number of unique values being counted in the Dimension.

**Filtered DimCounts**

DimCounts can be filtered, allowing you to count Dimensions that have certain Summary values. This is useful, for example, for doing counts of Customers that have positive Sales.

The Dimension Count Summary column type (in the Add Column dialog - Other Data area) accepts additional arguments that filter the Dimension Count based on the value of a Summary or calculated field. These appear alongside the Dimension Name and Dimension Values used for CrossTab columns.
The syntax is:

\[
\text{dimcount}[\{\text{Dimension Name}\}, \{\text{Filter - Dive}\}, \{\text{Filter - Dive}\}...]
\]

where \{\text{Filter - Dive}\} is defined to be either:

\[
\{\text{Dimension Name}\} = \{\text{Dimension Value}\}
\]

or

\[
\{\text{Column Definition}\} \{\text{comparison}\} \{\text{value}\}
\]

In the first option, Dimension Name is the name of the Dimension in which the specified Dimension Value can be found. For example:

\[
\text{dimcount}[\text{Product Name}, \text{Sales Region}="\text{North}"]
\]

returns a DimCount for only the North Sales Region.
In the second option, Column Definition is a Summary definition, such as Total[Units], or the name of a calculated field, such as Total[Profit]. Comparison is a numeric comparison object, such as =, <, >, <=, >= or <>. Value is a numeric value. For example:

\[
dimcount \{Customer, Total[Units] < 10000\}
\]

returns a DimCount for Customer, where the total number of Units are less than 10,000. Diver will dive on the Customer Dimension, and count the number of Customers who have purchased less than 10,000 units. You can dive to verify the results of the calculation. See the following screen capture.

A multi-filtered column can also be defined as follows:

\[
dimcount \{Sales Region, Sales Region = \text{"Mid Atlantic"}, Total[Actual Dollars] > 1700000\}
\]

which returns a DimCount for the Mid Atlantic Sales Region only when Actual Dollars exceeds one million, seven hundred thousand.

Finally, the Column Definition can also refer to a calculated field, so complex calculations can be used to filter the Dimension Count. For example:

\[
dimcount \{Company Name, Plan Units = 0, Product = \text{"Computer 100"}\}
\]

counts the number of Companies that have 0 Plan Units after an initial dive for the Product “Computer 100”. The filters and the dives can appear in any order.
Using Dimensions in Calculations

Dimension names can be used in calculations to specify a Dimension to which the calculation should be applied. For example:

```plaintext
if(dimension[Sales Region]="Boston",Total[Revenue],0)
```

This calc tells Diver that if the Sales Region Dimension Value Boston is present, then display the Total Revenue for Boston, otherwise, display 0.
Creating Dimension-Based Statistical Calculations

Diver Dimension based calcs allow you to calculate statistical functions (median, percentile, min, max, etc.) based on diving into a specific Dimension and performing a statistical calculation on a Summary column in that Tabular.

In these functions, “Dimension” is a Dimension in the Model or DivePlan and “Summary” is a Summary Field or Column Name. Percentile must be an integer between 0 and 100.

These functions calculate the corresponding math function on the given column of a Tabular, arrived at by diving into the specified Dimension, and are calculated by performing repeated dives for each row in the column. Performance is equivalent to a DimCount[] function that is not built into the Model.

The following functions are defined in Diver:

**DimMedian[Dimension, Summary]**

For example:

1. Dive on Sales Region.
2. Create the calc:

   DimMedian[YearMo, Total[Revenue]]
For each Sales Region, this number is the median value of the Revenue Summary column from a YearMo dive. You can verify the results by actually doing the dive and examining the rows. See the following screen capture.

**DimPercentile[Dimension, Summary, Percentile]**

For example:

1. Dive on Customer.

2. Create the calc:
   
   DimPercentile[Year-Month, Total[Units], 50]
For each Customer, this number is the Units for the Year-Month below which 50% of the months fall and over which 50% of the months fall. You can see this if you dive on YearMo, as shown in the screenshot below.

![Screenshot of Diver software showing Endural Profitability](image)

Note that the 50th percentile is equivalent to the median.

**DimMin[Dimension, Summary]**

For example:

1. Dive on Customer.
2. Create the calc:
   
   DimMin[Product, Total[Units]]
Each row of the DimMin column is calculated by diving into Product and determining the minimum of the Units column. You can see this if you select a Customer, dive on Product Name and sort the Units column.

**DimMax[Dimension, Summary]**

For example:

1. Dive on Sales Region.
2. Create the calc:
   
   ```
   DimMax[Sales Person,Total[Revenue]]
   ```
Each row of the DimMax column is arrived at by diving into Sales Person and determining the maximum of the Revenue column. You can see how this works if you select a Sales Region and dive on Salesperson; sort the Revenue column, and see that the maximum value was determined correctly. See the screen shot below.

**DimAverage[Dimension, Summary]**

For example:

1. Dive on Sales Region.
2. Create the calc:
   \[
   \text{DimAverage[Product Family, Total[Cost]]}
   \]
Each row of the DimAverage column is arrived at by diving into Product Family and calculating the average of the Cost column. For example, for the North region, the total cost divided by the 9 families gives the average (99,087,727.43/9=11,009,747.49). See screen shot.

**DimGeoMean[Dimension, Summary]**

For example:

1. Dive on Sales Region.
2. Create the calc:
   
   DimGeoMean[Quarter,Total[Cost]]
Each row of the DimGeoMean column is arrived at by diving into Quarter and calculating the Geometric Mean of the Cost column.

**DimStdDev[Dimension, Summary]**

For example:

1. Dive on Product Family.
2. Create the calc:
   
   \[
   \text{DimStdDev[Sales Region, Total[Cost]]}
   \]
Each row of the DimStdDev column is arrived at by diving into Product Family for that row and calculating the Standard Deviation of the Cost column.

Dimension-based functions do not allow filtered calculations, for example:

$$\text{dimMEDIAN}[\text{Saleperson}, \text{Total} [\text{Revenue}] > 500000]$$

is not a valid calculation. Diver will not return an error if this calculation is performed, and will not take the filter into consideration.

Creating Parameterized Calculations

A Parameterized Calc is a Calculated Column with a definition that includes the value of an external QuickView. Diver calculations have the ability to be parameterized. For example, assume you have a Model with the following columns:

- Total[cases]
- Total[dollars]
- calc[unit price] = Total[dollars]/Total[cases]

And a List QuickView named “Metric” with values:

- dollars
- cases
unit price

1. Create calculations for the Cases and Dollars columns as follows:
   cases = Total[cases]
   dollars = Total[dollars]

2. Create a parameterized calc defined as:
   calc[$(metric)]

If the value of the QuickView is numeric, it can be used to modify
calculations (for example currency conversion), or “what if” analysis using
percentages. Time Series QuickViews will begin with “Time Series” as part
of their name.

Using CrossTab Columns in Other Tabulars

The various Diver Summary types (Total, Min, Max, Std Dev, DimCount, etc.) accept additional
arguments that specify Dimension names and Dimension Values to dive on first, in order to obtain
a narrowed value. In simple terms, an additional dive (or dives) is performed before calculating the
value. The abstract syntax is:

   {Summary type}[{Summary name},{Dimension name}={Dimension Value},{Dimension name}={Dimension Value},...]

where:

- “Summary type” is one of the Diver Summary types (Total in the example below)
- “Summary name” is the name of a Summary, or in the case of the DimCount function,
  the name of a Dimension (Units in the example below)
- “Dimension name” is the name of the Dimension (Quarter in the following example)
- “Dimension Value” is a value for the given Dimension, or a group name defined in the
  Named Groups dialog box.

The Dimension Value must be enclosed in quotations if it contains spaces or anything other than
alphanumeric characters.

1. Create the following calculation:
   Total[Units,Quarter="2004/1"]
2. Enter Units only in Qtr 1 of 2004 in the Name field.

3. Click **OK**

   This calculation returns null values in rows where the underlying data does not have the Quarter Dimension Value “2004/1”, just as it would in a CrossTab.

4. Dive on Customer Name.

   The calculation shown in the example above is displayed. The blank cells show customers who made no purchases during the 1st quarter of 2004.
5. Recreate the calculation using an additional Dimension Value as follows:

\[
\text{Total[Units,Quarter=“2004/1”,Sales Region=“North”]}
\]

The resulting column displays values only on the rows where there is data for the first quarter “2004/1” and for customers is in the “North” Sales Region.

If you type an incorrect Dimension Value, Diver will give an “invalid crosstab _” error. The value in the calculation must exist in at least one row. There is no limit to the number of arguments since AND logic is used.

If a Summary is set to be nullable in the Builder (see the Builder manual), then the count of non-zero values can be found using the NZCount Summary type (NZ stands for non-zero). This will be a count of input records for which the Summary value was not null.

For example:

\[
\text{Average[Cost] / NZCount[Cost]}
\]

calculates the average for Cost, taking null data into account. If a Summary is not nullable, NZCount[field] is equal to the Count function.
Handling Division by Zero

Division by zero can occur when using a column for division, where some of the values in the column are zero. Because division by zero is undefined, Diver treats this as a null value and displays a blank. If additional calculations that reference this first calculation are created, blanks will be treated as non-numeric, even if “Show blanks as zeros” (on the Add Column, Options tab) is checked.

Further algebraic operations attempted against these blank fields, will return a null result. For this reason, calculations should use conditional if logic to test for and handle division by zero if the possibility exists, and a null result is not the preferred outcome.

Calculation References (also used in Report Palette cells) can be pasted into the Definition area to create a new calculation. For additional information, see Creating Calculation References on page 11-13.

Editing Columns

The Edit Columns dialog box allows you to change which columns are displayed, their order, and their attributes. These actions do not add any new data to the DivePlan, they just change the layout or presentation of the existing information.

To add a new column:
1. Select **Edit > Edit Columns...**

2. Click the **Add...** button to open the Add Column dialog box.

3. Define the calculation as necessary and click **OK** to add the new column. See **Using the Add Column Dialog on page 9-2** for more information on defining columns.

Alternatively, you can double-click a blank column header in any Dive Window to open the Add Column dialog box.

To edit an existing column:

1. Select **Edit > Edit Columns...**

2. Highlight the column to be edited.

3. Click **Edit...** to open the Edit Column dialog box. (Identical to Add Column, except it will already be populated with the current column settings.)

4. Make the necessary changes to the column and click **OK** to accept the changes.

Alternatively, you can double-click any column header in any Dive Window to open the Edit Column dialog box.

### Using Additional Column Editing Options

The following additional options are available in the Edit Columns dialog box:

- **Copy** allows you to copy a column definition from a DivePlan.
- **Paste** allows you to paste a column definition copied from one DivePlan into another DivePlan.
- **Delete** removes the highlighted column from the DivePlan.

There is no warning when deleting columns. To cancel a delete action, click the cancel button in the Edit Columns dialog box.

- **Named Groups** opens the Edit Named Groups dialog box, allowing you to create or edit Named Groups. For steps on creating Named Groups, refer to **Named Groups on page 9-46**.
- **Time Series** button opens the Time Series Control Panel, allowing you to add new Time Series columns. For more information, see **Chapter 10, Time Series & Period Comparison**.
Selecting Columns

Once columns have been created, use Edit > Select Columns... to open the Select Columns dialog box and add them to the Dive Window.

- **Available** lists all columns that are available for display in a Dive Window.
- **Selected** lists all columns that are currently being displayed in a Dive Window. Use the >> and << arrow buttons to move columns between the two areas.

  Info Fields may appear in the Selected list, but will not display if the associated Dimension is not in the active Dive Window.

  Summary columns may appear in the selected area, but may not display if the Required Dimension feature is being used for that column (see page 9-12 for more information on Required Dimensions).

  Calculated Columns using a Dimension Value will display only in Dive Windows containing that Dimension.

- **Up** moves columns in the Selected area up the list.
- **Down** moves columns in the Selected area down the list.
• **CrossTab Dimension** adds additional columns to a CrossTab, based on the Dimension selected. For example, if the CrossTab Dimension pulldown is set to Product Family, and Cost and Revenue are selected, then any CrossTab performed on the Product Family Dimension will automatically include Cost Total and Revenue Total columns, in addition to the Summary element chosen when the CrossTab was created.

• **OK** accepts all changes done to the DivePlan and closes the Edit Columns dialog box.

• **Cancel** closes the Edit Columns dialog box without making any changes to the DivePlan.

**Named Groups**

Named Groups are a collection of a Dimension’s values that are given a special label. They are used to add a calculated column which displays only some of the data in the Model by filtering on certain values of a Dimension. Clicking the Named Groups button will display the Edit Named Groups dialog box.

- **List Group** defines the name of the group being created. To create a new group, type its name in the List Group field. To edit an existing group, select it from the List Group pulldown.

- **Save/Edit Group** saves (or edits) the group selected in the List Group pulldown.

- **Remove** deletes the group selected in the List Group pulldown

- **Group Dimension** specifies the Dimension to be grouped. In the example above, the Dimension being grouped is “Quarter”.
- **Define Group By** specifies whether the group should be defined by Values or a Range of values.

- **Exclude Values** excludes (rather than includes) the selected Dimension Values, when checked. This option is only available when editing Named Groups by Values rather than by Range.

- **Enter value not in Model** allows you to add non-existing values to Named Groups. Enter the desired value, and click the `>` button to add the new element to the Selected list. For example, if you are creating Named Groups for each Quarter, and it is currently only March, you can add the non-existing values April, May, June, etc. to the Named Groups for their corresponding Quarter. These values will be present in the data later this year, and the Named Groups will automatically reflect the data as soon as they are present.

- **Add/Edit group and close** accepts the new or edited group, and exits the Edit Named Groups dialog box.

- **Close** exits the Edit Named Groups dialog without committing changes to the group.

### Defining Named Groups by Value

If **Values** is selected in the Define Group By pulldown, the **Values** area allows you to define the Named Group by selecting absolute, or hard-coded values.

To create a Named Group by values:

1. Enter a name for the group in the **List Group** pulldown.
2. Select the Dimension to use in the **Group Dimension** pulldown.
3. Move the desired Dimension Value between the Values list and the Selected list using the >> or << buttons (or double-click it).

4. Click Add group and close to create the new Named Group.

Defining Named Groups by Range

If the Group Dimension is defined as a Date or Period Dimension, you have the option of defining the group by Range, “From” some starting point, “To” some ending point. The date range is inclusive, meaning the start and end dates specified are included in the range. The start time goes in the “From” section and the end time in the “To” section of the dialog.

To define each of these dates, the range can be defined absolutely (February 15th through August 2nd), relatively (360 days ago to 181 days ago), or the two can be combined (January 1 through seven days ago).

Before defining a range, it is important to decide if you want the start and end dates to be relative or absolute. If the date should always be the same (January 1 is a common example), an absolute date should be used. If the date should be changed based on the current date, a relative date should be used. Relative dates include “today” and “fourteen days ago”. As previously stated, these can also be combined; for example, to create a “Year to Date” Named Group, choose an absolute “From” date (January 1) and a relative “To” date (today). Today is defined as the latest date in the DivePlan, and changes as the Model is rebuilt.
Named Groups defined by range are not affected by the Time Series Control Panel.

To define a Named Group by absolute Date Dimension range:

1. Select “Date” as the Group Dimension.
2. Set the Define Group By pulldown to Date Range.
3. Select the Date radio button in the From section, and select a date from the Date pulldown, or type it directly into the Date field.
   
   The date entered must match the format for the Date Dimension. For example, if the format is “YYYYMMDD”, type 20030101 for January 1, 2003. Leading zeros and the year may not be omitted.
   
   A date that is not included in the data can be listed, provided it is a valid calendar date.
4. Select the Date radio button in the To section, and select a date from the Date pulldown, or type it directly into the Date field.
   
   Again, the date entered must match the format for the Date Dimension.
5. If you wish to set absolute years (not required), select the desired year from the Year pulldown in the From and To sections.

If a year is specified in the Date field, and a different year is selected in the Year pulldown, the Year pulldown will be used.

6. Name the group in the List Group pulldown.

7. Click Add group and close to create the group and exit the Edit Name Groups dialog box.

To define Named Group by relative Date Dimension range:

1. Select the Current radio button in the From section.

2. To set a From date relative to the current date, enter the number of days forward from the current date.

   To set a start date prior to the current date, use a negative number.

   For example, two weeks from current would be “14”. 180 days prior to current, enter “-180”. Current is defined as the latest date in the Model.

3. To set a To date relative to the current date, enter the number of days forward or backward from the current date, as described in the previous step.

4. To set a relative year, choose “Current” from the Year pulldown list (not required).

   A number may be entered in the +/- field to the right of the Year pulldown to specify the offset from the current year. For example, to specify next year, enter “1”, or to specify two years ago, enter “-2”.

5. Name the group in the List Group pulldown.

6. Click Add group and close to create the group and exit the Edit Name Groups dialog box.

**Period Dimension Ranges**

If a Period Dimension has been selected for the Group Dimension, the process is essentially the same as for Date Dimensions, with a few minor changes.

When adding a Named Group based on a Period Dimension (such as Quarter in the example above), the Range section of the Edit Named Groups dialog box uses periods instead of dates. As a result, there are no entire dates, but rather period numbers in the Month pulldown in the “From” and “To” sections. As a result of this difference, the Year field may not be needed when using Period Dimensions.
When defining a relative period, the “Current” option will also use periods, not days. So Current -1 will give last month, rather than yesterday, if a Month Period is used.

For more information on adding Period Dimensions to the DivePlan, see Adding Date Roll-Up Dimensions on page 9-55.

Creating Multiple Named Groups

When creating Named Groups, if you wish to define additional groups before closing, select Save Group (rather than Add group and close) until all needed groups have been created.

Removing Named Groups

To delete a previously created Named Group, select it in the List Group pulldown menu and click Remove. Note that Remove will not become active until at least one Named Group has been saved.

Using Named Groups In Calculations

To use a Named Group in a calculation, first select the desired column type (any Summary, Calculated Column, Dimension Count, or Count), then click the Named Group that defines the Dimension and values needed to filter the column.

Clicking the two elements in order will cause a correctly formatted entry to appear in the Definition field. Some examples are included here.

For a basic Summary, the format is:

```plaintext
<summary type>[<summary name>,<Dimension/info>=<group>]
```

Example:

```
Total[Revenue,Date="YTD"]
```

For a Dimension Count, the format is very similar:

```plaintext
Dimcount[<dimcount Dimension name>,<Dimension/info>=<group>]
```

Example:

```
dimcount[Customer Name,Date="YTD"]
```

For a basic Count, the Named Group is the only thing inside the brackets:

```plaintext
Count[<Dimension/info>=<group>]
```

Example:

```
Count[Date="YTD"]
```
While multiple filters can be used in a single calculation, only one filter can be used per Dimension. For example:

```
Total [Revenue, Date="February", Date="March"]
```

is not a valid calculation, while the following is valid:

```
Total [Revenue, Date="February", Sales Region="Boston"]
```

**Using Named Group Lookups**

You have the ability to reference a Named Group Lookup that has been added to a DivePlan using The Diver Solution DiveMaster module (see the *DiveMaster* manual for more information).

Once added to the DivePlan, it can be used and referenced in Diver calculations and saved in Markers just as with Named Groups created directly in Diver. One notable difference is that Diver prevents you from editing Named Groups created through Lookups, and from creating a new Named Group with a matching name. In some cases there may already be a Named Group in the DivePlan that has the same name as a Named Group added from a Lookup. In these cases, the original Named Group will take precedence and the Named Group created from the Lookup will be ignored.
Setting Dynamic Dimensions

Builder has a limit of 32 core Dimensions per Model. By creating a special DivePlan, Diver can increase this limit by treating Info Fields as Dimensions. Info Fields that have been promoted to Dimensions are called **Dynamic Dimensions**. Dynamic Dimensions are indicated in the Console by a blue box, as shown for Address1 below.
To set Dynamic Dimensions:

1. Select **Edit > Add Dimensions...** to open the Dynamic Dimensions dialog.

2. Click **Alphabetize List**, if desired, to show the list of available Info Fields in alphabetical order.

3. Move all Info Fields to be promoted to the Dimensions list using the >> button.

4. Click **OK** to promote the selected Info Fields to Dynamic Dimensions, or **Cancel** to close the dialog box without making changes.

Although Dynamic Dimensions allow you to bypass the limit on Dimensions, there are considerations to using them. Dynamic Dimensions are not optimized by the Builder as Core Dimensions are, so they may cause a slower response from Diver. Dynamic Dimension settings are saved in a DivePlan. The Info Field retains its original placement in the Model as well. There is a limit of 200 total Dimensions per DivePlan.

Another use for Dynamic Dimensions is to allow an Info Field to be used for displaying maps. If Diver is given a field named Geographic Key, it will automatically create an Info Field for each map layer. These fields will automatically be promoted to Dynamic Dimensions in order to be used for map creation.
Adding Date Roll-Up Dimensions

Date Roll-Up is a way to create and add time-based Dynamic Dimensions to a DivePlan. It is used to convert time data from one format to another. For example, data can be changed from Year/Mo to Year/Quarter.

Because Date Roll-Up can only work with one Dimension at a time, that Dimension has to provide enough detail to generate the new Dimension. It would not be possible to generate a Date Dimension from a Month Dimension, but generating Month from Date works fine. Thus, it “rolls up” all weeks in January into one value, all weeks in February into another, and so on. For each new Dimension, Date Roll-Up creates a Dynamic Dimension attached to the original time-based Dimension.

Creating Date Roll-Up Dimensions is a 5 part procedure:

1. Selecting a Dimension to Roll Up
2. Selecting a Calendar Type
3. Editing Fiscal Calendars
4. Selecting Roll-Up Dimensions
5. Selecting Other Dimensions

Each part of the procedure is described in the following sections.

Part I - Selecting a Dimension to Roll Up

1. Select Edit > Add/Edit Dimensions to open the Dynamic Dimensions dialog box.
2. Click the Date Roll-Up... button to open the Select Dimension to roll up dialog box.

![Select Dimension to roll up dialog box]

Dimension:

Date

< Back Next Cancel
3. Select the **Dimension** that will be used to generate the new fields, for example, Date.

   If the desired Dimension is not in the pulldown, it is probably not defined as a Date or a Period Dimension in the DivePlan. To correct this, exit from both the Date Roll-up and the Edit Dimensions dialog boxes. Dive on the desired Dimension and double-click on the column header. In the Dimension Column Options window, classify the Dimension as an appropriate Date or Period Dimension.

4. Click **Next** > to display the Select Calendar Type dialog.

**Part II - Selecting a Calendar Type**

1. In the **Select Calendar Type** dialog box, choose a standard calendar from the **Select Calendar** pulldown, Calendar, in this example.

   ![Select Calendar Type Dialog](image)

   Alternatively, if you wish to create a custom calendar, proceed to Part III - Creating and Editing Fiscal Calendars.

2. All new Date Roll-Up Dimensions resulting from this procedure can have a **Prefix** attached to their names. Enter the desired text in the **Prefix** entry box; for example, “Ship” or “Order” might be qualifier prefixes for a Date Dimension.

3. Click **Next** to display the Select Roll-up Dimensions dialog, and skip to Part IV of this procedure.
Part III - Creating and Editing Fiscal Calendars

The **Edit Fiscal Calendars...** option allows you to create your own customized calendars for use in the Date Roll-Up. You can use these calendars to generate a custom Period Comparison display instead of using the standard calendar year.

1. Click **Edit Calendars** to open the Edit Calendars dialog box. 
   Any custom calendars that have already been created in the DivePlan will be listed under Calendars.

2. Click **Add...** to open the Edit Calendar dialog box.

3. Type the name of the calendar to be added in the **Calendar Name** text box.

4. Select the starting point of the fiscal year by selecting the day of the week that it starts on from the **Year Starts on the First** pulldown.

   Some fiscal years start on the same day of the week each year, meaning they do not have exactly 365 days and, therefore, start on a different day of the month. For example, a fiscal year may start on the first Monday on or after July 1.
5. Select the starting date of the fiscal year by choosing the month and day from the **On or After** and **Day** pulldown menus.

6. Specify how many weeks are in each month of each 13-week quarter from the **Month Roll-Up** pulldown.
   
   The default, 4-4-5, means that in each quarter, the first and second months each have 4 weeks and the third month has 5. Additional options are 4-5-4, and 5-4-4.

7. Check **Fiscal Year is after Calendar Year**, if needed.

8. Click **OK** to return to the Edit Calendars dialog box.

9. Choose the desired fiscal Calendar in the **Select Calendar** pulldown.

10. Click **Next >** to advance to the Select Rollup Dimensions dialog box, or **Back <** to return to the previous screen.

To edit a calendar that already exists:

1. Select the calendar and click the **Edit...** button to open the Edit Calendar dialog box.
   
   It looks the same as when adding a new calendar, except that the name of the calendar being edited appears in the Calendar Name field rather than the default “New Calendar”.

2. Changed all fields, as if adding a new calendar.

   Be careful not to give two different calendars the same name.

3. Click **OK** when all necessary changes have been made to return to the Edit Calendars dialog box.

   Calendars are saved in a DivePlan. Be sure to save a DivePlan after creating any custom calendars, or they will be lost.
Part IV - Selecting Rollup Dimensions

This dialog box shows the first set of new Dimensions that can be created. By default, any Dimensions that can be created will be checked, as shown below.

1. Uncheck any unnecessary Dimensions.

![Date Roll-up Dimensions Dialog Box]

The Roll-up Dimensions will be formatted as specified. For example, Year & Month in the example above will be formatted as mm-YYYY. Additional format options are shown in the table below.

### Table 9-1: Date Format Options

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>yyyy/mm</td>
<td>2012/01</td>
</tr>
<tr>
<td>yyyy/mmm</td>
<td>2012/Jan</td>
</tr>
<tr>
<td>yyyy/mmmm</td>
<td>2012/January</td>
</tr>
<tr>
<td>yyyy-mm</td>
<td>2012-01</td>
</tr>
<tr>
<td>yyyy-mmm</td>
<td>2012-Jan</td>
</tr>
<tr>
<td>yyyy-mmmm</td>
<td>2012-January</td>
</tr>
<tr>
<td>yyyyymm</td>
<td>201201</td>
</tr>
<tr>
<td>mm/yyyy</td>
<td>01/2012</td>
</tr>
<tr>
<td>mmm/yyyy</td>
<td>Jan/2012</td>
</tr>
<tr>
<td>mmmm/yyyy</td>
<td>January/2012</td>
</tr>
</tbody>
</table>
2. Once the desired Roll-up Dimensions are selected, click **Next** to continue, or **Back** to return to the previous dialog box.

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>mm-yyyy</td>
<td>01-2012</td>
</tr>
<tr>
<td>mmm-yyyy</td>
<td>Jan-2012</td>
</tr>
<tr>
<td>mmmmm-yyyy</td>
<td>January-2012</td>
</tr>
<tr>
<td>mmyyyy</td>
<td>012012</td>
</tr>
</tbody>
</table>

If an option is grayed out, it means that the data is not available to create that particular Roll-up Dimension. This would happen, for example, if trying to roll up Week from Month.

Selecting these Dimensions is not required, as there are more options available in the next section.
Part V - Selecting Other Dimensions

This is the second and final set of possible Dimensions that can be created in the Date Roll-Up. Unlike in the previous window, each of these Dimensions includes only one piece of time data. The options are Week, Month, Quarter, Half, Year, and Day of Week.

1. Check all desired Roll-up Dimensions
2. Click **Finish** to create the Date Roll-up.
For each Dimension chosen in the last two windows, Date Roll-Up will generate an Info Field attached to the original time-based Dimension. It will then automatically promote it to a Dynamic Dimension and classify it as a Period Dimension, as shown in this Console example:
Adding Info Fields Using a Lookup Table

Using Lookup Tables

New Info Fields may be added to a DivePlan based on Lookup Tables. Lookup Tables must meet the following criteria:

- Must be an ASCII file, for example, as saved from a spreadsheet or database extract.
- Must contain Dimension Values in one column and new Info Fields in additional columns.
- Must be tab-delimited.
- The first row must contain column names.

Lookup Tables can be used by DI-Diver’s Memory Builder, or they can be set up by an administrator using DiveMaster.

The example below shows a Lookup Table which was created as a spreadsheet, containing YearMo and Quarter.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>YearMo</td>
<td>Quarter</td>
</tr>
<tr>
<td>2</td>
<td>2003/01</td>
<td>2003/1</td>
</tr>
<tr>
<td>3</td>
<td>2003/02</td>
<td>2003/4</td>
</tr>
<tr>
<td>4</td>
<td>2003/03</td>
<td>2003/4</td>
</tr>
<tr>
<td>5</td>
<td>2003/04</td>
<td>2003/2</td>
</tr>
<tr>
<td>6</td>
<td>2003/05</td>
<td>2003/2</td>
</tr>
<tr>
<td>7</td>
<td>2003/06</td>
<td>2003/2</td>
</tr>
<tr>
<td>8</td>
<td>2003/07</td>
<td>2003/3</td>
</tr>
<tr>
<td>9</td>
<td>2003/08</td>
<td>2003/3</td>
</tr>
</tbody>
</table>

With the Lookup Table set, when diving on YearMo, Quarter will be available as an Info Field even though it is not included in the Model. If this is preset in DiveMaster, it is transparent.

To add an Info Field using a Lookup Table in Memory Builder:

1. Begin the build process as usual (see Chapter 12, Building a Memory Model).
2. In the Memory Builder’s Define Model Structure dialog, select the column to associate with a Lookup Table in the Model Specification list (this step assumes you have already defined Available Columns in the Model structure as Dimensions, Summaries, and Info Fields).
   The Lookup Table will be associated with this column in the Model.
3. Click Properties...
4. Check the Lookup Table check box.
DIVER

Saving a DivePlan

5. Specify the path for the file to use as the Lookup Table, or click the **Browse...** button to locate the file.

6. Click **OK**.

7. Finish building the Model

Once the Model is built, the Lookup column will be available for use as an Info Field that can then be promoted to a Dynamic Dimension, if desired, as described on page 9-53.

Setting Console Categories

Console Categories are defined using The Diver Solution DiveMaster module. Categories help organize Dimensions into logical groupings, to aid in the diving process. More information can be found in the *DiveMaster* reference manual.

Saving a DivePlan

After making any changes to the DivePlan, it must be saved to preserve the changes. A DivePlan can be saved as a stand-alone file, or as a DiveBook topic.

Saving a DivePlan as a Stand-Alone File

To save a DivePlan as a stand-alone file:

1. 1. Click **File > Save DivePlan**.
2. Select **To File...** to display the Save DivePlan as: dialog. The To File... and To DiveBook... options are only presented if a DiveBook is open. If a DiveBook is not open To File... is automatically assumed.

![Save DivePlan as: dialog](image)

3. Enter the DivePlan name in the **File name** field.

4. Click **Save**.
**Saving a DivePlan to a DiveBook**

When saving a DivePlan to a DiveBook, the DiveBook must already be open in Diver. To save a DivePlan as a DiveBook topic:

1. Click **File > Save DivePlan**.
2. Select **To DiveBook...**
3. Select an existing Area, or manually enter a new Area in which to save the DivePlan.
4. Select an existing Topic, or manually enter a new Topic name for the DivePlan.
   
   **WARNING:** If you select an existing Topic, you will overwrite that Topic’s current data in the DiveBook.
5. Click **OK**.
6. When prompted to Save the changed DiveBook, click **Yes**.
7. Use the existing File name, or enter a new one.
8. Click **Save**.

---

Due to ProDiver’s use of DiveLine for its security features, you may not be permitted to save files. If this is the case, please contact the system administrator for write permission.

---

**Using External DivePlans**

In Diver, DivePlans can be saved in a file externally to a Marker rather than included in the Marker file, using the **External DivePlan** option. This means that when the Marker is opened, it will automatically open the linked DivePlan file. The advantage of this feature is when a number of Markers are using the same DivePlan and a change is made to that DivePlan, either within Diver or within DiveMaster, all Markers referencing that DivePlan will reflect the change. See **Setting Marker Options on page 3-10** for more information.
Consolidating Internal and External DivePlans

When a Marker is saved, all current DivePlan settings are saved internal to the Marker (Internal DivePlan). To specify an additional External DivePlan, check the box next to the Dive and then browse to the DivePlan file (see Configuring a Marker to use Extra DivePlans on page 3-11). Instead of just using the saved DivePlan characteristics when the Marker is re-opened, a merging of both DivePlans occurs in memory.

The DivePlans are consolidated as follows:

- **Dynamic Dimensions** - If an Info Field is promoted in either DivePlan, it will be promoted in the resulting DivePlan. Note that this means that if you demote an Info Field that was previously promoted because of the External DivePlan, that Info Field will be promoted again the next time you open the saved Marker file.

- **Columns** - Columns are a union of the two sets of columns in each DivePlan. If there are conflicts (i.e., where a column exists in both DivePlans), the column definition and data-related fields (cumulative, Sum Total, Required Dimensions, and Exception Coloring) will be kept from the External DivePlan, while the formatting fields (output type, number of decimal places) will be kept from the Internal DivePlan.

- **Column Selection** - Columns that exist in both DivePlans, or only in the Internal DivePlan will get their selection state from the Internal DivePlan. Columns that only exist in the External DivePlan will get their selection state from the External DivePlan. For example, if column “A” exists in both DivePlans, but is not selected in the Internal DivePlan, it will not be selected in the resulting DivePlan. If column “B” exists (and is selected) in only the External DivePlan, it will be selected in the resulting DivePlan. This will prevent a column that is generated in either the Internal or External DivePlan from disappearing in the resulting DivePlan.

- **Named Groups** - Like Dynamic Dimensions, Named Groups will be the union of both groups, with conflicts deferring to the External DivePlan.

- **Time Series and User Defined Dimensions** - These will be copied directly from the Internal DivePlan, overwriting any Time Series or User Defined Dimensions in the External DivePlan. If there are no Time Series or User Defined Dimensions in the Internal DivePlan, the versions from the External DivePlan will be used.

All other settings, e.g. MultiModelings, Categories, Lookups, etc. will be preserved from the External DivePlan, with no reference to the Internal DivePlans settings.
DIVER
Chapter 10
Time Series & Period Comparison

Time Series and Period Comparisons are used in Diver to view data from varying time perspectives. For example, you can view Quarterly Revenue Data, or Revenue this year versus last year using the Time Series and Period Comparison functionality. Any columns added using the Time Series or Period Comparison dialogs can be saved in the Marker or DivePlan for future use.

Using the Time Series Control Panel

The Time Series Control Panel allows for flexibility when customizing Time Dimension columns. This functionality allows you to create multiple Time Dimension columns based on the criteria entered into the Time Series Control Panel. In order to create a Time Series, you must have a Dimension in the Model that has been formatted as a time Dimension. For more information on time Dimension formatting, see Setting Dimension Column Options on page 4-25.

Once your time Dimensions have been properly formatted, refer to the following pages for a description of the Time Series Control Panel screens. The screens and each of the elements on those screens are described, followed by a step-by-step example of Time Series creation. See Creating a Time Series on page 10-12.
A detailed Period Comparison example follows on page 10-20.
General Time Series Settings

To begin configuring a Time Series, you must open a Model that contains a Date Dimension from which to create the Time Series. Once the Model is open, select **Edit > Time Series Control Panel** to display the Time Series General dialog box.

This dialog box allows you to configure the basic settings for the Time Series being defined. Settings include:

- **Name** - allows you to specify a name for the Time Series being created. This name will be displayed in the Console under the Time Series Info area header, and in the QuickView bar if QuickViews are used for the Time Series.

- **Include Time Series Label in QuickView Bar** - allows you to toggle the appearance of the label “Time Series” in the Diver QuickView bar.

- **Time Dimension** - allows you to select any Time Dimensions in the Model to use for creating the Time Series.
• **Create Time Dimension QuickView** - allows you to create a QuickView that lists all valid Time Dimensions in the Model. They can then use the QuickView to change the Time Dimension that the Time Series is based on.

• **Prompt On Initial Selection** - if checked, asks you to select the Time Dimension to use for the Time Series each time the DivePlan or Marker is opened.

• **Current Date Name** - allows you to specify a name for the Current Date being defined. This name will be displayed in the Console under the Time Series area header and in the QuickView Bar if a QuickView is used for the Current Date. Not to be confused with the Time Series Name.

• **Current Date Definition** allows you to specify the default value of Current Date in the Time Series. There are six options to choose from, each of which is described below.
  
  — **Latest date in model** - chooses the latest date in the Time Dimension being used. For example, if the Time Dimension being used in the Time Series is YearMonth, and 2011/06 is the latest value in the YearMonth Dimension, then 2011/06 will be used as the Current Date.

  The offset text box becomes visible and active when this option is selected, allowing you to enter an offset or (+/-) “x” number of days.

  ![Offset:](image)

  — **System Date** - uses your computer’s system date.

  — **Date Built** - automatically sets the Current Date as the latest Model build date.

  — **Custom** - allows a set date to be chosen by you for the Current Date. The Custom pulldown shown below becomes visible and active when this option is selected in the Current Date Definition pulldown.

  ![Custom: 06/30/2011](image)

  — **Extract Date** - sets the Current Date to the date that the Model's data was extracted from the source. It can only be used if the extract_time attribute was used in the Model build.
**Date set by QuickView** - selects the Current Date from a QuickView. When selected, this will allow you to use any of the five options above to define Current Date, or it will allow you to save a specific Date QuickView value in the DivePlan. You will also be given the option to Prompt on initial selection.
Time Series Type

The Time Series Type dialog box allows you to create new or edit existing periods in the Time Series. Click **Next >** in the General dialog to display the Time Series Type dialog box.

**Select Template pulldown**

This area allows you to specify the Periods to use by choosing from a pulldown list of predefined Periods. The available options will depend upon the type of Time Dimension being used. The choices are as follows:

- **Blank** - This option allows you to add a user-defined template. When Blank is selected, click the Add button to manually define the Periods to be used.
- **YTD vs. Last YTD** - Year-to-Date compared to Last Year-to-Date. For example, 2011 to date compared to 2010 to date.
• **HYTD vs. Last HYTD** - Half-Year-to-Date compared to the Last Half-Year-to-Date. For example, July-December 2011 compared to January-June 2011.

• **HYTD vs. Same HYTD Last Year** - Half-Year-to-Date compared to the same Half-Year-to-Date Last Year. For example, January-June 2011 compared to January-June 2010.

• **QTD vs. Last QTD** - Quarter-to-Date compared to the Last Quarter-to-Date. For example, Q2 2011 compared to Q1 2011.

• **QTD vs. Same QTD Last Year** - Quarter-to-Date compared to the same Quarter-to-Date Last Year. For example, Q2 2011 compared to Q2 2010.

• **MTD vs. Last MTD** - Month-to-Date compared to the Last Month-to-Date. For example, June 2011 compared to May 2011.

• **MTD vs. Same MTD Last Year** - Month-to-Date compared to the same Month-to-Date Last Year. For example, June 2011 compared to June 2010.

• **Today vs Yesterday** - This option builds two Periods, each one day long, using the date set in the End Date.

• **Rolling 12** - This option builds a Period range. There are three options to choose from when building a Rolling 12 Period:
  
  — **Rolling Backward** - When the Number of Periods to Roll is set to the default value of 2, this option builds a Current Rolling Period ranging from 11 months back, to the Current Date (as defined in the Current Date area of the General Tab), and a Previous Rolling Period ranging from 23 months back from the Current Date, to 12 months back from the Current Date. For example, if the Current Date was set as Dec 31, 2011, the Current Rolling Period will represent Jan 1, 2011 through Dec 31, 2010, and the Previous Rolling Period will represent Jan 1, 2010 through Dec 31, 2010.

  — **Rolling Forward** - When the Number of Periods to Roll is set to the default value of 2, this option builds a Current Rolling Period ranging from 11 months back, to the Current Date (as defined in the Current Date area of the General Tab), and a Next Rolling Period ranging from the Current Date, to 11 months forward from the End Date. For example, if the Current Date was set as Dec 31, 2010, the Current Rolling Period will represent Jan 1, 2011 through Dec 31, 2010, and the Next Rolling Period will represent Jan 1, 2011 through Dec 31, 2011.

  — **Number of Periods** - This allows you to specify the number of Periods to build for the Roll. The default value is 2, which will build Current and Previous, or Current and Next Periods, depending on the Rolling Direction that was selected. If more Periods are specified, additional Periods will be created. For example, using a Backwards Rolling scenario and a Current Date of Dec 31, 2011, if 3 Periods are created, the Current Rolling Period will represent Jan 1, 2011 through Dec 31, 2011, the Previous Rolling Period will represent Jan 1, 2010 through Dec 31, 2010, and the final Period will be called Current - 2 years, and will represent Jan 1, 2009 through Dec 31, 2009.
- **Current Period vs YTD** - This option builds two Periods. Current is the Period to which End Date is set, and Previous is a Year to Date for the year defined in the End Date.

- **Current Period vs Previous Period** - This option compares the Current Period to the Previous Period, both of which are determined using the End Date.

- **Rolling Periods** - This option builds the specified number of Periods starting with the Period defined by the End Date and moving either forward, or backward, depending on the option chosen. The available options are described in detail in the previous Rolling 12 section.

### Periods

The Periods area allows you to add defined periods to the Time Series. It is blank by default.

Periods can be added in two ways, either by selecting a template from the Select Template pulldown, or by manually adding a period.
Manually Adding a Period

Click **Add** to open the Time Series Edit Period dialog box and manually create Periods.

- **Start** - This is the area in which you will define the start date for the manually created Period. The available options are:
  - **Use End Date** - Uses the End Date specified in the End Date Setup dialog box as the Start date for the Period.
  - **Pick Date** - Allows you to specify the Start Date for the Period.
  - **Use End Dates Period** - Uses the same Period as that in the End Date specified in the End Date Setup dialog box.
  - **Use End Dates Year** - Uses the same Year as that in the End Date specified in the End
Date Setup dialog box.

— **Create Start QuickView** - Allows you to change the Period Start date using a QuickView.

— **Prompt on initial selection** - Allows you to select the Start Date to use for the Period each time the DivePlan or Marker is opened.

• **End** - This is the area in which you will define the end date for the manually created Period. The available options are:

  — **Use End Date** - Uses the End Date specified in the End Date Setup dialog box as the End date for the Period.

  — **Pick Date** - Allows you to specify the End Date for the Period.

  — **Use End Dates Period** - Uses the same Period as that in the End Date specified in the End Date Setup dialog box.

  — **Use End Dates Year** - Uses the same Year as that in the End Date specified in the End Date Setup dialog box.

  — **End is editable via a QuickView** - Allows you to change the Period End date using a QuickView.

  — **Prompt on initial selection** - Allows you to select the End Date to use for the Period each time the DivePlan or Marker is opened.

**Edit**

Allows you to Edit previously created Periods. To manually edited an existing period, highlight it and click **Edit**. Both manually created Periods and Periods created using a template can be edited.

**Remove**

To Remove an unneeded Period from the Periods list, highlight it and click **Remove**.
Time Series Column Types

The Time Series Column Types dialog box allows you to select which columns will be used for the Time Series.

Click the Add button to open the Add Time Series Column dialog and add Total columns for any of the Periods created in the previous Periods area of the Time Series Type dialog box.

- **Select Column Type** - selects the type of column to be added. There are 3 options:
  - **Total** - adds Total columns for the specified Period.
  - **Difference** - adds Difference columns for the specified Periods.
  - **% Difference** - adds Percent Difference columns for the specified Periods.

- **Select Period** - selects the Period for which to add columns. Available options depend on the defined periods.

Edit

To edit the Time Series Column Types selections, highlight the desired columns and click **Edit**.

Remove

To delete a selected column, highlight it and click **Remove**.
Columns

The Columns dialog box allows you to specify the new Columns the Time Series will create. You can also specify which existing columns to display along with the new Time Series columns.

Data Columns

This area allows you to select the Data columns to apply the newly defined Time Series columns to. The data in these columns will be defined according to the newly created Time Series columns.

Summaries

When the Data Columns radio button is selected, you can choose from a list of Summaries available in the DivePlan. Columns can be selected by highlighting them in the Available list and using the >> button to move them to Selected.
**Dimcounts**

When the Dimcounts radio button is selected, you can choose from a list of Dimension Counts available in the DivePlan. Dimcounts can be selected by highlighting them in the Available list and using the >> button to move them to Selected.

**Completing the Time Series**

After each of the options described above is set as desired, the Time Series click **Finish** to create the Time Series. All defined options now appear in Diver, that is QuickViews in the QuickView bar, new columns in the Dive Window, and Time Series information in the Console.

An example of Time Series creation is described in the next section.

**Creating a Time Series**

To use the Time Series Control Panel, open a Model with date or period data, and follow the steps below:

1. Click **Edit > Time Series Control Panel.**
2. Click **Add** or double-click on the highlighted text to create a new Time Series.

![Time Series Control Panel](image)

3. In the General dialog box shown below, give the new Time Series the desired name. For this example, it will be named Revenue YTD vs. LYTD.

![General dialog box](image)
4. Choose the desired Time Dimension to use for the Time Series and put a check in both the Create Time Dimension QuickView and the Prompt on initial selection check boxes.

5. Leave the Current Date set to Last date in model, but please note that there are five additional options to choose from when setting Current Date: System Date, Date Built, Custom, Extract Date, or Date set by QuickView, each of which is described in detail under General Time Series Settings on page 10-2.

6. Click Next to advance to the Time Series Type dialog box shown below. Select the desired Template to use for the periods to be added (YTD vs. Last YTD in this example), and click the Add button to the right of the Select Template pulldown.
7. To create a custom Period that is not listed in the Select Template pulldown, click the Add button in the Periods area to open the Time Series Edit Period dialog box. Name the new Period “Q1 2011”. Check the Create Start QuickView, Create End QuickView, and both Prompt on initial selection check boxes. Select 01/01/2011 from the Start Pick Date pulldown and 03/31/2011 from the End Pick Date pulldown.

8. Click OK to return to the Time Series Type dialog box. A new listing named Q1 2011, defined as (Start = January 1, 2011, End = March 31, 2011) should now appear in the Periods area of the dialog box.
DIVER

This is one Period only. Diver will group all records within that Time Period to a total value. More than one period must be defined to do a Time Comparison.

Beneath the Periods area of the dialog box, there will also be the **Time Series Column Types** area, shown below. These are column types that have applied the Period groups as a limit.

9. Click the **Add** button to open the **Add Time Series Column** dialog box. Use the pulldown menus to add any additional Time Series columns that are needed, for example, Total YTD, and click **OK**.
10. Click **Next** to display the **Columns** dialog box.

11. With the **Summaries** radio button in the Data Columns area selected, move Revenue from the Available to the Selected column.
12. With the **DimCounts** radio button in the Data Columns area selected, move Customer from Available to Selected.

![Data Columns](image)

13. **Click Finish** and **OK** to complete the Time Series, choose the desired Time Dimension, Start and End from the prompted QuickViews, and dive on Product Family to see the resulting columns shown below.

*The resulting tabular displays Revenue and Customer DimCount columns for YTD, Last YTD, Delta YTD vs. LYTD, and % Change YTD vs. LYTD, as well as a total Revenue column for the Period defined in the Start and End date QuickViews.*

Any Summaries that were already selected in the tabular will continue to appear in the resulting Dive Window until they are removed. To remove unwanted Summaries, go to Edit > Select Column, and move them from Selected to Available. In the example above, the Units and Cost Summaries have been removed in this manner.

In addition to the new columns, there will also be two new QuickViews for “Q1 2011 Start” and “Q1 2011 End”. These QuickViews can be changed, allowing for dynamic Time Series columns.
The Time Series Info is displayed in the Console, as shown in Figure below.

```
Time Series Info
- Revenue YTD vs. LYTD
  - Time Dimension: Date
  - Current Date: defined as June 30, 2011 (last date in model).
    - YTD
      - Start: January 1, 2011 based on Current Date.
      - End: June 30, 2011 based on Current Date.
    - Last YTD
      - Start: January 1, 2010 based on Current Date.
      - End: June 30, 2010 based on Current Date.
  - Q1 2011
    - Start: January 1, 2011
    - End: March 31, 2011
  - Built Columns
    - Total(s) YTD, Last YTD
    - Difference of YTD and Last YTD
    - Percent Difference of YTD and Last YTD
  - Data Columns
    - Revenue (Data Column)
    - Customer (Dim Count)
```

The information displayed includes the Time Dimension that the Times Series is based on, the definition of the Current Date, the definition of all Periods that were created, the columns that were built, and the Data Columns being displayed for each built column.

# Deleting the Time Series

To remove the Time Series:

2. Highlight the Time Series to delete.
3. Click **Remove**.
Using Period Comparisons

In addition to the Time Series Control Panel, Diver has a Period Comparison wizard that can also be used to create time-based columns. The steps for using the wizard are described in the section below. You will find this to be a simple method for template time-based comparisons.

Creating a Period Comparison

1. Select **Edit > Period Comparison**, or click the **Period Comparison Toolbar** button to open the Select Time Dimension dialog box in the Period Comparison wizard.

   ![Select Time Dimension dialog box]

   The Dimension must be identified as a Date or a Period in order to be available in the Select Time Dimension pulldown. See **Setting Dimension Column Options on page 4-25**.
2. After selecting the desired Time Dimension, click **Next** to advance to the Define Periods dialog box, and select the desired Periods. We will use the YTD vs. Last YTD template in this example.

There are several Period Comparison Type Templates available, as shown in the pulldown menu below. A brief description of each follows.
Using Period Comparisons

- **Custom** - User-defined Current and Prior period ranges. The dialog box used to define a Custom Period appears below:

![Define Periods Dialog Box](image)

The Current and Previous Period dates are not in chronological order from oldest to newest. If you wanted to define Custom periods for this month and the same month last year in the above dialog box, the Periods would be defined as follows:

**Current Period**
- Start: 04/01/2011
- End: 04/30/2011

**Previous Period**
- Start: 04/01/2010
- End: 04/30/2010

- **Custom vs. Last Year** - User-defined Current period compared to Last Year.
- **Current Date vs. Prior Date** - Current Model date compared to Yesterday.
- **Current Date vs. Last Year** - Current Model date compared to Last Year.
- **YTD vs. Last YTD** - Year-to-Date compared to Last Year-to-Date. For example, 2011 to date compared to 2010 to date.
- **HYTD vs. Last HYTD** - Half-Year-to-Date compared to the Last Half-Year-to-Date. For example, July-December 2011 compared to January-June 2011.
• **HYTD vs. Same HYTD Last Year** - Half-Year-to-Date compared to the same Half-Year-to-Date Last Year. For example, January-June 2011 compared to January-June 2010.

• **QTD vs. Last QTD** - Quarter-to-Date compared to the Last Quarter-to-Date. For example, Q2 2011 compared to Q1 2011.

• **QTD vs. Same QTD Last Year** - Quarter-to-Date compared to the same Quarter-to-Date Last Year. For example, Q2 2011 compared to Q2 2010.

• **MTD vs. Last MTD** - Month-to-Date compared to the Last Month-to-Date. For example, June 2011 compared to May 2011.

• **MTD vs. Same MTD Last Year** - Month-to-Date compared to the same Month-to-Date Last Year. For example, June 2011 compared to June 2010.

3. After the desired Period Type has been selected and defined (YTD vs. Last YTD in this example), click **Next** to advance to the **Select Data Columns** dialog box. Move the desired columns from the “Available” list to the “Selected” list. We will use Revenue in this example.
4. Click the **Dim Counts** radio button to view a list of available DimCounts. Move the desired DimCounts from “Available” to “Selected”. In this example, we will use the Sales Region DimCount.
5. After the desired Data and DimCounts are selected, uncheck the Period Comparison Columns that are not needed (all four options are checked by default), and uncheck the Remove all non Time Series columns if desired. Click Finish.

Difference and Percent Difference display as “Delta” and “% Change columns”.

The resulting window looks like this:
The Time Series Info area of the Console should now appear as follows:

- **Time Dimension: Date**
  - Current: defined as June 30, 2011 (Last date in model).
  - **YTD**
    - Start: January 1, 2011 based on Current.
    - End: June 30, 2011 based on Current.
  - **Last YTD**
    - Start: January 1, 2010 based on Current.
    - End: June 30, 2010 based on Current.
- **Built Columns**
  - Total(s) YTD
  - Total(s) Last YTD
  - Difference of YTD and Last YTD
  - Percent Difference of YTD and Last YTD
- **Data Columns**
  - Revenue (Data Column)
  - Sales Region (Dim Count)
Understanding Report Palettes

Report Palettes (blank Reports) are available to hold links which can point to multiple Models or DivePlans, and can display multiple calculations, text, numbers, or graphics. The purpose of a Report Palette is to gather data and links from different sources into one view. It allows for creation of complex reports, including calculations and comparisons among Models.

Features of the Report Palette include:

- It starts off as a “Blank Report”.
- Each cell can be edited to include text, graphics, Diver functions, or Reference links.
- It can be used to create Reports that display information from more than one Model.
- Calculation References are used to reference columns in external Models.
- Reporter Links and Window Reference Strings are used to make cells in Palettes live (diveable).
- Advanced Report Item Reference Strings that use relative references and sum functions can be created.
- Report Macros are used to improve Report Palette development and functionality.
- QuickViews can be created to control Report Palettes.

The Report Palette can display information that resides in various Models, and can be saved and displayed as a Marker viewable by DI end-user clients. Report Palettes can be edited and used in DI-Diver and ProDiver, and viewed and dived in using Diver, DivePort, and NetDiver.

Opening a Report Palette Marker retrieves the latest information from all sources of data. The Palette provides cell-by-cell control for advanced report formatting. Every cell is addressable, and can be edited within the DI-Diver or ProDiver interface.
All cells can be configured to link to data Models. This provides the capability to open Dive Windows that link back to these Models for further analysis. Individual cells are used for calculations, and any one cell can be calculated from other cells. Additionally, multiple cells can be summed. The flexibility of this approach allows for highly customizable reporting and complex calculations and subtotaling in a spreadsheet-like interface, providing reporting solutions for almost any situation.

The Report Palette also enables the development of views containing multiple items, including graphics, in one screen.

Using Report Palettes

Companies today are producing a number of high-level reports, bringing together numbers derived from a variety of data sources. Financial reports (for example, Income Statements, Cash Flow Statements, and Balance Sheets) are complex reports. These reports derive their information from a variety of data sources. For example, an Income Statement may report Revenue Information, including Accounts Payable and Receivable Data from the Sales System; Salary information from the Payroll Database; and General Ledger and Journal Entry data. The types of Data Sources where this information resides can include complex Relational Databases, Mainframe Databases, small PC Databases, Excel Spreadsheets, and several Dimensional Insight Models. Bringing all this information together into one report, using an automated process, can be a daunting task.

Complex Reports can be useful tools in helping executives spot trends in key metrics. In many cases, though, the numbers in these reports generate more questions than they answer, such as:

- Why is advertising revenue down 7% year after year?
- Why is there a sudden increase in sales of a particular brand?
- Why is the Northeast Region short of goal?

Such questions may result in a search for the detailed information behind the numbers. With Report Palettes, the executive can dive from Summary information via links to Dive Windows containing explanatory detail-level information.
Creating a Report Palette

To create a new Report Palette, select **Window > New Report Palette**. Diver will display a blank Palette.

More than one Report Palette can be open at a time, but their Window Names must be different. To Edit the Window name, select **Edit > Edit Window Info** and type the new name.
When a Report Palette is first opened or created, it will be locked. To begin editing the Palette, click the **Lock** button in the Report toolbar. This unlocks the Report Palette, displays the additional buttons on the Report Edit toolbar, and displays the default Report Palette cell grid.

When first created, a Report Palette grid has 40 rows and ten columns. Additional rows and columns can be added as required. Report Palettes have a cell grid area and three Breaklevel locations: Head, Head 2, and Tail. When first created, the Head Section will contain a centered Text Item that contains the string: $WINDOW_NAME, and a Page Right Text Item that contains the $DATE string. The Head 2 area is below the Head area, cells in the Report Palette Grid will be placed next, and the Tail section is empty.

When editing large Palettes or Palettes with many interconnected cell references, a simple change, even to formatting, can take time. Time-consuming changes can be avoided using the **Cache Lock** feature, available through the right-click context menu. Selecting this option means that when a cell definition changes, only that cell will change. By default, the cache is unlocked. It can be locked by right-clicking the cell to be edited and selecting Cache Lock. The right-click context menu also includes a **Refresh** option allowing you to refresh the entire Palette.

**Using the Add/Edit Item dialog box**

The Add Item dialog box (Edit Item if working in an existing Report Palette), shown below, allows for the addition and configuration of items in the Palette. The Edit Item dialog box is identical, except that it displays when editing an existing item, and is populated with that item’s current attributes. Click the Add/Edit Item button in the Report Palette toolbar to access this dialog.
The figure above shows the Add/Edit dialog for head items. The Add/Edit dialog for body cell items varies. For information on body cell items, please refer to Adding Items to a Cell on page 11-9.
Using Report Palette Features

Adding Items to the Head and Tail Sections

To add a new item to the Head, Head 2, or Tail sections of the report, click the Add Item button on the Report toolbar of an unlocked Report Palette. To edit an existing item, double-click the item, or right-click it and select Edit Item… in order to open the Edit Item dialog box. The Report Palette Breaklevel Head, Head2, and Tail sections can contain two Item Types, Text and Graphics.

Adding Text Items and Text Variables to the Head and Tail Sections

The Add/Edit Item > Data Tab Text Item type, and Add/Edit Item > Text Tab, are used to add text or Text Variables to a Report Palette.

The Data Tab Text Item is only available in the Head, Head 2, or Tail section of the Report Palette. To define an item as Text, choose Text in the Item Type pulldown on the Data Tab, and enter the desired text in the Item Definition box. The scroll box to the right of the Text Item Definition box contains a list of Text Variables. These variables can be added to the Item Definition by single-clicking them. (See Chapter 6, Reports for explanation of each variable).

Many of the Text Variables require a Model name as a parameter or argument, as Report Palettes can contain information from more than one Model. These include: $BUILD_DATE(), $BUILD_TIME(), $COMMENTS(), $MODEL_FOOTER(), $MODEL_NAME(), and $MODEL_VAR(). The Model path and name must be specified when using these variables. For example:
If using ProDiver, the DiveLine path from root must be specified, for example: $BUILD_DATE(\Training\sales_0.mdl). Text Variable names must be all capitals.

The **Text Tab** can also be used to add simple text or variables to Report Palette Items. To include text, enter it in the **Preceding Text** or **Trailing Text** fields. It can include Diver-supported **Text Variables**. A list of Text Variables can be found beginning on page 6-27.
Adding Graphic Items to the Head and Tail Sections

To insert a graphic in the Head or Tail section of a Palette, click the Add Item button and select **Graphic** from the Data Tab Item Type pulldown. Enter the full path or URL to the graphic file in the **Location** box. Diver supports any png file (.png), jpeg (.jpg), or bitmap (.bmp) image. These graphics cannot be resized. Report Palettes will store a link to the graphic file but not the graphic itself. If the graphic file is moved or deleted after the Report Palette has been saved, the link will be broken and the graphic will no longer display. It is best to use a Web server URL to reference graphics, for example http://sunflower:6100/graphics/graphic.jpg as such a path will be valid throughout the network.
Adding Items to a Cell

To add a new item in the cell section of the report, double-click the cell location in the unlocked Report Palette. To edit an existing Cell Items, double-click it, or right-click it and select Edit Item… to open the Edit Item dialog box.

Using Cell Definition Strings

The items in the Report Palette grid have a data type: Cell. The Edit Item dialog box indicates this by labeling the first Tab Cell Definition rather than Data, as indicated above. Each cell has a unique identifier which allows other cells to refer to it (e.g., a1 identifies the cell in Column A row 1, a2 identifies the cell in Column A row 2). Cell b1 is shown above.

Cells contain Cell Definition Strings placed in the Cell Definition area. They can be numbers, text, expressions, or macros, or they can refer to data in other cells. These strings can also contain Calculation References that refer to data from external Models.
Using Text Variables in a Cell

The Text Item Definition area on the Cell Definition tab can be used to place text in a cell. Quotes will be automatically placed around text after the OK button is clicked. The **Text Tab** can also be used to add simple text or Diver-supported Text Variables to Report Palette cells. To include text, choose the Text Tab in the Edit Item dialog box, and enter the text in the **Preceding Text** or **Trailing Text** boxes.
Numbers should be typed in the Cell Definition box without formatting, that is, without commas as grouping symbols. For example, type (without quotes): “3000” not “3,000”. Negative numbers should be shown with a preceding minus (-) sign. Do not use parentheses to indicate negative numbers.
To format numbers, use the **Format tab**. Check the **Include Group (1000s) Separator** check box to add commas (when using US locale) to the number. Uncheck **Use Default Format** to enable additional formatting options.

![Edit Item](image)

The Report Palette recognizes cell definitions as numerical expressions, and displays the result. For example, the expression $13 + 7$ in an item definition displays as $20$. Algebraic expressions: addition (+), subtraction (-), multiplication (*), and division (/) are placed without an equals (=) sign.

The expression $2000-10$ will display as $1990$. To display months in the YYYY-MM format, be sure to place quotations, i.e. “2000-10” in the definition to force evaluation as a string.

### Saving Report Palettes

Report Palettes are saved as Markers. To save a Report Palette select the **File > Save Marker…** menu option. As with all Markers, Report Palettes can be saved in DiveBooks or as stand-alone files. Many of the Save Marker Options are also available with Report Palettes (including Apply an Application Template, Close All Models when opening, and Marker Info). The **Save As** and **External DivePlans** Marker options are not available when saving a Report Palette.
Viewing Report Palettes in the Console

When a Report Palette is opened in Diver, the Console displays its Window Name in a section called Palettes. Double-clicking on the name makes the window active.

Creating Calculation References

Definition and Syntax

Report Palettes can be used to display values from a number of different Models and DivePlans. This is accomplished by including a Calculation Reference in the Item Definition string of a Cell Item on the Report Palette. The general form of a Calculation Reference is:

```
<summary_type> ["model_name">. <column_name>; <parent_name>, <modifier>
```

- **Summary_type** - Any one of the valid Summary Types defined in Diver: Count, TotalX2, Minimum, Maximum, Average, Std Dev, Calc, Dimcount, and Info.
- **Model_name** - The path (system or DiveLine) and filename for the Model or DivePlan to be used. The model_name must be enclosed in quotes. If a DivePlan is used for the model_name, then any Named Group in that DivePlan can be used in the modifier section.
- **Column_name** - A column name defined in the given Model or DivePlan that identifies the column to use. It can be a Dimension, Info Field, Summary, or Calculation. The column_name option is not used if the summary_type is “Count”.

---

Report Palettes 11-13
DIVER

Creating Calculation References

Examples of Calculation Reference Strings

- **Parent_name** - A list of Dimension_Name=Dimension_Value pairs limiting the rows from the Model that should be included in the calculation reference (e.g., Sales Manager=“JACKSON”). The Dimension Value must be enclosed in quotes, and each Dimension pair is separated with a semicolon. If copying a calculation reference from an open dive, this will represent the previously opened Dive Windows and limiting values.

- **Modifier** - A Dimension_Name=Dimension_Value pair limiting the rows from the Model that should be included in the calculation reference. It represents the selected Dimension Value in the current Dive Window. The Dimension Value must be in quotes, and each Dimension pair in the list is separated by a comma.

Examples of Calculation Reference Strings

- **Total[“C:\DI_Users\Models\demo_drl.dvp”.Revenue;Salesperson =“Assil”]**
  Displays the total of the **Revenue** column from the specified DivePlan for Salesperson **Assil**.

- **Count[“C:\DI_Users\Models\demo_drl.dvp”;YearMo=“2011/01”;Customer Name=“Aaron Distributing”]**
  Displays the count of detail rows from the specified DivePlan, where the YearMo is **2011/01** and the Customer Name is **Aaron Distributing**.

- **Dimension[“C:\DI_Users\Models\demo_drl.dvp”.Product Family;Product Family=“Cheese”]**
  Displays the Dimension Value **Cheese** from the specified Model.

- **Calc[“C:\DI_Users\Models\demo_drl.dvp”.Revenue,Quarter=“2011/1”]**
  Displays the value of the **Revenue** calculation from the specified DivePlan when the **Quarter = 2011/1**.

- **Total[“C:\DI_Users\Models\demo_drl.dvp”.Revenue;YearMo=“2011/05”;Salesperson=“Assil”,Customer Name=“Aaron Distributing”]**
  Displays the total of the **Revenue** column from the specified DivePlan for the Customer Name **Aaron Distributing** and sold by **Salesperson Assil** in **May of 2011**.
The examples above are for use with DI-Diver. If using ProDiver, be sure to specify the DiveLine path from root; for example, $BUILD_DATE(\Home\Models\demo_drl.dvp). Text Variable names must be all capitals.

**Copying and Pasting Calculation References**

To aid in the development of complex Report Palettes, DI-Diver and ProDiver support copying and pasting of Calculation References. Adding a Calculation Reference to a Report Palette is a three-step process.

1. **Open the Model or Diveplan.** Start an instance of Diver and select *File > Open*. Browse to the Model or DivePlan that contains the information to be included in the Report Palette, and click *Open*. This will open the selected Diver file in the Console.

You must start from a Model or DivePlan, rather than a DiveBook or an existing Marker. When copying a large number of Calculation References, it may be easier to open two instances of Diver. Open the Report Palette in one instance, and use the other instance to dive and copy the Calculation References.

When copying Calculation References of calculated columns, the columns must exist in the saved DivePlan file. If new columns have been created in the current session, be sure to save the DivePlan before copying the Calculation Reference.
2. Use Diver to create a Tabular that contains the cell with the information to be displayed in the Report Palette. Right-click the cell and select **Copy Calculation Reference**. Diver will display a **Copying to Clipboard** window that displays the Calculation Reference string being copied. Click **OK** to accept the string. In the example below, a Calculation Reference is being copied to a cell that contains the Revenue Total for Salesperson “Assil” in Month “2011/01”.

If the Copying to Clipboard dialog box shown above does not display, the cell has not been copied. If the “null” string appears in the Calculation Reference, check to be sure that a Model or DivePlan is being used, rather than inadvertently starting from a Marker or DiveBook.
3. Open and unlock the Report Palette. Double-click the cell in which to paste the Calculation Reference, in order to open the Edit Item dialog box. Right-click inside the Cell: box and select Paste. Click OK.

The result is shown in the Palette below:
Using Reporter Reference Items

**Reporter Reference Items** can be used to copy both the Window Information (Window Reference String) and Data Information (Calculation Reference String) from a Dive Window into a Cell Item in a Report Palette. If you right-click a cell in a Dive Window, and select **Copy Reporter Reference Item**, Diver will open the **Copy Reporter Reference Item** dialog box. This dialog box defines the resulting window that should be displayed when the item is clicked in the Report Palette. The Link Information defines how the link should appear in the Report Palette. If a Report Palette Cell should contain both a Calculation Reference and a Window Reference, use the Copy Reporter Reference Item to accomplish both in the same copy.

Using the Copy Reporter Reference Item Dialog Box

The **Copy Reporter Reference Item** dialog box, shown below, is divided into two sections: the Window Information section and the Link Information section, each of which is described in further detail below.

![Copy Reporter Reference Item Dialog Box](image)

- **Window Information** Section - defines the resulting window that should be displayed when the item is clicked in the Report Palette.
  - **Use Marker** - To open a Marker, rather than opening the Model directly, click the Use Marker radio button, and type the name of the Marker. If a Marker was open when the Copy Reporter Reference Item option was selected, the Marker name will already
appear in the Use Marker text box. When the Reporter Reference Item is pasted into a Report Palette, the Link Type on the Link Tab will be set to Command Line, and the Marker Name will be put in the Command Line Text box.

— **Create Window Link** - If the Create Window Link radio button (the default selection) is used, the Window Dive Reference String will be copied into the Reporter Reference Item. If the window to be opened is in a Report display format, there are two formatting options to choose from. If the Report uses a **Report Template**, and the Report Palette should apply this template when it opens the Report, click on the Use Report Template radio button. If Diver should ignore the Report Template in use and just use the default style, click on the **Report Default Style** radio button. When the Reporter Reference Item is pasted into a Report Palette, the Link Type on the Link Tab will be set to Window Reference, and the Window Dive Reference String will be pasted into the Window Reference box.

Reference links can also be saved to a Reference Link (.ref) file from which Diver can then read the link. The first line of the file needs to consist of a diveref: string, and Diver will open the correct Models, do the right dives, etc. Reporter items can also link to Markers, or to other items that DiveBooks can link to. Those are “Command Line” options. Links can be used to point to HTML references built into an Info Field column.

• **Link Information Section** - The **Link Information** section defines how the link should appear in the Report Palette.

— **Use Window Name** - If the Use Window Name radio button is selected, the Palette will display the name of the Dive Window. This option can be used to create Report Palettes that contain lists of available dives.

— **Use Cell Text** - If Use Cell Text is selected, the Palette will display the text from the selected cell. To display text information in front of the cell text, check the **Use Prefix** box and enter the information in the text box.

— **Use Graphic** - If selecting the Use Graphic radio button, the system path and filename of a graphic file will need to be entered in the Filename box. Diver will set the **Item Type** to Graphic, and fill in the Filename when the Reporter Reference Item is pasted into the Palette. A Graphic referenced in this manner will be placed in the Head 2 section of the Palette.

**Copying and Pasting Reporter Reference Items**

To aid in the development of complex Report Palettes, copying and pasting of Reporter Reference Items is supported. Adding a Reporter Reference Item to an open Report Palette is a four-step process.
1. Start an instance of Diver and select **File > Open**. Browse to the Model or DivePlan that contains the information to be included in the Report Palette, and click **Open**. This will open the selected Diver file in the Console.

When copying a number of Reporter Reference Items, it may be easier to open two instances of Diver. Open the Report Palette in one instance and use the other instance to dive and copy the Reporter Reference Items.
2. Use Diver to create the Dive Window to link to from the Report Palette. The window can be a Tabular, a Report, a Graph, or a Map. Right-click the cell that contains the item to be displayed in the Palette, and select **Copy Reporter Reference Item**. In the example below, a Reporter Reference Item is being copied from a dive into the Salesperson Dimension from `demo_drl.mdl`. The cell referenced contains the Revenue Total for Salesperson Assil.
3. Diver will display the **Copy Reporter Reference Item** dialog box. Set the Window Information and Link Information as needed, and click **OK**. In the example below, a Window Link will be created, and the Cell Text will be displayed without a prefix. If a prefix text is entered here, it can be edited later using the Edit Item Text Tab Preceding Text box.

![Copy Reporter Reference Item dialog box](image)

4. To paste the Reference Item, open and unlock a new Report Palette. Right-click the cell where the Reporter Reference Item should be pasted, and select **Paste Report Item**. In the example below the Reporter Reference Item has been pasted into Cell a1. By default, the style for that cell is set to color blue and underlined to indicate that the cell has a clickable link.

![Report Palette](image)
Using Window Dive Reference Strings

Window Reference Strings are used to specify the contents and type of window to be loaded when the item containing the Reference String is clicked. They may specify a Dive path and any number of window attributes.

Every Window Reference String must begin with the keyword `diveref` and take the form:

```
diveref:window_type["model_name".dive_dimension,
  (parent_dimension="parent_value"),
  (_attribute_name="attribute_value")]
```

Parentheses here denote optional repetition of items, i.e., they are not part of the syntax.

diverfs can pass filters, but they must be shown with curly braces as in this example:

```
diveref:table["sales.tnl"{Month="January"}.Salesperson, Sales Region="North"]
```

- **window_type** - This setting specifies the window display format to be used. Acceptable window types are “table” and “report”.
- **model_name** - This specifies the path (system or DiveLine) and filename for the Model or DivePlan to be used. It must be enclosed in quotes. If a DivePlan is used for the model_name, then any Named Group in that DivePlan can be used as well (e.g., `month="Q1"`).
- **dive_dimension** - This is the Dimension that would be in the window at the final dive. For example:

```
diveref:table["C:\DI_Users\Models\demo_drl.dvp".Salesperson]
```

- **parent_dimension and parent_value** - Parent_dimension and parent_value pairs define all dives prior to the final dive. There can be any number of parent_dimension/value pairs, and the Dimension Value must be enclosed in quotes. For example:

```
diveref:table["C:\DI_Users\Models\demo_drl.dvp".Salesperson, Month="2011/01"]
```
• **Excluding parent_dimensions and parent_values** - Parent dimension/value pairs can also exclude values in parent Dimensions. The syntax for an exclusion pair is `<parent Dimension name>!="<parent Dimension Value to exclude>"`. For example, Month!="01" will create a parent dive in the Month Dimension that will group all Months except 01. These can be stacked. If the first value for a Dimension is an exclude, then the group will begin with all remaining values. If it is an included value, it will begin with only those values. In the example below, Q1 is a Named Group on the Month Dimension that contains the values “01”, “02”, and “03”.

```
Month="Q1", Month!="02"
```

This will create a group in the Month Dimension that includes Months 01 and 03. It starts by including all Months in Q1 (01, 02 and 03), and then it excludes 02.

• **attribute_name and attribute_value** - Attribute Name/Value pairs are options for the window type. Attribute Names are specified by a leading underscore. Some attributes can specify a list of values, such as MultiTab Dimensions. The list of values is contained within brackets `{}`. The valid attributes are:

  — **_Tab_type**: Type of tabular window. Valid values are: Tabular (default), CrossTab, MultiTab, and MultiCrossTab.
  — **_Across_dimension**: Specifies the name of the horizontal Dimension for CrossPlots and CrossTabs.
  — **_Cross_Column**: Specifies the column for CrossPlots and CrossTabs.
  — **_Mult_Keys**: Array of Dimension Names for MultiTab; e.g., `{Sales Manager, Salesperson}`.
  — **_Mct_Dimension**: Horizontal Dimension for MultiCrossTab.
  — **_Mct_Summaries**: Array of Summary names for MultiCrossTab; e.g., `{Revenue, Cases}`.

**Using Variables in Window Link References**

$TEXT, $(QVName), or $(MacroName) can be used in Window reference strings to provide variable links. The variable, $TEXT, represents the value of the item defined within the Item Cell, or Data tab.

**Setting Report-Specific Attributes**

Window Reference Strings do not include the data required to construct a complete Report window. Instead, they accept either a default report style or a Report Template.

• **_Report_Template**: Filename for a Report Template to use.
• _Report_Default_: Name of default Report Style (e.g., “Tabular MultiTab”).

**Copying and Pasting Window Dive Reference Strings**

To aid in the development of complex Report Palettes, DI-Diver and ProDiver support copying and pasting of Window Dive Reference strings. Adding a Window Dive Reference String to a Report Palette is a three-step process:

1. Start an instance of Diver and select **File > Open**. Browse to the Model or DivePlan that contains the information to be included in the Report Palette, and click **Open**. This will open the selected Diver file in the **Console**.

![Open File](Open_File.png)

2. Use Diver to create the Dive Window to link to. The window can be a Tabular, a Report, a Chart, or a Map. Right-click inside this Dive Window and select **Copy Window Dive Reference String**. Diver will display a **Copying to Clipboard** window that shows the

![Copying to Clipboard](Copying_to_Clipboard.png)
Using Window Dive Reference Strings

Copying and Pasting Window Dive Reference Strings

Window Dive Reference String being copied. Click OK to accept the string. In the example below, a Window Dive Reference String is being copied from a MultiTab on Sales Region and Salesperson from the \texttt{demo\_drl.dvp}.

If "null" appears, check to make sure a Model or DivePlan has been used.
3. Open and unlock the Report Palette. Double-click the cell in which to paste the Window Dive Reference String to open the **Edit Item** dialog box. Select the **Link Tab**, check the **Use Link** box, right-click inside the **Window Reference** box and select **Paste**.

---

**Using Reporter Links**

Reporter Links allow you to specify the action Diver should take when an item is clicked in the Report Palette. Some of the actions that can be configured are:

- Open a Dive Window
- Open a Model or DivePlan
- Open a Marker
- Open an HTML link in a browser window
- Open a Tunnel file (.tnl)
- Start another application
- Open a document (e.g., PDF file)
- Run MS-DOS Batch files
Using the Link Tab

Links can be set on all items, and each item can be configured to perform a different action. To enable linking for an item: edit the item, select the Link Tab in the Edit Item dialog box, and check the Use Link box. The Link Activation pulldown lets you control the click type (Single Click or Double Click) that should start the link. The Link Type section is used to configure the type of action Diver should take when the item is clicked.

Available Link Types

- **HTML Link Column** - HTML Link Columns are only available when using standard Diver Reports. They are not available for use in the Report Palette.

- **Command Line** - Command Line links are used to run other Markers, open other applications, run MS-DOS Batch files, or link to other items that Divebooks can link to.

Examples:
- C:\DI_Users\Models\salesdive.mrk - Runs the Marker salesdive.mrk in a new Diver window.
- C:\DI_Users\Models\brandpie.pdf - Opens the brandpie.pdf file in
the locally installed, default PDF reader.

— C:\DI_Users\temp\countydive.ref - Opens a window using the Dive path and values specified in the countydive.ref reference file.

- **Window Reference** - Opens a Dive Window to a Model using the Dive path and values specified in the Window Reference (see Using Window Dive Reference Strings on page 11-23 for more information).

## Setting Reference Link Files

Window Reference strings can be saved in external files called Reference Link files (.ref). The first line of a Reference Link file needs to start with the keyword **diveref**: and then contain the Window Reference string. You can link a cell in a Report Palette to one of these files by specifying a **Command Line** link on the **Link Tab**, and entering the full system path to the file in the **Command Line** box. When the cell is clicked, Diver will use the reference string in the file to open a Dive Window. If there are a number of cells in the Palette that open the same Dive Window, they can be pointed to a Reference Link file. If the Dive Reference changes, it only needs to be updated once, in the Reference Link file. Create the Link File with a text editor and save with the .ref extension.

**Examples:**

- `diveref:table["C:\DI_Users\Models\demo_drl.dvp".Product Family, Salesperson="Assil", _Tab_type=Tabular]`

- `diveref:report["C:\DI_Users\Models\demo_drl.dvp".Salesperson, _Report_Default=Tabular MultiTab, _Mult_Keys={Salesperson, Sales Region}]`

Reference Link files could be used for cross-platform compatibility between DI-Diver and ProDiver, since the external file can be edited to switch between UNC and DiveLine relative paths.
Working with Palette Cells

Pasting Dimension Values

Values from a Tabular Dive Window can be copied and pasted into a Report Palette. Each cell in the Dive Window is pasted into a Report Palette Cell as an Item Type Cell with the Cell Definition set to a string containing the value from Diver.

This feature can be used as a shortcut for listing the Dimension Values into a Report Palette. Open the Model or DivePlan that contains the Dimension. Dive on the desired Dimension, right-click in the Dive Window, choose Select Columns…, and remove all columns from the Selected list and click OK. Now select Edit > Copy, go to the Report Palette (unlock it if it is locked), select the cell where the list of Dimension Values should start, and select Edit > Paste (do not paste by right-clicking the mouse). This will paste the Dimension Values into the Palette.

In the example below, the values from the Salesperson Dimension in the demo_drl.mdl have been pasted into a Report Palette starting in cell a1.

Selecting Cells

To select an item in the Report Palette, single-click it. The selected item will have its background color changed to black, and, if the item has a type of ‘Cell’, its Item Definition String will be displayed in the status bar at the bottom of the window.
The right-click menu in a Report Palette has five options for selecting specific groups of cells, each of which are shown and described below. Clicking a Column label (e.g., A, B, C, etc.) selects all cells in that column.
• **Select All** - Selects all cells in the Report Palette, allowing global properties to be modified.

![Report Palette Diagram](image)

• **Select all Defined** - Selects all cells that have a Cell Definition String. This will not include cells with only Text Tab input.

![Report Palette Diagram](image)
- **Select all Blank** - The opposite of Select All Defined, selects all cells that have an empty Cell Definition String.

- **Select all with Links** - Selects all cells that have Links defined in the Link Tab.
• **Select all with...** - Selects all Cells that have the desired text in the Cell Definition String.

![Specify Text to Select](image)

The Text find is case-sensitive. Search variables ("**" or "??") are not accepted. Search looks for any instance of the character string. The result of the above search is demonstrated below.

![Report Palette](image)

Items such as preceding and trailing text, and attributes such as borders and backgrounds, are not selected.

---

**Multi-Selecting Cells**

To select multiple cells, hold **Ctrl** to pick individual cells or **Shift** to pick a range of cells. Hold the Shift key and double-clicking the last cell selected to display the **Edit Column** dialog box and update the properties of the selected cells as a group.
Using Cell References

Every cell in the Report Palette is assigned a unique name based on its column and row (e.g., a1). References to these names, such as $(a1)$, can be included in Cell Definition Strings, Macros, and Window Reference Strings.

While a Report Palette cell behaves like an Excel cell in many ways, syntax may be different; therefore, this manual should be used for determining correct syntax.

There are two types of cell references, **Absolute** and **Relative**. The format of an **Absolute** reference is $(a1)$, where a1 is the name of the cell in Column A, Row 1. To make a **Relative** cell reference, replace either the column letter or the row number with a #. For example, $(a#)$ is a reference to the cell in Column A of the row in which the reference is placed. $(#1)$ is a reference to the cell in Row 1 of the column in which the reference is placed. In the example below, the Cell Definition String for cell e4 contains a relative reference $(a#)$ in the Dimension Value field for the Salesperson Dimension. This is a reference to the cell in Column A4 which has a value of “Austin”. The resulting Calculation Reference shows the Revenue column in demo_drl.dvp for Salesperson Austin.
Using Relative Cell References with Offsets

A cell Offset, positive or negative, can be added to the relative cell reference. The format for an Offset reference includes a count in brackets, for example, $([#][-1])$. This would refer to the cell on row 1 in the previous column. Both the column and row can have an offset. For example, $([#][-1])$ refers to the cell in the previous row of the next column. The columns are counted left to right, and the rows, top to bottom. To reference cells in the same column, the syntax would be $([#][x])$, where x represents x rows above the cell containing this definition.

Using Functions

Standard cell references ($(a1), $(#1), $(a#),…$) return the cell definition string of the referenced cell. For example, if cell c1 contains the formula $(a1) + $(b1), then cell reference $(c1) actually returns the formula $(a1) + $b(1). Various functions can return different results when used in cell references.

- **$COL** - A cell with the $COL will appear with the column number inserted in the cell.
- **$INTVAL** - $INTVAL returns the integer value of another cell. For example, if the formula 5/4 in cell f1 is used, it will return 1.25. Use $INTVAL(f1) in cell g1 to display 1.00. Numbers with decimals greater than 0.5 will be rounded up. Be sure that the formatting is set properly if a whole-number display is desired, as the format will default to two decimal places.
- **$NUMVAL** - $NUMVAL is similar to $VAL with one exception: it returns the result as a number. If there is an error processing the cell (for example, division by zero), it will return a 0 rather than an error.
- **$QVPARM()** - $QVPARM() returns the QV values, but rather than return a blank for “All Values (x)”, it will return just “All Values”.
- **$QVVAL** - Using $QVVAL, you can reference a QuickView value in a Calc reference, in the format $QVVAL(quickview name). This will give the proper value of the Calc string when the All Values(x) selection is made. For example, $QVVAL(Sales Region) resolves to Sales Region=“Boston” when the QuickView contains “Boston”, and to a blank string when the QuickView contains “All Values(6)”. For example:
  
  diveredef:table[“demo_drl.mdl“.Product Family,$QVVAL(Sales Region),$QVVAL(Product Name),URL=“$TEXT”,_Tab_type=Tabular]
  
  A Time Series QuickView can also be referenced using $QVVAL(Time Series Name QV Name).
- **$ROW** - A cell with $ROW will appear with the row number inserted in the cell.
- **$SUM** - $SUM returns the sum value of the specified range of cells. For example, if 3.00 appears in cell f1, 4.00 appears in cell f2, and 5.00 appears in cell f3, the $SUM(f1:f3) will return 12.00.
Hiding Rows Working with Palette Cells

- **SVAL** - Using $SVAL allows you to return the value of the formula in a cell as a string (but not as a quoted string), in the format of $SVAL(cell label). For example, in the Report Palette below, cell a1 contains the number 4, cell b1 contains the number 5, and cell c1 contains the formula $(a1) + $(b1). If we put the formula:

\[
(c1) \times 10
\]

in cell d1, then cell d1 will display the number 54 ($4 + 5 \times 10$), due to the standard order of arithmetic operations.

However, if we put the formula:

\[
SVAL(c1) \times 10
\]

in cell e1, then the number **90** will be displayed ($9 \times 10$).

### Hiding Rows

**Hide Row** is a setting that allows you to hide the entire row containing a cell.

- **Default** – Do not hide the row.
- **On Error** – Row does not display if the Item Definition String returns an error.
- **Always** – Hide the row (used to hide calculations and references used in other cells).
Using Report Items and Report Definitions

Copying and Pasting Report Items

To copy the entire contents of a cell (Item Definition String, Window Reference string, formatting, and other cell attributes), right-click the cell and select the **Copy Report Item** option. If you right-click a different cell and select **Paste Report Item**, then the entire copied Report Item will be placed in the new cell. You can also paste Report Items into multi-selected cells. In the Report Palette below, the Report Item from cell c3 has been copied and pasted into cells c4 through c17. Since the Item Reference string for cell c3 contains a relative cell reference:

\[
\text{(Total["C:\DI_Users\models\demo_drl.mdl".Revenue,Salesperson=$ (a#))]
\]

the numbers displayed in cells c4 through c17 contain the **Revenue** numbers for the Salesperson in Column A of each row.

Ctrl–c and Ctrl–v can be used to copy and paste entire contents between cells.
To clear the entire contents of a cell item, right-click the cell and select the Delete Item option.

Copying a Report Item Definition

To copy just the Item Definition String of a cell, right-click the cell and select the Copy Report Item Definition option. The cell’s Item Definition String will be copied to the Clipboard. To paste the Item Definition into a new cell, double-click the new cell (to open the Edit Item dialog box), right-click inside the cell’s Item Definition box, and select Paste. In the example below, the Item Definition for cell c3 (above) has been copied and pasted into the Item Definition for cell c18. Since the Item Definition contains a relative reference to $a#, cell c18 will show the Revenue number for Salesperson Eisel. Notice, however, that the number is neither colored blue nor underlined. This is because the Item Definition was copied but the Window Reference was not.
Using the Sum Function

The $SUM$ function can be used to sum a series of adjacent cells in a Report Palette. The construct of the function is $SUM$(starting cell:ending cell). For example, the formula $SUM(a1:a20)$ would sum the cells in Column A for rows 1 to 20. The formula $SUM(a1:e1)$ would sum the cells in row 1 of Columns A through E. You can use relative cell references as well. The sum reference $SUM(#1:#20)$ will sum the cells in rows 1 through 20 of the column in which the reference is placed. In the example below, the calculation reference string for cell c20 has been set to $SUM(c3:c18)$. The reference is summing the numbers in rows c3 through c18. Cell offsets can be used. For example, $SUM(#[-1]5:#[-1]19$ would sum the columns to the left. Undefined cells are treated as zero.
Working with Rows and Columns

Inserting and Deleting Rows and Columns

Rows and Columns can easily be inserted or deleted from a Report Palette.

- To insert a new row into the Report Palette, right-click a cell and select Insert Row. A row will be inserted above the row in which the cell was right-clicked, and all other rows will be moved down.
- To delete a row, right-click any cell in the row to be deleted and select Delete Row.
- To insert a new column into the Report Palette, right-click a cell and select Insert Column, or click the Add Column button in the Report Palette toolbar. A column will be inserted to the left of the column in which the cell was right-clicked. If no cell is selected, Add Column will add to the far right.
- To delete a column, right-click any cell in the column to be deleted and select Delete Column, or click the Delete Column button in the Report Palette toolbar. As rows and columns are inserted or deleted, any cell references to the impacted cells are automatically adjusted.

Undoing and Redoing Actions

Many actions, such as inserting and deleting rows and columns, can be undone or redone by clicking the blue arrows in the Diver toolbar (as opposed to the Report Palette toolbar), or by clicking Edit > Undo or Edit > Redo.

Using the Style Tab

The Style tab allows you to configure Font and Line Spacing.

- **Font** - selects the Font to use in the Report Palette. It is not recommended that font sizes be mixed on the same row. Undersized gaps can result, especially when using background cell coloring.
- **Line Spacing** - used to increase the distance between rows of cells without inserting an entire row. The spacing is in pixels, and will be placed below the active cell. This spacing is exclusive of wrapped text.

Using the Column Fit Tab

The Wrap Words in Column and the Wrap Characters in Column selections under the Edit Item dialog box’s Column Fit Tab will expand the cell area to fit the string displayed.
Using the Border Tab

There are more than two selections in the Cell Border section of the Edit Item dialog box’s Border Tab, including Left and Right, and Row Bottom and Bottom. Row Bottom will include additional line spacing, while Bottom will draw a border at the end of the text line.

Formatting Cells

The Edit Item dialog box’s Format Tab can be used to control the formatting and decimal places displayed for Item Definitions that result in numbers. Uncheck the Use Default Format box to change these settings.

- **Number of Decimal Places** - The Palettes default number of decimal places is two. Once the format box is unchecked, it uses the default of 0. You can change the number of decimal places from 0 to any number desired. For decimal places greater than nine, type in the number.

- **Do Not Display Zeroes** - Displays a blank in the cell if the Item Definition String results in a zero value.

- **Include Group (1000s) Separator** - Display commas in numbers (in US regional settings).
• **Special Formats** - Control the format of Item Definitions that result in numbers. There are four format options available: **None**, **Accounting**, **Currency**, and **Percentage**.
  
  — **None** displays numbers as integers with no decimal places, no commas, and a leading negative sign for a negative number (e.g., –72218).
  
  — **Accounting** displays numbers with no decimal places, includes commas, and shows negative numbers inside parentheses (e.g., (72,218)).
  
  — **Currency** displays a currency symbol using the system regional settings (e.g., $42).
  
  — **Percentage** has two options: **Symbol Only** or **Adjust Values**. Adjust Values multiplies the ratio by 100 (e.g., from .56 to 56%).

**Error Handling**

Item Definition Strings can contain references to other cells, or to Calculation References that refer to columns in Models and DivePlans. A number of conditions may cause Diver to encounter an error when attempting to resolve the Item Definition String. Some examples of these errors are:

• Syntax errors (missing bracket, missing parenthesis, etc.).
• Calculation References to a DivePlan or to Models that cannot be found.
• Dimension Values in a Modifier_list that does not exist.
• Invalid Summary Types in Calculation References.
• A Build which does not contain the requested data.

The **Error Handling** pulldown on the Edit Item Cell Definition tab allows you to control what Diver should display if it encounters an error when attempting to resolve the Item Definition String. The behavior of each option is shown and described below.

- **Definition**: Displays the entire Item Definition String.
- **Blank**: Displays a blank string.
- **<ERROR>**: Default. Displays the string <ERROR>.
- **Display Error Information**: Displays a message string that contains information about the error that was encountered. For example, if Diver cannot find the Model or DivePlan in a Calculation Reference String, the message “Cannot Open File /path/to/file/filename” will be displayed.
• **Zero**: Displays the number “0.0”.

Using Report Macros and QuickViews

Using Report Macros

Report Macros is a tool that allows you to create complex Item Definitions in one place for later reference in cells. If the Item Definition needs to be changed, it only needs to be made in one place, the Report Macro, and not in each individual cell. Report Macros allow you to include conditional displays, and can be used for ease in portability. All Diver functions can be used.

Creating Report Macros

1. To create a new Report Macro, right-click inside the unlocked Report Palette and select **Edit Report Macros**... to open the **Edit Report Macros** dialog box.

2. Click the **Add**... button and assign a name to the new Macro. Click OK.
3. In the figure below, the Item Definition from cell c20 from the previous Sum Function example has been pasted into the **Macro Definition** box for the Report Macro named **Revenue Calc**. The **View Result** button will show the resolution of the Macro Definition. The **Apply** button will update all cells using the Macro in the Palette.
Using Macro References in Report Item Definitions

Once Report Macros have been created for the Palette, they will be displayed in the listbox to the right of the Item Definition box in the Edit Item dialog box. In the example below, we have replaced the Item Definition for cell c1 with a reference to the Revenue Calc Report Macro in the format of $(Macro Name). This Macro reference can be reused in any number of cells.

Using QuickView Features

Using QuickViews from an External DivePlan

When creating or editing a QuickView in a Report Palette, you must specify which external DivePlan or Model file the values in the QuickView should come from.

The main purpose of this feature is for use in Report Palettes, which are not associated with a specific Model, and may actually contain QuickViews and data from many Models. To enable this feature:

1. Edit or create a new Dimension QuickView, and select the desired option from the Source pulldown menu.
   — Standard - the values in the pulldown will be initialized to the Dimensions in the open Model. This is also true when selecting values in the Values Tab.
   — External - the Dimension pulldown will be empty and the Dimension Name will need
Using QuickView Features

2. If using External, click the **Browse...** button to find and select the Model or DivePlan file that contains the desired QuickView Dimension.

3. Once a Model or DivePlan is opened, select the Dimension to use in the **Dimension** pulldown, or enter the values manually (if using an External DivePlan)

**Skip All Values**

When creating or editing a Pulldown QuickView for use on-screen, you can set it to NOT display the “All Values” option by checking the **Skip “All Values”** check box.
**Label Type**

When creating or editing a QuickView for use on-screen, you can set the QuickView Name to a specific value, use the Dimension Name as the QuickView name, or leave the Name blank. The Dimension Name option is shown below:

Using QuickViews in Report Palettes

QuickViews can be used to control the information displayed in a Report Palette. Report Palettes are not associated with a specific Model, so you must use **DivePlan Type: External** when creating QuickViews for a Report Palette.

---

The Report Palette treats external Picklist QuickViews as merely an alternate display of a Pulldown where only a single value can be selected. Named Groups should be created in the external DivePlan being referenced by the QuickView in order to enable a user to select multiple values.
Adding QuickViews to a Report Palette

To add a QuickView to a Report Palette select **Edit > Add QuickViews** and click **Add…** to open the **Edit QuickView** dialog box. Click the **External** radio button, enter the system path and name of the Model or DivePlan in the **Model** input box (or use the **Browse…** button to find and select it). Enter the Dimension name in the **Dimension** pulldown and click **OK** and **Close**.
The result will be a QuickView that can be used with the Report Palette, as shown below:

Using QuickView Values in Report Palettes

If editing a cell on a Report Palette, you will notice that any QuickViews that exist in the Report Palette are displayed in the listbox to the right of the **Cell Definition** Box. The values from these QuickViews can be referenced in the Item Definition Strings and Window Dive Reference Strings by using the construct: “$(QuickView name)”, including the quotes. To reference a QuickView
value in an Item Definition String, position the cursor at the point in the string where the reference should be inserted, and click the QuickView name in the listbox. In the example below, the **Cell:** definition box contains a calculation reference to the Revenue Column from `demo_drl.dvp` for Salesperson Assil. Note the placement of double quotes around the QuickView Reference.
In the result below, the string “,YearMo=” has been inserted before the closing bracket, and then the **YearMo QuickView** was clicked in the listbox. The resulting Definition: YearMo=“$(YearMo)” limits the Revenue Totals displayed to the Month selected in the **YearMo QuickView**.

![Edit Item Window](image)

The $QVVAL variable can also be used. For more information, see **Using Functions on page 11-36**.

This syntax can also be used to limit Report Macro definitions and Window Reference Strings.

**Using Diver Functions in Report Palettes**

Diver Functions can be used in Report Macro Definitions and Cell Item Definitions. For example, a Macro called **Prev Month** can be created that determines the previous month for the set of example data, where months are represented by number. The Diver functions used would be `string()` and `concat()`. A list of functions available is displayed in the **Other Data Functions** area of the Edit/Add Column dialog box when a tabular window is open.
Creating Palette Graphs

All Palette graphs exist as separate windows in the Report Palette. Each is described below.

Using Spider Graphs

A Spider Graph is a Report Palette diagram that allows you to display unrelated data in the same
graph. When creating a Bar Plot or a Pie Plot, all the data points are measured relative to each
other. In order to do this, they must all have the same frame of reference (same y-axis, percentage
of the same total, etc.). However, with Spider Graphs, each one of the data values can be measured
on its own minimum and maximum value of scale. The low-end minimum is called the Threshold,
while the high-end maximum is called the Goal. Imagine if something is being measured on a
speedometer. There is a minimum speed (0 m.p.h.) and a maximum speed (100 m.p.h.). As the
speed is measured, you are able to deduce that the halfway point on the speedometer is around
50-60 m.p.h. Now imagine an RPM gauge, with a minimum of 0 and a maximum of 10000 RPM.
Both the Speedometer and RPM gauge can display a value relative to a minimum and a maximum,
yet both measure unrelated data. You cannot create a chart that displays RPM value in terms of
MPH or vice-versa. With a Spider Graph though, you can display these values side-by-side,
knowing that they are unrelated, yet both displaying their own low-end and high-end limits on a
scale.

By grouping values into categories, you can designate portions of the data to be related by content
or field of interest. Hence, a Category Column is defined. Also, you have to define the actual result
data, which will be displayed relative to the Threshold and the Goal. This is called the Data
Column. Finally, it is good to display what the data actually represents, so a Header Column must
be defined. This is the “title” of each piece of the Spider Graph.
Once each of the five columns has been defined in the Report Palette, you can choose to display as many or as few rows from the Report Palette as desired. This is done by defining the number of rows to be used, or “All Rows” to use the entire Report Palette.

When the Spider Graph is viewed, you will see each row of data as a “spoke” on the wheel. The Data Column value will be shown relative to its Threshold and Goal Column values. Each row will also be part of a category, which is defined by contiguously matching Category Column values. In other words, if we find ten rows that all have the same category value, the Spider Graph will show them as part of the same category. If you later use the same category value, it will be displayed as a whole new category. Finally, each data value will have a label that indicates its name or title, which is defined by the Entry Column. Certain cell properties, like Links, are preserved when cells are used to populate a Spider Chart.

Since the work in making a spider graph comes from creating the appropriate Report Palette, any changes needed in the Spider Graph should be done in the Report Palette. An example Palette and Spider Graph creation steps are shown below:
1. Click the Add Graph button in the Report Palette toolbar to open the Select Graph Type dialog box shown below:

![Select Graph Type dialog box](image)

2. Click Next >.
3. Set the Data Columns as desired in the Set Data Attributes dialog box:

- You can choose to display All rows in the Palette, or choose a Range. The range is a numeric value. The range of available rows is displayed in parentheses.
- Category Column: A grouping of related items to be displayed.
- Entry Column: The specific items (or metrics) name. This is a label for the “spoke”.
- Threshold Column: A minimum acceptable value. Data Values below this get colored red by default. This is not the minimum value in the scale.
- Goal Column: A maximum value defining the expected range. This is not the maximum value of the scale. Data values above this get colored green by default.
- Data Column: The current value of the metric. It is represented by a colored box containing its value along the items “spoke”. Those values between the Threshold and Goal are colored yellow by default.
4. **Click Finish** to display the Spider Graph:

Spider Graphs can be resized, relocated, and deleted, as can Images and Indicators. For more information, see **Working with Images on page 11-61**.

**Using Images in a Report Palette**

Diver supports graphics in a Report Palette. Images can be in png (`.png`), jpeg (`.jpg`), or bitmap (`.bmp`) format. They are resizeable, can be repositioned by clicking & dragging, and can be linked to data. There is no limit to the number of graphics places on a Report Palette. Graphics can be placed over data columns, as their backgrounds are opaque.

**Adding an Image**

Adding a graphic to a Report Palette requires a few steps:
1. **Click the Add Graph** button in the unlocked Report Palette toolbar. The Graph wizard will display. Select the Images button under the Images area.
2. Click **Next >** to open the Set Data Attributes dialog box.
3. If in DI-Diver, **click the Browse** button to open and select the desired file. You may need to change Files of Type: from *.bmp (Bitmap) to *.jpg (JPEG) files. In ProDiver, add a link to a Window Reference, URL, or file.
4. Click Finish. The graphic will display in its own window.

Working with Images

Resizing an Image

An Image can be resized by hovering the mouse cursor on any corner. The resize arrow will display. Hold the left mouse button down and drag to the desired size.
Relocating an Image

There are two ways to reposition images. You can click and drag the image, or right-click the mouse and select the **Edit Location…** option. The Edit Location dialog box allows you to modify the position of the image. The default option, **Location is tied to a page**, associates the image window with the page. The second option, **Location is tied to a cell**, ties the image to the specified cell by entering a cell reference in the form “a1”. The upper-left corner of the cell and the graphic image become aligned. Both relocation options are shown below:

Deleting an Image

The image can be deleted by right-clicking the mouse and selecting the **Delete** option. Caution: there is no undo or warning.
Using Indicators

Indicators, which are created in the Report Palette, are a type of KPI, or Key Performance Indicator, used by individuals wishing to see a quick snapshot of the health of their enterprise. Often presented on a daily basis, KPIs are a measure of trends and financial results for different aspects of a business. Diver allows the presentation of multiple indicators in various formats. The types of Indicators available are described below, followed by an explanation of the graph attributes that are set during graph creation.

Creating a Standard Gauge

After clicking on the Report Palette graph button, the following dialog box appears, allowing you to select the type of graph needed. In this case, Standard Gauge is selected.
Product Family is the reference column and “Milk” is the row being represented in the Standard Gauge.
Creating a Speedometer

In this example, Speedometer is selected in the Select Graph Type dialog box.
Product Family is the reference column and “Milk” is the row being represented in the Speedometer Indicator.
Creating a Thermometer

In our final example, Thermometer is selected in the Select Graph Type dialog box.
Product Family is the reference column and “Milk” is the row being represented in the Thermometer.

Working with Indicators

**Setting Data Attributes**

Each of the Data Attributes set in the creation of the Indicators above is described in further detail below.
• **Reference Column**: Contains the names of the value being displayed; for example, a column containing Sales Manager names.

• **Row**: The specific row of values being displayed. Select the name from the pulldown list; for example, the Sales Manager: Agate, Paul.

• **Threshold Column**: A minimum acceptable value. This is not the minimum value in the scale. If this column references a column not containing a number, it will default the threshold to the minimum scale value.

• **Goal Column**: A maximum value defining the expected range. This is not the maximum value of the scale.

• **Data Column**: The current value of the metric. This is represented by the position of the needle, or the height of the thermometer fluid.

**Setting Graph Attributes**

If you double-click on the newly created Indicator, or click Graph Options..., the Graph Attributes dialog box will display. Here, the graph characteristics can be modified. For example, you can change the graph background color under the General Tab, add a Title under the Headers Tab, change the scale minimum, maximum, or increment value, or change the fill color of each level.

As with Images, Indicators can also be resized, relocated, and deleted. For more information, see Working with Images on page 11-61.
Chapter 12
Building a Memory Model

A Model is a special, proprietary structure that allows fast access to data. Diver accesses data that has been translated, or built, into a Model.

Large Models are typically built using the Diver Solution Builder component, however, DI-Diver can create its own Model from input data, but will limit the finished Model to 256,000 records or fewer. This new Model is contained solely within memory, and is referred to as a Memory Model. The Memory Model may be named and saved to disk as a regular Model. The DI-Diver Model building component, known as the Memory Builder, can use a text file as input or provide ODBC access to a database. Both types of input will be described in this Chapter.

DI-Diver comes with a utility that allows the System administrator to disable the Memory Builder. If this feature has been utilized, the Build Model command will not appear in the File menu, and you will not be able to build Models within DI-Diver.
Understanding the Basic Model Components

When a Memory Model is created using the Memory Builder, input fields are defined as Dimensions, Summaries, or Info Fields. These classifications define the function of each data field.

- **Dimension** - One of three classifications for Diver to sort and display data. Any data field set as a Dimension will become a “diveable” label in the Console.
- **Summary** - The second classification for Diver to sort and display data. Summaries are numeric, so mathematical calculations can be done on these fields.
- **Info Field** - The third classification for Diver to sort and display data. Info Fields contain extra information related to a Dimension.

See the *Glossary of DI Terms* for more information on Dimensions, Summaries, and Info Fields. For a more extensive discussion of naming and classifying columns, please refer to the *Builder* manual.

Using the Build Wizard

The Build Wizard can be accessed by selecting the **File > Build Model** menu item shown below:
Upon selecting the Build Model menu item, the following dialog box is opened:

At this point, a Model can be built using either a text source file or an ODBC connection to a local database. Each option is outlined in further detail below.
Building a Model Using a Text Data Source

In order to build a Model, the Memory Builder requires input data. A text file contains the input data to be used, one record per line, and each row in the text file is divided into distinct columns, either in fixed-format or variable-format. To build a Model using a Text File:

1. Select **Text File** in the Source Type area of the Build Source dialog box.
2. Click **Browse...** next to Input File to display the Open File dialog box. Select the desired source text file, and click **Open** to use this file.
3. Set the **Format** option:

   a) **Fixed Width** - the column widths are defined and fixed in advance. The wizard facilitates column definition or allows for importing a Dictionary file.

   b) **Delimiter Separated** - the columns are of varied width and are separated by a delimiter character. For Delimiter Separated, there are two additional options:

      — **Contains Headers** - the column headers are in the first row of the input and the data starts in row two. Both the headers and the data are separated by the delimiter character.

      — **Uses Dictionary** - the columns are defined in a separate .dic or .dict file. If a dictionary is required, it can be imported using the **Import .dic...** button. A dictionary can also be saved, if desired, using the **Save .dic...** button.

The dictionary is an optional file that defines the file format of the input file. As previously described, input files can be fixed-format, where each field is a specified length, or variable-format, where the delimiter needs to be specified. If the first line of a delimited input file contains the headers to be used as column names, there is no need to define a dictionary. Dictionary files follow a specific format recognized by Diver, and must use the extension .dic to be viewed in the **Import .dic... > Open Dictionary File** dialog box.
4. Click **Next** to display the Define Model Structure dialog box. It is here that a Model’s Dimensions, Summaries, and Info Fields are defined.
5. Define each data field as needed. Each field of the Model can be defined in two ways:

   — Drag the field from **Available Columns**, to the desired heading under **Model Specification**. When using this method, Dimensions must be dragged onto the word “Dimensions”, Summaries must be dragged onto the word “Summaries”, and Info Fields must be dragged onto their associated Dimensions.

   — Highlight the field and press the letter “D” on the keyboard to make it a **Dimension**, the letter “S” for a **Summary**, or the letter “I” for an **Info Field**. When using this method, the Dimension that an Info Field should be associated with MUST be highlighted under Model Specification before clicking “I”.

   ![Define Model Structure - New Model](image)

When setting fields, remember the following:

   — If you make a mistake and need to change whether a field is defined as a Dimension, Summary, or Info Field, drag it to the intended heading within the Model Specification window.

   — Any field can be removed by highlighting it and clicking **Delete**.

   — Fields can be organized in the Model Specification area using the up and down arrows.
— Not all columns from the Input file need to be defined. Columns can be left out of the Model definition.

6. Once all Dimensions, Summaries, and Info Fields have been defined, you can change the properties of a particular field by highlighting it and clicking the Properties button.

In this example, “Ship Date” is being formatted as a date.

Properties that can be defined are:

— **Alias** - The name entered in the **Alias** text box will display as the name of that column when viewed in Diver.

Suppose Column Headers from the input file are used to create the Dictionary, and there is a field named Date. It might be preferable if the field were named “Ship Date” instead of “Date”. You can enter “Ship Date” in the box next to Alias and that will
become the name of the field in any Dive Window.

— **Sort By** - This property allows you to define an alternate sort order for the column whose properties you are setting. Instead of sorting alphabetically or numerically, as usual, Diver will sort this column according to the values in the field selected in the Sort By pulldown.

For example, you may wish to sort the Dimension “Parts” by “Part Number” rather than alphabetically (the default). Part Number must be defined as an Info Field of Parts in the Model. Part Number must also have the correct one-to-one relationship to Parts, as explained in the Info Field description under [Diver Glossary on page 1-10](#).

— **Lookup Table** - New Info Fields can be added to a Model based on Lookup Tables. These Lookup Tables are simple ASCII files that can be generated by a spreadsheet or from a relational database. They contain Dimension Values in one column and Info Field values in another column. The file must be tab-delimited, and the first row must contain the column names. Alternatively, you can use a Lookup Model. More information on Lookups can be found under [Adding Info Fields Using a Lookup Table on page 9-63](#).

— **String** - Checking the **Column is always a String** check box tells Diver to interpret the numeric data in the selected column as string data (numeric information is interpreted as numbers unless this box is checked).

For example, Zip Code should be defined as a string. If it is not, Diver will treat it as a number and remove leading zeros.

— **Date Format** - The **Date Format** pulldown lets you specify a date format for the column whose properties are being set. Choose a date format from the list. If the desired format is not in the list, it can be manually typed in the box.

When a Model is built using date formatting, DI-Diver converts the dates from the input file into integers representing the length of time between each date and December 31, 1899. This method allows Diver to sort dates chronologically, by year as well as by month and day (for example, 12/01/2010 would come before 01/01/2011, but after 01/01/2010).

The entered format must match the format of the dates in the input file. Use “M” to represent a month digit, “D” to represent a date digit, and “Y” to represent a Year digit. Any other character is treated as punctuation which DI-Diver tries to match exactly. If a special character is needed as punctuation, put a “\” before it when entering the format in DI-Diver. If the dates are in a format that looks like “01m31d2003y”, you can tell DI-Diver that the format is “mm\md\dyyyy\y”. DI-Diver reads the dates according to the format specified, and then reformats them automatically when it builds the Model. Dates before March 1, 1900 will not be interpreted and will display as “Date out of Range”.

When date formatting is used in a Memory Model, DI-Diver automatically creates a
DivePlan that can view the dates in date format. If the Memory Model is saved, make sure to save the DivePlan as well. If the saved Model is opened without using that DivePlan, dates will appear as integers (which is how they are stored in the Model).

7. Once all Properties have been defined, click **Next >** to display the Build Specification Options dialog box.

8. Enter a specific number of **Rows to Build**, up to 256000

The number of rows built are sequential from the beginning of the file.

9. Click **Ignore Parse Errors** to ignore any errors that occur during the build.

10. Click **Finish** to build the Model, or click **< Back** to make changes before the Model is built.
As mentioned in the previous section, the Memory Builder requires input data to build a Model. In addition to a Text File, an ODBC Data Source can be used. Before building a Model using an ODBC data source, you may need to create a Data Source Name (DSN) using the Windows ODBC (Data Sources) Manager, found in the system Control Panel. See your administrator for help in configuring your ODBC connection.

To build a Model using an ODBC Data Source:

1. Select **ODBC Data** in the Source Type area of the Build Source dialog box.

2. Select the source to use from the **Data Sources** list. The available sources will depend on the ODBC drivers that are installed on your system.
3. Once a Data Source has been clicked, the **Select Database** dialog box displays, allowing you to set various options and select the desired database. This dialog and its options will vary, depending upon the Data Source selected in the previous step. This example uses a Microsoft Access Database.

If the specified ODBC DSN identifies the database, this dialog box will not appear.
4. After selecting your database, click OK to use this source. The table or tables available in that database will be displayed in the Tables list.

5. Preview the columns in each table in the **Columns Preview** area, and use all those columns to create the Model, or check **Use Custom SQL** to define which columns should be available for use in building the Model (example shown below).
6. Click **Next >** to display the Define Model Structure dialog box. It is here that a Model’s Dimensions, Summaries, and Info Fields are defined.

![Define Model Structure - New Model](Image)

From here, proceed from Step 5 on **page 12-8** to finish defining and building the Memory Model.
Editing a Memory Model

To make changes to a Memory Model:

1. Select the name of the Model (Memory.mdl) in the Console.
2. Select File > Edit Model.
3. Make the appropriate changes, and click Finish to rebuild the Model.

A new Memory Model can be built without closing the first Memory Model, by opening the File > Build Model dialog box again. Be sure that the current Memory Model is NOT highlighted before doing so; otherwise, the Edit Model dialog box will be opened instead.
Saving a Memory Model

To save a Memory Model, you have two options. You can save the Model as a “Static Model” (a Model written to disk), or as a “Dynamic Model” (a Model saved as part of a Marker or as a DivePlan).

- Select File > Save Model, and the Model will be written to disk as a Static Model. After the Model has been saved, you can also save the DivePlan with the same name as the Model if date fields are defined or if the Model will be rebuilt at a later time. Any Markers saved after this will be based on the data in the Model as it was written to disk. If the input file changes, saved Marker data will not match the input file, unless the Model is updated and rewritten to disk.

- Save a Marker or DivePlan based on the Memory Model to save the Model “dynamically”. When saving a Marker or a DivePlan, the input text file (as it currently exists), or the original ODBC query, is defined as the data source in the saved file. As a result, every time the saved Marker or DivePlan is opened, DI-Diver will rebuild the Memory Model from the defined input file or database. This may take some extra time (a few seconds), but the Model will always be up to date and match the input file or the database.

Rebuilding a Model From a DivePlan

A Model that has been saved as a Dynamic Model, via Marker or DivePlan, can be rebuilt using the following steps:

1. Open the saved Marker or DivePlan in DI-Diver.

2. Select the name of the Model in the Console.

3. Select File > Edit Model.

All information used to create the Model will already be entered, allowing you to advance to the last screen of the Build Model wizard and click Finish to rebuild the Model. Once the Model is rebuilt, it can be made a static Model by saving it to disk, or it can remain a Dynamic Model by resaving the DivePlan or Marker.
Diver
Chapter 13
Application Templates & Preferences

Using Application Templates

Application Templates allow you full control of the functionality available to end users, as well as customization of appearances and preference settings, so they are easy to transfer from one Diver application to another. Application Templates are stored in a separate file (with the extension .tpl), and opened automatically each time Diver is started. The changes applied by an Application Template include:

- Modifications to available menu items (see Using the Modify Menus Dialog on page 13-3)
- Changes to the layout of the toolbar (see Using the Modify Toolbar Dialog on page 13-4)
- Modifications to Diver preferences (see Using the Preferences Dialog on page 13-5)

An Application Template can be used in several ways:

- It can be linked to a Marker so that Diver settings are changed to match the Marker’s needs.
- A local machine or client can be set to use a default Application Template, thus altering the appearance and functionality of Diver for a particular computer or user.
- A user can manually load an Application Template into any Diver at any time using the Diver Preferences dialog (see Activating an Application Template on page 13-7), thus carrying their Diver settings with them wherever they go.
Creating an Application Template

Creating an Application Template is a wizard guided process that takes you through each of Diver’s menus and Toolbar options. Select the options to keep and those to remove as you advance through each dialog, to create a customized Diver application.

Using the Open/New Diver Application Template Dialog

1. Select Edit > Application Templates... to display the Open/New Diver Application Template dialog box. Make a selection as follows:

   ![Open/New Diver Application Template dialog]

   a) Use Open Template (the default selection), and click Browse... to open an existing template.

   b) Select the radio button next to New Template to create a new template. Three choices will be presented.

      — New Template creates an Application Template with none of the Diver settings enabled. You can then choose each option you wish to allow in the template.
Creating an Application Template Using Application Templates

— Limited Diver creates an Application Template with some Diver functions removed.
— Full Diver creates an Application Template that allows complete access to all Diver’s functions.

2. Click Next > to advance to the Modify Menus dialog box.

Using the Modify Menus Dialog

The Modify Menus dialog box selects which of Diver’s functions will be available on each of its menus.

To choose from the available functions:

1. Select the menu to work with in the Menu List, then, Under Menu Contents, place a check in the box for each desired option.

2. After modifying each of the five menus, click Next > to advance to the Modify Toolbar dialog box, or < Back to return to the Open/New Diver Application Template dialog box.
Using the Modify Toolbar Dialog

The **Modify Toolbar** dialog box chooses which toolbar items will be visible to you. All available toolbar buttons are listed in the Available Icons list.

1. Use the >> or << buttons to move tools between the Available Icons list and the Selected Toolbar list. Any tools in the Selected Toolbar list will be accessible to users of this template.

![Modify Toolbar Dialog](image)

The buttons will appear in the order in which they are selected, but can easily be rearranged by clicking on a button and dragging it up or down within the Selected Toolbar list.

Any button that corresponds to a menu item that was excluded in the Modify Menus dialog box will not be available for selection.

2. Add as many Separators (small spaces between buttons) as needed.

3. After setting up the toolbar, click **Next >** to advance to the Preferences dialog box, or **< Back** to return to the Modify Menus dialog box.
Using the Preferences Dialog

The **Preferences** window looks identical to Diver’s File > Preferences dialog box, and sets the Preference options available to the end user. Removed options will no longer be editable in the File > Preferences dialog box.

1. Click on the **Preferences** tab to work in, and change preferences accordingly.

2. After all preferences are set on all tabs, click **Next >** to advance to the Save Application Template dialog box, or **< Back** to return to the Modify Toolbar dialog box.

   For information on what each Preference is used for, refer to **Setting Diver Preferences... on page 13-8.**
Saving an Application Template

When all selections have been made, the Application Template can be saved for later use.

1. Click **Browse...** to choose a directory for the Application Template, and enter a name in the **Template Name** text box. Be sure to include the `.tpl` extension. It is not appended to the file name by default.

2. Click **Finish**.
Activating an Application Template

There are four methods of enabling an Application Template within Diver.

- Select **File > Open** and locate the Template file. Application Template files end in `.tpl`.

- Under **File > Preferences**, the **Files** tab allows a Default Application Template to be set. When an Application Template is specified, Diver will always appear and behave as directed by the Application Template. This may include not permitting the Application Template to be changed.

- Open a Marker that is linked to the desired Application Template. See **Setting Marker Options on page 3-10** for information on setting an Application Template in a Marker.

- A DiveLine administrator can define an Application Template for each ProDiver user using the DI-Config utility. See the *DiveLine* manual for more information.

There is no way for a user to disable an Application Template once it has been enabled through File > Preferences, or defined using DI-Config. The Default Application Template option in the Preferences dialog is no longer accessible.

If an Application Template has been saved in a Marker, a different Marker or DivePlan may be opened, which may not contain an Application Template. In this case, the Application Template from the first Marker will no longer be in effect.

If a template used in a Marker is deleted, the Marker will still open, but without the template settings.
Setting Diver Preferences...

Diver allows you to set a number of options using the following tabs in the Preferences dialog box.

- **General** - sets basic Diver window options.
- **Tabulars** - sets default appearance for all Tabular Reports, colors for Picklist QuickViews, and the default number of decimal places to use for all new columns.
- **Graphs** - sets general preferences for all Graphs.
- **Maps** - sets Diver map files.
- **DiveLine (ProDiver only)** - sets DiveLine server information for ProDiver.
- **Files** - (DI-Diver only) - sets default files and search paths to be used by DI-Diver.

To specify Diver preferences, select **File > Preferences**.

Specifying General Preferences

The General Preference tab sets basic Diver window options.

- **Auto Close** - Sets the maximum number of Models that can be opened in Diver. If the number is exceeded, Diver will automatically close all open Models, except for the new one being opened. The default is blank.
• **Window Placement** - Specifies how Dive Windows should be opened. Child windows can be **Stacked** (offset from each other so that the header of every Dive Window is visible), or **Overlapped** (only the top Dive Window is visible). The default is Stacked.

• **Match Child to Parent Window** - Sets child windows to match the size and position of parent windows. Enabled by default.

• **Enable Window Controls** - Allows Dive Windows to be closed, moved, and resized. This option is checked by default. Unchecking it disables these features. Enabled by default.

• **Options** - Hides common non-fatal errors, for example, “Calculated field not found”, when opening DivePlans and Markers. Enabled by default.

A “Calculated field not found” error is a common error caused by building calculations around values that do not exist yet; for example, in a month-to-month DivePlan where all the data is not yet available. “Missing infos” is also a common error, because some Lookups might not always be available.

A “Missing Dimension” error, however, will display even if you enable this option, because it indicates a fundamental mismatch, a pathing problem, a security problem, or something more serious.
Setting Tabular Preferences

The Tabulars tab sets the Default appearance for all Tabular Reports, as well as colors for Picklist QuickViews and the default number of decimal places to use for all new columns.

- **Default Font** - Sets the default font for Tabular views (graphical views and Reports will not be affected).
- **Default Label Color** - If this check box is selected, the row and column headers will appear shaded with the selected color (the default color is white). Enable this option to shade the names of rows and column headers, as shown here:

<table>
<thead>
<tr>
<th>Sales Region</th>
<th>Units</th>
<th>Cost</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>35,365,605</td>
<td>714,715,545.94</td>
<td>781,765,141.51</td>
</tr>
<tr>
<td>Boston</td>
<td>9,520,622</td>
<td>200,456,644.76</td>
<td>213,736,971.77</td>
</tr>
<tr>
<td>North</td>
<td>4,570,256</td>
<td>59,807,274.43</td>
<td>107,969,054.43</td>
</tr>
<tr>
<td>Rhode Island</td>
<td>6,579,103</td>
<td>140,265,474.84</td>
<td>150,127,475.22</td>
</tr>
<tr>
<td>South Shore</td>
<td>5,018,506</td>
<td>117,416,471.38</td>
<td>125,293,136.71</td>
</tr>
<tr>
<td>Southwest</td>
<td>4,438,888</td>
<td>99,927,218.56</td>
<td>95,260,816.40</td>
</tr>
<tr>
<td>West</td>
<td>3,260,404</td>
<td>88,654,088.98</td>
<td>70,135,457.98</td>
</tr>
</tbody>
</table>

- **Picklist Color** - Sets the default color that should be used to shade Picklists.
Decimal Places - Sets the number of decimal places that should be displayed in a new column. Specifying the number of decimals using the Edit Column dialog Options tab overrides this setting.

Setting Graph Preferences

The Graphs tab sets general preferences for all Diver graph windows.

- Appearance - Sets the default graph Window Background and Graph Background colors for all newly created graphs, and the Graph Font and Graph Label Font.

- Graph Colors - Sets the colors or patterns that will be used as defaults for all graphs. These can also be changed for individual graphs when they are created.

Patterns are used only when the monitor being used is not a color monitor, or when printing to a legacy black and white printer that does not recognize gray scale. To change the color for a particular element, double-click on that color. Reset Colors will return all colors to the defaults.

- Graph Calendar: First Day of Week - Specifies which day of the week should begin a Calendar graph. Sunday is the default selection. This setting may be overridden when individual Graph Calendars are created.
Setting Map Preferences

You have the ability using Diver to display geographic data in the form of a map. In order to use this feature, a map data set that corresponds to the geographic data in the Model being used must be selected.

There are two components of this dialog box:

- **Map Directory** - The Map Directory, named MapData, contains one or more lower-level directories of mapping data, usually with the name of the country whose map files they contain. The actual map data is stored within these lower-level data folders. As a result, no map data exists at the Map Directory level. It is important the Map Directory preference be set to the top level map_data folder, and not to any of the individual lower-level folders.

1. Click on the **Set...** button, and select the MapData folder by navigating the directory structure of the computer.

2. Once the MapData directory has been selected, the list of lower-level directories contained within that directory will appear in the Map Folders area. Any new lower-level maps directories that are obtained should be added to the MapData directory.
• **Map Folders** - Lists the MapData directories contained within the Map Directory. This must be locally available to DI-Diver. Additionally, to use Geocoding in ProDiver, the `lookup.mdl` stored in the Map folder must also be located on the DiveLine server path.

The Map Directory is set locally for each computer in the `diver.ini` file, while the Map Folder being used is saved in the DivePlan and/or Marker. This allows the same DivePlan to work on different computers. If you are having problems getting the correct map data, or if you are changing to a new set of map data, the correct path must be entered and the DivePlan saved.

After the Map Directory is set, maps can be created. Dive on the appropriate Dimension or Dynamic Dimension, click on the Graph button in the toolbar, and select the desired map type.

**Setting DiveLine Preferences (ProDiver Only)**

The DiveLine Preferences tab changes the DiveLine server and password, and setting a Download Directory.

![Preferences](image)
Setting Diver Preferences...

- **Server** - Using the pulldown, you can type or choose the DiveLine server to connect to. Please contact the DiveLine administrator for the correct DiveLine server name.

- **Change Password** - Changes the DiveLine login password. If the password button is grayed out, contact the DiveLine administrator for password change permission.

- **Download Directory** - Changes which directory downloaded Models should be put into. Please note that this does not necessarily allow Model downloads. Download permission must also be granted by the DiveLine administrator.

Setting Default File Preferences (DI-Diver Only)

The Files tab sets default files and search paths to be used by DI-Diver. Please note that this tab is not available in ProDiver, but equivalent settings can be configured using the DiveLine administrative DI-Config utility. (see the DiveLine manual for more information)

- **Default DiveBooks** - Tells Diver to automatically open a default DiveBook file each time it is started. To set the Default DiveBook, click on the radio button next to DiveBook File. Type in the path and name of the DiveBook file, or click Browse to locate the file. After locating the DiveBook, click Open. More information about using DiveBooks can be found in Chapter 8, DiveBooks.
Diver will not open directly to the DiveBook set here, if Diver is started by double-clicking on a DivePlan, Marker, or Model. Instead it will open to the selected DivePlan, Marker, or Model.

- **Default Application Template** - Sets the default Application Template for Diver. When an Application Template is specified, Diver will always appear and behave as directed by the Application Template.

  More information about Application Templates can be found on page 13-1.

- **Search Path** - Specifies multiple paths for Diver to use when searching for data (Models, Lookups, etc.) opened by Markers and DivePlans. Diver will use the search paths in the order specified. This allows local saving of Markers while maintaining Models on a file server.
Appendix A
Command Line Options

Diver Command Line Options

Diver can specify commands to carry out in an unattended task in batch mode. The commands shown below are shown in the form used for Diver. To use the commands for ProDiver, change `diver.exe` to `prodiver.exe`. Use the rest of the command as shown, but include the full DiveLine path any time a filename is needed.

Cascade Print Commands

For more information about Cascade Print, please see page 3-18.

Table A-1: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
</table>
| `diver.exe -walk <QuickView> <quick-view marker>` OR `diver.exe -walk $ALL <marker>` | Cycles through all possible values of the named QuickView in the specified Marker.  
• A specific QuickView can be selected using `<QuickView>`, to cycle through that QuickView.  
• $ALL can be used to cycle through all QuickViews.  
• Output will be sent to the default printer unless the -pn option or the -pdf option is used. |
# Diver Command Line Options

## Diver Cascade Print Commands

Table A-1: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -skip_allvalues &lt;marker&gt;</code></td>
<td>Same as the <code>-walk</code> function above, but the <code>-skip_allvalues</code> causes the Diver to skip the “All Values” value for each QuickView.</td>
</tr>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -skip_blanks &lt;marker&gt;</code></td>
<td>Same as the <code>-walk</code> function above, except <code>-skip_blanks</code> allows the Diver to skip output of files if the Dive Window is empty.</td>
</tr>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -pdf &lt;marker&gt;</code></td>
<td>Specifies that the given Marker for each value of the QuickView should be output as a <code>.pdf</code> file. Same functionality as “Use Dimension Values for Filenames” in <em>Saving the Cascade to PDF on page 3-19.</em></td>
</tr>
</tbody>
</table>

- Each file will be named using the name of the QuickView plus the Dimension Values.
- Multiple QuickViews can be specified by separating them with commas.
- Filenames may look similar to this: `Sales Region=South.pdf`. 

---

Table A-2: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Table A-2: Diver Cascade Print Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Command</strong></td>
</tr>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -skip_allvalues &lt;marker&gt;</code></td>
</tr>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -skip_blanks &lt;marker&gt;</code></td>
</tr>
<tr>
<td><code>diver.exe -walk &lt;quickview&gt; -pdf &lt;marker&gt;</code></td>
</tr>
</tbody>
</table>

- Each file will be named using the name of the QuickView plus the Dimension Values.
- Multiple QuickViews can be specified by separating them with commas.
- Filenames may look similar to this: `Sales Region=South.pdf`. 

---

---

A-2
Table A-1: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
</table>
| `diver.exe -walk <quickview> -pdf# <marker>` | Performs the same functions as the `-pdf` option, except that the files are numbered instead of named. Same functionality as “Use Dimension Index for Filenames” in *Saving the Cascade to PDF on page 3-19*.  
  - Filenames may look similar to this:  
    Sales Region001.pdf. |
### Table A-1: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>diver.exe -walk $&lt;quickview&gt; -pdf_param $Dimension &lt;marker&gt;</td>
<td>Specifies that the Dimension Values be used to name the .pdf files. Same functionality as “Specify File-names” in [<em>Saving the Cascade to PDF on page 3-19</em>].</td>
</tr>
<tr>
<td></td>
<td>• The Dimension name is used as a variable by preceding it with a dollar sign ($) in order to use the values of the Dimension as the filenames.</td>
</tr>
<tr>
<td></td>
<td>• Dimension names that contain spaces, or characters other than letters, numbers, or the underscore character ( _ ), must be enclosed in parentheses.</td>
</tr>
<tr>
<td></td>
<td>• Filenames may look similar to this: Boston.pdf.</td>
</tr>
<tr>
<td>Example:</td>
<td>diver -walk “Sales Region” -pdf_param “C:\Output$(Sales Region).pdf” sales.mrk</td>
</tr>
<tr>
<td></td>
<td>would output files like “Far West.pdf” in the “C:\Output” directory.</td>
</tr>
</tbody>
</table>
### Table A-1: Diver Cascade Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>diver.exe -walk $&lt;quickview&gt; -pdf# -pdf_prefix &quot;prefix&quot; &lt;marker&gt;</code></td>
<td>Used with the <code>-pdf</code> or <code>-pdf#</code> options, this command will add a prefix to the beginning of the output filename. Same functionality as “Filename Prefix” area in Saving the Cascade to PDF on page 3-19.</td>
</tr>
<tr>
<td></td>
<td>• A prefix may contain a path (e.g., <code>-pdf_prefix &quot;C:\test&quot;</code>).</td>
</tr>
<tr>
<td></td>
<td>• Filenames may look similar to this: <code>test001.pdf</code>.</td>
</tr>
</tbody>
</table>


File Open Commands

Table A-2: Diver File Open Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>diver.exe &lt;marker&gt;</td>
<td>Opens the specified Marker in DI-Diver</td>
</tr>
<tr>
<td>diver.exe &lt;divebook&gt;</td>
<td>Opens the specified DiveBook in DI-Diver.</td>
</tr>
<tr>
<td>diver.exe &lt;diveplan&gt;</td>
<td>Opens the specified DivePlan in DI-Diver.</td>
</tr>
</tbody>
</table>

Marker Print Commands

Table A-3: Diver Marker Print Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>diver.exe -p &lt;marker&gt;</td>
<td>Opens the specified Marker and prints it using the default printer.</td>
</tr>
<tr>
<td>diver.exe -pn &lt;printername&gt; &lt;marker&gt;</td>
<td>Opens the specified Marker and prints it using the specified printer.</td>
</tr>
<tr>
<td>diver.exe -g -split_separate &lt;marker&gt;</td>
<td>Opens the specified Marker containing a split window and prints the two halves separately.</td>
</tr>
<tr>
<td>diver.exe -g -split_each_page &lt;marker&gt;</td>
<td>Opens the specified Marker containing a split window and prints every page of the output as a split page.</td>
</tr>
</tbody>
</table>
## Output Commands

### Table A-4: Diver Output Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
</table>
| `diver.exe -w outputfile <marker>` | Opens the specified Marker and performs the Save Window command on it, saving to the specified output file. In `outputfile`, an extension of:  
  - csv will save a file with comma-separated values.  
  - txt will save a tab-delimited text file.  
  - dbf will save a DBF format file.  
  - htm or html will save an HTML file.  
  - pdf will save an Adobe Acrobat file.  
  - xml will save an Extensible Markup Language file. |
| `diver.exe -wnt outputfile <marker>` | Performs the same functions as `-w`, but omits calculating totals. |
| `diver.exe -v outputfile.txt` | Puts Diver’s version number into the specified file. |
| `diver.exe -save_model <model_name> <diveplan_file>` | Opens `<diveplan_file>` and saves a Model with `<model_name>`. The DivePlan file does not have to be a DivePlan. It can be a Tunnel file, a Marker, or anything that will allow you to save a Model. |
Permit Commands

Diver can open a permit file associated with a password-protected Model on the command line.

Table A-5: Diver Permit Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>diver.exe -&lt;permit_file&gt;</code></td>
<td>For use when opening password-protected Models. Note: the password/permit functionality is deprecated.</td>
</tr>
</tbody>
</table>
ProDiver Commands

Table A-6: Diver ProDiver Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>prodiver.exe -S &lt;servername&gt;</td>
<td>Opens ProDiver and connects to the specified DiveLine server. Useful in a shortcut.</td>
</tr>
<tr>
<td>prodiver.exe -login &lt;username&gt; &lt;password&gt;</td>
<td>Opens ProDiver and connects to the DiveLine server using the given username and password. Useful in a shortcut.</td>
</tr>
</tbody>
</table>

QuickView Commands

Table A-7: Diver QuickView Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>diver.exe -qv quickview_name &lt;value&gt;</td>
<td>Provides a value for a prompted QuickView.</td>
</tr>
</tbody>
</table>

Registration Commands

Table A-8: Diver Registration Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>diver.exe -r</td>
<td>Opens a registration dialog box allowing you to browse to the license required for limited versions of Diver. Please note that this command ONLY works in limited versions of Diver.</td>
</tr>
</tbody>
</table>
Appendix B

diver.ini File

The diver.ini file is a Diver configuration file that stores some settings and preferences for the Diver and ProDiver software as parameters with the format `string=value`. Settings and preferences are automatically captured by the software and stored in the diver.ini file; however, additional parameters can be specified. The tables in this appendix include each parameter string in bold type, followed by a description of valid string values for that parameter. The application defaults are used if parameters are not specified in the diver.ini file.

By default, the diver.ini file is located in `C:\Windows`, but it can be moved to other locations.

On Windows 7, in addition to the copy in `C:\Windows`, there may also be a copy in `C:\Users\username\AppData\Local\VirtualStore\Windows`. These copies are kept harmonized, so the copy in `C:\Windows` should match the latest modified version in any of the VirtualStore locations.

ProDiver and Diver look in the following locations in the following order for an existing diver.ini:

- The user profile location, for example:
  ```
  C:\Documents and Settings\username\Application Data\Dimensional Insight\diver.ini
  ```
- The directory the diver executable is located in, for example:
  ```
  C:\DI_ProDiver\diver.ini
  ```
- The Windows directory location, for example:
  ```
  C:\Windows
  ```

The following should be considered.

- If a diver.ini file is not found in any of the above locations, Diver attempts to create one in `C:\Windows`. If that fails, it puts it in `C:\Documents and Settings\username\Application Data\Dimensional Insight`. 
- In Windows Vista and higher, and in UAC (User Account Control) enabled systems, attempted writes to `C:\Windows` with insufficient privilege, including Administrative users who are not running Diver as an Administrator, are quietly redirected by Windows to a per-user application data area (`C:\Users\username\AppData\Local\Virtual\Store\Windows`). Therefore the write will not fail, and Diver will not put `diver.ini` in Application Data as it would have previously done.

- With the UAC redirection feature, you can load `C:\Windows\diver.ini` into a text editor and see your local copy (The copy in `C:\Users\username\AppData\Local\Virtual\Store\Windows`), rather than the actual file. This means different users will see different `diver.ini` files specific to their machine.

- Installing a system-wide `diver.ini` file must be deliberate. Previously you could run Diver as an Administrator and your `diver.ini` would be saved in `C:\Windows` and be available to all users.

### Diver.ini Options

The `diver.ini` file contains various options, including:

- Dive Window options ([page B-3](#))
- File Menu options ([page B-4](#))
- Chart & Graph options ([page B-6](#))
- Report options ([page B-8](#))
- Map options ([page B-10](#))
- Find options ([page B-11](#))
- Help options ([page B-12](#))
- Miscellaneous options ([page B-13](#))

Options are described in the following tables.
# Diver Window Options

## Table B-1: Diver Window .ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoClose</td>
<td>Integer - Indicates the number of Models at which Diver will automatically start closing Models.</td>
</tr>
<tr>
<td>console_left_placement</td>
<td>TRUE or FALSE - Controls whether the Console window appears docked on the right or left side of the main window. True means it is docked on the left. False is the default.</td>
</tr>
<tr>
<td>ConsoleWidth integer</td>
<td>Lists the width of the Console, in pixels.</td>
</tr>
<tr>
<td>ConstantColumns</td>
<td>TRUE or FALSE - Determines whether you can adjust column width. The default is False.</td>
</tr>
<tr>
<td>Default Font</td>
<td>3-item string - Specifies the font name, font size, and font flags of user-defined fonts. The default is Arial,8,0.</td>
</tr>
<tr>
<td>Default Number Decimals</td>
<td>“Default” or 0 – 9 - Specifies the number of decimals to display in a new column to add to a tabular. The default is 2.</td>
</tr>
<tr>
<td>DiveBook_Title</td>
<td>String - A default title for DiveBooks. Only read if the application does not have a default name coded into the DiveBook.</td>
</tr>
<tr>
<td>Diver_Main_Window_Pos_H</td>
<td>Integer - The horizontal position the Diver window should be placed at when it next opens. Set when Diver exits.</td>
</tr>
<tr>
<td>Diver_Main_Window_Pos_V</td>
<td>Integer - The vertical position the Diver window should be placed at when it next opens. Set when Diver exits.</td>
</tr>
<tr>
<td>Diver_Main_Window_Size_H</td>
<td>Integer - Specifies the horizontal window size of the Diver window when it is next opened. Set when the Diver exits.</td>
</tr>
<tr>
<td>Diver_Main_Window_Size_V</td>
<td>Integer - Specifies the vertical window size of the Diver window when it is next opened. Set when the Diver exits.</td>
</tr>
<tr>
<td>Diver_Maximize</td>
<td>TRUE or FALSE - Sets whether the Diver should be opened in Maximized state or not. True if it should be maximized, False otherwise. Set when the Diver exits.</td>
</tr>
</tbody>
</table>
### Table B-1: Diver Window .ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>enable_window_frame</code></td>
<td>TRUE or FALSE - Allows window resize. The default is True.</td>
</tr>
<tr>
<td><code>parent_child_match</code></td>
<td>TRUE or FALSE.</td>
</tr>
<tr>
<td><code>window_placement</code></td>
<td>Overlapped or Stacked - Sets whether new Diver windows will appear stacked or overlapped in the display area. Any value other than “stacked” will be read as “overlapped”. The default is stacked.</td>
</tr>
</tbody>
</table>

### File Menu Options

### Table B-2: File Menu Diver Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Default Application Template</strong></td>
<td>Pathname string - Complete path name to a default application template. No value or a blank string is the same as selecting the “None” value.</td>
</tr>
<tr>
<td><strong>Default DiveBook</strong></td>
<td>Pathname string - Complete pathname to a default DiveBook. No value is the same as selecting the “None” radio button in Preferences.</td>
</tr>
<tr>
<td><strong>Default Extension</strong></td>
<td>Extension string (mdl, dvp, mrk, dbk, ref, *). This is the file extension that the File &gt; Open dialog box will list by default.</td>
</tr>
<tr>
<td><strong>Download_Directory</strong></td>
<td>Pathname string - Complete pathname to the Model download directory.</td>
</tr>
<tr>
<td><strong>ProDiver Application Template</strong></td>
<td>Pathname string - Complete pathname to a default application template. No value or a blank string is the same as selecting the “None” value.</td>
</tr>
<tr>
<td><strong>ProDiver_Recent[1-5]</strong></td>
<td>Pathname strings - Paths to the last five files opened in ProDiver. These are normally displayed in the File menu. Set when a file is opened or saved.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Recent[1-5]</td>
<td>Pathname strings - Paths to the last five files opened in DI-Diver. These are normally displayed in the</td>
</tr>
<tr>
<td></td>
<td>File menu. Set when a file is opened or saved.</td>
</tr>
</tbody>
</table>
# Chart & Graph Options

## Table B-3: Chart & Graph `diver.ini` Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CrossDataColumn</td>
<td>Summary Column - The Summary column last used in the creation of a CrossPlot.</td>
</tr>
<tr>
<td>CrossDimension</td>
<td>Dimension - The Dimension last used in the creation of a CrossPlot.</td>
</tr>
<tr>
<td>CrossObjectType[1-16]</td>
<td>Bar, Line, or Point - Indicates whether the specified row should appear in the CrossPlot as a Bar, Line, or Point.</td>
</tr>
<tr>
<td>CrossRow[1-16]</td>
<td>Dimension Value - The Dimension Value last used in the specified row of a CrossPlot.</td>
</tr>
<tr>
<td>Default_DOW</td>
<td>Sunday-Saturday - Specifies which day of the week should appear in the first column of a Calendar plot. The default is Sunday.</td>
</tr>
<tr>
<td>Default_Graph_Background_Color</td>
<td>RRGGBB values - The default background color that will be used in any graph. Each of RR, GG, &amp; BB is a hex value from 00-FF (e.g., “00ffff”).</td>
</tr>
<tr>
<td>Default_Graph_Foreground_Color</td>
<td>RRGGBB values - The default foreground color that will be used in any graph. Each of RR, GG, &amp; BB is a hex value from 00-FF (e.g., “00ffff”).</td>
</tr>
<tr>
<td>Default_Graph_Font</td>
<td>3-item string - Specifies the font name, font size, and font flags (e.g., “Arial,-11,0”) used in graphs.</td>
</tr>
<tr>
<td>Default_Graph_Label_Font</td>
<td>3-item string - Specifies the font name, font size, and font flags (e.g., “Arial,-11,0”) used in graphs labels.</td>
</tr>
<tr>
<td>Graph_Lines</td>
<td>TRUE or FALSE - Specifies whether or not to show graph lines.</td>
</tr>
<tr>
<td>Label_Color</td>
<td>RRGGBB value - The default color that will be used for labels. Each of RR, GG, &amp; BB is a hex value from 00-FF (e.g., “00ffff”).</td>
</tr>
<tr>
<td>LinearAxis[1-2]</td>
<td>Left or Right - Indicates whether the specified axis appears on the left or right side of a graph. 1 indicates left, 2 indicates right.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LinearDataColumn[1-16]</td>
<td>Summary Column - The Summary Column last used in the specified row of a Linear plot.</td>
</tr>
<tr>
<td>PieDataColumn</td>
<td>Summary Column - The Summary column last used in the creation of a Pie plot.</td>
</tr>
<tr>
<td>plotcolor[0-15]</td>
<td>RRGGBB values - The colors that will be used in any graphs. Each of RR, GG, &amp; BB is a hex value from 00-FF (e.g., “00ffff”).</td>
</tr>
<tr>
<td>plottpattern[0-15]</td>
<td>Integer 0-15 - Specifies the plot pattern desired for each value in plots.</td>
</tr>
<tr>
<td>ScatterX1DataColumn</td>
<td>Summary Column - The Summary column last used on the first X-axis in the creation of a Scatter plot.</td>
</tr>
<tr>
<td>ScatterY1DataColumn</td>
<td>Summary Column - The Summary column last used on the first Y-axis in the creation of a Scatter plot.</td>
</tr>
<tr>
<td>ScatterX2DataColumn</td>
<td>Summary Column - The Summary column last used on the second X-axis in the creation of a Scatter plot.</td>
</tr>
<tr>
<td>ScatterY2DataColumn</td>
<td>Summary Column - The Summary column last used on the second Y-axis in the creation of a Scatter plot.</td>
</tr>
<tr>
<td>StackDataColumn</td>
<td>Summary Column - The Summary column last used in the creation of a Stack plot.</td>
</tr>
<tr>
<td>StackDimension</td>
<td>Dimension - The Dimension last used in the creation of a Stack plot.</td>
</tr>
<tr>
<td>Use_Label_Color</td>
<td>TRUE or FALSE - Specifies the color of row and column labels in a Dive Window. If True, then use a defined custom color. The color is defined as an RRGGBB in the Label_Color parameter.</td>
</tr>
</tbody>
</table>
Report Options

All Report parameters are based on the last used setting in Diver.

Table B-4: Report diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report_Default_2level_mult</td>
<td>Tabular MultiTab, Paged MultiTab, or Indented 2 Level MultiTab - The default Report Style selected for two-level MultiTab Reports.</td>
</tr>
<tr>
<td>Report_Default_Crosstab</td>
<td>Basic CrossTab - The default Report Style selected for CrossTab Reports.</td>
</tr>
<tr>
<td>Report_Default_Date</td>
<td>TRUE or FALSE - Indicates whether or not the Date check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Fitpage</td>
<td>TRUE or FALSE - Indicates whether or not the Fit to Page check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Footer</td>
<td>TRUE or FALSE - Indicates whether or not the Include Print Footer check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Gridlines</td>
<td>TRUE or FALSE - Indicates whether or not the Gridlines check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Header</td>
<td>TRUE or FALSE - Indicates whether or not the Include Print Header check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Page_Numbe  rs</td>
<td>TRUE or FALSE - Indicates whether or not the Page Numbers check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Parents</td>
<td>TRUE or FALSE - Indicates whether or not the Include Parent Info check box is checked by default in the Default Report dialog box.</td>
</tr>
<tr>
<td>Report_Default_Screen</td>
<td>TRUE or FALSE - If true, then the Report Palette will default to screen reports.</td>
</tr>
<tr>
<td>Report_Default_Subtotal_Non e</td>
<td>TRUE or FALSE - Indicates whether or not subtotals are included in relevant default reports.</td>
</tr>
</tbody>
</table>
### Table B-4: Report diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report_Default_Subtotal_Top</td>
<td>TRUE or FALSE - If subtotals are included in a default report, indicates where they should appear. If TRUE, subtotals will appear at the top, if FALSE, they will appear at the bottom.</td>
</tr>
<tr>
<td>Report_Default_Total_Top</td>
<td>TRUE or FALSE - Indicates where totals should appear in a report. If TRUE, totals will appear at the top, if FALSE, they will appear at the bottom.</td>
</tr>
</tbody>
</table>
# Map Options

## Table B-5: Map diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MapDataColumn</td>
<td>Summary Column - The Summary Column last used for map creation.</td>
</tr>
<tr>
<td>Map_Directory</td>
<td>Pathname string - Complete path to the map data directory.</td>
</tr>
<tr>
<td>Map_Folder</td>
<td>Pathname string - Name of the current default map folder. This is the name of a subdirectory of mapdata.</td>
</tr>
<tr>
<td>state_auto_zoom</td>
<td>TRUE or FALSE - TRUE for “Auto zoom on background layer”. FALSE for “Auto zoom on top layer” in Preferences.</td>
</tr>
</tbody>
</table>
Find Options

All Find parameters are based on the last used setting in Diver.

Table B-6: Find diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>FindString[0-9]</code></td>
<td>String - Specifies the previous 10 values [0-9] entered into the Find dialog box text box.</td>
</tr>
<tr>
<td><code>FindStringFindOthers</code></td>
<td>0 or 1 - Indicates whether the Find Others check box is selected by default. 0 means that it is not checked, 1 means that it is checked.</td>
</tr>
<tr>
<td><code>FindStringFocus</code></td>
<td>0 or 1 - Indicates whether the Focus check box is selected by default. 0 means that it is not checked, 1 means that it is checked.</td>
</tr>
<tr>
<td><code>FindStringGroup</code></td>
<td>0 or 1 - Indicates whether the Group check box is selected by default. 0 means that it is not checked, 1 means that it is checked.</td>
</tr>
<tr>
<td><code>FindStringNumFirst</code></td>
<td>Integer - Indicates whether the Find First “n” items radio button is selected by default. The Integer specifies the number of “n” items to be found.</td>
</tr>
<tr>
<td><code>FindStringNumLast</code></td>
<td>Integer - Indicates whether the Find Last “n” items radio button is selected by default. The Integer specifies the number of “n” items to be found.</td>
</tr>
<tr>
<td><code>FindStringOptions</code></td>
<td>0 or 1 - Indicates whether the Options area of the Find dialog box is collapsed or expanded by default. 0 means that it is collapsed, 1 means that it is expanded.</td>
</tr>
<tr>
<td><code>FindStringSave</code></td>
<td>0 or 1 - Indicates whether the Save in Marker check box is selected by default. 0 means that it is not checked, 1 means that it is checked.</td>
</tr>
</tbody>
</table>
## Help Options

**Table B-7: Help diver.ini Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Help File</strong></td>
<td>Pathname string - Complete path to any Diver help file that is in text format.</td>
</tr>
<tr>
<td><strong>PDF Help File</strong></td>
<td>Pathname string - Complete path to the location of the PDF help file. If this preference does not exist, the PDF help option will be removed from the Help menu.</td>
</tr>
<tr>
<td><strong>PDF Tutorial File</strong></td>
<td>Pathname string - Complete path to the location of the PDF tutorial file. If this preference does not exist, the PDF tutorial option will be removed from the Help menu.</td>
</tr>
<tr>
<td><strong>ProDiver PDF Help File</strong></td>
<td>UNC Pathname string - Complete path to the location of the PDF help file. If this preference does not exist, the PDF help option will be removed from the Help menu.</td>
</tr>
<tr>
<td><strong>ProDiver PDF Tutorial File</strong></td>
<td>UNC Pathname string - Complete path to the location of the PDF tutorial file. If this preference does not exist, the PDF tutorial option will be removed from the Help menu.</td>
</tr>
</tbody>
</table>
# Miscellaneous Options

Table B-8: Miscellaneous diver.ini options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Application Name</strong></td>
<td>String - This value changes the name that is displayed in the title bar of the DI-Diver window.</td>
</tr>
<tr>
<td><strong>HideDivePlanWarnings</strong></td>
<td>TRUE or FALSE - True means that common DivePlan warnings should be hidden when a DivePlan is opened.</td>
</tr>
<tr>
<td><strong>ProDiver Application Name</strong></td>
<td>String - This value changes the name that is displayed in the title bar of the ProDiver window.</td>
</tr>
<tr>
<td><strong>Picklist_Color</strong></td>
<td>RRGGBB value - The default color that will be used for Picklists. Each of RR, GG, &amp; BB is a hex value from 00-FF (i.e., “00ffff”).</td>
</tr>
<tr>
<td><strong>ProductID</strong></td>
<td>String - Registration key for Diver.</td>
</tr>
<tr>
<td><strong>Use_Picklist_Color</strong></td>
<td>TRUE or FALSE - If True, then use a custom color for the picklist. The color is defined as an RRGGBB value in the Picklist_Color parameter.</td>
</tr>
</tbody>
</table>
## DiveLine Server

**Table B-9: DiveLine Server diver.ini Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Default Server Path</strong></td>
<td>Pathname string - This specifies the Default Server Path. It will have the form of “&lt;server&gt;:&lt;path&gt;.” This string is used by the File Open and File Save dialog boxes. If any files have been opened or a home directory has not been defined, the dialog box should open to this path instead. It is set every time the File Open or File Save dialog box successfully opens or saves a file.</td>
</tr>
<tr>
<td>DiveLine[1-4]</td>
<td>Strings - The names and optional port numbers of the last four DiveLine servers connected to.</td>
</tr>
<tr>
<td>DI-DiveLine</td>
<td>String - IP name/address of the DiveLine server that was last connected to. Set when a connection with any server is successful.</td>
</tr>
<tr>
<td>DI-Config Server</td>
<td>Server name string - The last server to which the application was connected. It will try to open this server by default the next time it is launched. Set when DI-Config successfully connects to a server.</td>
</tr>
<tr>
<td>DI-Controller Server</td>
<td>Server name string - The last server to which the application was connected. It will try to open this server by default the next time it is launched. Set when Controller successfully connects to a server.</td>
</tr>
<tr>
<td>DI-Scheduler Server</td>
<td>Server name string - The last server to which the application was connected. It will try to open this server by default the next time it is launched. Set when Scheduler successfully connects to a server.</td>
</tr>
<tr>
<td>DI-Scheduler Default Subject</td>
<td>Subject string - The default subject line that appears in the dialog box. Set any time the subject field is changed in the edit job dialog box, and click OK. When editing a job, the subject that will appear will be that of the job, and will not necessarily be the default. If that item is not edited, then no new preference will be saved.</td>
</tr>
</tbody>
</table>
### Table B-9: DiveLine Server diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DI-Scheduler Default Destination EMail Addresses</td>
<td>E-mail string - The default e-mail address that appears in the dialog box. Set any time the e-mail field is changed in the edit job dialog box, and click OK. When editing a job, the e-mail that will appear will be that of the job, and will not necessarily be the default. If that item is not edited, then no new preference will be saved.</td>
</tr>
<tr>
<td>DI-Server</td>
<td>String - IP name/address of the default DiveLine server. Set when a connection with any server is successful. The last server connected to will be the default when the client restarts.</td>
</tr>
<tr>
<td>Server[1-4]</td>
<td>Strings - The names and optional port numbers of the last four DiveLine servers connected to. These appear, in order, in the ProDiver File &gt; Preferences &gt; DiveLine tab Server pulldown.</td>
</tr>
<tr>
<td>Update_ADDR</td>
<td>Web address string - The web server that DiveLine attempts to download updates from.</td>
</tr>
</tbody>
</table>
## Other Server References

### Table B-10: Other Server diver.ini Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fallback</strong></td>
<td>True or False - Whether to allow a fallback or not with the database server declared in the “server” preference. False means it will not be used.</td>
</tr>
<tr>
<td><strong>Prefix</strong></td>
<td>String - Prefix associated with the db server declared in the “server” preference.</td>
</tr>
<tr>
<td><strong>Server</strong></td>
<td>String - Name of a database server to be accessed.</td>
</tr>
<tr>
<td><strong>Timeout</strong></td>
<td>Positive integer - Timeout on the database server name declared in the “Server” preference.</td>
</tr>
</tbody>
</table>
Example

A short example of a diver.ini file is presented below:

[Diver]
Default Extension=mdl
HideDivePlanWarnings=True
Recent1=c:\di_users\models\demo_drl.mdl
AutoClose=5
window_placement=stacked
enable_window_frame=true
Diver_Maximize=TRUE
Diver_Main_Window_Size_H=768
Diver_Main_Window_Size_V=558
Diver_Main_Window_Pos_H=306
Diver_Main_Window_Pos_V=166
Map_Directory=C:\DI_Diver\mapdata
Map_Folder=US_Map_Files_200505
console_left_placement=false
PDF Help File=C:\DI_Solution\Documentation\Diver64.pdf
ConsoleWidth=231
Default_Graph_Background_Color=eeeeee
Default_Graph_Foreground_Color=ffffff
Default_Graph_Font=Arial(variable,swiss),8.000000
Default_Graph_Label_Font=Arial(variable,swiss),8.000000
Default_Font=Arial(variable,swiss),8.000000
Use_Label_Color=FALSE
Label_Color=66ffb3
ConstantColumns=true
Use_Picklist_Color=TRUE
Picklist_Color=ffffff
Default_Number_Decimals=6
DIVER
Appendix C
Report Text Variables

Report Text Variables can be used in Diver Reports and Report Palettes. The variable name must be in all capital letters, prefaced with a dollar sign ($), and a space must follow a Text Variable in order for Diver to differentiate it from other text. Available Text variables are:

- **$BUILD_DATE** - Will be replaced with the date the Model being used in the Report, or the last Model in a DivePlan, was created. The $BUILD_DATE Text Variable can include an argument specifying which Model’s build date should be used. This example shows the path (C:\DI-Diver) and Model name (demo_drl.mdl): $BUILD_DATE(C:\DI-Diver\demo_drl.mdl).

- **$BUILD_TIME** - Will be replaced with the time the Model being used in the Report, or the last Model in a DivePlan, was created. The $BUILD_TIME Text Variable can include an argument specifying which Model’s build time should be used. This example shows the path (C:\DI-Diver) and Model name (demo_drl.mdl): $BUILD_TIME(C:\DI-Diver\demo_drl.mdl).

ProDiver uses the DiveLine path for the $BUILD_DATE and $BUILD_TIME items.

- **$COMMENTS** - Will be replaced with any comments that were put into the Model being used when the Model, or the first listed Model in a DivePlan, was created.

- **$CURRENT** - Will be replaced with the current period when using Period Comparison.

- **$DATE** - Will be replaced with today’s date. Using $DATE will always find the current date in a Report. This date is the client machine’s system date. If the Text Variable $DATE is followed by a date format in parentheses, then the date will be formatted as specified.
• **SDAY** - Will be replaced with today’s day of the week (e.g., Tuesday). Using SDAY will always find the **current day of the week** in a Report. This day is based on the client machine’s system date.

Text Variables cannot be used in Report Palette cells directly, but those above can be used in Preceding or Trailing Text items in the Edit Item dialog box Text Tab, in order to have them appear in the Palette. These Text Variables can also be placed in the Preceding or Trailing text items for the Report view.

• **$DIMNAME(n)** - Will be replaced with the Dimension Name of the nth Dimension. The order that the Dimensions were added to the MultiTab before switching to a Report will determine n, starting from the left.

The following report is used to demonstrate $DIMNAME(n). The Report was created by making a MultiTab starting with Quarter, adding Sales Region, and then adding Product Family. The display was then changed to show a Tabular MultiTab.
If the Text Variable SDIMNAME(1) is added to the Report shown above, at the head breaklevel, the result will look like this (notice the first Dimension name Quarter is displayed in the header):

If the Text Variable SDIMNAME(3) is added to the Report shown above, at the head breaklevel, the result will look like this (notice the third Dimension name Product Family is displayed in the header):

• **SDIMVAL(n)** - Will be replaced with the Value of the nth Dimension, at the breaklevel where the Text Variable is added. The order that the Dimensions were added to the MultiTab, before switching to a Report, will determine n, starting with the first. This is most useful at the smallest breaklevel.

If the text item SDIMVAL(1) is added to the Report shown above, at the Product Family breaklevel, the result will look like this (notice the first Dimension Value for Quarter is displayed in the header):
If the Text Variable $DIMVAL(3)$ is added to the Report shown above, at the Product Family break level, the result will look like this (notice the first Dimension Value for Product Family is displayed in the header):

- **$EXTRACT_DATE$** - Will be replaced with the date that the input data used to build the Model was extracted from the source data. This variable only returns a value when the extract_date attribute was used in the Model build.

- **$EXTRACT_TIME$** - Will be replaced with the time that the input data used to build the Model was extracted from the source data. This variable only returns a value when the extract_time attribute was used in the Model build.

- **$FIND_COLUMN$** - In a Report in which the Find function was used, will be replaced by the name of the column on which the search was performed. If the Find function was not used, this Text Variable will contain nothing. For example, if a Find was done for Revenue Total between 1,000 and 4,000, $FIND_COLUMN$ would be replaced with Revenue Total.

- **$FIND_DATE_FROM$** - In a Report in which the Find function was used on a date field, will be replaced by the value entered as the beginning of the search range. If the Find function was not used, this Text Variable will contain nothing. The result will be formatted as a date.

- **$FIND_DATE_TO$** - In a Report in which the Find function was used on a date field, will be replaced by the value entered as the end of the search range. If the Find function was not used, this Text Variable will contain nothing. The result will be formatted as a date.

- **$FIND_HIGH$** - In a Report in which the Find function was used, will be replaced by the value entered as the high end of the search range. If the Find function was not used, this Text Variable will contain nothing. For example, if a Find was done for Revenue Total between 1,000 and 4,000, $FIND_HIGH$ would be replaced with 4,000.

- **$FIND_LOW$** - In a Report in which the Find function was used, will be replaced by the value entered as the low end of the search range. If the Find function was not used, this Text Variable will contain nothing. For example, if a Find was done for Revenue Total between 1,000 and 4,000, $FIND_LOW$ would be replaced with 1,000.
- **$FIND_PERIOD_FROM** - In a Report in which the Find function was used on a period, will be replaced by the value entered as the beginning of the search range. If the Find function was not used, this Text Variable will contain nothing. The result will be formatted as a period.

- **$FIND_PERIOD_TO** - In a Report in which the Find function was used on a period, will be replaced by the value entered as the end of the search range. If the Find function was not used, this Text Variable will contain nothing. The result will be formatted as a period.

- **$FOOTER** - Will be replaced with the text that has been entered as a page footer in the Page Setup dialog box.

- **$HEADER** - Will be replaced with the text that has been entered as a page header in the Report > Page Setup dialog box.

- **$INFONAME(n)** - Will be replaced with the Info Field Name of the nth Info Field. The order that the Info Fields were added to the tabular display determines n, starting with the first.

- **$INFOVAL(n)** - Will be replaced with the Value of the nth Info Field, at the breaklevel where the Text Variable is added. The order that the Info Fields were added to the tabular display determines n, starting with the first. This Text Variable is most useful at the smallest breaklevel.

- **$LONGDATE** - Displays the current date in the format Day, Month Day, Year. For example, Friday, July 1, 2011.

- **$MAXPAGE** - Will be replaced with the last page number in the Report. This is useful when labeling pages in the manner of “Page 1 of 10”. To have that style of page number, the text dialog box would contain the following: *Page $PAGE of $MAXPAGE.*

- **$MODEL_FOOTER** - Will be replaced by the text of the Model footer (or the footer from the last Model in a DivePlan), as set by the Builder (not to be confused with $FOOTER, which is the footer set in the Page Setup dialog box of Diver).

- **$MODEL_NAME** - Will be replaced with the name of the Model being used in the Report, or by the name of the last Model in a DivePlan. The $MODEL_NAME Text Variable can include an argument specifying which Model’s name should be used. Note that the file name of a Model may be different than the Model’s name that appears in the Diver Console when DiveMaster is used. This example is showing the path (C:\DI-Diver) and Model name (demo_drl.mdl): $MODEL_NAME(C:\DI-Diver\demo_drl.mdl)
• **$MODELVAR(variable name)** - Is from the Builder attribute model_var, which is an array of substrings, one for each user-defined Text Variable to be defined in the Model. Each substring consists of a variable name, an equals sign, and the value of the variable. To reference these variables in Diver, use $MODELVAR(variable name) in Report or Report Palette data items of type Text.

• **$PAGE** - Will be replaced on each page of the Report with the current page number.

• **$PRIOR** - Will be replaced with the previous period when using Period Comparison.

• **$<quickview_name>** - Allows you to populate text items with Quick View selections.

• **$QVVAL(quickview_name)** - Allows you to add QuickView labels to a Report.

• **$QVVAL(Time Series quickview_name)** - Allows you to add Time Series QuickView labels to a Report.

• **$ROW** - Will be replaced with the row number for the current cell.

• **$SHORTDATE** - Will be replaced with the current date in the format MM/DD/YYYY; for example, 7/1/2011.

• **$SORT_COLUMN** - Will indicate, in a Report, on which column the data is sorted. This feature is particularly useful for multi-page Reports, where the sort column may not otherwise be obvious. The Report must be locked for $SORT_COLUMN to display properly.

• **$SUMNAME(n)** - Will be replaced with the name of the nth Summary. The order that the Summaries appear when the display was switched to a Report determines n, starting with the first. For example, if the text item “$SUMNAME(1)” is added to the Report shown below, at the head breaklevel, the result will look like this:
• **$SUMVAL(n,B)** - Will be replaced with the Total for the breaklevel determined by B, for Summary n. If “0” is used for B, the value displayed will be the Grand Total for the specified Summary. If “1” is used for B, the value displayed will be the total at the first breaklevel for the specified Summary. The following Report will be used to demonstrate the $SUMVAL. A text item “$SUMVAL(2,0)” is added to the Report shown below at the Page breaklevel. This example specifies the second Summary, Cost, at the zero breaklevel, which is the grand total of the full Report. Scrolling to the Totals line shows the numbers match: 714,715,545.94. The result looks like this:

![Report Example]

• **$TIME** - Will be replaced with the current time, and operates the same way the $DATE function does. This time is based on the client computer’s system time.

• **$TOTAL_STRING** - Will be replaced with current total.

• **$USER** - Will be replaced with the current DiveLine user in ProDiver. Displays the current Windows user in Diver.

• **$XTAB_DIMENSION** - Will be replaced with the name of the Dimension field used for the CrossTab. For example, if a CrossTab Report of Product and Month with the Summary Actual Dollars Total is displayed as a Report, $XTAB_DIMENSION would be replaced with Month.

• **$XTAB_ELEMENT** - Will be replaced with the name of the Summary used for the CrossTab. For example, if a CrossTab report of Product and Month with the Summary Actual Dollars Total is displayed as a Report, $XTAB_ELEMENT would be replaced with Actual Dollars Total.
DIVER
Index

Commands

.bmp 6-35
.csv 3-6
.dbf 3-6
.dbk 1-12, 1-15, 2-6
.dic 2-4
.dlk 1-15
.dvp 1-12, 1-16, 2-5, 9-1
gtpl 1-16, 5-98
.html 3-6
.ini 1-16
   Options for 13-13
.jou 2-4
.jpg 6-35
.log 2-4
.md0 1-16
.mdl 1-11, 1-16, 2-4, 2-5
.mk 1-13, 1-16, 2-5, 3-7, 3-8
.pdf 3-6, 3-19
.png 6-35
.qvs 1-16, 2-8
.ref 1-16, 2-7
.rep 1-17, 6-61
.tab 3-6
.tnl 1-17, 2-8
.tpl 1-17, 2-38, 3-53, 13-1, 13-6
.xml 3-7
% Count 9-8
% Total 9-6
$ variables C-1
$COL in Report Palettes 11-36

$INTVAL in Report Palettes 11-36
$NUMVAL in Report Palettes 11-36
$QV in Report Palettes 11-36
$QV in Report Palettes 11-36
$SUM in Report Palettes 11-36
$VAL in Report Palettes 11-36

Numerics

2 Level Indented MultiCrossTab Report 6-11
2 Level Tabular MultiCrossTab Report 6-12

A

About Diver 3-54
About Graphical Displays 5-82
Absolute Cell Reference 11-35
Access Control Lists 2-20
ACL 2-20
Add
   Column
to Report 6-21
DimCount Column 9-27
Dimensions 3-26
   Date Roll-Up 9-55
DiveBook Area 8-6
Links 8-7
Lookup Table 9-63
QuickViews 3-38
   in Report Palette 11-49
Index-2

DIVER

Report Item 6-23
Report Palette Image 11-57
Add Column... 4-16
Add-On Labels 5-93
Adding Info Fields Using a Lookup Table 9-63
Advanced Find
  overview of QVVAL function 7-68
Alias 12-9
Alternate Sort 3-46
Always Sum Total 9-10
Appearance 13-11
Application Template 2-43, 13-1
  Activation of 13-7
  Definition of 1-10
  Full Diver 13-3
  Limited Diver 13-3
  Modify Menus 13-3
  Modify Preferences 13-5
  Modify Toolbar 13-4
  New Template 13-2
  Use of 3-38, 13-2
Area
  Definition of 1-10
Area Plot 5-13
Area Spline Plot 5-14
Areas in a DiveBook 8-2
ASCII File 1-5, 3-6
Auto Close Model 13-8
Auto-Set Top-to-bottom Dependencies
  QuickView editing option 7-55
Average 9-6
Axes 5-84
Axis label 5-85

B

Background Color
  in Reports 6-23
Bar Plot 5-12
Basic MultiCrossTab Report 6-9
Basic Plots 5-6, 5-7
  Area Plot 5-7
Example of 5-13
Area Spline Plot 5-7
  Example of 5-14
Bar Plot 5-7
  Example of 5-12
Line Plot 5-7
  Example of 5-12
Linear Bubble Plot 5-15
  Example of 5-15
Point Plot 5-7
  Example of 5-13
Spline Plot 5-7
  Example of 5-14
Binomial Distribution 5-33
Border Tab 6-43
  Background Color 6-43
  Cell Border 6-43
  Reports 6-43
Breaklevel 6-4
  in a Report 6-4
Breaklevel Tab 6-37
  Breaklevel 6-38
    in Reports 6-38
    Threshold 6-38
Breaklevel Threshold Lines
  in Reports 6-23
Build Model 12-2
  Alias 12-9
  Bucket File 2-4
  Build Journal (.jou) 2-4
  Build Log (.log) 2-4
  Building a Model From a Text File 12-4
  Building a Model from ODBC 12-12
  Date Format 12-10
  Dictionary File (.dic) 2-4
  Lookup Table 12-10
  Sort By 12-10
  String 12-10
  Builder 1-5
  Building a Model 3-22
C

Cache Lock 11-4
Calculations
   Creation of 9-13
   Definition Tab 9-4
   CrossTab Columns in Other Tabulars 9-40
   Definition 9-5
   Dimensions in Calculations 9-31
   Filtered DimCounts 9-28
Model Columns 9-6
   % Count 9-8
   % Total 9-6
   Average 9-6
   Count 9-8
   Info Columns 9-7
   Max 9-6
   Min 9-6
   Std Dev 9-6
   Total 9-6
Name 9-4
Other Data 9-8
   DimCounts 9-26
   Functions 9-13
      Character Functions 9-16
      Date Functions 9-23
      Distance Functions 9-25
      Logic Functions 9-13
      Numeric Functions 9-20
      Statistical Functions 9-21
      Time Functions 9-25
      Trigonometric Functions 9-22
Named Groups 9-46
Parameterized Calculations 9-39
Dimension-Based 9-32
   DimAverage 9-36
   DimGeoMean 9-37
   DimMax 9-35
   DimMedian 9-32
   DimMin 9-34
   DimPercentile 9-33
   DimStdDev 9-38
Functions 9-13
   ABS 9-20
   AND 9-13
   ArcCOS 9-22
   ArcSIN 9-22
   ArcTAN 9-22
   CONCAT 9-16
   COS 9-22
   DATE_VALUE 9-23
   EXP 9-21
   FORMAT_DATE 9-23
   IF 9-14
   INDEX 9-16
   ISNAN 9-14
   ISNULL 9-15
   LN 9-21
   LOG10 9-21
   MODELVAR 9-17
   NOT 9-15
   OR 9-15
   PARENT 9-20
   PCT_VAR 9-20
   REGEXP 9-17
   REGEXP_VALUE 9-17
   SCAN 9-18
   SIGN 9-15
   SIN 9-22
   SQRT 9-22
   STRING 9-21
   TAN 9-22
   TIME_VALUE 9-25
   TODAY 9-24
   TRUNC 9-21
   VALUE 9-19
Options Tab 9-9
   Column Format 9-10
   Column Size 9-9
   Exception Column 9-12
   Other Column Attributes 9-10
   Required Dimensions 9-12
Calendar
Type 9-56
  Custom Calendar 9-57
  Fiscal Calendar 9-57
  Standard Calendar 9-56
Calendar Plots 5-16
  Calendar Active View 5-18
  Calendar Sorted View 5-21
  Calendar View with Bar Plots 5-16
  First Day of Week 13-11
Cascade 2-40, 4-30
  Definition of 1-10
Cascade Print 3-18
  Embed Fonts 3-20
  from Command Line A-1
  Save to PDF Options 3-19
  Skip All Values 3-19
  Skip Empty Windows 3-20
Categories in the Console 2-19
Category
  Definition of 1-10
Cell Reference
  Absolute 11-35
  Relative 11-35
CellDiver 1-6
Center Line 5-30
Change Password 13-14
Changing Your Login Password in ProDiver 13-14
Character Functions 9-16
Child Dive Window 2-41
Child Window
  Definition of 1-10
CL 5-30
Close
  All Models in the Console 2-30
  Dive Window 2-41
  DiveBook 3-36, 8-8
  Model in the Console 2-29
Closing a DiveBook 8-8
Closing a User Defined Dimension 4-23
Closing Models 3-5
Color
Exception Coloring 4-25, 9-12
  in Reports 6-42
  Resetting 13-11
  Setting for items in Report 6-21
  Tabular Labels 13-10
Column 4-12
  Addition of 4-16
  Creation of 9-13
  Editing of 4-12
  Fit to Data 9-9
  Format of 9-10
  Headers 4-11
  Label is different from name 9-5
  Moving of 4-13
  Removal of 4-12
  Renaming of 4-14, 4-25
  Resizing of 4-13
  Selection of 4-15, 4-16
  Set Size 9-9
  Size of 4-26, 9-9
Column Attributes 9-10
Column Labels 9-5
Column Style 6-63
Columns
  Space Between in Reports 6-22
Command Line Options B-1
Committing a User Defined Dimension 4-22
Console 3-51
  Active Window 2-41
  Categories in 2-19
  Context Menu Items 2-29
  Close All Models 2-30
  Close Model 2-29
  Create Model QuickView 2-33
  Delete Action 2-31
  Edit Model 2-34
  Find Before Dive 2-32
  Save Model 2-34
Copying of 3-25
  Definition of 1-10
  Description of 2-14
  Detail Information in 2-20
DIVER

DimCounts in 2-20
Dimensions in 2-19
Dive Selector 2-15
Docking 2-29
Find in 3-35
History Area 2-16, 4-12
Info Area 2-24
Models Area 2-17
Models in 2-18
Other Dimensions in 2-18
Period Comparison in 2-25
Report Palette in 11-13
Resizing 2-29
Time Series Info Area 2-25
Totals Area 2-23
Console Dive Selector 3-7
Context Menu
Definition of 1-10
Continuation Model 2-5
Definition of 1-16
Control Charts 5-30
C-Chart 5-37
Center Line 5-30
Individual MR-Chart 5-43
Lower Control Limit 5-30
MR-Chart 5-41
NP-Chart 5-35
P-Chart 5-33
U-Chart 5-39
Upper Control Limit 5-30
X-Chart 5-31
Control Limits
in Graphs 5-81
Convert to QuickView... 4-17
Copy 3-25
Calculation References 11-15
Console 3-25
Info Window 3-25
Report Item Definition 11-39
Report Items 11-38
Reporter Reference Item 4-17
Reporter Reference Items 11-19
Window Dive Reference String 4-17
Window Dive Reference Strings 11-25
Copy Dive Reference String 5-97
Copy Window 4-16, 5-97
Core Dimension
Definition of 1-11
Core Model
Definition of 1-11
Count 9-8
Create
Graphs 5-5
Model QuickView 2-33
QuickViews
in Report Palette 11-49
Report 6-1
Report Macros 11-44
Report Palette 11-3
Spider Graph 11-54
Creating a DiveBook 8-4
Creating a User Defined Dimension 4-19
CrossPlots 5-24
Bar CrossPlot 5-24
Example of 5-26
Bubble CrossPlot 5-28
Example of 5-28
Line CrossPlot
Example of 5-26
Line CrossPlots 5-24
Point CrossPlot
Example of 5-27
Summary CrossPlot 5-27
Example of 5-27
CrossTab 3-49, 4-3
Columns in Other Tabulars 9-40
Report 6-4
Cumulative Column 9-11
Cut Functionality 3-25

D

Data Integrator 1-5
Data Tab
Definition of 1-11
in the Console 2-20
DI-Broadcast 1-6
DI-Config 1-5
DI-Controller 1-6
DI-Diver 1-1, 1-7
DI-Scheduler 1-6
DI-Updater 1-6
DIAL 1-6
DimAverage 9-36
DimCount 9-26
Description of 2-20
Filtered 9-28
in the Console 2-20
Dimension
Column Options 4-25
Column Size 4-26
Fit To Data 4-26
Format 4-26
Pixels 4-26
Set Size 4-26
Width of Column 4-26
Definition of 1-11, 12-2
Dynamic 9-53
Format of 4-26
in Calculations 9-31
in the Console 2-19
Names 4-25
Required 9-12, 9-45
Dimension Functions 9-26
Dimension Limits in a DivePlan 9-54
Dimension QuickView
Behavior Panel options
Activation 7-13
Automatically associate with new Dive
Windows 7-14
Load Value 7-13
creating from a tabular window 7-18
Data Panel options
Dependencies 7-12
Dimension 7-12
Limits 7-12
Population Order 7-12
Source 7-12
Display Panel options
  Label Type 7-13
  example 7-14
Dimension QuickView options 7-10, 7-11, 7-13
Dimension-Based Calculations 9-32
  DimAverage 9-36
  DimGeoMean 9-37
  DimMax 9-35
  DimMedian 9-32
  DimMin 9-34
  DimPercentile 9-33
  DimStdDev 9-38
Dimensional Insight Support
  Consulting 1-3
  Technical Support 1-3
  Training 1-3
DimGeoMean 9-37
DimMax 9-35
DimMedian 9-32
DimMin 9-34
DimPercentile 9-33
DimStdDev 9-38
Display Blanks As Zeroes 9-10
Display Formats 4-1
  CrossTab 4-3
  MultiCrossTab 4-7
  MultiTab 4-5
  MultiTabMultiCrossTab 4-9
  Tabular 4-2
Display Menu 3-49
  CrossTab 3-49, 4-4
  Graphs 3-50
  MultiCrossTab 3-49, 4-8
  MultiTab 3-49, 4-6
  Report 3-50
  Tabular 3-49, 4-2
Display Non-Shared Columns 13-10
Distance Functions 9-25
Dive
Active Dive Window 2-40
  Definition of 1-11
  Description of 2-9
  Dive History 2-16
  Dive Path 2-41
  Dive Window
    Close Dive Window 2-41
Multiple Dives 2-6
  Dive A 3-10
  Dive Arrows
    Definition of 1-11
  Dive B 3-10
  Dive C 3-10
  Dive D 3-10
  Dive Path 4-30
    Definition of 1-12
  Dive Selector 2-15
    Definition of 1-12
  Dive Window
    Definition of 1-12
    Rearranging 2-40
Dive Window Context Menu 4-19
DiveBook 3-52
  Adding Links 8-7
  Area 2-6, 8-2, 8-6
  Area Selection 8-2
  Close 3-36
  Closing of 8-8
  Creation of 8-4
  Default 2-7
  Definition of 1-12
  Description of 2-6
  File 13-14
  Graphic 8-5
  Links in 8-7
  Modification of 8-4
    Areas 8-6
    Closing the Dialog 8-8
    Topics 8-7
  Modify 3-36
  Opening 8-1
  Opening of 8-4
Diver

Save 3-13
Saving 8-8
Title 8-5
Topic 2-6, 8-3, 8-7
Topic Selection 8-2
DiveBook QuickView
  example 7-24
DiveBook QuickView options 7-23
  Area 7-23
  Browse for DiveBook 7-23
  Display Type 7-23
  Topic 7-23
DiveLine 1-5, 2-43, 3-3
  Use of 2-44
DiveMaster 1-5, 2-5
DivePlan 9-2, 12-17, 13-13
  Date Formats in 4-27
  Definition of 1-12
  Description of 2-5
  Editing of 9-2
  External 9-67
  External to Marker 3-11, 9-66
  Internal 9-67
  Number of Dimensions in 9-54
DivePort 1-7
Diver
  .ini file 2-29
  Companion Manuals for 1-2
  File Naming Conventions 2-3
  Graph
    Gantt Charts 5-48
  Icon for 2-1
  Locating 2-1
  Location of 2-1
  Starting 2-2
  Terminology 1-10
diver.ini 2-29, 3-26, 6-22, B-1
diver.tpl 2-38
Diving
  using QuickViews 7-1, 7-7
Division by Zero in Calculations 9-43
Do Not Display Zeroes

in Reports 6-36
Don’t Show Total 9-11
Download Directory 13-14
Downloading a Model 3-22
Dynamic Dimension 1-13, 9-53
  Definition of 1-12
  Dynamic Dimensions 9-53
  Dynamic Model 12-17

E

Edit
  Calendar 9-57
    Fiscal Calendar 9-57
  Columns 3-39
  Detail Info 3-36
  Dimensions 3-26
  DivePlan 9-2
  Edit Columns... 9-43
  Edit Model 2-34
  Memory Model 12-16
  QuickViews 3-38
  Report Item 6-23
  Report Palette 11-4
  Select Columns... 9-45
  Window Info 3-37
Edit Menu 3-24
  Add Dimensions 3-26
  Add QuickViews 3-38
  Application Templates 3-38, 13-1
    Activation of 13-7
    Use of 13-2
  Close DiveBook 3-36, 8-8
  Copy 3-25
  Copy Console 3-25
  Copy Info Window 3-25
  Cut 3-25
  Delete 3-26
  Edit Columns 3-39
  Edit Detail Info 3-36
  Edit Dimensions 3-26
  Edit QuickViews 3-38
Index-9

DIVER

Edit Window Info 3-37
Find 3-26
   Advanced Find 3-32
   Find Date Range 3-30
   Find in the Console 3-35
   Find Number 3-29
   Find Period Range 3-31
   Find String 3-28
Font 3-36
Modify DiveBook 3-36, 8-4
Paste 3-25
Period Comparison 3-38, 10-20
Redo 3-24
Report Style 3-36, 6-63
Select All 3-26
Select Columns 3-39
Time Series Control Panel 3-38, 10-1
Undo 3-24
Edit Summary Layout 6-13
   Include Row Labels 6-14
   Label Style 6-16
   Report Positions 6-15
   Select Label Style 6-15
Edit Window Info... 5-97
Editing
   QuickViews
      Auto-Set Top-to-bottom Dependencies 7-55
      Optimize Dive Order 7-55
Editing a Memory Model 12-16
Editing a Model 3-22
Editing a User Defined Dimension 4-23
Editing Graphs 5-82
Embed Fonts 3-7, 3-20
Enable Window Controls 13-9
Example
   creating a Marker without a QuickView 7-2
example
   creating a Free Entry QuickView 7-39
   creating a List QuickView 7-31
   creating a QuickView Set 7-45
   how to create a DiveBook QuickView 7-24
   Exception Coloring 4-25, 9-12
   Other Column 9-12
   Self 9-12
   Exception Tab 6-46
   Define Range 6-46
   Reports 6-46
   Use Column 6-46
Exiting Diver 3-23
External DivePlan 9-67
External DivePlans 3-11, 9-66

F

File
   Naming Conventions for 2-3
File Menu 3-2
   Build Model 3-22, 12-2
   Cascade Print 3-18
   Close 3-5
   Edit Model 3-22
   Exit 3-23
   Login 3-20
   Open 3-3
   Page Setup 3-14
Preferences 3-22
   DiveLine Tab 13-13
   Files Tab 13-14
   General Tab 13-8
   Graphs Tab 13-11
   Maps Tab 13-12
   Tabulars Tab 13-10
Print 3-16
Print Preview 3-14
Proxy Login As 3-21
Recently Used Files 3-23
Save DiveBook 3-13
Save DivePlan 3-6, 9-64
Save Graph Template 3-13
Save Marker 3-7
   Save Marker Options 3-10
Save Model 3-13
Save QuickView Set 3-13

Index-9
Save Report Template 3-13
Save Window 3-6

File Type
DiveBook 2-6
DivePlan 2-5
Marker 2-5
Model 2-4
Reference Link 2-7
Tunnel File 2-8

Filtered DimCount 9-28
Find 3-26, 4-15, 5-97
Advanced Find 3-32
Find Before Dive 2-32
Find Date Range 3-30
Find in the Console 3-35
Find Number 3-29
Find Period Range 3-31
Find String 3-28

Fiscal
Calendar 9-57
Fit To Page 6-18
in Reports 6-22
Flip Axes 3-39, 4-12, 4-16, 5-97
Focus 3-41
Font 3-36, 5-95
Editing of 4-24
in Reports 6-42
Set in Report 6-21

Format Tab 6-36
Do Not Display Zeroes 6-36
Include Group Separator 6-36
Number of Decimals 6-36
Report 6-36
Special Formats 6-36
Use Default Font 6-36

Free Entry QuickView
example 7-39

Free Entry QuickView options 7-38

Functions 9-13
in a Report Palette 11-36
$COL 11-36
$INTVAL 11-36
$NUMVAL 11-36
$QVARM 11-36
$QVVAL 11-36
$ROW 11-36
$SUM 11-36
$VAL 11-37

functions
QVVAL overview 7-68

G

Gantt Charts 5-48
Creation of 5-49
Dependency Column in 5-48
End Date Column in 5-48
Legend Category Column in 5-48
Model Layout for 5-48
Start Date Column in 5-48
Tasks 5-3, 5-48

Geocoding 9-1, 13-13
Geographic Key 9-54
Geographic Type 5-54
Glossary of Common Diver Terms 1-10

Goal Line
in Graphs 5-81

Graph 3-50
Add-On Labels 5-93
Ambient Shading 5-72
Appearance Tab 5-71

Ambient Shading 5-72
Details
Pie Options 5-73
Shadow Effects 5-72

General 5-72
Background Color 5-72
Borders 5-72
Data Color 5-72

Scatter Reference Lines 5-72
Show Graph Toolbar 5-72
Use Skin 5-71

Auxiliary Subtitle 5-75
Aces 5-84
Background Color 5-72
Basic Plots 5-6
Basic Statistics
  Caption Placement 5-81
  Caption Text 5-81
  Show Goal Line 5-81
  Show Least Fit Squares 5-80
  Show Median 5-80
  Show Statistical Mean/Center Line 5-80
Borders 5-72
Calendar Plots 5-16
Colors 13-11
Context Menu 5-97
  Copy Dive Reference String 5-97
  Copy Window 5-97
  Edit Window Info... 5-97
  Find 5-97
  Flip Axes 5-97
  Select All 5-97
  Sort Down 5-97
  Sort Up 5-97
  Undo 5-97
Control Charts 5-30
Control Limits
  Divide Control Limit into Observation Sets 5-81
  Show Upper & Lower Control Limit 5-81
Creation of 5-5
CrossPlots 5-24
Current Skin 5-74, 5-76, 5-78, 5-80
Definition of 1-12
Delete Label 5-95
Delete Tag 5-95
Drag-and-Drop Labels 5-75
Editing of 5-82
Fill Empty Items 5-11
Font 5-96
Font Color 5-96
Graph Font 5-74
Horizontal Scale (X-Axis) 5-77
Show Scale Title 5-77
Labels 5-93
Lasso Tool 5-88
Left Scale (Numerical Scale) 5-77
Legend 5-87
Legend Tab 5-78
Legend Color Boxes 5-78
Color Palette
  Use Color Range 5-78
Current Skin 5-78
Legend Placement 5-79
Live Objects 5-83
Locking of 5-88
Maps 5-54
Multiple Selection 5-88
Parent Subtitle 5-75
Pie Options 5-73
Pie Plots 5-57
Radar Graphs 5-60
Radius Tool 5-90
Right Scale (Numerical Scale) 5-77
Scales Tab 5-76
  Current Skin 5-76
  Horizontal Scale (X-Axis) 5-77
    Show Scale Title 5-77
  Left Scale (Numerical Scale) 5-77
  Right Scale (Numerical Scale) 5-77
    Vertical Scale (Y-Axis) 5-77
      Show Scale Title 5-77
Scatter Plots 5-63
Scatter Reference Lines 5-72
Scrolling 5-89
Selection Mode 5-89
Selection Tool 5-89
Show Data Column Label Title 5-75
Show Data Column Labels 5-75
Show Main Title 5-74
Show Numeric Values on Data Objects 5-75
Skins 5-71
Stack Plots 5-68
Statistics Tab 5-80
Basic Statistics
- Caption Placement 5-81
- Caption Text 5-81
- Show Goal Line 5-81
- Show Least Fit Squares 5-80
- Show Median 5-80
- Show Statistical Mean/Center Line 5-80

Control Limits
- Divide Control Limit into Observation Sets 5-81
- Show Upper & Lower Control Limit 5-81

Current Skin 5-80

Tags 5-94
- Text Tab 5-74
  - Auxiliary Subtitle 5-75
  - Current Skin 5-74
  - Drag-and-Drop Labels 5-75
  - Graph Font 5-74
  - Parent Subtitle 5-75
  - Show Data Column Label Title 5-75
  - Show Data Column Labels 5-75
  - Show Main Title 5-74
  - Show Numeric Values on Data Objects 5-75
  - Title Text 5-74

Title Text 5-74
- Toolbar 5-72, 5-88
- Unlocking of 5-88
- Vertical Scale (Y-Axis) 5-77
  - Show Scale Title 5-77
- Zoom Tool 5-89

Graph Templates 5-98
- in Graph Options Dialog 5-98
- Saving of 3-13, 5-98
- Usage of 5-98

Graphical Displays
- About 5-82
- Add-On Labels 5-93
- Axes 5-84
- Font 5-96

Font Color 5-96
- Lasso Tool 5-88
- Legend 5-87
- Live Objects 5-83
- Multiple Axis Scales 5-85
- Scrolling 5-89
- Selections 5-88
- Window Characteristics 5-82
- Zoom Tool 5-89

Graphics for Report Palettes 11-8, 11-57
- Graphics for Reports 6-35, 6-58
- Grid Lines
  - in Reports 6-22
  - Gridlines
  - in Reports 6-18
- Group 3-45
  - Definition of 1-12

H

Help Menu 3-54
  - About Diver 3-54
  - PDF Help 3-54

Hide
- Console 3-51
- Info Window 3-52
- Toolbar 3-51

Home Directory 3-4

HTML
  - DiveBook Link 2-6, 8-7
  - Report Links 6-44

I

Images for Report Palettes 11-8, 11-57
- Images for Reports 6-35, 6-58

Include
  - Group Separator
    - In Reports 6-36
  - Parent Dimension Info 6-19
  - Print Header 6-18
  - Row Labels 6-14
<table>
<thead>
<tr>
<th>Index-13</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIVER</td>
</tr>
<tr>
<td>Indented 2 Level MultiTab Report 6-7</td>
</tr>
<tr>
<td>Info Field</td>
</tr>
<tr>
<td>Adding using a Lookup Table 9-63</td>
</tr>
<tr>
<td>Definition of 1-13, 12-2</td>
</tr>
<tr>
<td>in Calculations 9-7</td>
</tr>
<tr>
<td>in the Console 2-24</td>
</tr>
<tr>
<td>Info Window</td>
</tr>
<tr>
<td>Copying of 3-25</td>
</tr>
<tr>
<td>Internal DivePlan 9-67</td>
</tr>
<tr>
<td>Introduction</td>
</tr>
<tr>
<td>QuickViews 7-1</td>
</tr>
<tr>
<td>Links in a DiveBook 8-7</td>
</tr>
<tr>
<td>List QuickView</td>
</tr>
<tr>
<td>example 7-31</td>
</tr>
<tr>
<td>List QuickView options 7-29</td>
</tr>
<tr>
<td>Live Objects 5-83</td>
</tr>
<tr>
<td>Lock Graph 5-88</td>
</tr>
<tr>
<td>Locked Report 6-20</td>
</tr>
<tr>
<td>Logged in as 2-44</td>
</tr>
<tr>
<td>Logging in to ProDiver 3-20</td>
</tr>
<tr>
<td>Logic Functions 9-13</td>
</tr>
<tr>
<td>Lookup File 1-13</td>
</tr>
<tr>
<td>Lookup Table 12-10</td>
</tr>
<tr>
<td>Definition of 12-10</td>
</tr>
<tr>
<td>Use of 9-63</td>
</tr>
<tr>
<td>Using in Memory Builder 9-63</td>
</tr>
<tr>
<td>lookup.mdl 13-13</td>
</tr>
<tr>
<td>Lower Control Limit 5-30</td>
</tr>
<tr>
<td>J</td>
</tr>
<tr>
<td>Jump 3-11</td>
</tr>
<tr>
<td>Definition of 1-13</td>
</tr>
<tr>
<td>K</td>
</tr>
<tr>
<td>Key Performance Indicator 11-63</td>
</tr>
<tr>
<td>Keyboard Shortcuts 2-42</td>
</tr>
<tr>
<td>KPI 11-63</td>
</tr>
<tr>
<td>M</td>
</tr>
<tr>
<td>map_data Directory 13-12</td>
</tr>
<tr>
<td>Maps 5-54</td>
</tr>
<tr>
<td>Column 5-55</td>
</tr>
<tr>
<td>Creation of 5-54</td>
</tr>
<tr>
<td>Directory for 13-12</td>
</tr>
<tr>
<td>Features of 13-12</td>
</tr>
<tr>
<td>Folders for 13-13</td>
</tr>
<tr>
<td>Geographic Type 5-54</td>
</tr>
<tr>
<td>Map Folder 5-54</td>
</tr>
<tr>
<td>Radius Tool 5-90</td>
</tr>
<tr>
<td>Marker 6-1, 13-1</td>
</tr>
<tr>
<td>Application Templates 13-7</td>
</tr>
<tr>
<td>Comments in 3-4</td>
</tr>
<tr>
<td>Definition of 1-13</td>
</tr>
<tr>
<td>Description of 2-5</td>
</tr>
<tr>
<td>External DivePlan 3-11</td>
</tr>
<tr>
<td>Saving 3-7</td>
</tr>
<tr>
<td>As a Stand-Alone File 3-8</td>
</tr>
<tr>
<td>To a DiveBook 3-9</td>
</tr>
<tr>
<td>Marker Options 3-10</td>
</tr>
<tr>
<td>Match Child To Parent 13-9</td>
</tr>
<tr>
<td>Max 9-6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>L</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
</tr>
<tr>
<td>Color 13-10</td>
</tr>
<tr>
<td>Style 6-16</td>
</tr>
<tr>
<td>Labels 5-93</td>
</tr>
<tr>
<td>Lasso Tool 5-88</td>
</tr>
<tr>
<td>LCL 5-30</td>
</tr>
<tr>
<td>Least Fit Squares</td>
</tr>
<tr>
<td>in Graphs 5-80</td>
</tr>
<tr>
<td>Legend 5-87</td>
</tr>
<tr>
<td>Line Plot 5-12</td>
</tr>
<tr>
<td>Line Spacing</td>
</tr>
<tr>
<td>in Reports 6-41</td>
</tr>
<tr>
<td>Link Tab 6-44</td>
</tr>
<tr>
<td>Link Activation Type 6-44</td>
</tr>
<tr>
<td>Link Type 6-44</td>
</tr>
<tr>
<td>Reports 6-44</td>
</tr>
</tbody>
</table>
Median in Graphs 5-80
Memory Builder 12-2
  Setting Lookup Tables in 9-63
Memory Model
  Building a Memory Model 12-2
  Definition of 1-14
Menus 13-3
  Edit Menu
    Application Templates 13-1
    Close DiveBook 8-8
    Edit Columns... 9-43
    Modify DiveBook 8-4
    Period Comparison 10-20
    Report Style 6-63
    Select Columns... 9-45
    Time Series Control Panel 10-1
File 3-2
  File Menu
    Preferences 13-8
    Save DivePlan 9-64
Min 9-6
Missing Data in a Dive Window 4-31
Model 1-5
  Comments in 3-4
  Continuation Model 2-5
  Definition of 1-11
  Description of 2-4
  Downloading 3-22
  Dynamic 12-17
  Edit 2-34
  in the Console 2-18
  Save 2-34, 3-13
  Static 12-17
  Variables 9-17
Model Build Time 3-4
Modify
  DiveBook 3-36
  Menus 13-3
  Preferences 13-5
  Toolbar 13-4
Modifying a DiveBook 8-4
Moving Range Chart 5-41
Multi-Dimension
  MultiTab 6-7
Multi-Dimension MultiTab Report 6-7
  Indented Subtotal MultiTab 6-8
  Paged MultiTab Bottom 6-7
  Paged MultiTab Top 6-8
MultiCrossTab 3-49, 4-7
  Report 6-9
    Basic MultiCrossTab 6-9
Multiple Axis Scales 5-85
Multiple Selection 5-88
MultiTab 3-49, 4-5
  Report 6-4
    Multi-Dimension MultiTab Report 6-7
      Indented Subtotal MultiTab 6-8
      Paged MultiTab Bottom 6-7
      Paged MultiTab Top 6-8
    Two Dimension MultiTab 6-6
      Indented 2 Level MultiTab 6-7
      Paged MultiTab 6-6
MultiTabMultiCrossTab 4-9
  Report 6-10
    2 Level Indented 6-11
    2 Level Tabular 6-12
    Paged MultiCrossTab 6-10
MultiTabs
  Diving from in Reports 6-59

N

Named Groups 9-46
  Completion of 9-51
Define Group By
  Absolute Date Range 9-49
  Period Range 9-50
  Relative Date Range 9-50
  Value 9-47
Define Group By Range 9-48
  Definition of 1-14
  Use of in Calculations 9-51
NetDiver 1-7
Normal Distribution 5-31, 5-41, 5-43
Numeric Data
  Formatting as a String 12-10
Numeric Functions 9-20
NZCount 9-42

O
ODBC 12-1, 12-12
Open
  File 2-2
    File Security Warning 2-2
    Models 2-18
Open File Dialog 3-4
Opening a DiveBook 8-1
Opening Files 3-3
Opening Recent Files 3-23
Optimize Dive Order
  QuickView editing option 7-55
Options 13-9
Organize Menu 3-39
  Flip Axes 3-39
  Focus 3-41
  Group 3-45
    Group with Others 3-46
  Sort 3-47
    Sort Up 3-46
  Stop Focus 3-41
  Stop Group 3-45
Other Dimensions 2-18

P
Page Numbers
  in Reports 6-22
Page Setup 3-14
Page Size
  in Reports 6-22
Paged MultiCrossTab 6-10
Paged MultiTab Report 6-6
Paging
  in Reports 6-23
Parameterized Calculations 9-39
Parent Dimension
  Definition of 1-14
Parent Dive Window 2-41
Parent Window
  Definition of 1-14
Password
  for ProDiver Login 3-20
Paste 3-25
  Calculation References 11-17
  Dimension Values 11-30
  Report Items 11-38
  Reporter Reference Item 11-22
  Window Dive Reference Strings 11-27
Path
  Image URL for Report 6-35, 6-58
  Image URL for Report Palettes 11-8
Patterns 13-11
Period
  Formatting of 4-27
  Period Comparison 3-38, 10-20
    Definition of 1-14
    in the Console 2-25
Picklist Color 13-10
Pie Plots 5-57
  Other Wedge 5-57
Plot Graph Lines 13-10
Point CrossPlot 5-24
Point Plot 5-13
Poisson Distribution 5-37
Position Tab 6-39
  Column 6-39
  Column Fit 6-40
    Offset 6-40
Report 6-39
Preferences 3-22, 13-8
  Application Templates 13-7
  DiveLine Tab 13-13
    Change Password 13-14
    Download Directory 13-14
    Server 13-14
Files Tab 13-14
Index-16

 Default Application Template 13-15
 Default DiveBooks 13-14
 General Tab 13-8
   Auto Close 13-8
   Enable Window Controls 13-9
   Match Child To Parent 13-9
   Options 13-9
   Window Placement 13-9
 Graphs Tab 13-11
   Appearance 13-11
   Calendar Plots
     First Day of Week 13-11
 Graph Colors 13-11
 Maps Tab 13-12
   Mapping Features 13-12
 Tabulars Tab 13-10
   Decimal Places 13-11
   Default Font 13-10
   Default Label Color 13-10
   Picklist Color 13-10
 Print 3-16
   Cascade 3-18
   Graphs 3-17
   Maps 3-17
   Print Preview 3-14
   Tabular Data 3-17
 ProDiveMaster 1-5
 ProDiver 1-1, 1-7
   Changing Your Password 13-14
   Location of 2-1
 ProReporter 1-8
 Proxy Login As 3-21
 Proxy login as... 2-44

 Q
 QuickView
   Definition of 1-14
   DivePlan Type 11-46
   Model QuickView
     Creation of 2-33
 QuickView Set

 overview 7-45
 QuickView Set File 2-8
 QuickView Sets
   Saving of 3-13
 QuickViews
   Dimension QuickView options 7-10
     Behavior panel 7-13
     Data panel 7-11
     Display panel 7-13
   DiveBook QuickView options 7-23
     editing options 7-53
     enhanced diving 7-1
     expanding the scope of a dive 7-7
   Free Entry QuickView options 7-38
     incorporating in reports 7-55
   Introduction 7-1
   List QuickView options 7-29
     overview of editing dialog 7-53
   Types 7-1
 QVVAL function
   overview 7-68

 R
 Radar Graphs 5-60
   Radar Area Graph 5-61
   Radar Line Graph 5-62
   Radar Point Graph 5-63
 Radius Tool 5-90
 Rearranging Dive Windows 2-40
 Rebuilding a Memory Model 12-17
 Recently Used Files
   List of 3-23
 Record
   Definition of 1-14
 Redo 3-24
 Reference Link
   Description of 2-7
 Relative Cell Reference 11-35
 Renaming Files 3-5
 Report 6-1
   Adding an Item 6-23
Attributes of 6-2
Border Tab 6-43
Breaklevel Threshold 6-38
CrossTab 6-4
Data Tab 6-23
Date 6-18
Default Attributes 6-2
Default Dialog
  Date 6-18
  Edit Summary Layout 6-13
  Fit to Page 6-18
  Gridlines 6-18
  Include Parent Dimension Info 6-19
  Page Numbers 6-18
  Subtotals 6-17
  Title 6-17
  Totals 6-17
Definition of 1-14
Edit Summary Layout 6-13
Exception Tab 6-46
Fit To Page 6-18
Format Tab 6-36
Graphics 6-35, 6-58
Gridlines 6-18
Include Parent Dimension Info 6-19
Including a Print Footer in 6-18
Including a Print Header in 6-18
Item Type 6-23
  CrossTab Data 6-30
  CrossTab Header 6-31
  CrossTab Row Totals 6-31
  CrossTab Totals 6-31
  Dimension Name 6-25
  Dimension Value 6-25
  Graphic 6-35
  Group Dimension Name 6-34
  Group Name 6-34
  Group Value 6-34
  Info Name 6-26
  Info Value 6-27
  MultiCrossTab Cell Value 6-33
  MultiCrossTab Column Total 6-33
  MultiCrossTab Dimension Value 6-32
  MultiCrossTab Row Total 6-33
  MultiCrossTab Summary Name 6-32
  Others 6-26
  Parent Dimension Name 6-27
  Parent Dimension Name and Value 6-28
  Parent Dimension Value 6-27
  Parent Info Name 6-30
  Parent Info Value 6-30
  Summary Name 6-25
  Summary Value 6-26
  Text 6-27
  Link Tab 6-44
  MultiCrossTab 6-9
  MultiTab 6-4
    Two Dimension MultiTab 6-6
      Indented 2 Level MultiTab 6-7
      Paged MultiTab 6-6
  Page Numbers 6-18
  Position Tab 6-39
  Report Item Editing 6-23
  Screen Tools 6-20
    Add Item 6-21
    Delete Column 6-21
    Delete Item 6-21
    Paging 6-23
    Set Font 6-21
  Style Column Handling 6-48
  Style Tab 6-41
  Subtotals 6-17
  Tabular 6-3
  Text Tab 6-42
  Title 6-17
  Totals 6-17
  Use of 6-1, 6-62
  Report Item 6-21, 6-23
  Report Palette 3-52
  Add Item 11-4
  Border Tab 11-42
  Cache Lock 11-4
  Calculation References 11-13
DIVER

<table>
<thead>
<tr>
<th>Copying 11-15</th>
<th>in Production 11-53</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition of 11-13</td>
<td>in the Console 11-13</td>
</tr>
<tr>
<td>Examples of 11-14</td>
<td>Overview of 11-1</td>
</tr>
<tr>
<td>Pasting 11-17</td>
<td>QuickView Values</td>
</tr>
<tr>
<td>Syntax 11-13</td>
<td>Use of 11-50</td>
</tr>
<tr>
<td>Cells 11-9</td>
<td>QuickViews 11-44, 11-46</td>
</tr>
<tr>
<td>SVAL() Functions 11-36</td>
<td>Adding 11-49</td>
</tr>
<tr>
<td>Cell Items 11-9</td>
<td>Creating 11-49</td>
</tr>
<tr>
<td>Cell Reference 11-35</td>
<td>DivePlan Type 11-46</td>
</tr>
<tr>
<td>Definition Strings 11-9</td>
<td>Use of 11-48</td>
</tr>
<tr>
<td>Error Handling 11-43</td>
<td>Reference Link Files 2-7, 11-29</td>
</tr>
<tr>
<td>Formatting of 11-42</td>
<td>Report Definitions 11-38</td>
</tr>
<tr>
<td>Pasting Dimension Values 11-30</td>
<td>Report Items 11-38</td>
</tr>
<tr>
<td>Selecting Cells 11-30</td>
<td>Report Macros 11-44</td>
</tr>
<tr>
<td>Text Variables 11-10</td>
<td>Creating 11-44</td>
</tr>
<tr>
<td>Working with 11-30</td>
<td>Use of 11-44</td>
</tr>
<tr>
<td>Column Fit Tab 11-41</td>
<td>Reporter Links 11-27</td>
</tr>
<tr>
<td>Columns</td>
<td>Link Tab 11-28</td>
</tr>
<tr>
<td>Working with 11-41</td>
<td>Link Types 11-28</td>
</tr>
<tr>
<td>Copy Reporter Reference Items</td>
<td>Window Dive Reference Strings 11-23</td>
</tr>
<tr>
<td>Copy Report Item 11-18</td>
<td>Reporter Reference Items 11-18</td>
</tr>
<tr>
<td>Creating 11-3</td>
<td>Rows</td>
</tr>
<tr>
<td>Definition of 1-15, 11-1</td>
<td>Working with 11-41</td>
</tr>
<tr>
<td>Diver Functions in 11-52</td>
<td>Saving 11-12</td>
</tr>
<tr>
<td>Edit Item 11-4</td>
<td>Style Tab 11-41</td>
</tr>
<tr>
<td>Editing 11-4</td>
<td>Sum Function 11-40</td>
</tr>
<tr>
<td>Editing of</td>
<td>Tail Section 11-6</td>
</tr>
<tr>
<td>Cache Lock 11-4</td>
<td>Text Items 11-6</td>
</tr>
<tr>
<td>Features of 11-6</td>
<td>Text Variables 11-6</td>
</tr>
<tr>
<td>Functions 11-36</td>
<td>Use of 11-2</td>
</tr>
<tr>
<td>Graph 11-53</td>
<td>Window Dive Reference Strings 11-23</td>
</tr>
<tr>
<td>Images 11-57</td>
<td>Report Positions 6-15</td>
</tr>
<tr>
<td>Indicators 11-63</td>
<td>Report Preferences</td>
</tr>
<tr>
<td>Speedometer 11-65</td>
<td>Breaklevel Threshold Lines 6-23</td>
</tr>
<tr>
<td>Standard Gauge 11-63</td>
<td>Default to Screen Reports 6-22</td>
</tr>
<tr>
<td>Thermometer 11-67</td>
<td>Fit to Page 6-22</td>
</tr>
<tr>
<td>Working with 11-68</td>
<td>Grid Lines 6-22</td>
</tr>
<tr>
<td>Spider Graph 11-53</td>
<td>Page Numbers 6-22</td>
</tr>
<tr>
<td>Creation of 11-54</td>
<td>Page Size 6-22</td>
</tr>
<tr>
<td>Graphics 11-8, 11-57</td>
<td>Space Between Columns 6-22</td>
</tr>
<tr>
<td>Head section 11-6</td>
<td>Report Screen Tools 6-62</td>
</tr>
<tr>
<td>Hide Row 11-37</td>
<td>Lock 6-20</td>
</tr>
</tbody>
</table>

Index-18
Unlock 6-20
Report Style 3-36
Report Styles
  Definition of 6-63
Report Template 3-13, 6-1
  Loading of 6-62
  Saving of 6-61
  Selected Report Area 6-62
Report Templates 6-61
Report Text Variables C-1
  $BUILD_DATE C-1
  $BUILD_TIME C-1
  $COMMENTS C-1
  $CURRENT C-1
  $DATE C-1
  $DAY C-2
  $DIMNAME C-2
  $DIMVAL C-3
  $EXTRACT_DATE C-4
  $EXTRACT_TIME C-4
  $FIND_COLUMN C-4
  $FIND_DATE_FROM C-4
  $FIND_DATE_TO C-4
  $FIND_HIGH C-4
  $FIND_LOW C-4
  $FIND_PERIOD_FROM C-5
  $FIND_PERIOD_TO C-5
  $FOOTER C-5
  $HEADER C-5
  $INFONAME C-5
  $INFOVAL C-5
  $LONGDATE C-5
  $MAXPAGE C-5
  $MODEL_FOOTER C-5
  $MODEL_NAME C-5
  $MODELVAR C-6
  $PAGE C-6
  $PRIOR C-6
  $QVVAL C-6
  $ROW C-6
  $SHORTDATE C-6
  $SORT_COLUMN C-6
  $SUMNAME C-6
  $SUMVAL C-7
  $TIME C-7
  $TOTAL_STRING C-7
  $XTAB_DIMENSION C-7
  $XTAB_ELEMENT C-7
Reports 3-50
reports
  leveraging with QuickViews 7-55
Required Dimension 9-12, 9-45
Resetting the Toolbar to Default 3-53
Row 4-11
  Labels 4-11
  Selection of 4-15

S

Save
  DiveBook 3-13
  DivePlan 3-6, 9-64
  Graph Template 3-13
  Marker 3-7
    As a Stand-Alone File 3-8
    Save Marker Options 3-10
    To a DiveBook 3-9
Memory Model 12-17
Model 3-13
QuickView Set 3-13
Report 6-1
Report Palette 11-12
Save Model 2-34
to Excel 2-38
to PDF 2-38
  Options 3-19
Window 3-6
  ASCII 3-6
  CSV 3-6
  DBF 3-6
  Embed Fonts 3-7
  HTML 3-6
  PDF 3-6
Save Totals 3-7
TAB 3-6
XML 3-7

Save Marker Options
Closing All Models When Opening 3-12
Configuring Comments in a Marker 3-12
Configuring Dives 3-10
Configuring Extra DivePlans 3-11
Removing Redundant Actions 3-12
Setting a Report Template 3-12
Setting Application Templates 3-11
Specifying a DiveBook Area and Topic 3-12

Saving a DiveBook 3-13, 8-8
Saving a DivePlan 3-6
Saving a Marker 3-7
As a Stand-Alone File 3-8
To a DiveBook 3-9

Saving a Memory Model 12-17
Saving a Report Template 3-13
Saving a Window as a CSV File 3-6
Saving a Window as a DBF File 3-6
Saving a Window as a PDF File 3-6
Saving a Window as a Tab-Delimited File 3-6
Saving a Window as an XML File 3-6
Saving a Window as HTML 3-6

Scatter Plots 5-63
Data Color 5-72
Reference Line 5-72
Scatter Bubble Plot 5-67
Example of 5-67
Scatter Line Plot 5-65
Scatter Point Plot 5-65

Screen Reports 6-22
Scroll Bar 4-12
Scrolling 5-89
Search Path 13-15

Select
Cells 11-30
All 11-32
All Blank 11-33
All Defined 11-32

All with Links 11-33
All With... 11-34
Multi-Select 11-34
Deselect 4-15
Label Style 6-15
Non-Adjacent Labels 4-15
Select All 3-26, 4-16, 5-97
Select Columns 3-39
Select Columns... 4-16
Select DiveLine Server
Changing the DiveLine Server 3-21
Select Tool 5-88
Selecting a DiveBook Area 8-2
Selecting a DiveBook Topic 8-2
Selection
in Windows 4-15
Mode 5-89
Tool 5-89

Setting Preferences 3-22
Setting Print Options 3-14
Setting the Default DiveLine Server 13-14
Show
Console 3-51
Info Window 3-52
Toolbar 3-51

Skins
in Graphs 5-71
Sort 3-47, 12-10
Alternate Sort 3-46
Down 4-16, 5-97
Up 3-46, 4-16, 5-97

Special Formats
in Reports 6-36
Spline Plot 5-14
Split Window 3-53, 4-28
Split Horizontal 4-28
Split Vertical 4-28
Stack Plots 5-68
Bar Stack Plot
Example of 5-69
Percentage Stack Plot
Example of 5-69
Additional Toolbar Buttons 2-38
Customization of 3-53
Default Toolbar Buttons 2-36
Report Button 6-2
Resetting to Default 3-53
Toolbars
  in Graphs 5-72
Topic
  Definition of 1-15
Topics in a DiveBook 8-3
Total 9-6
  in the Console 2-23
Trigonometric Functions 9-22
Tunnel File
  Description of 2-8
Two Dimension MultiTab Report 6-6
Types of QuickViews 7-1

V
Variables
  in Models 9-17
  Setting in a Report C-1
Viewing Marker Info 3-12
Visual Integrator 1-5

W
Walk A-1
Window
  Characteristics of 5-82
  Console Resizing 2-29
  Controls 13-9
  Location of
    Console Docking 2-29
    Placement 13-9
  Split Window 4-28
  Unsplit Window 4-29
Window Dive Reference Strings 11-23
  attribute_name 11-24
  attribute_value 11-24
  dive_dimension 11-23
  model_name 11-23
  parent_dimension 11-23
  parent_value 11-23
  window_type 11-23
Window Menu 3-51
  Customize Toolbar 3-53
  DiveBook 3-52
  Hide Console 3-51
  Hide Info Window 3-52
  Hide Toolbar 3-51
  Report Palette 3-52
  Reset Toolbar to Default 3-53
  Show Console 3-51
  Show Info Window 3-52
  Show Toolbar 3-51
  Split Horizontal 3-53
  Split Vertical 3-53
  Split Window 4-28

U
UCL 5-30
UDD 1-15, 4-19
Undo 3-24, 5-97
Unlock Graph 5-88
Unlocked Report 6-20
Unsplit Window 3-53, 4-29
Update Model
  Definition of.mdu 1-16
Upper Control Limit 5-30
URL 4-27, 6-35, 8-7
Use Default Font 6-36
User Defined Dimension 1-15
  Closing 4-23
  Committing 4-22
  Configuration of 4-19
  Creating 4-19
  Editing 4-23
User Name
  for ProDiver Login 3-20
Using the Proxy Login 3-21
Unsplit Window 3-53
Wrap On Any Character 9-10

Z

Zoom Tool 5-89